Part 1

General Project Setup

- Chapter 1: Exploring the User Interface
- Chapter 2: Creating an Effective Project Template
- Chapter 3: Worksets and Worksharing
- Chapter 4: Best Practices for Sharing Projects with Consultants
- Chapter 5: Schedules
- Chapter 6: Details
- Chapter 7: Sheets
Chapter 1

Exploring the User Interface

Revit MEP 2011 is the second release of Revit utilizing the ribbon-style interface. Having a good knowledge of where tools are located and how to access commands easily is the best way to be efficient in your use of Revit MEP 2011. Some improvements and changes have been made to the ribbon portion of the interface, so there is a slight learning curve when transitioning from Revit MEP 2010.

If you are transitioning to Revit MEP 2011 from a release prior to Revit MEP 2010, then the ribbon-style interface will be totally new to you. The ribbon works well with Revit because it allows tools to be organized in one area of the interface, which gives you more screen real estate for viewing the model. Although the user interface is customizable, you are limited in the amount of customization and number of features that you can change. At first this may seem a bit restrictive, but like any software, once you work with it enough, it will become more familiar, and your efficiency will increase.

Improvements have been made to the user interface for Revit MEP 2011. Some features have been added to improve workflow and efficiency, and typical workflow features that were previously accessed through buttons in the interface are now available as part of the interface itself.

Knowing your way around the Revit MEP 2011 user interface is the first step to success in reaping the benefits of utilizing a building information modeling (BIM) solution for your building projects. In this chapter, you will learn to

- Navigate the ribbon interface
- Utilize user interface features
- Use settings and menus

The Ribbon

Making the transition to a ribbon interface has been difficult for some people. If you are familiar with the Revit MEP user interface prior to the 2010 version, transitioning to the ribbon-style interface may indeed take some getting used to. Once you understand the way that the ribbon is
set up and how you can customize it to better suit your workflow, though, you will see that it is an optimal interface for a BIM and design application.

**Tabs**

The ribbon portion of the user interface consists of several tabs, each organized by panels that relate to the topic of the tab. Each panel contains one or more buttons for the relevant features available in Revit MEP 2011. You can access a tab by simply clicking the name at the top of the ribbon. Although each tab is designed to provide a unique set of tools, some of the features of Revit are repeated on different tabs. The panels and tools for each tab are described here (not all panels are shown for each tab):

**Home**  The Home tab is the main tab for MEP modeling tools. This tab is divided into panels that are specific to each of the main disciplines. This tab is where you will find the tools to build an MEP model. Each of the discipline panels has a small arrow in the lower-right corner that provides quick access to the MEP settings dialog box for that discipline.

**Insert**  The Insert tab contains the tools for bringing other files into your Revit projects. The tab is organized by panels for linking and importing files and also contains tools for loading Revit families. The small arrow at the lower right of the Import panel is for accessing the Import Line Weights dialog box, where you can associate imported CAD color numbers to a Revit line weight. The Insert tab also contains the Autodesk Seek panel, which provides a search window for content available on the Autodesk Seek website.

**Annotate**  On the Annotate tab you will find the tools needed to add annotations to your model views along with drafting tools for creating details. The Dimension and Tags panels can be extended by clicking the arrow next to the panel name, revealing the tools for establishing settings. The Symbol button is used for placing annotation families onto views or sheets. The small arrow at the lower-right corner of the Text panel provides access to the Type Properties dialog box for creating or modifying text styles.
Analyze  Tools for model analysis and systems checking are located on the Analyze tab. There are some other tools on this tab that allow you to add color to your ductwork and piping based on defined criteria. The Spaces & Zones panel on this tab contains the tools for placing Space objects and Space Separator lines.

Architect  Revit MEP 2011 is capable of modeling much more than just the components of an MEP engineering system. The Architect tab contains tools that allow you to model architectural components or to create conceptual mass objects. The Room & Area panel contains the Legend button, which allows you to apply color fill to your views based on defined criteria.

Collaborate  To keep your model coordinated with other disciplines and work in a multi-user environment, you need tools that allow you to do so. These tools can be found on the Collaborate tab. The Worksets panel has a drop-down for switching worksets, and the Coordinate panel contains tools for copying and monitoring objects from linked files. The Coordinate panel has a new tool for locating face-hosted elements that have lost their association to their host. You can check for clashes between model objects by using the Interference Check tool on the Coordinate tab.

View  You can use the tools available on the View tab to create views. There are also tools for managing the views you have open in the drawing area. On the Graphics panel there are tools for creating view templates and filters. The Sheet Composition panel has tools for creating sheets as well as for adding matchlines or revisions. The User Interface button allows you to toggle the visibility of key user interface features.
Manage  On the Manage tab, you can find the tools needed to establish project settings. The Inquiry panel has tools that can be used to locate specific objects in your project model and display any warnings associated with your project. Along with the settings that can be accessed from the tools on the Settings panel, the Additional Settings button is a drop-down list of even more options. New to Revit MEP 2011 is the Panel Schedule Templates button, which allows you to define and edit the layout of panel schedules.

Modify  The Modify tab is in a new location for Revit MEP 2011. It is now located at the end of the tabs, moving it closer to the center of the user interface for easier access. The Modify tab has the tools needed to make changes to components or line work in your project views. The tools on the Modify panel have been arranged with the more commonly used tools having larger buttons. Some of the tools that used to be drop-downs have been separated into individual buttons to reduce the number of mouse clicks required to access them. You can toggle the Properties palette on and off from this tab.

If you are running any external applications or macros, the Add-Ins tab will appear on your ribbon as the last tab. The buttons or other features provided by the external application will appear on the tab as configured.

The Modify button appears in the Select panel on every tab. This button allows you to exit from any active command, giving you an alternative to using the Esc key multiple times or selecting another tool.

Contextual Tabs
In addition to the tabs provided by default on the ribbon, there are tabs that appear when you select objects in your project. These contextual tabs appear with tools specific for modifying the selected object. Contextual tabs appear in the location of the Modify tab and are identified by their green color and a name that applies to the selected object. A contextual tab for a selected object is an extension of the Modify tab, which is why the base Modify tab is so compact compared to the other tabs. This allows for the selection-specific tools to appear on the right side of the Modify tab. Figure 1.1a shows the contextual tab for an air terminal selected in the model of a project. The standard tools on the Modify tab are available at the left but not shown in this figure for clarity.

When you select an object in the model that is part of a system, an additional contextual tab appears with tools for editing the system. These tabs are completely separate from the standard Modify tab and only contain tools for system editing. If you select an object on a system, the system tab will appear along with the contextual Modify tab, as shown in Figure 1.1b, but if
you select an actual system, only the system tab appears. The panels and buttons on contextual
tabs cannot be removed or rearranged on the ribbon. The buttons cannot be added to the Quick
Access toolbar.

**FIGURE 1.1**
(a) Contextual tab
for an air terminal;
(b) contextual tab
for duct system

---

**Family Editor Tabs**

The tabs in the Family Editor environment differ from those in the project file environment. When you open a family file, the tabs on the ribbon contain some familiar tools, but many of them are specific to the creation and modification of family components. The tabs available in the Family Editor environment are as follows:

**Home** The Home tab in the Family Editor environment contains tools for creating solid geometry and lines, adding system connectors, and creating and managing references.

**Insert** The Insert tab in the Family Editor environment contains tools for bringing other files into your family file. The tools for linking are visible but disabled, because importing is the only available method for bringing a CAD file into your Revit family file.
Annotate  On the Annotate tab within the Family Editor environment, you will find the types of annotation tools that can be used in a family file. The Dimension panel can be expanded to establish dimension styles within the family file.

View  The View tab in the Family Editor environment is limited to tools for managing the family views. Section views can be created and camera positions can be established for 3D views also.

Manage  In the Family Editor environment the Manage tab is populated with tools for establishing settings within the family file. The MEP Settings button allows you to establish load classifications and demand factors while the Additional Settings button drops down for access to general settings.

Modify  The Modify tab in the Family Editor environment is the same as the one found in the project file environment. This tab is also compact, allowing for a contextual tab when objects within the family are selected.

The Load Into Project button is available on each tab in the Family Editor environment.

Customizing the Ribbon
You can customize the ribbon interface to better suit your workflow. For example, you can rearrange the order of the tabs by holding the Ctrl key and clicking a tab name to drag it to a new location.
You can move panels on a tab to different locations on the tab by clicking a panel name and dragging it to a new location. Figure 1.2 shows the Mechanical panel being dragged from its location on the Home tab. The panels to the right will slide over to fill in the space left by the moved panel.

**Figure 1.2**
Moving a tab panel

You cannot move a panel from one tab to another, however. If you attempt to drop a panel onto another tab, it will return to its original location on its normal tab.

You can remove panels from a tab and place them in another location on your screen. You can dock floating panels together by dragging one panel over the other, and you can move the docked panels as a group by clicking and dragging the gray grip that appears when you hover the mouse pointer over a floating panel. If you use dual monitors, you can even drag a panel to the second monitor. The panel’s new position is maintained when you restart the software but will not appear until a file is opened. Keep in mind that moving tools to another screen may actually hinder your workflow efficiency.

**BACK TO NORMAL**

You can return a floating panel to its default location by clicking the small button in the upper-right corner of the panel.

If you want to return the entire ribbon interface to its default settings, you can do so by locating and deleting the UIS\State\dat file. Deleting this file will also remove any customization done to the Quick Access toolbar.

You can control the visibility of the ribbon tabs by clicking the small button to the right of the tabs. This button will cycle through the different display options. You can also click the small arrow next to the button to display and select a specific option.
You can establish the switching behavior of the tabs on the ribbon to determine what tab is displayed when you exit a tool or command. When you click a tool, the contextual Modify tab for that tool appears. The interface will stay on the Modify tab when you exit the tool, or you can set it to return to the previous tab. These settings are located on the User Interface tab of the Options dialog box, which is discussed later in this chapter.

**Quick Access Toolbar**

As you are working and switching between tabs, you may find yourself taking extra steps to switch tabs in order to access the desired tools. The Quick Access toolbar (QAT) is a place where you can put frequently used tools for instant access.

You can add tools from any of the standard tabs to the QAT by simply right-clicking the button or drop-down and selecting the Add To Quick Access Toolbar option. The tool will be placed at the end of the QAT. To manage the tools available on the QAT, you can click the small arrow button at the far right of the QAT, as shown in Figure 1.3. Each button on the QAT is listed, and removing the check mark next to it will turn off its visibility in the QAT.
The option at the bottom of the list allows you to set the location of the QAT either above or below the ribbon. Setting it below the ribbon moves it closer to the drawing area for easier access. Moving it to this location does not take the place of the Options Bar, however. If you add several buttons to the QAT, you may want to move it below the ribbon so that it does not crowd out the filename on the title bar.

Clicking the Customize Quick Access Toolbar option in the drop-down opens the dialog box shown in Figure 1.4. In this dialog box, you can change the order of the buttons, create separator lines, or delete buttons.

![Figure 1.4 Customize Quick Access Toolbar dialog box](image)

You can also right-click a button on the QAT for quick options such as removing the button, adding a separator line, or accessing the customization dialog box.

**User Interface Features**

The Revit MEP 2011 user interface is full of features designed to help you design and model efficiently. Some items are new, some have been modified, and some are the same as they have always been. The title bar at the top of the screen will still inform you of what file you are in and what view is currently active in the drawing area.

**Options Bar**

Despite the functionality of the ribbon with its contextual tabs, the Options Bar is still an important part of the user interface. This should be the first place you look when a tool or object in the project is selected. Though the number of options that appear may be limited, they are usually
very important to the task you are engaging in. When placing Space objects, for example, pay close attention to the Upper Limit and Offset options to ensure proper space height.

You can dock the Options Bar at the top of the screen below the ribbon, which is the default location, or at the bottom of the screen just above the status bar. Right-click the Options Bar to change its docked position.

**Properties Palette**

New to Revit MEP 2011 is the Properties palette. This feature reduces the number of mouse clicks necessary to access the properties of a model object or project component. You can dock the Properties palette to the sides, top, or bottom of the screen, or it can float. If you dock the Properties palette to the same side of the screen as the Project Browser, the two features will split the docked space, as shown in Figure 1.5.

**Figure 1.5**

Project Browser and Properties palette docked together
If you do not have the Properties palette turned on, you can access it by clicking the Properties button located on the Modify tab or contextual Modify tab of a selected object. The Properties palette will remain on until you close it.

When no object is selected in the model or in a drafting view, the Properties palette will display the properties of the current view in the drawing area. You can select a view in the Project Browser to view its properties in the Properties palette.

The top section of the Properties palette acts as the Type Selector when an object is selected or a tool is chosen for placing an object. When an object is selected, you can switch to the properties of the current view by using the drop-down located just below the Type Selector, as shown in Figure 1.6.

![Figure 1.6 Properties palette](image)

The properties shown in the Properties palette are instance properties. You can click the Edit Type button to display the Type Properties dialog box for the selected item or view. When viewing the instance properties of an object or view, the scroll bar at the right side of the palette will hold its position when you move your mouse pointer away from the palette. The scroll bar will remain in position even when other items are selected in the model.

When you make a change to a parameter in the Properties palette, you can click the Apply button at the bottom-right corner of the palette to set the change, or you can simply move your mouse pointer away from the palette, and the change will be applied.

**View Control Bar**

The View Control Bar is often overlooked but contains tools that are very important to the display of the contents in the drawing area. There are a few new features for the View Control Bar in the Revit MEP 2011 release. The Sun Settings button has been added so that the Sun Path can be turned on or off in the view. You can access the Sun Path settings by clicking the Edit button in the Graphic Display Options parameter of a view’s properties.
Another change to the View Control Bar is the addition of styles to the Visual Styles tool. The Consistent Colors setting has been added so that the colors of objects will appear in a shaded view with the same consistency regardless of its orientation to a light source. So when you are viewing the model in a 3D view, the color of all sides of an object looks the same. The Realistic setting allows the rendering materials of objects to be displayed in an editable view. This setting works only if you have Hardware Acceleration turned on.

Take some time to explore the new visual styles by completing the following exercise. If you do not have Hardware Acceleration turned on, you can do so by clicking the Options button on the Application menu and going to the Graphics tab. You must do this prior to opening the file. If activating Hardware Acceleration causes problems because of your video driver, you can choose to not activate it and skip step 4:

1. Open the Ch1_Project.rvt file found at www.wiley.com/go/masteringrevitmep2011.

2. Click the Visual Styles button on the View Control Bar. Set Visual Style to Shaded With Edges. Zoom, pan, and orbit the view, and make note of the variations in color based on the model orientation.

3. Click the Visual Styles button, and change the style to Consistent Colors. Notice that the colors remain a consistent shade when you zoom, pan, and orbit the view.

4. Click the Visual Styles button, and change the style to Realistic. Notice that the render material defined for the objects is now displayed.

5. Click any object in the model. If you do not already have the Properties palette active, click the Properties button on the Properties panel of the contextual tab. Take some time to become familiar with the behavior of the Properties palette.

**Status Bar**

Improvements have been made to the status bar for Revit MEP 2011. The status bar will still report the information about a selected item or prompt with instructions for multilevel commands, but it now also has an active workset indicator and design option indicator.
You can access the Worksets dialog box by clicking the Worksets button next to the active workset window, and you can switch between active worksets by clicking the window and selecting the desired workset. These are the same tools as found on the Collaborate tab, but having them on the status bar eliminates the need to switch tabs on the ribbon to access them. This also eliminates the need to add the tools to the Quick Access toolbar. The Design Options window displays the active design option, and you can access the Design Options dialog box by clicking the button.

The Editable Only and Press And Drag check boxes are located on the status bar. The Editable Only check box is for filtering a selection by only those objects that are editable in a worksharing environment, and the Press And Drag check box allows you to drag objects in the model without having to select them first. So, you can click an object and immediately drag it when the box is checked. When deselected, you must first click to select the object, release your mouse button, and then click the object again to drag it. In some cases, you may want to deselect this box to avoid moving objects inadvertently when working in a crowded area of the model.

Info Center

The Info Center is the portion of the title bar that gives you quick access to the Help menu or information about Revit MEP 2011. The search window allows you to search for information about a topic, and you can choose the locations to be searched by clicking the arrow next to the binoculars button.

You can easily access the Subscription Center by clicking the button with a key on it. Any topics found in the search window or listed in the Subscription Center panel can be added to your Favorites list by clicking the star icon to the right of the topic. Clicking the star button on the Info Center will list all your favorite topics. The Help menu is displayed by clicking the question mark button. Revit MEP 2011 has a web-based Help menu. You can access additional information by clicking the arrow next to the Help button, as shown in Figure 1.7.

The Communication Center button is the one with the radar device on it. The Communication Center provides information about product updates and announcements.
CHAPTER 1  EXPLORING THE USER INTERFACE

**Figure 1.7**  Additional Help options

**User Interface Control**

Many components of the Revit MEP 2011 user interface can be turned on or off for workflow efficiency or to maximize screen real estate. The User Interface button, located at the far right of the View tab, allows you to select which user interface components are visible, as shown in Figure 1.8.

This is not only a way to display or remove interface components for more screen real estate but is also a way to access the Recent Files screen, which cannot be accessed from the Switch Windows drop-down button.

**Figure 1.8**  User Interface button options

**Menus and Settings**

Some changes and new features are available for user interface settings and for context menus when right-clicking. Along with options for file export, printing, and opening and saving files, the Application menu has an Options button where you can access the settings to establish the behavior of the interface as well as the location of directories and files used for working on projects. You access the Application menu by clicking the Revit logo button in the upper-left corner of the user interface; the Options button is located in the lower-right corner of the menu, as shown in Figure 1.9.
Clicking the Options button opens the Options dialog box, which has several tabs for different settings within Revit MEP 2011. The User Interface tab shown in Figure 1.10 is where you can set some general behavior for the interface. For example, you can choose between a light gray or dark gray theme for the interface from the Active Theme drop-down.

The Tab Display Behavior section in the center of the tab is where you define how the ribbon tabs will behave after an action is completed. There are settings for the behavior in both the project and Family Editor environments. The check box for displaying a contextual tab on selection allows you to have the ribbon tab switch immediately to the contextual tab when an object is selected. If that check box is not selected, the contextual tab will still appear on the ribbon, but it will not automatically become the active tab.

In addition, you can define the level of information provided by tooltips from the Tooltip Assistance drop-down. If you are still learning the function of different tools within Revit MEP 2011, you may want to set this option to High so that you will receive detailed descriptions of how tools work when you hover over them with your mouse pointer. If you find the tooltips interfere with your workflow, you can set this option to None.
**What Do I Type?**

With Tooltip Assistance set to at least Minimal, you can see the keyboard shortcut for a tool by hovering your mouse pointer over it. The keyboard shortcut is shown in parentheses next to the name of the tool.

**Keyboard Shortcuts**

On the User Interface tab of the Options dialog box is a button that enables you to customize your keyboard shortcuts. Clicking this button activates the Keyboard Shortcuts dialog box. In this dialog box you can filter the commands to make the list easier to manage and edit. You can even filter by specific tabs or menus, as shown in Figure 1.11.

**Shortcut Access**

You can access the Keyboard Shortcuts dialog box by clicking the User Interface button on the View tab. There is even a keyboard shortcut for the Keyboard Shortcuts dialog box, KS.

You can sort the list in ascending or descending alphabetical order by clicking the desired column. Once you have located a command that you want to create a keyboard shortcut for,
you can select the command to activate the Press New Keys window at the bottom of the dialog box. Input the desired keys that will activate the command. You can input up to five characters for a keyboard shortcut. Reserved keys cannot be used for keyboard shortcuts; you can find the reserved keys using the filter in the Keyboard Shortcuts dialog box. Click the Assign button to apply the shortcut to the selected command.

**Figure 1.11**
Keyboard shortcut list filter options

You can create multiple shortcuts for a single tool, and you can use the same shortcut keys for multiple tools. When you create a shortcut that is used for multiple tools, you must use the status bar to determine which tool to use when working in your project. When you type the shortcut, the first matching command will be displayed on the status bar. You can use the up or down arrows to cycle through available commands for the shortcut. Once the desired command is displayed on the status bar, you can activate it by hitting the spacebar. You can remove a keyboard shortcut from a command by selecting the specific shortcut and clicking the Remove button.
You can export your keyboard shortcut settings by clicking the Export button at the bottom of the Keyboard Shortcuts dialog box. This will save your settings as an .xml file that can be edited using a spreadsheet program. Using a spreadsheet is another way to manage and share your keyboard shortcuts. The .xml file can then be imported into Revit using the Import button, allowing you to set a standard for keyboard shortcuts in a multiuser work environment.

**Real World Scenario**

**COMMON SHORTCUTS**

Clark is responsible for teaching Chris and Allyson Revit MEP 2011. He has established keyboard shortcuts that fit his workflow best and allow for efficient use of the software. Because these shortcuts are what he is most familiar with, he wants to share them with his students so that during class they will all be using the same shortcuts.

Clark exports his shortcut settings to a file, which he imports into Revit MEP 2011 on the training computers. Prior to importing the custom settings, he exported the default settings so they can be used later if necessary. During class it is noted that the settings provided are preferred, but each student can further customize them if it results in improved efficiency.

**Graphics**

The Graphics tab of the Options dialog box allows you to set the selection, highlight, and alert colors used in the drawing area. The drawing area’s background color can be inverted if you are more comfortable using a black background. Settings for temporary dimensions are also available to make them more readable, as shown in Figure 1.12. You can set the background for temporary dimensions to transparent or opaque (this setting is not shown in figure).

Settings for the appearance and behavior of the SteeringWheels and ViewCube can be found on their respective tabs in the Options dialog box.

**Context Menus**

Though the ribbon interface is designed for efficient workflow, context menus can be the easiest, most effective way to access settings or make changes to components of your Revit projects.
A context menu is a menu that appears when you right-click in open space, on an item in the Project Browser, or on an object in the drawing area. New to Revit MEP 2011 is the addition of the Repeat and Recent Commands options on the context menus. You can now repeat the last command by using the Enter key or by clicking the option on the context menu. The Recent Commands option displays a list of recently used commands for easy access during repetitive work. Figure 1.13 shows a context menu and the recent commands used during a working session. The last five commands used are displayed in the Recent Commands list.

**Figure 1.12**
Temporary dimension appearance settings

The options displayed on a context menu depend on the object selected when the menu is accessed. Another new feature to Revit MEP 2011 is the ability to define the selection set when the Select All Instances option is chosen. Figure 1.14 shows that you now have the option to select only the objects in the active view or to select them throughout the entire project. This makes the Select All Instances feature much more useful without worrying that objects that should not be selected are not inadvertently included in the selection set.

There is no longer a View Properties or Element Properties option in the context menus because of the addition of the Properties palette. The Properties option at the bottom of a context menu allows you to toggle the Properties palette on or off.
You can also right-click an element in the Project Browser for a context menu. Right-clicking a view will activate a menu with options for applying or creating a view template from the view. You can also save the view to a new file, as shown in Figure 1.15.

When you right-click a family in the Project Browser, you get a context menu with options to edit, rename, or reload the family. You can right-click a family type in the Project Browser to access its type properties or to select the instances in the project without having to locate one of the instances in the model, as shown in Figure 1.16.
**Figure 1.15**
Context menu for a view selected in the Project Browser

**Figure 1.16**
Context menu for a selected family type
You can also use a right-click context menu to manage linked files through the Project Browser. Figure 1.17 shows the options available on a context menu when a linked Revit file is selected in the Project Browser.

**Figure 1.17**
Context menu for a linked file in the Project Browser

---

**The Bottom Line**

**Navigate the ribbon interface** The ribbon is an efficient user interface style that works well in Revit. The ability to house numerous tools in a single area of the interface allows for maximum screen real estate for the drawing area.

*Master It* Along with the standard tabs available on the ribbon interface, contextual tabs also are available while you’re working on a project. Explain what a contextual tab is and how it may differ throughout your workflow.

**Utilize user interface features** Many features are available in the Revit MEP 2011 user interface that allow for quick access to tools and settings. The use of keyboard shortcuts can also improve workflow efficiency.

*Master It* It is important to workflow efficiency to know how to access features of the user interface. What tool can be used to activate or remove user interface features?

**Use settings and menus** Establishing settings for your user interface is another way to create a working environment that is the most efficient and effective for your use of Revit MEP 2011.

*Master It* The use of keyboard shortcuts has been part of design and drafting software for a long time. The ability to customize the shortcuts to best suit your workflow is key to improved efficiency. How can the settings for keyboard shortcuts be accessed? How can the settings be shared among users?