Chapter 1

**Working in Maya**

Maya’s working environment has evolved to accommodate both the individual artist as well as a team of artists working in a production pipeline. The interface in Maya 2011 has changed significantly from previous versions of the program to reflect this evolution. The interface presents tools, controls, and data in an organized fashion to easily allow you to bring your fantastic creations to life.

Understanding the way Maya organizes data about the objects, animation, textures, lights, dynamics, and all the other elements contained within the 3D environment of a scene is essential to understanding how the interface is organized. Maya uses what’s known as the Dependency Graph to keep track of the various packets of data, known as nodes, and how they affect each other. Any single element of a Maya scene consists of multiple nodes connected in a web, and each of these nodes is dependent on another. Maya’s interface consists of editing windows that allow you to connect these nodes in an intuitive way and edit the information contained within each node.

There is usually more than one way to accomplish a task in Maya. As you grow comfortable with the interface, you’ll discover which editing windows best suit your working style.

This chapter is a brief overview of what professionals need to understand when working in Maya. You’ll learn what types of nodes you’ll be working with and how they can be created and edited in Maya. You’ll also learn how to work with projects and scene data as well as the various windows, panels, and controls that make up the interface. This will help you whether you are working alone or as part of a team of artists.

If you’ve never used Maya before, we strongly encourage you to read the Maya documentation as well as *Introducing Maya 2011* by Dariush Derakhshani (Sybex, 2010). This chapter is about working with nodes, but it is not meant to be a comprehensive guide to each and every control within Maya. That information is contained within the Maya documentation.

In this chapter, you will learn to:

- Understand transform and shape nodes
- Create a project
- Use assets
- Create file references

**Creating and Editing Maya Nodes**

A Maya scene is a system of interconnected nodes that are packets of data about what exists within the world of a Maya scene. The nodes are the building blocks you, as the artist, put together to create the 3D scene and animation that will finally be rendered for the world to see. So if you can think of the objects in your scene, their motion, and appearance as nodes, think
of the Maya interface as the tools and controls you use to connect those nodes. The relationship between these nodes is organized by the Dependency Graph, which describes the hierarchical relationship between connected nodes. The interface provides many ways to view the graph, and these methods are described in this chapter.

Any given workflow in Maya is much like a route on a city map. There are usually many ways to get to your destination, and some of these make more sense than others depending on where you’re going. In Maya, the best workflow depends on what you’re trying to achieve, and there is usually more than one possible ideal workflow.

There are many types of nodes in Maya that serve any number of different functions. All the nodes in Maya are considered Dependency Graph (DG) nodes. Let’s say you have a simple cube and you subdivide it once, thus quadrupling the number of faces that make up the cube. The information concerning how the cube has been subdivided is contained within a DG node that is connected to the cube node.

A special type of DG node is the Directed Acyclic Graph (DAG) node. These nodes are actually made of two specific types of connected nodes: transform and shape. The arrangement of DAG nodes consists of a hierarchy in which the shape node is a child of the transform node. Most of the objects you work with in the Maya viewport, such as surface geometry (cubes, spheres, planes, and so on), are DAG nodes.

To understand the difference between the transform and shape node types, think of a transform node as describing where an object is located and a shape node as describing what an object is.

The simple polygon cube in Figure 1.1 consists of six flat squares attached at the edges to form a box. Each side of the cube is subdivided twice, creating four polygons per side. That basically describes what the object is, and the description of the object would be contained in the shape node. This simple polygon cube may be 4.174 centimeters above the grid, rotated 35 degrees on the x-axis, and scaled four times its original size based on the cube’s local x- and y-axes and six times its original size in the cube’s local z-axis. That description would be in the transform node (see Figure 1.1).

**Figure 1.1**
A shape node describes the shape of an object and how it has been constructed; a transform node describes where the object is located in the scene.
Maya has a number of workspaces that enable you to visualize and work with the nodes and their connections. The following sections describe how these workspaces work together when building a node network in a Maya scene.

**Using the Hypergraph**

The Hypergraph is a picture of the nodes and their connections in Maya. A complex scene can look like a very intricate web of these connections. When you really need to know how a network of nodes is connected, the Hypergraph gives you the most detailed view. There are two ways to view the Hypergraph, the hierarchy view and the connections view:

- The **hierarchy view** shows the relationships between nodes as a tree structure.
- The **connections view** shows how the nodes are connected as a web.

You can have more than one Hypergraph window open at the same time, but you are still looking at the same scene with the same nodes and connections.

This short exercise gives you a sense of how you would typically use the Hypergraph:

1. Create a new Maya scene.
2. Create a polygon cube by choosing Create ➔ Polygon Primitives ➔ Cube.
3. You will be prompted to draw a polygon on the grid by dragging on the surface. Drag a square on the grid, release the cursor, and then drag upward on the square to turn it into a three-dimensional cube (see Figure 1.2). Release the mouse button to complete the cube. At this point, feel free to make your own decisions about the size and position of the cube on the grid.
4. Select the cube in the viewport, and choose Window ➔ Hypergraph ➔ Hierarchy to open the Hypergraph in hierarchy mode. You’ll see a yellow rectangle on a black field labeled pCube1. The rectangle turns gray when deselected.

**Figure 1.2**

When Interactive Creation is on, Maya prompts you to draw the object on the grid in the scene.
Chapter 1
Working in Maya

Interactive Creation

By default Maya creates objects using the Interactive Creation method, which allows you to draw on the canvas as you create your geometry. To turn this feature off, choose the Create ➔ Polygon Primitives menu, and deselect the Interactive Creation option at the bottom of the menu.

While the Interactive Creation mode is on, you can deselect the Exit On Completion method; this means that each time you draw on the grid, you will continue to create cubes until you switch to another tool.

5. Hold the right mouse button down, and hover the cursor over the pCube rectangle. Choose Rename from the pop-up window. Rename the cube myCube.

6. Select myCube, and choose, from the Hypergraph menu, Graph ➔ Input And Output connections. This switches the view to the connections view just as if you had originally opened the Hypergraph by choosing Windows ➔ Hypergraph:Connections. It’s the same Hypergraph, but the view mode has changed, allowing you to see more of the scene.

Navigating the Hypergraph

You can navigate the Hypergraph by using the same hot key combination you use in the viewport: Alt+MMB-drag pans through the Hypergraph workspace, and Alt+RMB-drag zooms in and out. Selecting a node and pressing the f hot key focuses the view on the currently selected node. (MMB means clicking with the middle mouse button, and RMB means clicking with the right mouse button.)

When you graph the input and output connections, you see the connected nodes that make up an object and how the object appears in the scene. In the current view, you should see the myCube node next to a stack of connected nodes labeled polyCube1, myCubeShape, and initial-ShadingGroup, as shown in Figure 1.3. (The nodes may also be arranged in a line; the actual position of the nodes in the Hypergraph does not affect the nodes themselves.)

Figure 1.3
The node network appears in the Hypergraph. This shape node (myCubeShape) is connected to two other nodes, while the transform node (myCube) appears off to the side.
The myCube node is the transform node. The myCubeShape node is the shape node. In the Hypergraph, the shape and transform nodes are depicted as unconnected; however, there is an implied connection, as you’ll see later. This is demonstrated when you rename the myCube node; the shape node is renamed as well.

In Maya, the construction history feature stores a record of the changes used to create a particular node. The polyCube1 node is the construction history node for the myCubeShape node. When you first create a piece of geometry, you can set options to the number of subdivisions, spans, width, height, depth, and many other features that are stored as a record in this history node. Additional history nodes are added as you make changes to the node. You can go back and change these settings as long as the history node still exists. Deleting a history node makes all the previous changes to the node permanent (however, deleting history is undoable).

1. Keep the Hypergraph open, but select the cube in the viewport.

2. Set the current menu to Polygons (you can change the menu set by choosing Polygons from the menu in the upper left of the Maya interface).

3. Choose Mesh ➔ Smooth. The cube will be subdivided and smoothed in the viewport.

   In the Hypergraph you’ll see a new polySmoothFace1 node between the polyCube1 node and the myCubeShape node (see Figure 1.4). This new node is part of the history of the cube.

4. Select the polySmoothFace1 node, and delete it by pressing the Backspace key on the keyboard. The cube will return to its unsmoothed state.

Figure 1.4
Performing a smooth operation on the cube when construction history is activated causes a new polySmoothFace node to be inserted into the node network.
Chapter 1  Working in Maya

WORKING WITH HISTORY

Over the course of a modeling session, the history for any given object can become quite long and complex. This can slow down performance. It’s a good idea to periodically delete history on an object by selecting the object and choosing Edit ➤ Delete By Type ➤ History. You can also choose to delete all the history in the scene by choosing Edit ➤ Delete All By Type ➤ History. Once you start animating a scene using deformers and joints, you should not delete the history or use the Delete By Type ➤ Non-Deformer History option.

You can turn off the history globally by clicking the history toggle switch on the status line, as shown here.

5. Select the transform node (myCube), and press the s hot key. This creates a keyframe on all the channels of the transform node.

You’ll see a new node icon appear for each keyframed channel with a connection to the transform node (see Figure 1.5).

6. Hold the cursor over any line that connects one node to another. A label appears describing the output and input attributes indicated by the connection line.

FIGURE 1.5
The attributes of myCube’s transform node have been keyframed. The keyframe nodes appear in the Hypergraph.
Connecting Nodes with the Connection Editor

Connections between nodes can be added, deleted, or changed using the Hypergraph and the Connection Editor.

1. Start a new Maya scene.
2. Create a locator in the scene by choosing Create ➤ Locator. A simple cross appears at the center of the grid in the viewport. This locator is a simple nonrendering null that indicates a point in space. Locators are handy tools that can be used for a wide variety of things in Maya.
3. Press the w hot key to switch to the Move tool; select the locator at the center of the grid, and move it out of the way.
4. Press the g hot key to create another locator. The g hot key repeats the last action you performed, in this case the creation of the locator.
5. Create a NURBS sphere in the viewport by choosing Create ➤ NURBS Primitives ➤ Sphere. If you have Interactive Creation selected, you’ll be prompted to drag on the grid in the viewport to create the sphere; otherwise, the sphere will be created at the center of the grid based on its default settings.

NURBs

A Non-Uniform Rational B-Spline (NURBS) object is a type of surface that is defined by a network of editable curves. Chapter 3 introduces how to create and model NURBS surfaces.

6. Move the sphere away from the center of the grid so you can clearly see both locators and the sphere.
7. Use the Select tool (hot key = q) to drag a selection marquee around all three objects.
8. Open the Hypergraph in connections mode by choosing Window ➤ Hypergraph:Connections. You should see eight nodes in the Hypergraph (see Figure 1.6).

Figure 1.6
The input and output connections of the two locators and the sphere are graphed in the Hypergraph.
locator1 and locator2 are the two transform nodes for the locators. locatorShape1 and locatorShape2 are the two shape nodes for the locators. nurbsSphere1 is the transform node for the NURBS sphere. And nurbsSphereShape1 is the shape node for the sphere; it’s connected to MakeNurbsSphere1, which is the history node, and to initialShadingGroup. The initialShadingGroup node is the default shading group that is applied to all geometry; without this node, the geometry can’t be shaded or rendered. When you apply a new shader to an object, the connection to initialShadingGroup is replaced with a connection to the new shader.

9. In the Hypergraph window, use Alt+RMB to zoom out a little.

10. Select the locator1, locator2, and nurbsSphere1 nodes, and drag them away from the other nodes so you can work on them in their own space.

11. In the Hypergraph, MMB-drag the locator1 node over the nurbsSphere1 node.

12. From the pop-up menu, choose Other at the bottom (Figure 1.7). A new dialog box will open; this is the Connection Editor.

**FIGURE 1.7**
You can connect two nodes in the Hypergraph by MMB-dragging one on top of the other and choosing from the options in the pop-up menu.

The Connection Editor is where you create and edit connections between nodes. The left side of the panel represents the output of a selected node, in this case the locator1 node. The output is the controlling node; the right side is the input, and in this case is nurbsSphere1, which will be controlled based on whatever connections you make in the list.

The list represents the attributes of each node. Any of the attributes that have a plus sign next to them can be expanded to reveal nested attributes. For instance, find the Translate attribute in the left side of the column, and expand it by clicking the plus sign. You’ll see that Translate has Translate X, Translate Y, and Translate Z. This means you can choose either to select the Translate attribute, which will automatically use all three nested attributes as the output connection, or to expand Translate and choose one or more of the nested Translate X, Y, or Z attributes as the output connection. In some situations, a connection becomes grayed out, indicating that the connection between the two attributes cannot be made, usually because the connection is not appropriate for the selected attributes (see Figure 1.8).
13. Select the Translate attribute on the left. You’ll notice that many of the selections on the right side become grayed out, meaning that they cannot be connected to Translate. This is because Translate is a vector—it is an output consisting of three connections (Translate X, Translate Y, and Translate Z). The vector can be connected only to other vectors on the right side of the list.

14. On the right side, scroll down and select Translate. Both connections in the list are italicized, indicating that there is a connection to this attribute. If one of the other attributes on the right were italicized, it would indicate that another node is already connected to that attribute (see Figure 1.8).

15. In the viewport, switch to wireframe mode. You can do this by pressing 4 on the keyboard or clicking the wireframe icon on the icon bar at the top of the viewport window; the wireframe icon is the wireframe cube.

16. In the viewport, you’ll notice that the sphere has snapped to the same position as the locator. Select the sphere, and try to move it using the Move tool (hot key = w). The sphere is locked to the locator, so it cannot be moved. Select the locator, and try to move it; the sphere moves with the locator. The output of the locator’s Translate attributes are the input for the sphere’s Translate.

**Incoming Connections**

In wireframe view, an object will be highlighted in purple if it has an incoming connection from the selected object.
17. Select the nurbsSphere1 node in the Hypergraph, and MMB-drag it on top of locator2.

18. From the pop-up list, choose Rotate (see Figure 1.9). The Connection Editor opens again.

**Figure 1.9**
The nurbsSphere1 node is MMB-dragged on top of the locator2 node, making the sphere the input connection for locator2.

---

**Specifying Connections**

In some cases when you choose to make a connection from the pop-up window, Maya will automatically make it for you without opening the Connection Editor; however, in other cases, even when you choose what seems like an obvious connection from the list, Maya will still open the Connection Editor so you can make exactly the connection you want.

19. Now the nurbsSphere1 node is listed on the left, and locator2 is on the right. Find the Rotate attributes, expand the list, and choose Rotate X from the list.

20. On the right side, find the Rotate attributes, expand them, and choose Rotate Y. This causes the Rotate X of the nurbsSphere1 node to control the Rotate Y of the locator.

21. In the viewport, select the sphere, and switch to the Rotate tool (hot key = e).

22. Drag up and down on the red circle of the tool to rotate the sphere in X only. The locator rotates around its y-axis.

---

**Use the Connection Editor to Make Simple Connections**

The Connection Editor is best used when you want to make a one-to-one relationship between attributes on two nodes. In other words, the value of the output connection needs to equal exactly the value of the input connection. More complex connections can be made using expressions, special nodes, or Set Driven Key. All of these options will be discussed throughout the book.
You can break a connection by reselecting the connected node on either side of the Connection Editor so that the attribute is no longer highlighted. You can also select the connecting line in the Hypergraph and press the Delete key to break the connection.

**Creating Node Hierarchies in the Outliner**

The Outliner shows a hierarchical list of the nodes in the scene in a form similar to the outline of a book. It is another way to view the transform and shape nodes in a scene and a way to create hierarchical relationships between nodes through parenting. The Outliner does not show the connections between nodes like the Hypergraph; rather, it shows the hierarchy of the nodes in the scene. To see how this works, try the following exercise:

1. Open the miniGun_v01.ma file from the Chapter1/scenes directory on the DVD. The scene consists of a minigun model in three parts.

2. Open the Outliner by choosing Window ➤ Outliner.

**OUTLINER LAYOUT PRESETS**

The Outliner can be opened as a separate panel or, like many of the panels in Maya, can be opened in a viewport. A popular window arrangement is to split the viewports into two views, with the left view set to the Outliner and the right view set to the perspective view. You can open this arrangement by going to the menu bar in a viewport window and choosing Panels ➤ Saved Layouts ➤ Persp/Outliner (as shown here). You can also click the third layout button on the left side of the interface just below the toolbox.

3. At the top of the Outliner is a menu bar. In the Display menu, make sure DAG Objects only is selected and Shapes is deselected (see Figure 1.10).

**FIGURE 1.10**
The Display menu at the top of the Outliner
In the Outliner, you’ll see three nodes listed: gunBarrels, housing, and mount in addition to the four default cameras and several set nodes (don’t worry about the set nodes). These are the three transform nodes for the pieces of the minigun. Select each node, and you’ll see the corresponding part highlighted in the perspective view. At the moment, each piece is completely separate and unconnected.

4. Select the housing node, and switch to the Rotate tool (hot key = e).

5. Rotate the objects; nothing else is affected. Try moving housing (hot key = w); again, nothing else is affected.

6. Hit Undo a few times until the housing node returns to its original location and orientation.

7. In the Outliner, select the gunBarrels object. Then Ctrl+click the housing object, and choose Edit ➤ Parent.

Parenting one object to another means you have made one transform node the child of the second. When an object is a child node, it inherits its position, rotation, scale, and visibility from the parent node. In the Outliner, you’ll notice that the housing node has a plus sign beside it and the gunBarrels node is not visible. The plus sign indicates that the node has a child node.

8. Click the plus sign next to the housing node to expand this two-node hierarchy. The gunBarrels node is now visible as the child of the housing node.

9. Select the housing node, and try rotating and translating it. The gunBarrels node follows the rotation and translation of the housing node (see Figure 1.11).

Unlike the situation presented in the “Connecting Nodes with the Connection Editor” section of the chapter, the rotation and translation of the gunBarrels object are not locked to the rotation and translation of the housing node; rather, as a child, its rotation, translation, scale, and visibility are all relative to that of its parent.

**Figure 1.11**
When the gunBarrels node is made a child of the housing object, it inherits changes made to the housing object’s transform node.
10. Select the gunBarrels node, and try rotating and translating the object; then rotate and translate the housing node. You’ll see the gun barrels maintain their position relative to the housing node. You could create an animation in which the gun barrels rotate on their own z-axis to spin around while firing, while the housing node is animated, rotating on all three axes in order to aim.

11. Hit Undo a few times (hot key = Ctrl+z) until both the housing and gunBarrel objects are back to their original positions.

12. In the Outliner, select the housing node, and MMB-drag it on top of the mount node. This is a way to quickly parent objects in the Outliner.

13. Click the plus signs next to the mount and housing nodes in the Outliner to expand the hierarchy. The lines indicate the organization of the hierarchy; the gun barrels are parented to the housing node, which is parented to the mount node.

---

**SHIFT+CLICK TO EXPAND THE HIERARCHY**

You can expand an entire hierarchy with one click in the Outliner. Just Shift+click the arrow for the hierarchy you want to expand.

---

14. Select the mount node, and choose Edit ➤ Duplicate (hot key = Ctrl+d). This makes a copy of the entire hierarchy. The duplicated mount node is named mount1.

15. Select the mount1 node, and switch to the Move tool (hot key = w). Pull on the red arrow of the tool to move the duplicate along the x-axis about two units.

16. Select the mount node, and then Ctrl+click the mount1 node in the Outliner.

17. Choose Edit ➤ Group (hot key = Ctrl+g) to group these two nodes under a single parent node.

   A group node is a transform node that has no shape node. It’s just a location in space used to organize a hierarchy. Like a parent node, its children inherit its rotation, translation, scale, and visibility.

18. Select the group1 node, and Shift+click the plus sign next to it in the Outliner to expand the group and all its children.

19. Double-click the label for the group1 node in the Outliner to rename it; rename the group **guns**.

---

**RENAME NODES**

You’ll notice that the duplicate mount node has been renamed mount1 automatically. Nodes on the same level of the hierarchy can’t have the same name. The child nodes do have the same name, and this is usually a bad idea. It can confuse Maya when more complex connections are made between nodes. Whenever you encounter this situation, you should take the time to rename the child nodes so that everything in the scene has a unique name.
20. Select the mount1 node in the Guns hierarchy, and choose Modify > Prefix Hierarchy Names.

21. In the pop-up window, type right_. This renames the top node and all its children so that “right_” precedes the name. Do the same with the other mount node, but change the prefix to left_.

22. Select the guns group, and choose Modify > Center Pivot. This places the pivot at the center of the group. Try rotating the Guns group, and you’ll see both guns rotate together (see Figure 1.12).

Each member of the hierarchy can have its own animation, so both gun barrels can rotate around their z-axes as they fire, the two housing nodes could be animated to aim in different directions, and the two guns could rotate as one unit, all at the same time. The entire group can be parented to another node that is part of a vehicle.

**Displaying Options in the Outliner**

There are several options in the Outliner for displaying nodes and their hierarchical arrangements. You can see that the default perspective, top, side, and front cameras are visible as nodes at the top of the Outliner. Also, there are a number of sets such as the defaultLightSet that appear at the bottom of the Outliner. These sets are mainly used for organization of data by Maya and are usually not directly edited or altered.

1. In the Display menu of the Outliner, select the Shapes option to display the shape nodes of the objects. The shape nodes appear parented to their respective transform node. You can select either the transform node or the shape node in the Outliner to select the object.
You can right-click in the Outliner to quickly access the Outliner’s display options rather than use the menu at the top of the Outliner.

2. In the Display menu, activate the visibility of attributes by selecting the Attributes (Channels) option. Each node now has an expandable list of attributes. Most of the time you may want this option off because it clutters the Outliner and there are other ways to get to these attributes. Ultimately, how you use these options is up to you.

3. Turn off the Attributes display, and turn off the DAG Objects Only option. This allows you to see all the nodes in the scene in the Outliner list as opposed to just the DAG nodes.

DAG stands for “Directed Acyclic Graph,” and DAG objects are those objects that have both a shape and a transform node. It’s not really crucial to understand exactly what Directed Acyclic Graph means as long as you understand that it is an arrangement in which a shape node is parented to a transform node. When you turn off DAG Objects Only in the Outliner, you’ll see all the nodes in the Maya scene appear. Many of these are default utility nodes required to make Maya function, such as the renderLayerManager node or the dynController1 node. Many other nodes appear when you create a new node or connection. An example of this would be a keyframe or an expression node.

When you turn off DAG Objects Only, the list can get quite long. To find a node quickly, you can type the node’s name in the field at the very top of the Outliner. This hides all nodes except the named node. Clearing the field restores the visibility of all nodes in the Outliner (see Figure 1.13).

**Figure 1.13**
The Outliner can display shape nodes as well as other types of nodes in the scene.
Additional viewing options are available in the Show menu, which contains options for displaying only nodes of a certain type. Throughout this book the Outliner will be used extensively, so you’ll have lots of practice working with this panel.

To see a finished version of the scene, open minGun_v02.ma from the chapter1\scenes directory on the DVD.

Real World Scenario

**SEARCHING FEATURES IN THE OUTLINER**

A complex scene in Maya can easily have hundreds of nodes. Just one character often has associated geometry, dozens of animation controls, joints, textures, and so on. Add another character to the scene with their own set of node networks, and the Outliner can become very cluttered very quickly. Establishing an organized naming system for the nodes in your scenes has many benefits, one of which is that you can use the search feature in the Outliner to filter what is displayed, thus making it easy to access the nodes you need. In my work, I make sure that I take the time to name my nodes in such a way as to make searching easy. The following illustrates how the search feature can be used in a complex scene.

Let’s say I have a scene with two complex characters, one named Larry and the other named Cecil. Both characters have similar rigs that use NURBS curves to control their animation rigs, and both have geometry, joints, shaders, and so on. When naming the nodes associated with each character, I would make sure that all larry nodes start with the name “larry.” So, Larry’s skin geometry might be named “larry_SKIN_GEO,” while his clothes would use names like “larry_PANTS_GEO.” Using capital letters in this case is purely personal preference; the important thing is that the name of each node starts with “larry.” Cecil would use the same convention; his skin geometry would be “cecil_SKIN_GEO,” and his pants would be “cecil_PANTS_GEO.” I end the names using GEO, so I know that this is a geometry node.

The controls for the animation rig would use names like “larry_LEFT_HAND_wrist_CTRL1,” “larry_SPINE_CTRL1,” and “larry_NECK_CTRL1.” You get the idea. You can see that each of these nodes belongs to Larry, nodes for the left side of the body are clearly identified, the associated body part is identified, and they end with the letters CTRL. The same goes for Cecil.

Now here’s where this type of organization, or something similar, is helpful in the Outliner. At the top of the Outliner is a blank field. To filter the nodes listed in the Outliner, you need to type some text and either precede or follow the text with an asterisk (*). The asterisk tells Maya to show all nodes that use the text before or after the asterisk in the name. So if you want to see all nodes associated with larry, type larry*. If you want to see all the control nodes for both Cecil and Larry, type *CTRL*. In this case, there may be text before and after the CTRL letters, so use an asterisk before and after CTRL. If you want to see the controls associated with Cecil’s hands, type cecil*HAND*, and so on.
The following images show variations on how to search through the Outliner with this method. If nothing appears in the Outliner when you type some text, check to see whether the asterisk is in the right place. To find one specific node, type its full name without the asterisk.

The Channel Box

The term channel is, for the most part, interchangeable with attribute. You can think of a channel as a container that holds the attribute’s value. The Channel Box is an editor that lists a node’s attributes for quick access. The Channel Box displays the node’s attributes, which are most frequently keyframed for animation.

The Channel Box is located on the right side of the screen at the end of the status bar when the view mode button in the upper right of the status line is set to Show The Channel Box/Layer Editor (see Figure 1.14).

Figure 1.14
The icon in the upper right of the interface toggles the visibility of the Channel Box.
Chapter 1

There are two tabs on the very right side of the screen that allow you to quickly switch between the Channel Box and the Attribute Editor, as shown in Figure 1.15. (The Attribute Editor is discussed in detail later in this chapter.) These tabs are visible when both the Attribute Editor icon and the Channel Box icon are activated on the status bar in the upper-right corner of the interface.

This short exercise gives a quick tour of how to work in the Channel Box:

1. Create a new scene in Maya, and create a NURBS Sphere on the grid (Create ➤ NURBS Primitives ➤ Sphere). You’ll be prompted to draw the sphere on the grid if Interactive Creation mode is on; if not, the sphere will appear at the center of the grid. Either option is fine.

2. Make sure the Channel Box is visible on the right side of the screen. To do this, click the icon at the farthest right of the status bar (shown in Figure 1.14). This is a toggle to display the Channel Box. Click it until the Channel Box appears, as in Figure 1.16.

3. The Channel Box will list the currently selected object. Select the sphere, and you’ll see nurbsSphere1 appear. The list below it shows the attributes for the nurbsSphere1’s transform node.
The lower half of the Channel Box lists the connections to this node. You’ll see the name of the associated shape node under SHAPES, and below this a section for the inputs. In this case, the input is the history node, named makeNurbSphere1, which contains the original settings used to create the sphere. If you delete history on the sphere, these attributes will no longer be accessible.

4. In the upper section of the Channel Box, under nurbsSphere1, try selecting the fields and inputting different values for Translate, Scale, and Rotate. The sphere updates its position, orientation, and size.

5. In the Visibility channel, select the word On in the field, and type 0. The sphere disappears. Input the value 1, and it reappears. Visibility is a Boolean, meaning it is either on or off, 1 or 0.

6. Select the Translate X field so it is highlighted. Shift+click the Rotate Z value, and all the values in between are also selected.

7. Type 0 in the Translate X field while they are selected, which sets all the Translate and Rotate values to the same value, places the sphere at the center of the grid, and returns it to its original orientation (see Figure 1.17).

8. In the makeNurbsSphere section, highlight the Start Sweep channel. Enter a value of 90, and the sphere opens up. You’re altering the construction history of the sphere so it is no longer a closed surface.

9. Select the word Sections so it is highlighted in blue. MMB-drag in the viewport view back and forth. Doing this creates a virtual slider so you can change the value of the field interactively instead of numerically. This should work for all the channels (most of the time).

10. Set the timeline to frame 1, and press the s hot key. You’ll see all the channels turn orange, indicating that they have been keyframed. The s hot key keyframes all the available channels.

11. Move the timeline to frame 24, and change some settings on both the transform node (the upper half of the Channel Box) and under makeNurbsSphere1.

12. Press the s hot key again to set another key. Play the animation, and you’ll see the sphere update based on the keyframed changes.
The s hot key keyframes everything, even those channels you may not need to keyframe. You can use the Channel Box to keyframe specific channels.

13. Rewind the timeline, and choose Edit ➤ Keys ➤ Delete Keys to remove all the keyframes on the sphere.

14. Highlight Translate X and Shift+click Translate Z so that the translation channels are all selected.

15. Right-click these values, and choose Key Selected (see Figure 1.18).

16. Move to frame 24, and enter different values in the Translate fields.

17. Right-click and choose Key Selected. This places a keyframe on just the selected channels, which is often a cleaner and more efficient way to work because you’re placing keyframes only on the channels you need to animate and not on every keyable channel, which is what happens when you use the s hot key.

**Be Thrifty with Keyframes**

Creating extra, unnecessary keys leads to a lot of problems, especially when you start to refine the animation on the Graph Editor (discussed in Chapter 5). Keyframes also can increase the scene size (the amount of storage space the scene uses on disk). Be cheap with your keyframes, and use the Key Selected feature to keyframe only the channels you need. Avoid using the s hot key to create keys on everything.

18. To remove keys, you can highlight the channels, right-click, and choose Break Connections. This removes any inputs to those channels. The values for the current keyframe will remain in the channels.

The channels are color coded to show what kind of input drives the channel:

- Pink indicates a keyframe.
- Purple indicates an expression.
- Yellow indicates a connection (as in a connection from another node or channel made in the Connection Editor).
- Brown indicates a muted channel.
- Gray means the channel is locked.
Locking and Muting Channels

You can mute a channel by right-clicking it and choosing Mute Selected from the pop-up menu. When you mute a channel, the keyframes on that channel are temporarily disabled; as long as the channel is muted, the animation will not update. This is useful when you want to disable the keyframes in a channel so that you can focus on other aspects of the animation. Locking a channel is another option available when you right-click selected channels in the Channel Box. A locked channel prevents you from adding keyframes to a channel regardless of whether it has been animated. Animation techniques are explored further in Chapter 5.

The Channel Box will be explored throughout the book and used frequently, particularly in the chapters concerning animation.

The Attribute Editor

The Attribute Editor is a tabbed panel that gives detailed information and access to a node’s attributes. The tabs at the top of the editor allow you to move between the attributes of all the upstream (input) and downstream (output) connected nodes. This exercise gives a brief tour on how to use the Attribute Editor:

1. Create a new scene in Maya. Create a polygon cube on the grid (Create ➤ Polygon Primitives ➤ Cube).
2. Select the cube, and open its Attribute Editor. There are several ways to do this:
   - Right-click the cube, and choose pCube1.
   - Select the cube, and choose Windows ➤ Attribute Editor.
   - Click the Show Or Hide The Attribute Editor icon in the upper right of the Maya interface (Figure 1.19).
3. With the Attribute Editor open, choose the pCube1 tab at the top (Figure 1.20). The panel that opens contains the attributes for the cube’s transform node, much like the upper section of the Channel Box described in the previous section. It also contains options for setting limits on the transform attributes.

Figure 1.19
The Show Or Hide The Attribute Editor icon resides in the upper-right corner of the Maya interface.

Figure 1.20
The Attribute Editor contains tabs that allow you to move through the connected nodes of a network.
Many of the settings can be accessed through the Attribute Editor’s rollout panels. These are collapsible sections of grouped settings.

4. In the Attribute Editor, on the pCube1 tab, click the triangle next to mental ray. This reveals mental ray–specific settings related to the cube. Note that there are subsections under mental ray that are also collapsible.

5. Choose the pCubeShape1 tab at the top of the Attribute Editor. This tab contains settings related to the shape node. For example, expand the Render Stats section, and you’ll see a list of settings that control how the shape will appear in a render.

6. Choose the polyCube1 tab, and you’ll see the construction history settings. If you delete history on the cube, this tab will no longer appear.

7. Expand the Poly Cube History rollout. If you right-click any of the fields, you get a pop-up menu that offers options, such as expressions, key setting, or locking, much like the fields in the Channel Box (Figure 1.21).

8. In the Subdivisions Width field, type \(9 \times 2\). The field becomes highlighted, indicating that you can add an expression.

9. Type \(9 \times 2\); and press the Enter key on your keyboard’s numeric keypad (see Figure 1.22). This adds an expression to this attribute that makes the Subdivisions Width value equal to 18. Note that the field turns purple, and the slider can no longer be moved.

**Figure 1.21**
Right-clicking an attribute field reveals a menu with options for animating the attribute value.

**Figure 1.22**
You can enter simple mathematical expressions directly into a field in the Attribute Editor.
Creating and Editing Maya Nodes

Note that a new tab called Expression1 is added to the top of the Attribute Editor; this is a new expression node that is now part of the cube’s node network.

If the number of connected nodes is too large to fit within the tab listing at the top, you can use the two arrow buttons to the right of the tabs to move back and forth between the tab listings. Likewise, if not all connections are visible, you can use the Go To Input and Go To Output Connections buttons to the right of the field indicating the node name.

The Notes field at the bottom is useful for typing your own notes if you need to keep track of particular settings or leave a message for yourself or other users (see Figure 1.23). You can collapse this section by dragging the bar above it downward, thus making more room for the other settings in the Attribute Editor.

**Figure 1.23**
Messages can be entered in the Notes section at the bottom of the Attribute Editor.

<table>
<thead>
<tr>
<th>Load Attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td>You can use the Load Attributes button if the attribute display needs to be refreshed. Maya automatically updates the editor when new attributes are added, but occasionally it misses an update and needs to be refreshed.</td>
</tr>
</tbody>
</table>

The Attribute Editor is the workhorse panel of Maya. Throughout this book we will use it constantly. Make sure you are comfortable with the core concepts of how to switch between node settings using the tabs as well as how to change the available values.

**Working with Shader Nodes in the Hypershade**
The Hypershade, as the name suggests, is similar in function to the Hypergraph. It gives a visual display of how nodes in a Maya scene are connected. The Hypershade is mostly concerned with shaders—nodes used to define the color and material properties of renderable objects in a scene. These include materials (also known as shaders), textures, lights, cameras, and shading utilities. However, it is not unusual to use the Hypershade Work Area to make connections between other types of nodes as well. In this exercise, you’ll use the Hypershade to connect several types of nodes.

1. Create a new scene in Maya. Create a NURBS cone on the grid. You’ll be prompted to draw the cone on the grid if Interactive Creation mode is on; if it is not, the sphere will appear at the center of the grid. Either option is fine.

2. Switch to smooth shaded mode by pressing 6 on the keyboard, or click the Smooth Shade All and Textured icons on the viewport’s menu bar (Figure 1.24).

3. Press 3 on the keyboard to switch to a high-quality display of the geometry.

4. Open the Hypershade by choosing Window ➤ Rendering Editors ➤ Hypershade.
Chapter 1

Working in Maya

The Hypershade comprises several frames. The format of this editor has been updated in Maya 2011. On the left side is a list and a visual menu of the nodes you can create in the Hypershade. The list is divided into sections for the Maya nodes, mental ray nodes, and a customizable list for your own favorites at the very top. Clicking a category in the list filters the node creation buttons to the right of the list, which helps to cut down on the amount of time you need to hunt for specific nodes. To add a node to the Favorites list, MMB-drag the node button from the right on top of the Favorites menu. You can also search through the nodes by typing in the field at the very top of the list. For example, typing mia in this field filters the node creation buttons so that all the mia (mental images architectural) nodes are displayed (see Figure 1.25).

The Hypershade comprises several frames. The format of this editor has been updated in Maya 2011. On the left side is a list and a visual menu of the nodes you can create in the Hypershade. The list is divided into sections for the Maya nodes, mental ray nodes, and a customizable list for your own favorites at the very top. Clicking a category in the list filters the node creation buttons to the right of the list, which helps to cut down on the amount of time you need to hunt for specific nodes. To add a node to the Favorites list, MMB-drag the node button from the right on top of the Favorites menu. You can also search through the nodes by typing in the field at the very top of the list. For example, typing mia in this field filters the node creation buttons so that all the mia (mental images architectural) nodes are displayed (see Figure 1.25).

The right side of the Hypershade contains a visual display of the nodes in the scene at the top and the Work Area at the bottom (Figure 1.26). The upper section is organized by tabs named Materials, Textures, Utilities, Lights, Cameras, Shading Groups, Bake Sets, Projects, and Container Nodes. If you want to access all the file textures used in the scene, you can choose the Textures tab to see them listed with preview icons.

5. On the left side of the Hypershade, click Surface in the list of Maya nodes. Click the Blinn button to create a new Blinn material.

You can see the new blinn1 material listed on the Materials tab; it also appears in the Work Area.
If tabs appear to be missing, you can revert to the default tab layout by choosing Tabs ➤ Revert To Default Tabs, as shown here. This clears the current tabs and replaces them with the default Materials, Textures, Utilities, Lights, Cameras, and other default tabs. You can use the Tabs menu to create your own custom tabs and determine which tabs you want visible and in what order.

**Default Scene Materials**

All Maya scenes start with three materials already created: lambert1, particleCloud, and shaderGlow. The lambert1 material is the default material applied to all newly created geometry, the particleCloud material is a special material reserved for particle cloud objects, and the shaderGlow node sets the glow options for all shaders in the scene.
6. Select the blinn1 material in the Work Area, and from the menu at the top of the Hypershade choose Graph ➤ Input And Output Connections. This displays all the upstream and downstream nodes connected to blinn1. Upstream nodes are nodes that plug into a node and affect its attributes; downstream nodes are ones that are affected by the node.

The blinn1SG node is a downstream node known as a shader group, connected to blinn1. All materials have a shader group node connected to them. This node is a required part of the network that defines how the shader is applied to a surface and is often used when creating complex mental ray shader networks and overrides (see Figure 1.27).

**Figure 1.27**
Shaders all have shading group nodes attached, which define how the shader is applied to the geometry.

7. In the Work Area of the Hypershade, select the blinn1 node, right-click it, and choose blinn1. This opens the Attribute Editor for the Blinn shader, if it’s not open already. This is where you adjust the settings that define the look of the material.

8. In the viewport, select the cone. You can apply the blinn1 material in several ways to the cone:

- MMB-drag the material icon from the Hypershade on top of the cone in the viewport window.
- Select the cone, right-click the blinn1 node in the Hypershade, and choose Assign Material To Selection (Figure 1.28).
- Right-click the surface in the viewport, and choose Assign New Shader to create a new shader or choose Assign Existing Material to assign a shader you’ve already created.

**Figure 1.28**
Right-click a shader, and drag upward on the marking menu to choose Assign Material To Selection.
Use the Shelf Buttons to Create a New Shader

You can assign a new material to a surface using the buttons in the rendering shelf at the top of the Maya interface (shown here). If you select an object and click one of these buttons, a new shader is created and assigned to selected objects. If no objects are selected, then it just creates a new shader, which you’ll find on the Materials tab of the Hypershade.

9. In the Attribute Editor for the blinn1 node, rename the material **coneShader** by typing in the field at the top of the editor.

10. Click the checkered box to the right of the Color slider. This opens the Create Render Node window (Figure 1.29).

![Create Render Node window](image)

**FIGURE 1.29**
Click the checkered box next to the Color slider to open the Create Render Node window.

11. Select 2D Textures from the list on the left, and click the Grid button on the right side of the panel to create a grid texture; this is applied to the color channel of the cone and is visible on the cone in the viewport when textured and smooth shaded mode is on (hot key = 6) See Figure 1.30.

12. Select coneShader in the Work Area, and right-click its icon. Choose Graph Network. You’ll see that the coneShader node now has the grid1 texture node as well as the place2dTexture1 node attached (Figure 1.31).
13. Click the place2dTexture1 node in the Work Area, and its attributes will be displayed in the Attribute Editor.

14. Type 0.5 in the first field next to Coverage. This reduces the coverage of the grid texture in U space by one half.
NURBS UV Texture Coordinates

NURBS surfaces have their U and V texture coordinates based on the parameterization of the surface, unlike polygon meshes, which require defined UV coordinates. You can use the attributes in the place2dTexture node to position textures on NURBS surfaces. NURBS surfaces are discussed in Chapter 3, and UV coordinates are discussed in Chapter 11.

15. Select the grid1 node in the Work Area of the Hypershade to open its settings in the Attribute Editor.

16. Expand the Color Balance rollout, and click the color swatch next to Default Color. This opens the Color Chooser. Set the color to red.

Default Color

The default color of the texture is the color “behind” the grid texture. Any part of the surface that is not covered by the grid (based on the settings in the place2dTexture node) will use the default color.

17. In the left panel of the Hypershade, select 2D Textures in the Maya list, and click the Ramp button to create a ramp node. At the moment, it is not connected to any part of the coneShader network. This is another way to create render nodes in the Hypershade.

Navigating the Hypershade Work Area

You can zoom out in the Work Area of the Hypershade by holding the Alt button while dragging with the right mouse button; likewise, you can pan by holding the Alt button while MMB-dragging.

18. Select the grid texture to open its settings in the Attribute Editor.

19. In the Work Area of the Hypershade, MMB-drag the ramp texture from the Work Area all the way to the color swatch next to the Filler color in the grid’s Attribute Editor. Hold the middle mouse button while dragging; otherwise, you’ll select the ramp texture, and the Attribute Editor will no longer display the Grid texture attributes (see Figure 1.32).

20. Select the coneShader node in the Work Area of the Hypershade, and choose Graph ➢ Input And Output Connections from the Hypershade menu. In the Work Area, you can see that the ramp texture is connected to the grid texture. The grid texture is connected to the coneShader, and the shader is connected to the blinn1SG node (see Figure 1.33).
Chapter 1  Working in Maya

Graphing Shader Networks

You can graph the shader network at any time to refresh the view of the connected nodes in the Work Area. Just right-click the node you want to graph and choose Graph Network, or click the Input/Output connections button at the top of the Hypershade (shown here). More options for displaying the network are available in the Graph menu at the top of the Hypershade.
21. Select the blinn1SG node, and graph its input and output connections. The cone’s shape node appears (if the bottom caps option was on in the creation options for the NURBS cone, you’ll see a second shape node for the cone’s bottom cap surface). The blinn1SG node is also connected to the render partition and the light linker, which defines which lights are used to light the cone (see Figure 1.34).

**Figure 1.34**
The shape nodes for the cone are included in the graph when the input and output connections of the blinn1SG node are graphed.

The Hypershade is a very powerful and easy-to-use editor. You can build complex networks of nodes quickly just like rearranging building blocks. You can see how nodes are connected by holding the mouse pointer over the lines that connect the nodes.

The previous sections of this chapter revealed the many ways Maya nodes can be displayed, connected, and edited in a Maya scene. You should make sure that you are comfortable with the basics of working with the editors described. You will rely on them heavily throughout the book, and through the various exercises you will gain proficiency in using them.

**Creating Maya Projects**

Organization is the key to creating a successful animation. Whether you are working by yourself or with others in a production pipeline, you’ll want to know where to find every file related to a particular project, whether it’s a scene file, a texture map, an image sequence, or a particle disk cache. To help you organize all the files you use to create an animation, Maya offers you the option of easily creating a Maya project, which is simply a directory with subfolders where each file type related to your scenes can be stored.

**Creating a New Project**

Creating a new project is very simple. Projects can be created on your computer’s primary hard drive, a secondary drive, or a network. The scene files used for each chapter in this book are stored in their own project directories on the DVD that comes with the book. Maya uses a default project directory when one has not been specified. This is located in your My Documents\maya\projects folder in Windows or Documents\maya\projects on a Mac. As an example, you’ll create a project directory structure for the examples used in this chapter.

1. Start a new Maya 2011 session. You’ll note that an empty scene is created when you run Maya.
2. Choose File ➤ Project ➤ New.

3. The New Project dialog box opens. In the Name field, type Mastering Maya Chapter01.

4. In the Location field, use the Browse button to find where on your computer or network you want the project to be stored, or simply type the path to the directory. The project folder can be a subfolder of another folder if you like (see Figure 1.35).

In the Project Locations section, you’ll see a large number of labeled fields. The labels indicate the different types of files a Maya scene may or may not use. The fields indicate the path to the subdirectory where these types of files will be located.

5. At the bottom of the New Project dialog box, click the Use Defaults button. This automatically fills in all the fields (see the left side of Figure 1.36).

**Figure 1.35**
The New Project dialog box lets you set the location of a new project directory structure on your hard drive.

**Figure 1.36**
Clicking the Use Defaults button fills in all the fields with Maya’s preferred default file structure (left side of the image). The directory structure is created on the specified drive (right side of the image).
The fields contain the name of the subdirectory relative to the project file. So when you choose to use the default settings, all Maya scene files (files with the .mb or .ma file extension) will be stored in a folder labeled Scenes. The path to that folder will be, in this example, Mastering_Maya_Chapter01\Scenes.

**EDITING DEFAULT FILE LOCATIONS**

If you decide you want to store the scene files in a different directory, you can type the path to that directory in the field or type a name of a directory you’d like Maya to create when it makes the project.

6. Click Accept. Maya will take a few moments to create the project directory and all subfolders on the specified disk drive.

7. Use your computer’s file browser to locate the new project; then expand the folder, and you’ll see all the subfolders (see the right side of Figure 1.36).

**Editing and Changing Projects**

You may not need to use every folder Maya creates for you, or you may decide to change where Maya looks for elements, such as file textures. If you’re working on a number of different projects, you may need to switch the current project. All of these options are available in the Maya File menu.

1. To edit the current Project, choose File ➤ Project ➤ Edit Current. The Edit Project window opens with all the paths to the project subdirectories. You can type a new directory path into any one of these fields.

**RELINKING FILES AFTER CHANGING PROJECT SETTINGS**

If you edit the project, Maya will look in the newly specified folders from this point on, but files used prior to editing the project will not be copied or moved. You’ll need to move these files using the computer’s file browser if you want Maya to easily find them after editing the project.

If you don’t want a particular directory to be created when you set up a project, leave the field blank.

2. To switch Projects, you can choose File ➤ Project ➤ Set or choose a project listed in the Recent Projects menu.

When working on a project with a number of other animators, you can choose to share the same project, which is a little risky, or each animator can create their own project directory structure within a shared folder. The latter example is a little safer because it prevents two people...
from having the same project open or overwriting each other's work. Later in the chapter, you'll learn how multiple animators can share parts of the scene using file references.

It is possible to work on a scene file outside the current project. This happens usually when you forget to set the project using the File ➤ Project ➤ Set option. Make a habit of setting the current project each time you start to work on a scene; otherwise, linked files such as textures, dynamic caches, and file references can become broken, causing the scene to behave unpredictably (which is a nice way of saying the scene will fall apart and possibly crash Maya).

### Overriding Project Settings

You can choose to override a project setting for an individual scene element. For instance, by default, Maya looks to the source images directory for file textures. However, when you create a file texture node, you can use the Browse button to reference a file anywhere on your machine or the network. This is usually not a great idea; it defeats the purpose of organizing the files in the first place and can easily lead to broken links between the scene and the texture file. It's a better idea to move all file textures used in the scene to the source images directory or whatever directory is specified in your project settings.

### Organizing Complex Node Structures with Assets

A production pipeline consists of a number of artists with specialized tasks. Modelers, riggers, animators, lighting technical directors (TDs), and many others work together to create an animation from a director's vision. Organizing a complex animation sequence from all the nodes in a scene can be a daunting task. Assets are a workflow management tool designed to help a director separate the nodes in a scene and their many attributes into discrete interfaces so each team of specialized artists can concern itself only with its own part of the project.

Assets are a collection of nodes you choose to group together for the purpose of organization. An asset is not the same as a group node; assets do not have an associated transform node and do not appear in the viewport of a scene. For example, a model, its animation controls, and its shaders can all be placed in a single asset. This example demonstrates some of the ways you can create and work with assets.

### Creating an Asset

In this example, you'll create an asset for the front wheels of a vehicle:

1. Open the `vehicle_v01.ma` file from the `Chapter1\scenes` directory on the DVD. You'll see a three-wheeled vehicle. In the Outliner, the vehicle is grouped.

2. Expand the vehicle group in the Outliner. The group consists of subgroups for the two front wheels, the rear wheel, the chassis, the suspension, and a NURBS curve named steering.

3. Select the steering node in the Outliner. This is the animation control for the steering. Switch to the Rotate tool (hot key = e), and drag the green circular handle of the Rotate tool to rotate the steering node on the y-axis. The front wheels match the arrow's orientation (see the left image in Figure 1.37).
If you select one of the front_wheel groups in the Outliner, you’ll see that its Rotate Y channel is colored yellow in the Channel Box, indicating it has an incoming connection. The steering curve’s Y rotation is connected to both front_wheel groups’ Y connection.

4. Select steering again, and switch to the Move tool (hot key = w).

5. Move steering up and down along the y-axis by dragging the green arrow of the Move tool. The front wheels rotate on the x-axis based on the height of the steering object, making them tilt (see the right image in Figure 1.37).

If you look in the Channel Box for either of the front_wheel groups, you’ll see that the Rotate X channel is colored orange, indicating that it has been keyframed. In fact, the Rotate channels of the group use what’s known as a driven key to determine their values. The keyframe’s driver is the Y translate of the arrow group. You’ll learn more about using this technique in Chapter 5.

6. Select the vehicle group node, and switch to the Move tool.

7. Drag the red arrow of the Move tool to translate the vehicle back and forth along the x-axis. All three wheels rotate as the car moves.

If you expand the front_wheel1 group in the Outliner and select the wheel1Rotate child group node, you’ll see that the Rotate Z channel is colored purple in the Channel Box, indicating an expression is controlling its z-axis rotation. You can open the Attribute Editor for the front_wheel1 group and switch to the Expression4 tab to see the expression; see Figure 1.38. (The field isn’t large enough to display the entire expression; you can click the field and hold down the right arrow button on the keyboard to read the whole expression.) Creating expressions will be covered in Chapter 5.

This model uses a very simple rig, but already there are a lot of nodes connected to the vehicle geometry to help the job of the animator. To simplify, you can create an asset for just the wheels and their connected nodes so the animator can focus on just this part of the model to do its job without having to hunt through all the different nodes grouped in the Outliner.
8. In the Outliner, expand the vehicle group and the two front_wheel groups.

9. Ctrl+click front_wheel1, wheel1Rotate, front_wheel2, wheel2Rotate, and the steering curve node.

10. Open the Hypergraph in connections mode (Window ➤ Hypergraph:Connections).

11. In the Hypergraph menu, choose Graph ➤ Input And Output Connections (see Figure 1.39).

12. In the Hypergraph, select the node named time1 and the vehicle node, and drag them out of the way of the other nodes.

13. Drag a selection over all the nodes except time1 and vehicle. These nodes include the group nodes, keyframe nodes, and expression nodes all related to controlling the rotation of the front wheel groups.

14. In the Hypergraph menu, choose Edit ➤ Assets ➤ Advanced Assets ➤ Create Asset ➤ Options (Options is selected by clicking the small square to the right of the command list in the menu).

**Figure 1.38**
The Z rotation of the wheels is controlled by an expression node. The expression node is a separate tab in the Attribute Editor.

**Figure 1.39**
The vehicle group is expanded, and several of the nodes related to the front wheels are selected and graphed on the Hypergraph.
**The Options Box**

The small square to the right of a listing in the menu indicates the options. When you select just the listing in the menu, the action will be performed using the default settings. When you click the Options box to the right of the menu listing (shown here), a dialog box will open allowing you to change the options for the action. In this book, when you’re asked to choose options, this means you need to click the Options box to the right of the menu listing.

![Options Box Image]

15. In the Create Advanced Assets Options dialog box, set the name of the container to `front_wheels`. Make sure all the settings under Include Options and Publish Options are deselected. All of the keyframes and expressions are applied to the rotation of the wheel groups, not the geometry nodes contained in the groups, so you needn’t worry about including the contents of the groups in the asset (see Figure 1.40).

16. Choose the Create Asset option.

**Figure 1.40**
The options are set for the container that will hold all the selected nodes in the Hypergraph.

![Hypergraph Image]

**Preview the Asset Contents**

The Preview Contents options selects all the nodes that will be included in the asset when you click the Apply button, but it will not actually create the asset. This is so you can verify that you have all the various nodes you want included in the Asset before creating it.
17. Click Apply and Close to create the asset.

In the Hypergraph, you’ll see a gray box labeled front_wheels; this box is also visible in the Outliner. The time1 and vehicle nodes are still visible in the Hypergraph. It may appear as though they have been disconnected, but that’s not actually the case.

18. Select the front_wheels asset in the Hypergraph, and graph its input and output connections (Graph ➤ Input And Output Connections). The connections to the time1 and vehicle nodes are visible again.

19. Select the front_wheels asset in the Hypergraph, and click the Expand Selected Assets(s) icon on the Hypergraph menu bar (or double-click the container). You will see the nodes within the container (see Figure 1.41).

**Figure 1.41**
Expanding the view of a container in the Hypergraph makes the connections between nodes within the container visible.

20. Double-click the thick border of the asset to collapse it, or click the Collapse Selected Assets icon at the top of the Hypergraph.

You can select a node inside the container and remove it from the container by right-clicking the node and choosing Remove From Container.

21. Save the scene as **vehicle_v02.ma**.
Here are some tips for working with assets:

- To delete an asset, select it and choose (from the Hypergraph menu) Edit ➤ Asset ➤ Remove Asset. Don’t select the asset and delete it; deleting the asset will delete the contents from the scene as well.

- You can remove all the assets in a scene, without deleting their contents, by choosing Edit ➤ Delete By Type ➤ Assets.

- In the Outliner, you can expand the asset node to reveal the contents. Note that the wheel groups are no longer shown as children of the vehicle group but are now inside the asset group. The nodes themselves still behave as children of the vehicle group. If you change the position of the vehicle, the wheels will still rotate and move with the vehicle.

- Assets can be created in the Hypershade as well and can contain any type of node including shaders and textures.

- You can create assets without going into the Hypershade. Just select the nodes in the scene, and use the options in the Assets menu.

- If you choose Set Current Assets from the Assets menu, all new nodes created in the scene will automatically become part of the specified asset.

- You can use the Create Assets With Transform option in the Assets menu to create an asset with a selectable transform handle. Translating or rotating the asset will also translate and rotate the contents of the asset.

**Publishing Asset Attributes**

You can publish selected attributes of the container’s nodes to the top level of the container. This means that the animator can select the asset node and have all the custom controls available in the Channel Box without having to hunt around the various nodes in the network. You can also template your asset for use with similar animation rigs.

In this exercise, you’ll publish the attributes of the front_steering asset:

1. Continue with the file from the previous section, or open vehicle_v02.ma from the chapter1\scenes folder on the DVD.

2. In the Outliner, select the front_wheels asset, and expand the node by clicking the plus sign to the left of the node. Select the steering node from within the asset.

3. In the Channel Box, select the Translate Y channel, and from the Edit menu in the Channel Box, choose Publish To Asset ➤ Options.

4. In the Publish Attribute Options box, choose both Selected Channel Box Attributes and Custom Name.

5. Type wheelTilt in the Custom String field. Click Apply and Close (see Figure 1.42).

6. Select the front_wheels container in the Outliner; you’ll see the wheelTilt channel has been added in the Channel Box. If you change this value between -1 and 1, the arrow controller moves up and down, and the front wheels tilt.
If you need to publish a specific attribute that does not appear in the Channel Box, you can open the Attribute Editor for the appropriate node, right-click the attribute name, and choose the publish options from the pop-up menu.

Using the Asset Editor

The Asset Editor can help you further customize and manage your scene’s assets. You can use it as another way to publish specific attributes of an asset.

1. Open the scene vehicle_v03.ma from the chapter1\scenes folder on the DVD.

   In the Outliner you’ll see two containers: one for the wheels and another named carPaint, which holds the blue paint shader applied to the car.

2. To open the Asset Editor, choose Assets ➤ Asset Editor. The editor is in two panels; on the left side you’ll see all the assets in the scene.

   The Asset Editor opens in view mode. In the list of assets on the left, you can click the plus sign in the square to see the nodes contained within each container. You can see the attributes of each node listed by clicking the plus sign in the circle next to each node.

3. Select the front_wheels container, and click the pushpin icon above and to the right of the asset list to switch to edit mode. On the right side of the editor, you’ll see the wheelTilt attribute you created in the previous section.

4. Select the arrow next to wheelTilt on the right panel, and the wheels container expands to reveal the Translate channel of the steering node. This is the attribute originally published to the container as wheelTilt.

5. In the list on the left below the Translate channels, expand the Rotate attributes of the steering node. Select Rotate Y, and click the second icon from the top in the middle bar of the Asset Editor. This publishes the selected attribute to the container with a custom name (see Figure 1.43).

6. A dialog box will open, prompting you to name the selected attribute. Name it steer.
Note that steps 5 and 6 are just another way to publish an attribute; the end result is the same as when you published the wheelTilt attribute from the Channel Box in the previous section.

7. Steer now appears in the right side of the Asset Editor. The view on the right side of the Asset Editor shows the attributes grouped by node. If you want to see just the published attributes, choose View ➤ Mode ➤ Flat from the Asset Editor’s menu bar.

8. Select the front_wheels asset in the Outliner, and open its Attribute Editor.

9. Expand the Asset Attributes rollout, and turn on Black Box (see Figure 1.44). When you do this, the only attributes that appear in the Channel Box are the ones that have been published to the asset (wheelTilt and steer). Likewise, in the Outliner, you can no longer expand the asset node.

The Black Box option allows you to restrict access to an asset’s attributes so that other artists working on the team can focus on just the attributes they need.

The Asset Editor has a number of advanced features, including the ability to create templates of complex assets that can be saved to disk and used in other scenes for similar assets.
File References

File referencing is another workflow tool that can be used when a team of artists is working on the same scene. For example, by using file references, an animator can begin animating a scene while the modeler is still perfecting the model. This is also true for any of the other team members. A texture artist can work on textures for the same model at the same time. The animator and texture artist can import a reference of the model into their Maya scene, and each time the modeler saves a change, the model reference in the other scenes will update (when the animator and texture artist reload either the scene or the reference).

**FILE REFERENCING VS. IMPORTING**

File referencing is not the same as importing a Maya scene into another Maya scene. When you import a Maya scene, all the imported nodes become fully integrated into the new scene and have no links to any external files. On the other hand, file references maintain a link to external files regardless of whether the referenced files are open or closed. You can alter a referenced file in a scene, but it’s not a great idea; it can break the link to the referenced file and defeats the purpose of file referencing in the first place.

Referencing a File

In this example, you’ll reference a model into a scene, animate it, and then make changes to the original reference to get a basic idea of the file referencing workflow.

1. Find the `vehicleReference_v01.ma` scene and the `street_v01.ma` scene in the `chapter1\scenes` directory of the DVD. Copy both of these files to your local hard drive. Put them in the `scenes` directory of your current project.

2. Open the scene `street_v01.ma` from the `scenes` directory of the current project (or wherever you placed the file on your local drive). The scene contains a simple street model. A locator named `carAnimation` is attached to a curve in the center of the street. If you play the animation, you’ll see the locator zip along the curve.

3. To bring in a file reference, choose File ➤ Create Reference. The File Browser will open.

4. Find the `vehicleReference_v01.ma` scene that you copied to your local drive. Select it and choose Reference from the File dialog box. After a few moments, the car will appear in the scene (see Figure 1.45).

In the Outliner, you’ll see the `vehicleReference_v01:vehicle` node as well as the `vehicleReference_v01:front_wheels` and `carPaint` container nodes. The container node is an asset with both the wheelTilt and steer attributes created in the previous section.

**Referencing Maya Scenes**

You don’t need to do anything special to the scene you want to reference; it can be a standard Maya scene. When you reference a file in a scene, all of its associated nodes appear using the referenced file’s scene name as a prefix. You can change this to a custom string using the options in the Create Reference command.
5. In the Outliner, select the carAnimation locator, and then Ctrl+click the vehicleReference_v01:vehicle node.

6. Switch to the Animation menu set, and choose Constrain ➔ Parent ➔ Options.

7. In the options for the Parent constraint, turn off Maintain Offset, make sure both Translate All and Rotate All are selected, and set the weight to 1.

8. Click Add to make the constraint. The car is now constrained to the locator and will zip along the curve in the center of the street.

9. Try setting keyframes on the wheelTilt and steer attributes of the vehicleReference_v01:front_wheels node.

10. Save the scene to your local scenes directory as street_v02.ma.

11. Open the vehicleReference_v01.ma scene from the directory where you copied this file on your local drive.

12. Expand the Vehicle group and the Chassis subgroup.

13. Select the Body subgroup. Set its Scale Y attribute to 0.73 and its Scale Z attribute to 1.5.

14. Open the Hypershade (Window ➔ Rendering Editors ➔ Hypershade), and select the bluePaint material.

15. Click the blue color swatch next to the Color channel, and use the Color Chooser to change the color to red.

16. Save the scene using the same name (vehicleReference_v01.ma).

17. Open the street_v02.ma scene. The car model has all the changes you created in the vehicleReference_v01.ma scene. It is red, and the body is much wider (see Figure 1.46).
This is the basic file referencing workflow; however, a file referencing structure can be made much more complex to accommodate the needs of multiple teams. In addition, a referenced file can also use other references so that a file referencing tree can be constructed layering several levels of file references. This kind of structure is best planned out and agreed upon in the beginning in order to minimize confusion and keep a consistent workflow.

Using Reference Proxies
You can use proxy objects for your file references to temporarily substitute higher-resolution objects with lower-resolution objects. This can make animating the scene a little easier because the lower-resolution objects will improve performance and update faster in Maya as you play the animation on the timeline.

Multiple versions of the model can be created and used as proxies to facilitate different needs in the scene. A proxy should be the same size and roughly the same shape as the referenced file.

1. Open the `street_v03.ma` scene from the `chapter1\scenes` directory on the DVD. This scene has the same street as before with the same animated locator.

2. First bring in the file reference by choosing File ➤ Create Reference ➤ Options.

3. Under General Options in the Reference Options dialog box, turn on Group and Locator (see Figure 1.47). This will create a locator in the scene and a parent reference to the locator. Set File Type to Maya Ascii.

Reference Grouping
For the reference and proxy to share the same translation, rotation, and scale animation, the reference must have grouping enabled when it is brought into the scene. Otherwise, when you animate the proxy and then switch to the reference, animation placed on the transform node of the proxy will not be transferred to the reference.

4. Click the Reference button, and choose the `vehicleReference_v01.ma` file from the `chapter1\scenes` directory on the DVD.

When the reference loads, you’ll see that it is parented to a locator named `vehicleReference_v01RNlocator` in the Outliner.
5. In the Outliner, MMB-drag the vehicleReference_v01RNlocator on top of the carAnimation locator.

6. Then select the vehicleReference_v01RNlocator, open the Channel Box, and set all of its Translate and Rotate channels to 0 (Figure 1.48).

**Figure 1.47**
In the file reference options, make sure Group is on if you want to animate the reference and proxies.

**Figure 1.48**
The vehicle-Reference_v01RNlocator is parented to the carAnimation locator, and all of its Translate and Rotate channels are set to zero so it follows the animation of the car-Animation locator.
7. Choose File ➤ Reference Editor to open the Reference Editor window.

8. In the bottom half of the Reference Editor window, select the vehicleReference_v01RN node. Choose Proxy ➤ Add Proxy ➤ Options.

9. In the Proxy Options, type loRes into the Set Proxy Tag To field. Click the Apply button.

10. Use the File Browser dialog box to choose the loResCar_v01.ma scene from the chapter1\scenes directory on the DVD.

11. The Proxy Options dialog box should remain open after you add the loRes proxy. Change the field so that it reads mediumRes, and click the Proxy button.

12. Use the File Browser to select the medResCar_v01.ma scene from the chapter1\scenes folder on the DVD.

The Reference Editor won't look much different except that the icon next to the vehicleReference listing in the lower half has changed to the double-diamond icon, indicating that the reference has proxies available.

13. To switch to the proxy, make sure vehicleReference_v01PM is selected in the Reference Editor.

14. From the menu bar in the Reference Editor, choose Proxy ➤ Reload Proxy As ➤ loRes. After a moment, the original vehicle is replaced with the lower-resolution version.

15. Try using this menu to switch to the mediumRes version of the vehicle. The vehicle should be replaced with a slightly higher-resolution version. If you play the animation, the vehicle still moves along the animation curve (Figure 1.49).

16. To bring back the reference, select the original from the list in the Proxy ➤ Reload Proxy As menu.

The Reference Editor can be used to change proxies; remove proxies; and load, duplicate, unload, and reload references. When a reference is unloaded, it is removed from the scene.

**Figure 1.49**
The Reference Editor is used to switch between different versions of the proxy and the original referenced model.
The Bottom Line

**Understand transform and shape nodes**  DAG nodes have both a transform node and a shape node. The transform node tells where an object is located; the shape node describes how it is made. Nodes can be parented to each other to form a hierarchy.

**Master it**  Arrange the nodes in the `miniGun_v03.ma` file in a hierarchical structure so the barrels of the guns can rotate on their z-axis, the guns can be aimed independently, and the guns rotate with the turret.

**Create a project**  Creating a project directory structure keeps Maya scene files and connected external files organized to ensure the animation project is efficient.

**Master it**  Create a new project named Test, but make sure the project has only the scene, source images, and data subfolders.

**Use assets**  An asset is a way to organize the attributes of any number of specified nodes so that their attributes are easily accessible in the Channel Box. This means that members of each team in a pipeline only need to see and edit the attributes they need to get their job done, thus streamlining production.

**Master it**  Create an asset from the nodes in the `miniGun_v04.ma` scene in the `chapter1\scenes` folder. Make sure that only the Y rotation of the turret, the X rotation of the guns, and the Z rotation of the gun barrels are available to the animator.

**Create file references**  File references can be used so that as part of the team works on a model, the other members of the team can use it in the scene. As changes to the original file are made, the referenced file in other scenes will update automatically.

**Master it**  Create a file reference for the `miniGun_v04.ma` scene; create a proxy from the `miniGun_loRes.ma` scene.