This chapter serves as an introductory overview of Excel 2007. If you’re already familiar with a previous version of Excel, reading this chapter is still a good idea. Excel 2007 is different from every previous version—very different.

What Is Excel Good For?

Excel, as you probably know, is the world’s most widely-used spreadsheet program, and is part of the Microsoft Office suite. Other spreadsheet programs are available, but Excel is by far the most popular and has become the world standard.

Much of the appeal of Excel is due to the fact that it’s so versatile. Excel’s forte, of course, is performing numerical calculations, but Excel is also very useful for non-numerical applications. Here are just a few of the uses for Excel:

- **Number crunching**: Create budgets, analyze survey results, and perform just about any type of financial analysis you can think of.
- **Creating charts**: Create a wide variety of highly customizable charts.
- **Organizing lists**: Use the row-and-column layout to store lists efficiently.
- **Accessing other data**: Import data from a wide variety of sources.
- **Creating graphics and diagrams**: Use Shapes and the new SmartArt to create professional-looking diagrams.
- **Automating complex tasks**: Perform a tedious task with a single mouse click with Excel’s macro capabilities.
Understanding Workbooks and Worksheets

The work you do in Excel is performed in a workbook file, which appears in its own window. You can have as many workbooks open as you need. By default, Excel 2007 workbooks use an XLSX file extension.

Each workbook is comprised of one or more worksheets, and each worksheet is made up of individual cells. Each cell contains a value, a formula, or text. A worksheet also has an invisible draw layer, which holds charts, images, and diagrams. Each worksheet in a workbook is accessible by clicking the tab at the bottom of the workbook window. In addition, workbooks can store chart sheets. A chart sheet displays a single chart and is also accessible by clicking a tab.

Newcomers to Excel are often intimidated by all the different elements that appear within Excel's window. Once you become familiar with the various parts, it all starts to make sense.

Figure 1.1 shows you the more important bits and pieces of Excel. As you look at the figure, refer to Table 1.1 for a brief explanation of the items shown in the figure.

### TABLE 1.1

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Active cell indicator</td>
<td>This dark outline indicates the currently active cell (one of the 17,179,869,184 cells on each worksheet).</td>
</tr>
<tr>
<td>Application close button</td>
<td>Clicking this button closes Excel.</td>
</tr>
<tr>
<td>Window close button</td>
<td>Clicking this button closes the active workbook window.</td>
</tr>
<tr>
<td>Column letters</td>
<td>Letters range from A to IXFD — one for each of the 16,384 columns in the worksheet. You can click a column heading to select an entire column of cells.</td>
</tr>
<tr>
<td>Office button</td>
<td>This button leads to lots of options for working with your document, or Excel in general.</td>
</tr>
<tr>
<td>Formula bar</td>
<td>When you enter information or formulas into Excel, they appear in this line.</td>
</tr>
<tr>
<td>Horizontal scrollbar</td>
<td>Enables you to scroll the sheet horizontally.</td>
</tr>
<tr>
<td>Maximize/Restore button</td>
<td>Clicking this button increases the workbook window's size to fill Excel's complete workspace. If the window is already maximized, clicking this button “unmaximizes” Excel’s window so that it no longer fills the entire screen.</td>
</tr>
<tr>
<td>Minimize application button</td>
<td>Clicking this button minimizes Excel's window.</td>
</tr>
<tr>
<td>Minimize window button</td>
<td>Clicking this button minimizes the workbook window.</td>
</tr>
<tr>
<td>Name box</td>
<td>Displays the active cell address or the name of the selected cell, range, or object.</td>
</tr>
<tr>
<td>Page view buttons</td>
<td>Change the way the worksheet is displayed by clicking one of these buttons.</td>
</tr>
<tr>
<td>Quick Access Toolbar</td>
<td>A toolbar that you customize to hold commonly-used commands</td>
</tr>
<tr>
<td>Ribbon</td>
<td>The main location to find Excel's commands. Clicking an item in the Tab list changes the ribbon that's displayed.</td>
</tr>
<tr>
<td>Row numbers</td>
<td>Numbers range from 1 to 1,048,576 — one for each row in the worksheet. You can click a row number to select an entire row of cells.</td>
</tr>
<tr>
<td>Sheet tabs</td>
<td>Each of these notebook-like tabs represents a different sheet in the workbook. A workbook can have any number of sheets, and each sheet has its name displayed in a sheet tab. By default, each new workbook that you create contains three sheets. Add a new sheet by clicking the Insert Worksheet button (which is displayed after the last sheet tab).</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Sheet tab scroll buttons</td>
<td>These buttons let you scroll the sheet tabs to display tabs that aren’t visible.</td>
</tr>
<tr>
<td>Status bar</td>
<td>This bar displays various messages as well as the status of the Num Lock, Caps Lock, and Scroll Lock keys on your keyboard. It also shows summary information about the range of cells that is selected. Right-click the status bar to change the information that’s displayed.</td>
</tr>
<tr>
<td>Tab list</td>
<td>Commands that display a different ribbon, similar to a menu.</td>
</tr>
<tr>
<td>Title bar</td>
<td>All Windows programs have a title bar, which displays the name of the program and the name of the current workbook and also holds some control buttons that you can use to modify the window.</td>
</tr>
<tr>
<td>Vertical scrollbar</td>
<td>Lets you scroll the sheet vertically.</td>
</tr>
<tr>
<td>Zoom control</td>
<td>A scroller that lets you zoom your worksheet in and out.</td>
</tr>
</tbody>
</table>

**FIGURE 1.1**

The Excel screen has many useful elements that you will use often.
Moving Around a Worksheet

This section describes various ways to navigate through the cells in a worksheet. Every worksheet consists of rows (numbered 1 through 1,048,576) and columns (labeled A through XFD). After column Z comes column AA, which is followed by AB, AC, and so on. After column AZ comes BA, BB, and so on. After column ZZ is AAA, AAB, and so on.

The intersection of a row and a column is a single cell. At any given time, one cell is the active cell. You can identify the active cell by its darker border, as shown in Figure 1.2. Its address (its column letter and row number) appears in the Name box. Depending on the technique that you use to navigate through a workbook, you may or may not change the active cell when you navigate.

Notice that the row and column headings of the active cell appear in different colors to make it easier to identify the row and column of the active cell.

![FIGURE 1.2](image)
The active cell is the cell with the dark border — in this case, cell C8.

Navigating with your keyboard

As you probably already know, you can use the standard navigational keys on your keyboard to move around a worksheet. These keys work just as you’d expect: The down arrow moves the active cell down one row, the right arrow moves it one column to the right, and so on. PgUp and PgDn move the active cell up or down one full window. (The actual number of rows moved depends on the number of rows displayed in the window.)

You can use the keyboard to scroll through the worksheet without changing the active cell by turning on Scroll Lock, which is useful if you need to view another area of your worksheet and then quickly return to your original location. Just press Scroll Lock and use the direction keys to scroll through the worksheet. When you want to return to the original position (the active cell), press Ctrl+Backspace. Then, press Scroll Lock again to turn it off. When Scroll Lock is turned on, Excel displays Scroll Lock in the status bar at the bottom of the window.

The Num Lock key on your keyboard controls how the keys on the numeric keypad behave. When Num Lock is on, Excel displays Num Lock in the status bar, and the keys on your numeric keypad generate numbers. Most keyboards have a separate set of navigational (arrow) keys located to the left of the numeric keypad. The state of the Num Lock key doesn’t affect these keys.

Table 1.2 summarizes all the worksheet movement keys available in Excel.
**TABLE 1.2**

**Excel’s Worksheet Movement Keys**

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Up arrow</td>
<td>Moves the active cell up one row.</td>
</tr>
<tr>
<td>Down arrow</td>
<td>Moves the active cell down one row.</td>
</tr>
<tr>
<td>Left arrow of Shift+Tab</td>
<td>Moves the active cell one column to the left.</td>
</tr>
<tr>
<td>Right arrow or Tab</td>
<td>Moves the active cell one column to the right.</td>
</tr>
<tr>
<td>PgUp</td>
<td>Moves the active cell up one screen.</td>
</tr>
<tr>
<td>PgDn</td>
<td>Moves the active cell down one screen.</td>
</tr>
<tr>
<td>Alt+PgDn</td>
<td>Moves the active cell right one screen.</td>
</tr>
<tr>
<td>Alt+PgUp</td>
<td>Moves the active cell left one screen.</td>
</tr>
<tr>
<td>Ctrl+Backspace</td>
<td>Scrolls the screen so that the active cell is visible.</td>
</tr>
<tr>
<td>Up arrow*</td>
<td>Scrolls the screen up one row (active cell does not change).</td>
</tr>
<tr>
<td>Down arrow*</td>
<td>Scrolls the screen down one row (active cell does not change).</td>
</tr>
<tr>
<td>Left arrow*</td>
<td>Scrolls the screen left one column (active cell does not change).</td>
</tr>
<tr>
<td>Right arrow*</td>
<td>Scrolls the screen right one column (active cell does not change).</td>
</tr>
</tbody>
</table>

* With Scroll Lock on

**Navigating with your mouse**

To change the active cell by using the mouse, click another cell; it becomes the active cell. If the cell that you want to activate isn't visible in the workbook window, you can use the scrollbars to scroll the window in any direction. To scroll one cell, click either of the arrows on the scrollbar. To scroll by a complete screen, click either side of the scrollbar's scroll box. You also can drag the scroll box for faster scrolling.

**TIP**

If your mouse has a wheel on it, you can use the mouse wheel to scroll vertically. Also, if you click the wheel and move the mouse in any direction, the worksheet scrolls automatically in that direction. The more you move the mouse, the faster the scrolling.

Press Ctrl while you use the mouse wheel to zoom the worksheet. If you prefer to use the mouse wheel to zoom the worksheet without pressing Ctrl, choose Office → Excel Options and select the Advanced section. Place a check mark next to the Zoom On Roll With Intellimouse check box.

Using the scrollbars or scrolling with your mouse doesn't change the active cell. It simply scrolls the worksheet. To change the active cell, you must click a new cell after scrolling.

**Introducing the Ribbon**

The most dramatic change in Office 2007 is the new user interface. Traditional menus and toolbars are gone, and they’ve been replaced with the Ribbon. Office 2007 is the first software in history to use this new interface, and it remains to be seen whether it will catch on and replace traditional menus and toolbars.
Ribbon tabs
The commands available in the Ribbon vary, depending upon which tab is selected. The Ribbon is arranged into groups of related commands. Here’s a quick overview of Excel’s tabs.

- **Home**: You’ll probably spend most of your time with the Home tab selected. This tab contains the basic Clipboard commands, formatting commands, style commands, commands to insert and delete rows or columns, plus an assortment of worksheet editing commands.
- **Insert**: Select this tab when you need to insert something in a worksheet—a table, a diagram, a chart, a symbol, and so on.
- **Page Layout**: This tab contains commands that affect the overall appearance of your worksheet, including settings that deal with printing.
- **Formulas**: Use this tab to insert a formula, name a range, access the formula auditing tools, or control how Excel performs calculations.
- **Data**: Excel’s data-related commands are on this tab.
- **Review**: This tab contains tools to check spelling, translate words, add comments, or protect sheets.
- **View**: The View tab contains commands that control various aspects of how a sheet is viewed. Some commands on this tab are also available in the status bar.
- **Developer**: This tab isn’t visible by default. It contains commands that are useful for programmers. To display the Developer tab, choose Office Excel Options and then select Popular. Place a check mark next to Show Developer Tab In The Ribbon.
- **Add-Ins**: This tab is visible only if you’ve loaded a workbook or add-in that customizes the menu or toolbars. Because menus and toolbars are no longer available in Excel 2007, these customizations appear in the Add-Ins tab.

The appearance of the commands on the ribbon varies, depending on the width of Excel window. When the window is too narrow to display everything, the commands adapt and may seem to be missing. But the commands are still available. Figure 1.3 shows the Home tab of the Ribbon with all controls fully visible. Figure 1.4 shows the Ribbon when Excel’s window is made more narrow. Notice that some of the descriptive text is gone, but the icons remain. Figure 1.5 shows the extreme case when the window is made very narrow. Some groups display a single icon. However, if you click the icon, all the group commands are available to you.

![FIGURE 1.3](image)
The Home tab of the Ribbon.
If you would like to hide the Ribbon to increase your worksheet view, just double-click any of the tabs. The Ribbon goes away, and you're able to see about five additional rows of your worksheet. When you need to use the Ribbon again, just click a tab, and it comes back temporarily. To keep the ribbon turned on, double-click a tab. You can also press Ctrl+F1 to toggle the Ribbon display on and off.

### Contextual tabs

In addition to the standard tabs, Excel 2007 also includes **contextual tabs**. Whenever an object (such as a chart, a table, or a SmartArt diagram) is selected, specific tools for working with that object are made available in the Ribbon.

Figure 1.6 shows the contextual tab that appears when a chart is selected. In this case, it has three contextual tabs: Design, Layout, and Format. Notice that the contextual tabs contain a description (Chart Tools) in Excel's title bar. When contextual tabs appear, you can, of course, continue to use all the other tabs.
Types of commands on the Ribbon

When you hover your mouse pointer over a Ribbon command, you’ll see a pop-up box that contains the command’s name, and a brief description. For the most part, the commands in the Ribbon work just as you would expect them to. You do encounter several different styles of commands on the Ribbon:

- **Simple buttons**: Click the button, and it does its thing. An example of a simple button is the Increase Font Size button in the Font group of the Home tab. Some buttons perform the action immediately; others display a dialog box so that you can enter additional information. Button controls may or may not be accompanied by text.

- **Toggle buttons**: A toggle button is clickable and also conveys some type of information by displaying two different colors. An example is the Bold button in the Font group of the Home tab. If the active cell is not bold, the Bold button displays in its normal color. But if the active cell is already bold, the Bold button displays a different background color. If you click this button, it toggles the Bold attribute for the selection.

- **Simple drop-downs**: If the Ribbon command has a small downward pointing arrow, then the command is a drop-down. Click it, and additional commands appear below it. An example of a simple drop-down is The Conditional Formatting command in the Styles group of the Home Tab. When you click this control, you see several options related to conditional formatting.

- **Split buttons**: A split button control combines a one-click button with a drop-down. If you click the button part, the command is executed. If you click the drop-down part (a down-pointing arrowhead), you choose from a list of related commands. You can identify a split button command because it displays in two colors when you hover the mouse over it. An example of a split button is the Merge & Center command in the Alignment group of the Home tab (see Figure 1.7). Clicking the left part of this control merges and centers the selected cells. If you click the arrow part of the control (on the right), you get a list of commands related to merging cells.
Check boxes: A check box control turns something on or off. An example is the Gridlines control in the Show/Hide group of the View tab. When the Gridlines check box is checked, the sheet displays gridlines. When the control isn’t checked, the sheet gridlines don’t appear.

Spinners: Excel’s Ribbon has only one spinner control. It’s in the Scale To Fit group of the Page Layout tab. Click the top part of the spinner to increase the value; click the bottom part of the spinner to decrease the value.

Some of the Ribbon groups contain a small icon on the right side, known as a dialog launcher. For example, if you examine the Home Alignment group, you see this icon (refer to Figure 1.8). Click it, and Excel displays the Format Cells dialog box, with the Alignment tab pre-selected. The dialog launchers generally provide options that aren’t available in the Ribbon.

The Merge & Center command is a split button control.

Some of the Ribbon groups contain a small icon on the right side, known as a dialog launcher.

Accessing the Ribbon using your keyboard

At first glance, you may think that the Ribbon is completely mouse-centric. After all, none of the commands have the traditional underline letter to indicate the Alt+keystrokes. But in fact, the Ribbon is very keyboard friendly. The trick is to press the Alt key to display the pop-up keytips. Each Ribbon control has a letter (or series of letters) that you type to issue the command.

You don’t need to hold down the Alt key as you type the keytip letters.
Changing Your Mind

You can reverse just about every action in Excel by using the Undo command, located in the Quick Access Toolbar. Click Undo (or press Ctrl+Z) after issuing a command in error, and it’s as if you never issued the command. You can reverse the effects of the last 100 actions that you performed by executing Undo more than once.

If you click the arrow on the right side of the Undo button, you see a description of the action that you can reverse. If you click an item in that list, that action and all the subsequent actions will be undone.

You can’t reverse every action, however. Generally, anything that you do using the Office button can’t be undone. For example, if you save a file and realize that you’ve overwritten a good copy with a bad one, you’re just out of luck.

The Repeat button, also in the Quick Access Toolbar, performs in the opposite direction of the Undo button: Repeat re-issues commands that have been undone. If nothing has been undone, then you can use the Repeat button (or Ctrl+Y) to repeat the last command that you performed. For example if you applied a particular style to a cell (by choosing Home ➤ Styles ➤ Cell Styles), you can activate another cell and press Ctrl+Y to repeat the command.

Figure 1.9 shows how the Home tab looks after I hit the Alt key to display the keytips. If you press one of the keytips, the screen then displays more keytips. For example, to use the keyboard to align the cell contents to the left, press Alt, followed by H (for Home) and then AL (for Align Left). If you’re a keyboard fan (like me), it takes just a few times before you memorize the keystrokes required for commands that you use frequently.

FIGURE 1.9

Pressing Alt displays the keytips.

![Figure 1.9](image)

After you press Alt, you can also use the left and right arrow keys to scroll through the tabs. When you reach the proper tab, press down arrow to enter the Ribbon. Then use left and right arrow keys to scroll through the Ribbon commands. When you reach the command you need, press Enter to execute it. This method isn’t as efficient as using the keytips, but it’s a quick way to take a look at the commands available.
Using the shortcut menus

In addition to the Ribbon, Excel features a slew of shortcut menus, which you access by right-clicking just about anything within Excel. Shortcut menus don't contain every relevant command, just those that are most commonly used for whatever is selected.

As an example, Figure 1.10 shows the shortcut menu that appears when you right-click a cell. The shortcut menu appears at the mouse-pointer position, which makes selecting a command fast and efficient. The shortcut menu that appears depends on what you're doing at the time. For example, if you're working with a chart, the right-click shortcut menu contains commands that are pertinent to what is selected.

FIGURE 1.10
Click the right mouse button to display a shortcut menu with the commands that you're most likely to use.

The box above the shortcut menu is known as the Mini toolbar and contains commonly used tools from the Home tab. The Mini toolbar was designed to reduce the distance your mouse has to travel around the screen. Just right-click, and common formatting tools are within an inch from your mouse pointer. The Mini toolbar is particularly useful when a tab other than Home is displayed. If you use a tool on the Mini toolbar, then the toolbar remains displayed in case you want to perform other formatting on the selection.

TIP If you find the Mini toolbar too distracting, you can turn it off. Choose Office ➤ Excel Options. Click the Popular tab and remove the check mark from Show Mini Toolbar On Selection.
Customizing your Quick Access Toolbar

In previous versions of Excel, end users were free to customize their menus and toolbars. Things have changed in Excel 2007. Now, the only end user customization option is the Quick Access Toolbar (QAT). Normally, the QAT appears on the left side of the title bar. Alternatively, you can display the QAT below the ribbon. Right-click the QAT and select Show Quick Access Toolbar Below Ribbon.

By default, the QAT contains three tools: Save, Undo, and Repeat. You can, of course, customize the QAT by adding other commands that you use often. To add a command from the Ribbon to your QAT, right-click the command and choose Add To Quick Access Toolbar. If you click the downward-pointing arrow to the right of the QAT, you see a drop-down menu with some additional commands that you might want to place in your QAT.

Excel has commands that aren’t available in the Ribbon. In most cases, the only way to access these commands is to add them to your QAT. Figure 1.11 shows the Customization section of the Excel Options dialog box. This section is your one-stop shop for QAT customization. A quick way to display this dialog box is to right-click the QAT and choose Customize Quick Access Toolbar.

**FIGURE 1.11**

Add new icons to your QAT by using the Customization section of the Excel Options dialog box.

Refer to Chapter 23 for more information about customizing your QAT.
Working with Dialog Boxes

Many Excel commands display a dialog box, which is simply a way of getting more information from you. For example, if you choose Review ➤ Changes ➤ Protect Sheet, Excel can't carry out the command until you tell it what parts of the sheet you want to protect. Therefore, it displays the Protect Sheet dialog box, shown in Figure 1.12.

![Figure 1.12](image)

Excel uses a dialog box to get additional information about a command.

The Excel dialog boxes vary in how they work. Excel uses two types of dialog boxes:

- **Normal dialog box**: A modal dialog box, which takes the focus away from the spreadsheet. When this type of dialog box is displayed, you can't do anything in the worksheet until you dismiss the dialog box. Clicking the OK button performs the specified actions, and clicking Cancel (or pressing Esc) closes the dialog box without taking any action. Most Excel dialog boxes are of this type.

- **Stay-on-top dialog box**: A modeless dialog box, which works in a manner similar to a toolbar. When a modeless dialog box is displayed, you can continue working in Excel, and the dialog box remains open. Changes made in a modeless dialog box take effect immediately. For example, if you're applying formatting to a chart, changes you make in the Format dialog box appear in the chart as soon as you make them. Modeless dialog boxes have a Close button instead of an OK button.

Most people find working with dialog boxes to be quite straightforward and natural. If you've used other programs, you'll feel right at home. You can manipulate the controls either with your mouse or directly from the keyboard.

Navigating dialog boxes

Navigating dialog boxes is generally very easy — you simply click the control you want to activate.
Although dialog boxes were designed with mouse users in mind, you can also use the keyboard. Every dialog box control has text associated with it, and this text always has one underlined letter (a hot key or accelerator key). You can access the control from the keyboard by pressing the Alt key and then the underlined letter. You also can use Tab to cycle through all the controls on a dialog box. Shift+Tab cycles through the controls in reverse order.

When a control is selected, it appears with a darker outline. You can use the spacebar to activate a selected control.

**Using tabbed dialog boxes**

Many of Excel’s dialog boxes are “tabbed” dialog boxes. A **tabbed dialog box** includes notebook-like tabs, each of which is associated with a different panel.

When you click a tab, the dialog box changes to display a new panel containing a new set of controls. The Format Cells dialog box is a good example. This dialog box is shown in Figure 1.13; it has six tabs, which makes it functionally equivalent to six different dialog boxes.

**FIGURE 1.13**

Use the dialog box tabs to select different functional areas in the dialog box.
Tabbed dialog boxes are quite convenient because you can make several changes in a single dialog box. After you make all your setting changes, click OK or press Enter.

To select a tab by using the keyboard, use Ctrl+PgUp or Ctrl+PgDn, or simply press the first letter of the tab that you want to activate.

Excel 2007 introduced a new style of modeless tabbed dialog box in which the tabs are on the left, rather than across the top. An example is shown in Figure 1.14. To select a tab using the keyboard, use the up and down arrow keys and then press Tab to access the controls.

A “new style” tabbed dialog box with tabs on the left.

Using the Taskbar

The final user interface element that I discuss is the taskbar. The taskbar appears automatically in response to several commands. For example, if you want to insert a clip art image, choose Insert ➪ Illustrations ➪ Clip Art. Excel responds by displaying the Clip Art Task bar, shown in Figure 1.15. The taskbar is similar to a dialog box, except that you can keep it visible as long as you like. There’s no OK button. When you’re finished using a Task bar, click the Close button in the upper right corner. By default, the taskbar is docked on the right side of the Excel window, but you can drag it anywhere you like.
Creating Your First Excel Worksheet

This section presents an introductory hands-on session with Excel. If you haven’t used Excel, you may want to follow along on your computer to get a feel for how this software works.

In this example, you create a simple monthly sales projection table along with a chart.

Getting started on your worksheet

Start Excel and make sure that you have an empty workbook displayed. To create a new, blank workbook, press Ctrl+N.

The sales projection will consist of two columns of information. Column A will contain the month names, and column B will store the projected sales numbers. You start by entering some descriptive titles into the worksheet. Here’s how to begin:

1. Move the cell pointer to cell A1 by using the direction keys. The Name box displays the cell’s address.
2. Enter Month into cell A1. Just type the text and then press Enter. Depending on your setup, Excel either moves the cell pointer to a different cell, or the pointer remains in cell A1.
3. Move the cell pointer to B1, type Projected Sales, and press Enter.
Filling in the month names

In this step, you enter the month names in column A.

1. Move the cell pointer to A2 and type Jan (an abbreviation for January). At this point, you can enter the other month name abbreviations manually, but we’ll let Excel do some of the work by taking advantage of the AutoFill feature.

2. Make sure that cell A2 is selected. Notice that the active cell is displayed with a heavy outline. At the bottom-right corner of the outline, you’ll see a small square known as the fill handle. Move your mouse pointer over the fill handle, click, and drag down until you’ve highlighted from A2 down to A13.

3. Release the mouse button, and Excel will automatically fill in the month names.

Your worksheet should resemble the one shown in Figure 1.16.

![Figure 1.16](image)

Your worksheet, after entering the column headings and month names.

Entering the sales data

Next, you provide the sales projection numbers in column B. Assume that January’s sales are projected to be $50,000, and that sales will increase by 3.5 percent in each of the subsequent months.

1. Move the cell pointer to B2 and type50000, the projected sales for January.

2. To enter a formula to calculate the projected sales for February, move to cell B3 and enter the following: =B2*103.5%. When you press Enter, the cell will display 51750. The formula returns the contents of cell B2, multiplied by 103.5%. In other words, February sales are projected to be 3.5% greater than January sales.
3. The projected sales for subsequent months will use a similar formula. But rather than retype the formula for each cell in column B, once again take advantage of the AutoFill feature. Make sure that cell B3 is selected. Click the cell’s fill handle, drag down to cell B13, and release the mouse button.

At this point, your worksheet should resemble the one shown in Figure 1.17. Keep in mind that, except for cell B2, the values in column B are calculated with formulas. To demonstrate, try changing the projected sales value for the initial month, January (in cell B2). You’ll find that the formulas recalculate and return different values. But these formulas all depend on the initial value in cell B2.

![Figure 1.17](image)

Your worksheet, after creating the formulas.

### Formatting the numbers

The values in the worksheet are difficult to read because they aren’t formatted. In this step, you apply a number format to make the numbers easier to read and more consistent in appearance:

1. Select the numbers by clicking cell B2 and dragging down to cell B13.
2. Choose Home ▶ Number, click the drop-down Number Format control (it initially displays General), and select Currency from the list. The numbers now display with a currency symbol and two decimal places. Much better!

### Making your worksheet look a bit fancier

At this point, you have a functional worksheet — but it could use some help in the appearance department. Converting this range to an “official” (and attractive) Excel table is a snap:

1. Move to any cell within the range.
2. Choose Insert ▶ Tables ▶ Table. Excel displays its Create Table dialog box to make sure that it guessed the range properly.
3. Click OK to close the Create Table dialog box. Excel applies its default table formatting and also displays its Table Tools ▶ Design contextual tab. Your screen should look like Figure 1.18.
4. If you don’t like the default table style, just select another one from the Table Tools ➪ Design ➪ Table Styles group. Notice that you can get a preview of different table styles by moving your mouse over the ribbon. When you find one you like, click it, and style will be applied to your table.

Summing the values
The worksheet displays the monthly projected sales, but what about the total sales for the year? Because this range is a table, it’s simple:

1. Activate any cell in the table
2. Choose Table Tools ➪ Design ➪ Table Style Options ➪ Totals Row. Excel automatically adds a new row to the bottom of your table, including a formula that calculated the total of the Projected Sales column.
3. If you’d prefer to see a different summary formula (for example, average), click cell B14 and choose a different summary formula from the drop-down list.

Creating a chart
How about a chart that shows the projected sales for each month?

1. Activate any cell in the table.
2. Choose Insert ➪ Charts ➪ Column and then select one of the 2-D column chart types. Excel inserts the chart in the center of your screen.
3. To move the chart to another location, click its border and drag it.
4. To change the appearance and style of the chart, use the commands in the Chart Tools context tab.

Figure 1.19 shows the worksheet after creating the chart. Your chart may look different, depending on the chart layout or style you selected.
Printing your worksheet

Printing your worksheet is very easy (assuming that you have a printer attached and that it works properly).

1. **First, make sure that the chart isn’t selected.** If a chart is selected, it will print on a page by itself. To deselect the chart, just press Esc or click any cell.

2. **To make use of Excel’s handy new page layout view, click the Page Layout View button on the right side of the status bar.** Excel will then display the worksheet page by page (see Figure 1.20) so that you can easily see how your printed output will look. For example, you can tell immediately if the chart is too wide to fit on one page. If the chart is too wide, click and drag its lower right corner to resize it.
3. When you’re ready to print, choose Office ➪ Print ➪ Quick Print

The worksheet is printed using the default settings.

Saving your workbook

Until now, everything that you’ve done has occurred in your computer’s memory. If the power should fail, all may be lost — unless Excel’s AutoRecover feature happened to kick in. It’s time to save your work to a file on your hard drive.

1. Click the Save button on the Quick Access Toolbar. (This button looks like an old-fashioned floppy disk.) Because the workbook hasn’t been saved yet and still has its default name, Excel responds with the Save As dialog box.

2. In the box labeled File Name, enter a name such as Monthly Sales Projection, and then click Save or press Enter. Excel saves the workbook as a file. The workbook remains open so that you can work with it some more.

By default, Excel saves a copy of your work automatically every ten minutes. To adjust this setting (or turn it off), use the Save tab of the Excel Options dialog box. To display this dialog box, choose File ➪ Excel Options. However, you should never rely on Excel’s AutoRecover feature. Saving your work frequently is a good idea.

If you’ve followed along, you may have realized that creating this workbook was not at all difficult. But, of course, you’ve barely scratched the surface. The remainder of this book will cover these tasks (and many, many more) in much greater detail.