Chapter 1

Navigating the AutoCAD Civil 3D User Interface

If you’re new to the AutoCAD® Civil 3D® software environment, then your first experience has probably been a lot like staring at the instrument panel of a 747. Civil 3D can be quite intimidating, with lots of buttons, strange shapes, and strange icons—all packed into a relatively small area. In addition, you may be even more intimidated by the feeling that there is a lot of power under the hood. This leads us to our main objective for this chapter, which is to alleviate that feeling of intimidation and make you feel much more at ease within the Civil 3D environment. Let me start you down that path by saying that there’s a big difference between a 747 and Civil 3D. In Civil 3D, if you really mess up, you can simply close the drawing file without saving. When piloting a 747, it’s a little more difficult to undo your mistakes.

After completing this chapter, you will have achieved a greater comfort level within the Civil 3D environment by being able to identify main user interface components and utilize them for basic functions. You will also be able to use two specific features that will serve you well throughout the program: the Transparent Commands toolbar and the Inquiry Tool.

- Getting to know the Civil 3D user interface
- Using the application menu
- Using the ribbon
- Using the Toolspace
- Using the drawing area
- Using the command line
- Using Panorama
- Using the Transparent Commands toolbar
- Using the Inquiry Tool
Getting to Know the Civil 3D User Interface

To begin learning about the Civil 3D environment, let’s take our 747 analogy down a notch and think about this as learning to drive an automobile. When your parents first sat you down at the wheel and talked about the car’s controls, they probably didn’t mention the air conditioning or the radio. Those, of course, are important parts of the driving experience, but I’m betting they started with the most important parts, such as the steering wheel, the gas pedal, and most important, the brake pedal. We’re going to approach your first experience with “driving” Civil 3D in much the same manner.

There are many, many parts to the Civil 3D user interface. For the purposes of this book, I’ll cover just the ones that will be most important in enabling you to navigate the software effectively. Figure 1.1 shows the major components of the user interface.
**Application Menu** The place where everyday file handling commands can be found that enable you to do things like open, save, and print your drawings.

**Ribbon** The place where most Civil 3D commands are launched.

**Toolspace** The Civil 3D “command center” where all of the data and settings are laid out in an organized fashion.

**Drawing Area** The place where the drawing is created.

**Command Line** The chat window where you and Civil 3D talk to one another.

**Panorama** A multipurpose window where you can view and/or edit drawing information and properties.

**Inquiry Tool** A tool with many smaller tools within it that enable you to get information about your design.

**Transparent Commands Toolbar** Special commands that allow drafting and geometric construction to be done the way that civil engineers and surveyors do it.

---

**Using the Application Menu**

The application menu (Figure 1.2) expands out from the square AutoCAD Civil 3D icon located at the top left of your screen. In previous versions of Civil 3D, this icon was often referred to as “the big red C” but due to its new look, that name will now be “the big purple A.” Here you’ll find commands for creating, opening, saving, and printing your drawing files.

![Image of the Civil 3D application menu]

**FIGURE 1.2** Part of the Civil 3D application menu
Chapter 1 • Navigating the AutoCAD Civil 3D User Interface

To use the application menu to open a file, follow these steps:

1. Launch Civil 3D by double-clicking the Civil 3D 2013 Imperial (Metric) icon on the desktop of your computer.

2. Click the application menu icon (the big purple A). Click Open, and then click Drawing.

3. Browse to the Chapter 01 class data folder and open User Interface.dwg.

4. Open the application menu once more and investigate the commands that are listed there. You’ll notice that most of them have to do with creating, opening, saving, and printing drawing files.

5. Keep this drawing open for the next exercise.

Using the Ribbon

The ribbon is located at the top of your screen and is the launching pad for most of your Civil 3D commands. The commands that it contains are organized into groups through the use of *tabs and panels*. The ribbon itself is divided into a series of tabs that include Home, Insert, Annotate, and so on, as illustrated in Figure 1.3.

![Figure 1.3 Tabs arrange large numbers of similar Civil 3D commands into groups.](image)

Each tab is divided into *panels*. For instance, the Home tab shown in Figure 1.4 includes the Palettes, Create Ground Data, Create Design, and Profile & Section Views panels.

![Figure 1.4 Panels provide another level of grouping within a ribbon tab.](image)
Because Civil 3D groups the commands in this way, you never have to choose from more than a handful of commands once you’ve taken your best guess at the correct tab and panel. Also, you’ll find that the more you use Civil 3D, the better you will be at knowing where the commands are. It’s not so much memorizing their locations as it is learning how Civil 3D “thinks”—that is, the way in which it relates commands to one another and categorizes them into tabs and panels.

One other thing you should know is that most panels expand downward to show you the less frequently used commands in that particular category. You’ll know they expand when you see a downward-pointing black triangle next to their name. For example, Figure 1.5 shows the Home tab’s Create Design panel expanded with more commands. Don’t forget to look on these hidden panels when searching for commands.

![Figure 1.5](image)

**FIGURE 1.5** Most panels expand downward to reveal more commands, as is the case with the Create Design panel on the Home tab of the ribbon.

One of the best features of the ribbon is its ability to respond to what you select in the drawing area. For example, if you click a Civil 3D alignment, the ribbon changes and serves up alignment-related commands on a special tab. The same is true for surfaces, parcels, and so on. These special tabs are referred to as contextual ribbon tabs. They are a huge help when you’re first learning Civil 3D and a huge time-saver even after you’ve become a master.

Follow these steps to familiarize yourself with the ribbon’s tabs and panels (User Interface.dwg should still be open from the previous exercise):

1. Click the Home tab of the ribbon to bring it to the forefront (it may be already). Notice that there is a mixed assortment of commands here. The Home tab is designed to contain your most heavily used commands. Since you don’t yet know what most of the commands mean, the selection of commands could seem kind of random.

2. Click the gray strip at the bottom of the Create Design panel and note how it expands out, as shown in Figure 1.5.
3. Click the Insert tab of the ribbon. Here, you see words like *insert*, *import*, and *attach*—all ways of bringing information into the drawing. The commands here are much more specific to a certain purpose as compared to the randomness of the Home tab.

4. Click the other tabs of the ribbon and see whether you can relate some of the words you see in the commands to the title of each ribbon tab.

5. Place your cursor in the drawing area, and roll the mouse wheel forward to zoom in to the drawing. Keep zooming in until you can clearly see the road centerlines labeled with stationing numbers (these are Civil 3D alignments). Click one of the road centerlines, and note that the ribbon displays a contextual tab to make alignment commands accessible (Figure 1.6).

6. Keep this drawing open for the next exercise.

**Figure 1.6** The ribbon displays the contextual Alignment: Side Road A tab, because an alignment has been selected in the drawing.

### Using the Toolspace

Think of the Toolspace as the Civil 3D “command center” where all Civil 3D data and settings are laid out in a nice, orderly arrangement. It has several main functions that are represented by the different tabs it can contain. Altogether, the Toolspace can house four tabs: Prospector, Settings, Survey, and Toolbox.

### Prospector Tab

Prospector is arguably the most important part of the Civil 3D user interface. As you build your design, Prospector arranges the different components of your design in a tree structure (Figure 1.7). Why a tree structure and not just a list of...
items? Later in this book, you’ll study how Civil 3D creates relationships between different parts of your design. In some ways, this tree structure helps represent some of those relationships as a hierarchy. Another, more practical reason for a tree structure is that it’s an efficient way to show a long list of items in a relatively small area—the branches of the tree can be collapsed to make room to expand other branches.

Figure 1.7 The Prospector tab with a portion of the tree structure highlighted in red.

Another way to think about Prospector is that it arranges your design categorically rather than spatially. In other words, in your drawing area, you see road centerlines crossing through parcels, which cross through contours, which cross through survey points. Everything is in the right place spatially, but from an organizational standpoint, it’s kind of a mess. Prospector sorts out this mess and puts all the points in one place, all the parcels in one place, and so on. Prospector also knows exactly where those objects are in the drawing. You can right-click an object in Prospector and use the Select command or Zoom To command to locate that object within the drawing.

To explore the Prospector tab, follow these steps (you should still have User Interface.dwg open):

1. If the Toolspace is not already open, click Toolspace on the Home tab of the ribbon.

2. Click the Prospector tab of Toolspace to bring it to the forefront.

3. Explore the tree structure of Prospector by clicking the plus signs to expand the different branches.
4. Expand Alignments ➞ Centerline Alignments ➞ Main Road A ➞ Profiles. This hierarchical arrangement provides effective organization and suggests a relationship between the alignment and its profiles (as described later in the chapter).

5. Right-click Side Road B and select Zoom To. Notice how Prospector knows where the alignment named Side Road B is, even if you don’t.

6. Keep this drawing open for the next exercise.

It’s important to point out that Prospector isn’t just a place for viewing your design; it’s also a place where you can change the appearance of your design, create new components for your design, edit your design, and so on. These types of functions are accessed through contextual menus such as the one used in step 5 of the previous exercise. A good rule of thumb when using Prospector is, “When in doubt, right-click it.”

**Settings Tab**

Civil 3D has a lot of settings that control nearly every aspect of how the software behaves. In fact, one of the things that make Civil 3D so powerful is that you can customize its settings to accommodate nearly any type of design, company standard, or any other factor that defines the environment within which you use it. The Settings tab is where these settings are managed; however, you won’t be spending much time here for the early part of your Civil 3D career. This area is more often the territory of a CAD manager or Civil 3D guru.

To explore the Settings tab, follow these steps (you should still have User Interface.dwg open from the previous exercise):

1. Click the Settings tab of the Toolspace.
2. Expand Surface ➞ Surface Styles and take note of the list of styles shown there. These styles control the appearance of models that represent the shape of the ground.
3. Expand Surface ➞ Label Styles ➞ Contour and take note of the list of styles shown there. These styles control a certain type of label that is used to annotate surface models.
4. Keep this drawing open for the next exercise.

**Survey Tab**

The Survey tab is specifically for working with survey data. You could call it “Prospector for surveyors,” because it serves the same functions and works
in much the same way as the Prospector tab. It displays survey data in a tree structure, and it allows you to launch commands through contextual menus.

**Toolbox Tab**

As if Civil 3D didn’t have enough stuff packed into it already, the Toolbox is a place where other add-ons can be plugged in. Your company may have some custom programming that is designed to run in Civil 3D or some add-on modules provided by Autodesk®. This is the place where you can load and run these additional enhancements to Civil 3D.

**Using the Drawing Area**

The drawing area is where you can actually see and “touch” the design model you are creating. The design model is most often viewed from above, referred to as *plan view*, but it can be viewed from any perspective. For example, because Civil 3D specializes in representing designs as 3D models, you may want to display your model using 3D view. Figure 1.8 shows a model in both plan and 3D views.

![Figure 1.8 The drawing area showing the same model in plan view on the left and 3D view on the right](image)
Using the Command Line

Think of the command line (Figure 1.9) as a chat window where you talk with Civil 3D. Nearly everything you do is reported on the command line along with Civil 3D’s response to it. A response can be a request for more information, reporting of a result, or notification of a problem. It’s good to get into the habit of always watching the command line, because it often tells you what to do next. You can also launch commands from the command line, but you will likely find it much easier to use the visual interface provided by the ribbon and other tools.

**Figure 1.9** A view of the command line while using a transparent command (covered later in this chapter) to draw a line. Notice how the command line reports that the LINE command has been started and then prompts for the first piece of information: the “first point.”

Using Panorama

Panorama is a multipurpose window that is used to show and/or modify many different types of information. It works by displaying a tab for the information that you or the program has called for. For example, the Events tab (also known as the Event Viewer) will show up when Civil 3D needs to tell you something about the drawing. In another example, if you launch the command to edit the geometric details of an alignment, the Alignment Entities tab will appear. As shown in Figure 1.10, while Panorama displays information for one task, it also displays tabs for other tasks that you can access with a single click. This enables you to multitask within the same window.

**Figure 1.10** Panorama showing the Events and Alignment Entities tabs
To get a feel for the Panorama window, follow these steps (you should still have User Interface.dwg open from the previous exercise):

1. On the Home tab of the ribbon, expand the Palettes panel and click the icon for Event Viewer.
2. Experiment with resizing, auto-hiding, and docking the Panorama window. You’ll find that it behaves much like other dockable windows in Civil 3D.
3. Press Esc to clear any selections in the drawing. Click one of the contour lines in the drawing to display the Tin Surface: Existing Ground ribbon tab, and then click Volumes Dashboard on the Analyze panel. Notice the Volumes Dashboard tab that shows up next to the Events tab in Panorama.
4. Keep this drawing open for the next exercise.

Using the Transparent Commands Toolbar

As you may already know, civil engineers and surveyors draw things a little differently than architects or mechanical engineers. They use things such as bearings, curve deltas, northings, and eastings to define geometry. The Transparent Commands toolbar enables Civil 3D users to draw things based on the special geometric concepts that are unique to civil engineers and surveyors.

For example, when drawing a line, you can use the Northing Easting transparent command to specify the first point and the Bearing Distance transparent command to specify the end point (Figure 1.11).

To practice using the Transparent Commands toolbar, follow these steps (you should have User Interface.dwg open from the previous exercise):

1. Type LINE at the Command: prompt, and press Enter.
2. When prompted to specify the first point, click any point within the drawing.
3. When prompted to specify the next point, click Bearing Distance on the Transparent Commands toolbar. Refer to Figure 1.11 for the location of this command.

4. When prompted for a quadrant, either enter 1 or click in the upper-right quadrant created by the crosshairs on the screen.

5. When prompted for the bearing, type 45 and press Enter.

6. When prompted for the distance, type 500 (150) and press Enter. Press Esc twice to exit the command. You have just drawn a line that is 500 feet (150 meters) long at a bearing of N 45° E.

**Using Specialized Line and Curve Commands**

Another Civil 3D feature that enables you to draw like a surveyor or civil engineer is a set of specialized line and curve commands. These commands are mixed in with basic AutoCAD line and curve commands on the Draw panel of the ribbon. You can find specialized line commands by expanding the Line icon to reveal commands like Create Line By Bearing, Create Line By Point # Range, and so on. There is also a Curves icon that expands to reveal commands like Create Curve Through Point and Create Multiple Curves. Finally, there is also a Best Fit icon that expands to include commands for best fit lines and curves. The following image shows the expanded form of the Line, Curve, and Best Fit icons.
Using the Inquiry Tool

Most of the time, you’ll be the one providing the information for a drawing, but sometimes, you need your drawing to tell you something. That’s where the Inquiry Tool comes in. The Inquiry Tool is a separate window whose sole purpose is to give you information about things in the drawing. There is a long list of drawing items to choose from, and beneath each item is a list of things that you can ask about (Figure 1.12).

![Figure 1.12 The Inquiry Tool showing a partial list of available inquiry types](image)

To try the Inquiry Tool, follow these steps:

1. On the Analyze tab of the ribbon, click Inquiry Tool.
2. Under Select An Inquiry Type, select Point ➤ Point Inverse.
3. When prompted to specify the first point, hold down the Shift key, right-click, and select Endpoint on the contextual menu that appears.
4. Click the southwestern endpoint of the line you drew earlier.
5. Use the Shift+right-click combination again to select Endpoint, and then click the opposite end of the line for the second point.
6. Scroll down to the Direction and Horizontal Distance values in the Inquiry Tool window. Note that they show the same bearing and distance you entered earlier.
Now that you have learned some of the basic controls, you are ready to take the car for its first spin around the block. As you are guided through more lessons, you will understand how to execute basic tasks such as “turn the wheel” and “step on the brake.” You’re not ready to navigate the streets of New York City yet, but you’ve certainly taken a major step.

Of course, driving is just an analogy, and what we’re really talking about here is your ability to operate the basic controls of Civil 3D. With the skills and knowledge that you’ve gained in this chapter, you will be better equipped to execute the tasks in upcoming chapters that deal with specific Civil 3D functions. You’ll become more efficient at using the software as you spend more time with it.

**Additional Exercises**

1. For each command listed here, what is the name of at least one ribbon tab where it can be found?
   - A. Match Properties
   - B. Import Survey Data
   - C. Add Labels
   - D. Inquiry Tool
   - E. Elevation Editor
   - F. Toolspace
   - G. Points From File

2. To practice becoming more fluent within the Civil 3D interface, open the drawing named `User Interface 2.dwg`, which is located in the Chapter 01 class data folder. Within this drawing, use at least one command or function from each of the following parts of the Civil 3D user interface:
   - A. Application menu (this one’s easy, because you have to use it to open the drawing)
   - B. Command line
   - C. Ribbon
   - D. Prospector
   - E. Transparent Commands
   - F. Inquiry Tool

Visit www.sybex.com/go/civil2013essentials to download a video of the author completing this exercise. You can also download the Answers to Additional Exercises Appendix which contains even more information about completing this exercise.