Discovering Some Useful Shortcut Keys

Excel has no shortage of shortcut keys. Your productivity is sure to increase if you take the time to learn the shortcut keys for commands that you use frequently. In the following table, I list some of the most useful shortcut keys. This list is certainly not an exhaustive one — it describes just the commands that I find most useful.

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>What You Can Do with It</th>
</tr>
</thead>
<tbody>
<tr>
<td>F11</td>
<td>Create a new chart on a separate chart sheet (of the default chart type) by using data in the selected range.</td>
</tr>
<tr>
<td>Alt+F1</td>
<td>Create a new, embedded chart (of the default chart type) by using the data in the selected range.</td>
</tr>
<tr>
<td>F5</td>
<td>Display the Go To dialog box.</td>
</tr>
<tr>
<td>Alt</td>
<td>Display the keytips for the Ribbon commands so that you can access the commands by using letters on the keyboard.</td>
</tr>
<tr>
<td>F2</td>
<td>Edit the active cell.</td>
</tr>
<tr>
<td>Shift+F2</td>
<td>Edit the comment in the active cell or insert a comment if the cell doesn’t have one.</td>
</tr>
<tr>
<td>Ctrl+Shift+_</td>
<td>Remove all borders from the selected cells.</td>
</tr>
<tr>
<td>Shift+F10</td>
<td>Display the shortcut menu for the selected item. Equivalent to right-clicking the item.</td>
</tr>
<tr>
<td>Ctrl+F6</td>
<td>Activate the next window.</td>
</tr>
<tr>
<td>Ctrl+PgUp</td>
<td>Activate the previous sheet in the workbook.</td>
</tr>
<tr>
<td>Ctrl+PgDn</td>
<td>Activate the next sheet in the workbook.</td>
</tr>
<tr>
<td>Alt+Ctrl+V</td>
<td>Display the Paste Special dialog box.</td>
</tr>
<tr>
<td>Alt+=</td>
<td>Perform the equivalent of clicking the AutoSum button.</td>
</tr>
<tr>
<td>Ctrl+B</td>
<td>Make the selected cells bold.</td>
</tr>
<tr>
<td>Ctrl+C</td>
<td>Copy the selected cells.</td>
</tr>
<tr>
<td>Ctrl+D</td>
<td>Copy the top cell in a selected range to the other cells in the selection.</td>
</tr>
<tr>
<td>Ctrl+F</td>
<td>Display the Find dialog box.</td>
</tr>
<tr>
<td>Ctrl+H</td>
<td>Display the Replace dialog box.</td>
</tr>
<tr>
<td>Ctrl+I</td>
<td>Make the selected cells italic.</td>
</tr>
<tr>
<td>Ctrl+N</td>
<td>Create a new default workbook.</td>
</tr>
</tbody>
</table>

continued
### Bonus Tip 1: Discovering Some Useful Shortcut Keys

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>What You Can Do with It</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+R</td>
<td>Copy the leftmost cell in a selected range to the other cells in the selection.</td>
</tr>
<tr>
<td>Ctrl+S</td>
<td>Save the active workbook.</td>
</tr>
<tr>
<td>Ctrl+V</td>
<td>Paste a copied or cut item in the selected cell.</td>
</tr>
<tr>
<td>Ctrl+X</td>
<td>Cut the selected cells.</td>
</tr>
<tr>
<td>Ctrl+Y</td>
<td>Repeat the last repeatable command. If the last command was Undo, this shortcut reverses the Undo.</td>
</tr>
<tr>
<td>Ctrl+Z</td>
<td>Undo the last action.</td>
</tr>
</tbody>
</table>
Bonus Tip 2: Resetting the Used Area of a Worksheet

Resetting the Used Area of a Worksheet

When you press Ctrl+End, Excel activates the lower-right cell in the used area of the worksheet. In some cases, you find that the lower-right cell in the worksheet is an empty cell — not the real last cell. In other words, Excel sometimes loses track of the used area of your worksheet. For example, you may find that a workbook’s file size seems much too large. It’s possible that Excel has misidentified the used area and is storing a large number of empty cells.

First, try saving the workbook. After the workbook is saved, Excel may correctly identify the last cell. If Excel still doesn’t identify the last cell, it’s probably because you deleted data but left the formatting in the cells. To force Excel to identify the real used area, you need to delete the columns to the right of your data and then delete the rows below your data.

For example, assume that the real last cell in your workbook is G25 but pressing Ctrl+End takes you to some other cell — M50, for example.

To delete those formatted cells, follow these steps:

1. Select all columns to the right of column G.
   To do so, activate any cell in column H. Press Ctrl+spacebar followed by Shift+End and then press Shift while you press the right-arrow key.

2. Select Home ➜ Cells ➜ Delete ➜ Delete Sheet Columns (or right-click any column header and choose Delete).

3. Select all rows below row 25.
   To do so, activate any cell in row 26. Press Shift+spacebar followed by Shift+End and then press Shift while you press the down-arrow key.

4. Select Home ➜ Cells ➜ Delete ➜ Delete Sheet Rows (or right-click any row header and choose Delete).

5. Save your workbook, and Excel resets the last cell.

After performing these steps, pressing Ctrl+End takes you to the real last cell.

By the way, if you can’t remember Ctrl+End, you can use the Go To Special dialog box. Choose Home ➜ Find & Select ➜ Go To Special. Choose the Last Cell option and click OK.
Hiding Columns or Rows

If you have data in a column or row that you don’t want to see, you can hide the column or row. Doing so is often useful if you have formulas that provide intermediate calculations and you don’t want them to appear in a report. Or you may just want to hide unused rows and columns so that you can focus only on the used area of the sheet.

Formulas that refer to data in hidden rows or columns continue to function normally. An exception is the SUBTOTAL function. If the first argument for SUBTOTAL is greater than 100, the SUBTOTAL function ignores the data in the hidden rows or columns resulting from filtering or outlines. In addition, the new AGGREGATE function has an option to ignore hidden data in rows, even if the rows are hidden manually. Refer to the Help system for information about these functions — which do a lot more than just add numbers.

Hiding

To hide one or more columns, use any of these techniques:

➤ Select a cell in the column (or columns) to be hidden. Then choose Home ➜ Cells ➜ Format ➜ Hide & Unhide ➜ Hide Columns.
➤ Select entire columns and then right-click and choose Hide from the shortcut menu.
➤ Select a cell in the column (or columns) to hide and press Ctrl+0 (that’s a zero).

To hide one or more rows, use any of these methods:

➤ Select a cell in the row (or rows) to be hidden. Then choose Home ➜ Cells ➜ Format ➜ Hide & Unhide ➜ Hide Rows.
➤ Select entire rows and then right-click and choose Hide from the shortcut menu.
➤ Select a cell in the row (or rows) to be hidden and press Ctrl+9.
**Unhiding**

That which is hidden may also need to be unhidden.

To unhide one or more hidden columns, use any of these techniques:

- A hidden column appears in the column header as two vertical bars. Click and drag the right bar to the right to unhide the column.
- Select a range that consists of cells to the left and to the right of the hidden columns. Then choose Home ➜ Cells ➜ Format ➜ Hide & Unhide ➜ Unhide Columns.
- Select entire columns to the left and to the right of the hidden columns and then right-click and choose Unhide from the shortcut menu.

To unhide one or more hidden rows, use any of these methods:

- A hidden row appears in the row header as two horizontal bars. Click and drag the bottom bar downward to unhide the row.
- Select a range that consists of cells above and below the hidden rows. Then choose Home ➜ Cells ➜ Format ➜ Hide & Unhide ➜ Unhide Rows.
- Select entire rows above and below the hidden rows and then right-click and choose Unhide from the shortcut menu.
- Select a range that consists of cells above and below the hidden rows and press Ctrl+Shift+9.
Hiding Cell Contents

Excel doesn’t provide a direct way to hide the contents of cells (without hiding entire rows and columns), but you can fake it in a few ways:

➤ Use a special custom number format. Select the cell or cells to be hidden, press Ctrl+1 and click the Number tab in the Format Cells dialog box. Select Custom from the Category list and then, in the Type field, enter ;; (three semicolons).

➤ Make the font color the same as the cell’s background color.

➤ Add a shape to your worksheet and position it over the cell or cells to be hidden. You should make the shape the same color as the cell background and (probably) remove the borders.

All these methods have problems: The cell’s contents are still shown on the Formula bar when the cell is selected. If you don’t want to see the cell contents on the Formula bar after you use one of those methods, you can either hide the Formula bar (use View ➜ Show ➜ Formula Bar) or perform these additional steps:

1. Select the cells.

2. Press Ctrl+1 and then click the Protection tab in the Format Cells dialog box.

3. Select the Hidden check box and click OK.


5. In the Protect Sheet dialog box, add a password, if desired, and click OK.

Keep in mind that when a sheet is protected, you can’t change any cells unless they aren’t locked. By default, all cells are locked. You change the locked status of a cell by using the Protection tab in the Format Cells dialog box.
Limiting the Usable Area in a Worksheet

Have you ever wanted to restrict access to a certain range within a worksheet? For example, you may want to set up a worksheet so that cells only in a particular range can be activated or modified. This tip describes two ways to accomplish this task: by using the ScrollArea property and by using worksheet protection.

Setting the ScrollArea property

A worksheet’s ScrollArea property determines which range is visible. The instructions that follow describe how to restrict the usable area of the worksheet to a specific range.

Here’s how to do it:

1. Make sure that the Developer tab of the Ribbon is displayed.

   By default, this tab is not shown. To turn on the Developer tab, access the Excel Options dialog box (choose File ➜ Options), click the Customize Ribbon tab, and place a check mark next to Developer, in the list box on the right.

2. Choose Developer ➜ Controls ➜ Properties.

   In Figure 5-1, the range is C6:F13. You can’t point to the range; you must enter the range address manually.

![Properties window](image)

**Figure 5-1:** Use the Properties window to set the scroll area for the worksheet.

After performing these steps, you cannot activate any cell outside the specified range. Also, some commands no longer work. For example, you cannot select entire rows and columns. Note that the scroll area is limited to a single contiguous range of cells.
Bonus Tip 5: Limiting the Usable Area in a Worksheet

There’s a problem: The ScrollArea property isn’t persistent. In other words, if you save your file, close it, and then open it again, the ScrollArea is reset, and you’re free to select any cell you like. One solution is to write a simple VBA macro that is executed when the workbook is opened. To add this type of macro, follow these instructions:

1. **Make sure that the workbook window is not maximized.**
   
   One way to do so is to press Ctrl+F5.

2. **Right-click the workbook’s title bar and choose View Code from the shortcut menu.**
   
   This action accesses the ThisWorkbook code module for the workbook.

3. **Enter the following VBA code in the ThisWorkbook code module (adjusting the sheet name and range address, of course):**

   ```vba
   Private Sub Workbook_Open()
       Worksheets("Sheet1").ScrollArea = "C6:F13"
   End Sub
   ```

4. **Press Alt+F11 to return to Excel.**

5. **Save the workbook, close it, and reopen it.**

   If your workbook has an XLSX extension, you need to save it as a macro-enabled workbook (with an XLSM extension).

   When the workbook is opened, the Workbook_Open procedure is executed automatically, and the ScrollArea property is set.

   **Caution**

   This method is by no means a foolproof way to prevent users from accessing parts of a workbook. Nothing can prevent a savvy user from using the Properties window to delete the contents of the ScrollArea field. Or, when the workbook is open, the user can choose to disable macros for the workbook. Another way to bypass the Workbook_Open macro is to press and hold Shift while the file opens.
**Bonus Tip 5: Limiting the Usable Area in a Worksheet**

**Using worksheet protection**

The second method of limiting the usable area of a worksheet relies on unlocking cells and protecting the workbook:

1. Select all cells that you want to be accessible.
   
   They can be single cells or any number of ranges.
2. Press Ctrl+1 to open the Format Cells dialog box.
3. Click the Protection tab and remove the check mark from the Locked check box.
4. Choose Review ➜ Changes ➜ Protect Sheet to open the Protect Sheet dialog box.
5. Remove the check mark from the Select Locked Cells check box.
6. If desired, specify a password that will be required in order to unprotect the sheet and then click OK.

After you perform these steps, only the unlocked cells (those you selected in Step 1) are accessible.

---

**Caution**

Worksheet passwords are not at all secure. In fact, it’s a trivial matter to crack such a password. Therefore, worksheet protection is more of a convenience feature than a security feature.
Using an Alternative to Cell Comments

As you probably know, you can attach a comment to any cell by using the Review ➜ Comments ➜ New Comment button (or by right-clicking the cell and choosing Insert Comment from the shortcut menu). Use Review ➜ Comments ➜ Show All Comments to toggle the display of comments. The Excel Options dialog box has additional options for viewing comments, which are found in the Display section of the Advanced tab. A user can choose to hide all comments and comment indicators — which means that your comments will probably never be seen.

This tip describes how to use Excel’s Data Validation feature to display a pop-up message whenever a cell is activated. It’s a good way to ensure that your comment will always be seen, regardless of the user’s settings for viewing comments.

Follow these steps to add a message to a cell:

1. Activate the cell that you want to show the pop-up message.
2. Choose Data ➜ Data Tools ➜ Data Validation.
   The Data Validation dialog box appears.
3. Click the Input Message tab.
4. (Optional) In the Title field, enter a title for your message.
5. Enter the message in the Input Message box.
6. Click OK to close the Data Validation dialog box.

After you perform these steps, the message appears whenever the cell is activated (see Figure 6-1 for an example). You can also click and drag the message to a different location, if it’s in your way.

![Figure 6-1: This pop-up message was created by using Excel’s Data Validation feature.](image)
Making a Worksheet Very Hidden

You probably already know how to hide a worksheet: Just right-click the sheet tab and choose Hide Sheet from the shortcut menu. And, of course, it's just as easy to unhide a sheet: Right-click any sheet tab and choose Unhide from the shortcut menu. (You see a list of all hidden sheets.)

To make it more difficult for the casual user to unhide a hidden sheet, make the worksheet “very hidden.” Here’s how to do it:

1. Make sure that the Developer tab of the Ribbon appears.

   By default, this tab is not shown. To turn on the Developer tab, access the Excel Options dialog box (choose File ➜ Options), click the Customize Ribbon tab, and place a check mark next to Developer, in the list box on the right.

2. Activate the sheet you want to hide.

3. Click Developer ➜ Controls ➜ Properties to open the Properties window (see Figure 7-1).

4. In the Properties window, click the Visible property to display a down-arrow button; click the button to display a drop-down list and select 2-xlSheetVeryHidden.

![Figure 7-1: Use the Properties window to make a worksheet “very hidden.”](image)

After performing these steps, you find that you cannot unhide the sheet by using an Excel command. In fact, you cannot even unhide the sheet by using the Properties window. The Properties window shows the properties of the active sheet. When a sheet is hidden, it’s never the active sheet.
Is the sheet hidden forever? Nope. To make the very hidden sheet visible again, you use a simple VBA macro. The macro listed here unhides Sheet2 of the active workbook (change the sheet name as appropriate):

```
Sub UnhideSheet()
    Worksheets("Sheet2").Visible = True
End Sub
```

Making a worksheet very hidden is not a security feature. Anyone who really wants to know what resides on a very hidden sheet can easily find out by using a macro such as the one listed here.
Moving the Cell Pointer After Entering Data

By default, when you press Enter after entering data into a cell, Excel automatically moves the cell pointer to the next cell down. To change this setting, use the Excel Options dialog box (choose File ➜ Options). The setting you’re looking for is on the Advanced tab of the Excel Options dialog box, in the Editing Options section (see Figure 8-1).

The check box that controls this behavior is labeled After Pressing Enter, Move Selection. When that check box is enabled, you can also specify the direction in which the cell pointer moves (down, left, up, or right).

![Figure 8-1: Use the Advanced tab in the Excel Options dialog box to specify where to move the cell pointer after you press Enter.](image)

Your choice is completely a matter of personal preference. I prefer to keep this option turned off and use the arrow keys rather than press Enter. Not surprisingly, the arrow keys send the cell pointer in the direction that you indicate. For example, if you’re entering data in a row, press the right-arrow key rather than Enter. The other arrow keys work as expected, and you can even use the PgUp and PgDn keys.
**Keeping Titles in View**

A common type of worksheet contains a table of data with descriptive headings in the first row. But, as you scroll down the worksheet, the first row scrolls off the screen so you can no longer see the column descriptions.

A feature introduced in Excel 2007 eliminated this age-old spreadsheet problem — but only if your data is in the form of a table (created with Insert ➜ Tables ➜ Table). Figure 9-1 shows a table that has been scrolled down. Normally, the column headers are scrolled out of view. But, when you're working with a table, Excel displays the column headers where the column letters normally appear.

![Figure 9-1: The column headers for this table are displayed where the column letters normally appear.](image)

Note that the column headers are visible only when a cell within the table is selected.

If your data isn’t in the form of a table, you have to resort to the old-fashioned method: freeze panes. This method keeps the headings visible while you’re scrolling through the worksheet.

To freeze the first row, choose View ➜ Window ➜ Freeze Panes ➜ Freeze Top Row. Excel inserts a dark horizontal line to indicate the frozen row. To freeze the first column, choose View ➜ Window ➜ Freeze Panes ➜ Freeze First Column.
If you want to freeze more than one column or one row, move the cell pointer to the cell below and to the right of where you want the freeze to occur. Then choose View ➜ Window ➜ Freeze Panes ➜ Freeze Panes. For example, if you want to freeze the first two rows and the first column, move the cell pointer to cell B3 before you issue the command. To freeze the first three rows (but not any columns), select cell A4 before you issue the Freeze Panes command.

Some navigation keys operate as though the frozen rows or columns don’t exist. For example, if you press Ctrl+Home while the worksheet has frozen panes, the cell selector moves to the upper-left unfrozen cell. Similarly, the Home key moves to the first unfrozen cell in the current row. You can move into the frozen rows or columns by using the direction keys or your mouse.

To remove the frozen panes, choose View ➜ Window ➜ Freeze Panes ➜ Unfreeze Panes.
Working with Fractions

Although most users work with decimal values, some types of data are normally displayed as fractions, not as decimals. This tip describes how to enter non-integer values as fractions.

To enter a whole number and a fraction into a cell, leave a space between the whole number and the fractional part. For example, to display $6\frac{7}{8}$, type $6\ 7/8$ and then press Enter. When you select the cell, $6.875$ appears on the Formula bar, and the cell entry appears as a fraction.

If you have only a fraction (for example, $\frac{1}{8}$), you must enter a zero first, like this: $0\ 1/8$ — otherwise, Excel likely assumes that you’re entering a date. When you select the cell and look at the Formula bar, you see $0.125$. In the cell, you see $1/8$.

If the numerator is larger than the denominator, Excel converts it to a whole number and a fraction. For example, if you enter $0\ 65/8$, Excel converts it to $8\ 1/8$.

After you enter a fraction, bring up the Format Cells dialog box and take a look at the number format for the cell. You see that Excel automatically applied one of its Fraction number formats (see Figure 10-1).

![Figure 10-1: A list of the Excel built-in Fraction number formats.](image)
If none of the built-in Fraction number formats meets your needs, you may be able to create a custom number format. Press Ctrl+1, and in the Format Cells dialog box, click the Number tab. In the Category list, click Custom and then enter a number format string in the Type field. For example, enter the following Number format string in the Type field to display a value in 32nds:

# ??/32

The following number format string displays a value in terms of fractional dollars. For example, the value 154.87 is displayed as 154 and 87/100 Dollars.

0 "and "??/100 "Dollars"

The following example displays the value in 16ths, with a quotation mark appended to the right. This format string is useful when you deal with inches (for example, 3/16”).

# ??/16"
Controlling Automatic Hyperlinks

One of the most common Excel questions is “How can I prevent Excel from creating automatic hyperlinks?”

Normally, Excel watches you type, and if it looks at all like you’re typing an e-mail address or a web URL, the entry is converted into a hyperlink. Sometimes that capability is helpful, but sometimes it’s not.

Overriding an automatic hyperlink

To override a single automatic hyperlink, just click Undo (or press Ctrl+Z) after you enter the text. The hyperlink disappears, but the text you entered remains intact. Another option is to precede the entry with an apostrophe so that it’s evaluated as plain text.

Turning off automatic hyperlinks

If you never want to create automatic hyperlinks, here’s how to turn off this feature (it’s not exactly intuitive):

1. Choose File ➜ Options.
   The Excel Options dialog box appears.
2. Click the Proofing tab.
3. Click the AutoCorrect Options button.
   The AutoCorrect dialog box appears.
4. Click the AutoFormat As You Type tab and deselect the Internet and Network Paths with Hyperlinks check box (see Figure 11-1).
**Removing existing hyperlinks**

To remove a hyperlink from a cell (but keep the cell’s contents), right-click the cell and choose Remove Hyperlink from the shortcut menu.

To remove all hyperlinks in a range, select the range, right-click, and choose Remove Hyperlinks. This command works even if the selection includes cells that don’t contain a hyperlink.

To remove all hyperlinks on a worksheet, press Ctrl+A to select all cells. Then right-click any cell and choose Remove Hyperlinks. Depending on the location of the cell pointer, you may need to press Ctrl+A twice to select all cells.
Controlling the Office Clipboard

You’re undoubtedly familiar with the Windows Clipboard. When you copy (or cut) something (such as text or an image), the information is stored on the Clipboard. Then you can paste the information somewhere else.

Microsoft Office has another Clipboard that works only in the Office products. The Office Clipboard is more versatile than the Windows Clipboard, and it enables you to store as many as 24 copied items. The Windows Clipboard, on the other hand, can hold only a single item. When you copy or cut something, the previous Windows Clipboard contents are wiped out. The downside to the Office Clipboard is that it works only in Microsoft Office applications.

If the Office Clipboard doesn’t seem to be working, you can display it by clicking the dialog box launcher in Clipboard group in the Home tab. The dialog box launcher is the small icon to the right of the Clipboard group name. Clicking this dialog box launcher toggles the display of the Office Clipboard.

Every time you copy (or cut) something, the Office Clipboard displays a portion of the information (see Figure 12-1). After you store 24 items, newly added items replace older items. To paste the information, just select the location where you want to paste and click the item in the Office Clipboard.

Figure 12-1: The Office Clipboard, displaying five copied items.
For Excel users, the Office Clipboard has a serious limitation that makes it almost worthless: It cannot hold formulas! If you copy a range of formulas to the Office Clipboard and then paste the data elsewhere, you find that the formula results (not the formulas themselves) are pasted. In a few situations, this behavior can be advantageous. In the vast majority of cases, you want to copy and paste formulas, not their values.

Although the Office Clipboard can be useful, a significant number of users find it annoying. To control some aspects of the Office Clipboard, click the Options button at the bottom of the Clipboard task pane. Normally, the Office Clipboard appears automatically whenever you copy two pieces of information. To prevent this from happening, deselect the Show Office Clipboard Automatically check box.
Displaying Times That Exceed 24 Hours

There’s nothing really special about a time value. An Excel time value is a normal number that is formatted to display as a time. For example, 0 represents 12:00 a.m., 0.50 represents noon (halfway through the day), and 0.75 represents 6:00 p.m.

Because time values are numbers, you can add them together. Figure 13-1 shows a worksheet that sums several time values. The formula in cell B7 is a simple SUM formula:

\[ \text{=SUM(B2 : B6)} \]

![Figure 13-1: Summing time values might not display the correct result.](image)

As you can see, the formula returns an incorrect result. Because a day has only 24 hours, Excel normally ignores hours that exceed 24 hours. To force Excel to display times that exceed 24 hours, you need to modify the number format. Select the cell, press Ctrl+1 to go to the Format Cells dialog box, and then choose the Number tab. To display the correct value, select the Custom category and edit the number format code by placing square brackets around the h part:

\[ [h]:mm \]

Figure 13-2 shows the result after changing the number format for cell B7.

![Figure 13-2: Adjusting the number format causes the cell to display the correct value.](image)
Adding a Frame to a Range

Excel supports lots of graphical formatting effects: shadows, glow, and reflection, for example. These effects apply only to graphical objects, such as pictures, shapes, and charts.

If you need to make a range of cells stand out, you can insert a shape to serve as a frame. The shape must be transparent (or semitransparent), but you can apply effects. Choose the Insert ➜ Illustrations ➜ Shape command to add a shape to your worksheet.

Figure 14-1 shows an example of a range that has a transparent rectangular shape superimposed on top of it. I applied some bevel effects and a shadow to the shape to make it resemble a matted picture frame that's floating above the worksheet. The shape in the figure uses a thick compound line style, a beveled top, and a shadow.

![Figure 14-1: A transparent shape on top of a range.](image)

For maximum flexibility in formatting a shape, use the Format Shape task pane rather than the Ribbon commands. To display this dialog box, select the shape and press Ctrl+1.
Dealing with Gridlines, Borders, and Underlines

If you need to draw attention to or delineate cells in a worksheet, one way to do it is with lines. Excel provides three options:

- Worksheet gridlines
- Cell borders
- Cell underlining

Worksheet gridlines is an all-or-none setting. Turn gridlines on or off for the active worksheet by using the View ➜ Show ➜ Gridlines check box. Normally, worksheet gridlines are not printed, but if you want the gridlines to appear on your printed output, use the Page Layout ➜ Sheet Options ➜ Gridlines Print check box.

You can also change the color of the gridlines. Choose File ➜ Option, and select the Advanced tab in the Excel Options dialog box. Scroll down to the section Labeled Display Options For This Worksheet, and select the new gridline color.

Cell borders can be applied to individual cells or to a range of cells. The Borders control in the Home ➜ Font group provides the most common cell border options, but for complete control, use the Border tab of the Format Cells dialog box, which is shown in Figure 15-1. (Press Ctrl+1 to display the Format Cells dialog box.) This dialog box gives you control over border color, line style, and location (for example, horizontal borders only) and works with the selected cell or range. This dialog box can be a bit confusing, but if you take a few minutes to experiment with the various options, you’ll understand how it works. Generally, you choose a style and color and then use the Presets or the Border buttons to make your choice.

Cell underlining is completely independent of gridlines and cell borders. Excel provides four different types of underlining:

- Single
- Double
- Single accounting
- Double accounting

The Underline control in the Home ➜ Font group lets you choose from single or double underlining. To apply the other two types of underlining, you must select the underline type from the Underline drop-down list found on the Font tab in the Format Cells dialog box.
How is accounting underlining different from normal underlining? The difference is subtle. When accounting underlining is applied to a cell that contains text, the complete width of the cell is underlined. In addition, the underline appears slightly lower in the accounting underline formats, making the underlined data more legible.

Figure 15-2 shows all four types of underlining for text (column A) and for values formatted as currency. Worksheet gridlines are turned off to make the underlining more visible.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>No Underline</td>
<td>$1,234.56</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Single Underline</td>
<td>$1,234.56</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Double Underline</td>
<td>$1,234.56</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Single Accounting Underline</td>
<td>$1,234.56</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Double Accounting Underline</td>
<td>$1,234.56</td>
<td></td>
</tr>
</tbody>
</table>
Seeing All Characters in a Font

You probably have dozens of fonts installed on your system. Here’s a quick way to view the characters available in any font.

Start with a new worksheet and then follow these steps:

1. Enter this formula into cell A1:
   \[ =\text{CHAR (ROW ( ))} \]

2. Copy cell A1 down the column to cell A255.
3. Click the Column A header to select the entire column.
4. Choose a font from the Font drop-down list in the Home ➜ Font group.
5. Scroll down the worksheet to see the various characters in the selected font.
6. Repeat Steps 3 and 4 as often as you like.

Figure 16-1 shows a partial view of the characters in the Webdings font. The row number corresponds to the character number. You can enter these characters from the keyboard by using the numeric keypad, but make sure that NumLock is turned on. For example, to enter the character shown in row 120, hold down the Alt key while you type \[ 120 \] on the numeric keypad. For codes less than 100, enter a leading zero. Make sure that the cell (or character) is formatted using the correct font.

Figure 16-1: A few characters from the Webdings font.
If you plan to share your workbook with others, be careful about using nonstandard fonts (fonts that don’t ship with Windows or Microsoft Office). If the font you specified isn’t available on your colleague’s system, Excel attempts to substitute the closest match. But it’s not always successful.

The CHAR function works with only the first 255 characters in the font. Unicode fonts contain many additional characters that cannot be displayed by using the CHAR function. Excel 2013 includes a new function, UNICHAR, that accepts an argument greater than 255. Here’s an example of a formula that uses the UNICHAR function:

=UNICHAR(8309)

You can also access these characters (and determine their value) by using the Symbol dialog box (choose Insert ➜ Symbols ➜ Symbol). The Symbol dialog box shows the code in hexadecimal. The UNICHAR function accepts only a decimal argument, so you can convert it using the HEX2DEC function. For example, I learned from the Symbol dialog box that the hexadecimal code for a chessboard pawn character is 265F. To display this character, use this formula:

=UNICHAR(HEX2DEC("265F"))

The character displays correctly in most (but not all) fonts.
Annotating a Formula Without Using a Comment

The Excel comment feature is a great way to annotate your formulas. Just right-click the cell and choose Insert Comment from the shortcut menu. You can then describe the formula any way you like inside the comment.

This tip describes another, less obtrusive, way to annotate a formula. The trick involves Excel’s rarely used N function. (This function is included in Excel primarily for compatibility with old Lotus 1-2-3 files.) The N function takes one argument, and this argument is converted to a value. When the argument is a text string, the N function returns 0. You can take advantage of this and modify the formula so that it uses the N function.

Consider this simple formula:

=A4+.275

You can modify the formula to contain a comment. Because the N function returns 0, the comment has no effect on the value returned by the formula:

=A4+.275+N("27.5% represents the anticipated tax rate")
Displaying and Printing Formulas

When you enter a formula into a cell, Excel displays the calculated value of the formula. To view a formula, activate the cell, and Excel shows the formula on the Formula bar.

To view all your formulas, choose Formulas ➜ Formula Auditing ➜ Show Formulas. Or press Ctrl+` (that’s the grave accent character, usually located above the Tab key). Excel then displays the formulas rather than their results. In addition, you can see which cells are referenced by the selected formula because Excel displays those cells with a colored border. Figure 18-1 shows a worksheet in Formula view. D8 is the selected cell, and it references cells B8 and C8, which are displayed with a colored border.

![Figure 18-1: Excel's Formula view displays the formulas rather than their results.](image)

In Formula view, you can use all Excel commands and even modify the formulas.

In practice, you may find that Formula view isn’t very useful. Although Excel widens the columns, you can see an entire formula only if it’s very short. And, if you print the sheet in Formula view, you usually end up with a meaningless mess.

To document a worksheet by printing its formulas, your best bet is to locate a VBA macro to do the job. This simple, no-frills VBA procedure makes a list of all formulas on the active worksheet:

```vba
Sub ListFormulas()
    Dim FormulaCells As Range
    Dim FormulaSheet As Worksheet
    Dim Row As Long
    Dim Cell As Range
    On Error Resume Next
    Set FormulaCells = Range("A1").SpecialCells(xlFormulas, 23)
    If FormulaCells Is Nothing Then Exit Sub
    Set FormulaSheet = ActiveWorkbook.Worksheets.Add
    Row = 1
    For Each Cell In FormulaCells
        With FormulaSheet
```


Bonus Tip 18: Displaying and Printing Formulas

```vbnet
Cells(Row, 1) = Cell.Address(False, False)
Cells(Row, 2) = " " & Cell.Formula
Cells(Row, 3) = Cell.Value
Row = Row + 1
End With
Next Cell
End Sub
```

To use this macro, press Alt+F11 to activate the Visual Basic Editor. Select your workbook in the Project window and choose Insert ➜ Module to insert a new VBA module. Type the code exactly as it appears. To execute the macro, activate the sheet that has the formulas, press Alt+F8, select ListFormulas from the macro list, and click Run.

Figure 18-2 shows an example of the output from this macro. The first column contains the address of the formula, the second column contains the formula, and the third column shows the current result of the formula.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>D3</td>
<td>=C3-B3</td>
<td>13704</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>D4</td>
<td>=C4-B4</td>
<td>16390</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>D5</td>
<td>=C5-B5</td>
<td>21917</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>D6</td>
<td>=C6-B6</td>
<td>10126</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>D7</td>
<td>=C7-B7</td>
<td>7641</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>D8</td>
<td>=C8-B8</td>
<td>5968</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>D9</td>
<td>=C9-B9</td>
<td>8318</td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>D10</td>
<td>=C10-B10</td>
<td>19344</td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>D11</td>
<td>=C11-B11</td>
<td>24726</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>D12</td>
<td>=C12-B12</td>
<td>35134</td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>D13</td>
<td>=C13-B13</td>
<td>40571</td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>D14</td>
<td>=C14-B14</td>
<td>34465</td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>B15</td>
<td>=SUM(B2:B14)</td>
<td>1129510</td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>C15</td>
<td>=SUM(C2:C14)</td>
<td>1367873</td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>D15</td>
<td>=SUM(D2:D14)</td>
<td>238362</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Figure 18-2:** A list of formulas generated by a VBA macro.

Yet another option to list all formulas is to use the Inquire add-in, which is included with Office 2013 Professional Plus.
Creating a List of Names

The Name Manager dialog box, shown in Figure 19-1, is a handy tool that displays a list of all names defined in the active workbook. Access this dialog box by choosing Formulas ➜ Defined Names ➜ Name Manager, or just press Ctrl+F3.

![Figure 19-1: The Name Manager dialog box displays a sortable list of all names.](image)

Suppose that you want to put a list of those names into a worksheet range, as a way to document your project. Although the Name Manager dialog box doesn’t provide a way to paste a list of names, doing so is possible — you just need to know where to look.

The secret Paste List button is in the Paste Name dialog box. To go to this dialog box, choose Formulas ➜ Defined Names ➜ Use in Formula ➜ Paste Name, or press F3. Then click the Paste List button to create a list of names (and their definitions) starting at the active cell. Figure 19-2 shows the result of using the Paste List button in the Paste Name dialog box.

Unfortunately, this list isn’t as comprehensive as the list shown in the Name Manager dialog box.
### Figure 19-2: Use the Paste List button to create a list of names in your worksheet.

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>B</td>
<td>C</td>
</tr>
<tr>
<td>1</td>
<td>April</td>
<td>=Sheet1!$B$5:$E$5</td>
</tr>
<tr>
<td>2</td>
<td>August</td>
<td>=Sheet1!$B$9:$E$9</td>
</tr>
<tr>
<td>3</td>
<td>December</td>
<td>=Sheet1!$B$13:$E$13</td>
</tr>
<tr>
<td>4</td>
<td>February</td>
<td>=Sheet1!$B$3:$E$3</td>
</tr>
<tr>
<td>5</td>
<td>January</td>
<td>=Sheet1!$B$2:$E$2</td>
</tr>
<tr>
<td>6</td>
<td>July</td>
<td>=Sheet1!$B$8:$E$8</td>
</tr>
<tr>
<td>7</td>
<td>June</td>
<td>=Sheet1!$B$7:$E$7</td>
</tr>
<tr>
<td>8</td>
<td>March</td>
<td>=Sheet1!$B$4:$E$4</td>
</tr>
<tr>
<td>9</td>
<td>May</td>
<td>=Sheet1!$B$6:$E$6</td>
</tr>
<tr>
<td>10</td>
<td>November</td>
<td>=Sheet1!$B$12:$E$12</td>
</tr>
<tr>
<td>11</td>
<td>October</td>
<td>=Sheet1!$B$11:$E$11</td>
</tr>
<tr>
<td>12</td>
<td>Region_1</td>
<td>=Sheet1!$B$2:$E$2</td>
</tr>
<tr>
<td>13</td>
<td>Region_2</td>
<td>=Sheet1!$C$2:$E$2</td>
</tr>
<tr>
<td>14</td>
<td>Region_3</td>
<td>=Sheet1!$D$2:$E$2</td>
</tr>
<tr>
<td>15</td>
<td>Region_4</td>
<td>=Sheet1!$E$2:$E$2</td>
</tr>
<tr>
<td>16</td>
<td>SalesTax</td>
<td>=0.25%</td>
</tr>
<tr>
<td>17</td>
<td>September</td>
<td>=Sheet1!$B$10:$E$10</td>
</tr>
</tbody>
</table>

**Note:** If you display the Paste Name dialog box when you’re editing a formula, the Paste List button doesn’t appear in the dialog box.
Rounding Time Values

You may need to create a formula that rounds a time to a particular number of minutes. For example, you may need to enter your company's employee time records rounded to the nearest 15 minutes. This tip presents examples of various ways to round a time value.

The following formula rounds the time in cell A1 to the nearest minute:

```
=ROUND(A1*1440,0)/1440
```

This formula works by multiplying the time by 1440 (to get the total number of minutes). This value is passed to the ROUND function, and the result is divided by 1440. For example, if cell A1 contains 11:52:34, the formula returns 11:53:00.

The following formula is similar, except that it rounds the time in cell A1 to the nearest hour:

```
=ROUND(A1*24,0)/24
```

If cell A1 contains 5:21:31, the formula returns 5:00:00.

The following formula rounds the time in cell A1 to the nearest 15 minutes (quarter of an hour):

```
=ROUND(A1*24/0.25,0)*(0.25/24)
```

In this formula, 0.25 represents the fractional hour. To round a time to the nearest 30 minutes, change 0.25 to 0.5, as in the following formula:

```
=ROUND(A1*24/0.5,0)*(0.5/24)
```
Converting Temperatures

This tip presents formulas for conversion among three units of temperature: Fahrenheit, Celsius, and Kelvin.

The formulas in Table 21-1 assume that the temperature for conversion is in a cell named temp.

Table 21-1: Temperature Conversion Formulas

<table>
<thead>
<tr>
<th>Type of Conversion</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fahrenheit to Celsius</td>
<td>((\text{temp}-32) \times \frac{5}{9})</td>
</tr>
<tr>
<td>Fahrenheit to Kelvin</td>
<td>((\text{temp}-32) \times \frac{5}{9} + 273)</td>
</tr>
<tr>
<td>Celsius to Fahrenheit</td>
<td>((\text{temp} \times 1.8) + 32)</td>
</tr>
<tr>
<td>Celsius to Kelvin</td>
<td>(\text{temp} + 273)</td>
</tr>
<tr>
<td>Kelvin to Celsius</td>
<td>(\text{temp} - 273)</td>
</tr>
<tr>
<td>Kelvin to Fahrenheit</td>
<td>(((\text{temp} - 273) \times 1.8) + 32)</td>
</tr>
</tbody>
</table>
Calculating Roots

If you need to calculate the square root of a value, use the SQRT function. The following formula, for example, calculates the square root of the value in cell A1:

$$=\text{SQRT}(A1)$$

What about other roots? You won’t find a CUBEROOT function, and there certainly isn’t a FOURTHROOT function. The trick is to raise the number to the \((1/\text{root})\) power. For example, to calculate the cube root of the value in cell A1, use this formula:

$$=A1^{(1/3)}$$

To calculate the fourth root, use this formula:

$$=A1^{(1/4)}$$
Calculating a Remainder

When you divide two numbers, if the result isn’t a whole number, you end up with a remainder. When Excel performs division, the result is a decimal value. How can you determine the remainder (if any) that results from a division?

The solution is to use the MOD function, which takes two arguments: the number and the divisor. The MOD function returns the remainder.

For example, if you have 187 books to be divided equally among 5 offices, how many will be left over? Use this formula to determine the number of books per office (which is 37):

\[ =\text{INT}(187/5) \]

Use this formula to calculate how many books will be left over (which is 2):

\[ =\text{MOD}(187, 5) \]
Creating Sparkline Graphics

A Sparkline is a small chart displayed in a single cell. A Sparkline lets you quickly spot time-based trends or variations in data. Because they are so compact, Sparklines are often used in a group.

Although Sparklines look like miniature charts (and can sometimes take the place of a chart), this feature is completely separate from Excel’s charting feature. For example, charts are placed on a worksheet’s draw layer, and a single chart can display several series of data. A Sparkline is displayed inside a cell and displays only one series of data.

Figure 24-1 shows examples of each of the three types of Sparkline graphics, displayed in column H. Each Sparkline depicts the six data points to the left.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Line Sparklines</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fund Number</td>
<td>Jan</td>
<td>Feb</td>
<td>Mar</td>
<td>Apr</td>
<td>May</td>
<td>Jun</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A-13</td>
<td>103.36</td>
<td>98.92</td>
<td>88.12</td>
<td>86.34</td>
<td>75.58</td>
<td>71.2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>C-09</td>
<td>212.74</td>
<td>218.7</td>
<td>202.18</td>
<td>198.56</td>
<td>190.12</td>
<td>181.74</td>
<td></td>
<td></td>
</tr>
<tr>
<td>K-88</td>
<td>75.74</td>
<td>73.68</td>
<td>69.86</td>
<td>60.34</td>
<td>64.92</td>
<td>59.46</td>
<td></td>
<td></td>
</tr>
<tr>
<td>W-91</td>
<td>91.78</td>
<td>95.44</td>
<td>96.1</td>
<td>99.46</td>
<td>98.68</td>
<td>105.86</td>
<td></td>
<td></td>
</tr>
<tr>
<td>M-03</td>
<td>324.48</td>
<td>309.14</td>
<td>313.1</td>
<td>287.82</td>
<td>276.24</td>
<td>260.9</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

| **Column Sparklines** | | | | | | | | |
| Fund Number | Jan | Feb | Mar | Apr | May | Jun | | |
| A-13 | 103.36 | 98.92 | 88.12 | 86.34 | 75.58 | 71.2 |
| C-09 | 212.74 | 218.7 | 202.18 | 198.56 | 190.12 | 181.74 |
| K-88 | 75.74 | 73.68 | 69.86 | 60.34 | 64.92 | 59.46 |
| W-91 | 91.78 | 95.44 | 96.1 | 99.46 | 98.68 | 105.86 |
| M-03 | 324.48 | 309.14 | 313.1 | 287.82 | 276.24 | 260.9 |

| **Win/Loss Sparklines** | | | | | | | | |
| Fund Number | Jan | Feb | Mar | Apr | May | Jun | | |
| A-13 | #N/A | -5.06 | -10.8 | -3.78 | -10.76 | -4.38 |
| C-09 | #N/A | -5.96 | -16.52 | -9.62 | -8.44 | -8.38 |
| K-88 | #N/A | -2.06 | -3.92 | -9.52 | 4.58 | -5.46 |
| W-91 | #N/A | 3.66 | 2.56 | 1.38 | -0.78 | 7.18 |
| M-03 | #N/A | -15.34 | 3.36 | -25.29 | -11.58 | -15.34 |

**Figure 24-1**: Examples of Sparkline graphics.

The three types of Sparklines available in Excel are:

- **Line**: Similar to a line chart. As an option, the line can display with a marker for each data point. The first group in Figure 24-1 shows line Sparklines, with markers. A quick glance reveals that with the exception of Fund Number W-91, the funds have been losing value over the six-month period.
Bonus Tip 24: Creating Sparkline Graphics

➤ **Column:** Similar to a column chart. The second group shows the same data displayed with column Sparklines.

➤ **Win/Loss:** A binary-type chart that displays each data point as a high block or a low block. The third group shows win/loss Sparklines. Notice that the data is different. Each cell displays the change from the previous month. In the Sparkline, each data point is depicted as a high block (win) or a low block (loss). In this example, a positive change from the previous month is a win, and a negative change from the previous month is a loss.

To create Sparkline graphics, select the data that will be depicted. Then choose Insert ➜ Sparklines and click one of the three Sparkline types: Line, Column, or Win/Loss. The Create Sparklines dialog box appears, where you specify the location for the Sparklines.

Typically, you put the Sparklines next to the data, but that’s not a requirement. Most of the time, you use an empty range to hold the Sparklines. However, Excel doesn’t prevent you from inserting Sparklines into cells that already contain data. The Sparkline location that you specify must match the source data in terms of number of rows or number of columns.

After you create some Sparklines, you have a fair amount of control over their appearance. Use the tools in the Sparkline Tools Design tab (which appears when you select a cell that contains a Sparkline).

Figure 24-2 shows a group of Sparklines in the range H4:H12, plus a line chart that uses the same data. The line chart is a bit jumbled, but it’s a better choice if you want to compare the cities. The Sparklines, on the other hand, are useful for showing trends for a single city.

![Figure 24-2: A group of Sparklines and a line chart that shows the same data.](image-url)
Using Images as Line Chart Markers

When you create a Line chart (or a scatter chart), you can choose from a few different marker styles. For added pizzazz, you may want to use a shape or a simple clip art image for your markers. This technique works best when the chart has a small number of data points.

Figure 25-1 shows an example. This line chart uses a shape for its markers.

The procedure is simple:

1. Create a line chart with markers.
2. Choose Insert ➜ Illustrations ➜ Shapes to add a shape to your worksheet.
3. Format the shape any way you like, and size it so that it’s suitable for the chart.
4. Select the shape and press Ctrl+C.
5. Activate the chart, select the line series, and press Ctrl+V.

You can even use different shapes for each data point. The trick is to click the series once to select the entire series and then click a single data point marker. When you press Ctrl+V, only the selected marker is changed. Figure 25-2 shows a chart that uses two different shapes.
**Figure 25-2:** A line chart with two shapes for the line markers.

You can also use clip art for the line markers. Choose Insert ➜ Illustrations ➜ Online Pictures to search for clip art. For best results, use a relatively simple image. Figure 25-3 shows an example of a chart that uses a clip art image for line markers. I applied a shadow to the image before I pasted it, and the shadow transfers when the image is pasted to the chart series.

**Figure 25-3:** A line chart with a clip art image for the line markers.
Randomizing a List

This tip describes a quick method to randomize a list. It’s like shuffling a deck of cards, where each row is a card.

Figure 26-1 shows a four-column list, sorted by column A. The goal is to arrange the rows in random order.

<table>
<thead>
<tr>
<th>Rank</th>
<th>Artist</th>
<th>Title</th>
<th>Year</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Bob Dylan</td>
<td>Like a Rolling Stone</td>
<td>1965</td>
</tr>
<tr>
<td>2</td>
<td>The Rolling Stones</td>
<td>(I Can't Get No) Satisfaction</td>
<td>1965</td>
</tr>
<tr>
<td>3</td>
<td>The Beach Boys</td>
<td>Good Vibrations</td>
<td>1966</td>
</tr>
<tr>
<td>4</td>
<td>Nirvana</td>
<td>Smells Like Teen Spirit</td>
<td>1991</td>
</tr>
<tr>
<td>5</td>
<td>Aretha Franklin</td>
<td>Respect</td>
<td>1967</td>
</tr>
<tr>
<td>6</td>
<td>Chuck Berry</td>
<td>Johnny B-Goode</td>
<td>1959</td>
</tr>
<tr>
<td>7</td>
<td>Otis Redding</td>
<td>Sittin' on the Dock of the Bay</td>
<td>1960</td>
</tr>
<tr>
<td>8</td>
<td>Marvin Gaye</td>
<td>I Heard It Through the Gospeln</td>
<td>1969</td>
</tr>
<tr>
<td>9</td>
<td>Sex Pistols</td>
<td>Anarchy in the U.K.</td>
<td>1976</td>
</tr>
<tr>
<td>10</td>
<td>Led Zeppelin</td>
<td>Stairway to Heaven</td>
<td>1971</td>
</tr>
<tr>
<td>11</td>
<td>The Temptations</td>
<td>My Generation</td>
<td>1965</td>
</tr>
<tr>
<td>12</td>
<td>The Ronettes</td>
<td>Be My Baby</td>
<td>1963</td>
</tr>
<tr>
<td>13</td>
<td>Elvis Presley</td>
<td>Heartbreak Hotel</td>
<td>1956</td>
</tr>
<tr>
<td>14</td>
<td>Grandmaster Flash and The Furious Five</td>
<td>The Message</td>
<td>1982</td>
</tr>
<tr>
<td>15</td>
<td>Joy Division</td>
<td>Love Will Tear Us Apart</td>
<td>1980</td>
</tr>
<tr>
<td>16</td>
<td>The Beatles</td>
<td>Strawberry Fields Forever</td>
<td>1987</td>
</tr>
<tr>
<td>17</td>
<td>The Kinks</td>
<td>You Really Got Me</td>
<td>1964</td>
</tr>
<tr>
<td>18</td>
<td>Marvin Gaye</td>
<td>What's Going On</td>
<td>1971</td>
</tr>
<tr>
<td>19</td>
<td>The Beatles</td>
<td>A Day in the Life</td>
<td>1967</td>
</tr>
<tr>
<td>20</td>
<td>The Beatles</td>
<td>God Save the Queen</td>
<td>1977</td>
</tr>
<tr>
<td>21</td>
<td>Ike and Tina Turner</td>
<td>River Deep Mountain High</td>
<td>1966</td>
</tr>
<tr>
<td>22</td>
<td>The Beatles</td>
<td>I Want to Hold Your Hand</td>
<td>1963</td>
</tr>
<tr>
<td>23</td>
<td>The Righteous Brothers</td>
<td>You've Lost That Lovin' Feelin'</td>
<td>1964</td>
</tr>
<tr>
<td>24</td>
<td>John Lennon</td>
<td>Imagine</td>
<td>1971</td>
</tr>
<tr>
<td>25</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>26</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Figure 26-1:** This list will be randomly arranged.

The following steps describe how to sort the data in Figure 26-1:

1. In cell E1, enter the column heading **Random**.
2. In cell E2, enter this formula:

   =RAND()

3. Copy E2 down the column to accommodate the number of rows in the list.
4. Activate any cell in column E and choose Home ➔ Editing ➔ Sort & Filter ➔ Sort Smallest to Largest (or right-click and choose the Sort command on the shortcut menu).
To get a different random configuration, press F9 to generate new random numbers and then sort again. Figure 26-2 shows the randomized list.

<table>
<thead>
<tr>
<th>Rank</th>
<th>Artist</th>
<th>Title</th>
<th>Year</th>
<th>Random</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Ike and Tina Turner</td>
<td>River Deep Mountain High</td>
<td>1966</td>
<td>0.7400354644</td>
</tr>
<tr>
<td>3</td>
<td>Marvin Gaye</td>
<td>What’s Going On</td>
<td>1971</td>
<td>0.9307793981</td>
</tr>
<tr>
<td>4</td>
<td>The Righteous Brothers</td>
<td>You’ve Lost That Lovin’ Feelin’</td>
<td>1964</td>
<td>0.7273056556</td>
</tr>
<tr>
<td>5</td>
<td>Marvin Gaye</td>
<td>I Heard It Through the Grapevine</td>
<td>1969</td>
<td>0.3623940215</td>
</tr>
<tr>
<td>6</td>
<td>The Kingsmen</td>
<td>Louie Louie</td>
<td>1963</td>
<td>0.2605956761</td>
</tr>
<tr>
<td>7</td>
<td>The Who</td>
<td>My Generation</td>
<td>1965</td>
<td>0.5409347795</td>
</tr>
<tr>
<td>8</td>
<td>Sex Pistols</td>
<td>Anarchy in the U.K.</td>
<td>1976</td>
<td>0.9304651311</td>
</tr>
<tr>
<td>9</td>
<td>Aretha Franklin</td>
<td>Respect</td>
<td>1967</td>
<td>0.6658946143</td>
</tr>
<tr>
<td>10</td>
<td>The Beatles</td>
<td>Strawberry Fields Forever</td>
<td>1967</td>
<td>0.6894903936</td>
</tr>
<tr>
<td>11</td>
<td>Bob Dylan</td>
<td>Like a Rolling Stone</td>
<td>1965</td>
<td>0.264030044</td>
</tr>
<tr>
<td>12</td>
<td>The Beach Boys</td>
<td>Good Vibrations</td>
<td>1966</td>
<td>0.7718146655</td>
</tr>
<tr>
<td>13</td>
<td>Nirvana</td>
<td>Smells Like Teen Spirit</td>
<td>1991</td>
<td>0.888421869</td>
</tr>
<tr>
<td>14</td>
<td>Sex Pistols</td>
<td>God Save the Queen</td>
<td>1977</td>
<td>0.2184928879</td>
</tr>
<tr>
<td>15</td>
<td>Led Zeppelin</td>
<td>Stairway to Heaven</td>
<td>1971</td>
<td>0.8658134546</td>
</tr>
<tr>
<td>16</td>
<td>Elvis Presley</td>
<td>Heartbreak Hotel</td>
<td>1956</td>
<td>0.6801946932</td>
</tr>
<tr>
<td>17</td>
<td>Chuck Berry</td>
<td>Johnny B. Goode</td>
<td>1959</td>
<td>0.340152271</td>
</tr>
<tr>
<td>18</td>
<td>The Beatles</td>
<td>I Want to Hold Your Hand</td>
<td>1963</td>
<td>0.482097277</td>
</tr>
<tr>
<td>19</td>
<td>The Rolling Stones</td>
<td>I Can’t Get No Satisfaction</td>
<td>1965</td>
<td>0.6275954316</td>
</tr>
<tr>
<td>20</td>
<td>Otis Redding</td>
<td>Sittin’ on the Dock of the Bay</td>
<td>1969</td>
<td>0.035764531</td>
</tr>
<tr>
<td>21</td>
<td>The Beatles</td>
<td>A Day in the Life</td>
<td>1967</td>
<td>0.2902675812</td>
</tr>
<tr>
<td>22</td>
<td>The Ronettes</td>
<td>Be My Baby</td>
<td>1963</td>
<td>0.44587964</td>
</tr>
<tr>
<td>23</td>
<td>Grandmaster Flash and The Furious Five</td>
<td>The Message</td>
<td>1982</td>
<td>0.784141873</td>
</tr>
<tr>
<td>24</td>
<td>Joy Division</td>
<td>Love Will Tear Us Apart</td>
<td>1989</td>
<td>0.7126730519</td>
</tr>
<tr>
<td>25</td>
<td>John Lennon</td>
<td>Imagine</td>
<td>1971</td>
<td>0.2113940435</td>
</tr>
<tr>
<td>26</td>
<td>The Kinks</td>
<td>You Really Got Me</td>
<td>1964</td>
<td>0.625917813</td>
</tr>
</tbody>
</table>

**Figure 26-2**: The list after being randomized.
Displaying a Workbook’s Full Path

If you have lots of files open in Excel, you may need to know the full path of the active workbook. Oddly, Excel provides no direct way to get this information. This tip describes several methods to enable you to determine the path of the active workbook.

Go backstage

One way to see the path of the active workbook is to choose File ➜ Info. Look in the Related Documents section and hover your mouse over Open File Location. The path of the workbook appears.

Use a formula

Another option is to enter the following formula into a cell:

\[ =\text{CELL}("\text{filename}\") \]

The formula accesses the workbook’s path — and also the name of the worksheet that contains the formula.

Add a control to your Quick Access toolbar

A control named Document Location isn’t available on the Ribbon, but you can add it to your Quick Access toolbar. Figure 27-1 shows what this control looks like. Unfortunately, you can’t change the width of this control, but if you click the displayed name, you can see the entire path.

Figure 27-1: The Document Location control, added to the Quick Access toolbar.
**Bonus Tip 27: Displaying a Workbook’s Full Path**

To add this control to your Quick Access toolbar, follow these steps:

1. Right-click the Quick Access toolbar and choose Customize Quick Access Toolbar. The Excel Options dialog box appears.
2. In the Quick Access Toolbar tab, choose Commands Not in the Ribbon from the drop-down list on the left.
3. Scroll down the list and select Document Location.
4. Click the Add button to add the selected control to the Quick Access toolbar.
5. Click OK to close the Excel Options dialog box.

**Use a macro**

If you’re comfortable using VBA macros, enter this Sub procedure in a VBA module in your Personal Macro Workbook:

```vba
Sub ShowPath()
    MsgBox ActiveWorkbook.Path
End Sub
```

Then add the ShowPath macro to your Quick Access toolbar. When this procedure is executed, the path of the active workbook appears in a message box.
Closing All Workbooks

One of the changes in Excel 2013 is the new single document interface. Every workbook opens in its own window. This new approach has a few problems. For example, assume that you have a dozen workbooks open and you’re ready to quit for the day. How do you close all of those workbooks?

In previous versions of Excel, Alt+F4 was a quick way to shut down the program. But in Excel 2013, Alt+F4 closes only the active workbook.

One partial solution is to add a new command to your Quick Access toolbar:

1. Right-click the Quick Access toolbar and choose Customize Quick Access Toolbar.
   The Excel Options dialog box appears.
2. In the Quick Access Toolbar tab, choose Commands Not in the Ribbon from the drop-down list on the left.
3. Scroll down the list and select Close All.
4. Click the Add button to add the selected control to the Quick Access toolbar.
5. Click OK to close the Excel Options dialog box.

Clicking the Close All button will immediately close all saved workbooks and prompt you to save workbooks that have changed since they were opened. The only problem is that one window remains open — an empty window that has no workbook. Press Alt+F4 to close it.

I suspect that this is a bug. Surely, there must be a way to close all Excel workbooks.
Copying Page Setup Settings Across Sheets

Each Excel worksheet has its own printing options (orientation, margins, and headers and footers, for example). These options are specified in the Page Setup group on the Page Layout tab.

When you add a new sheet to a workbook, the sheet contains the default Page Setup settings. Here’s an easy way to transfer the settings from one worksheet to additional worksheets:

1. Activate the sheet that contains the setup information you want.
   This is the source sheet.

2. Select the target sheets.
   Ctrl+click the sheet tabs of the sheets you want to update with the settings from the source sheet.

3. Click the dialog box launcher in the Page Layout ➜ Page Setup group.
   It’s the small icon to the right of the Page Setup group name. The Page Setup dialog box appears when you click this icon.

4. Click OK to close the Page Setup dialog box.

5. Ungroup the sheets by right-clicking any selected sheet and choosing Ungroup Sheets from the shortcut menu.
   The Page Setup settings of the source sheet are transferred to all the target sheets.

Note: Two settings located on the Sheet tab of the Page Setup dialog box aren’t transferred: Print Area and Print Titles. In addition, pictures in the header or footer aren’t transferred.
Printing Cell Comments

Normally, when you print a worksheet that contains cell comments, the comments are not printed. If you want to print the comments, follow these steps:

1. Click the dialog box launcher in the Page Layout ➜ Page Setup group.
   It’s the small icon to the right of the Page Setup group name. The Page Setup dialog box appears when you click this icon.

2. Click the Sheet tab.

3. Make your choice from the Comments drop-down control: At End of Sheet or As Displayed on Sheet (see Figure 30-1).
   If you choose the As Displayed on Sheet option, the comments will not print unless they’re visible. Choose Review ➜ Comments ➜ Show All Comments to toggle the visibility of cell comments.

4. Click OK to close the Page Setup dialog box.
   Or click the Print button to print the worksheet.

That setting is saved with your workbook.

Figure 30-1: Specifying how to print cell comments.