SYMBOLS

<< and >> (double-angle quotes), 509

$ (ARCH) variants, 341-342

/bin folder, 5

//Comments options (Indentation tab, Xcode Prefer-
ences window), 121-122

/Developer folder, 5, 6

/Library/Application Support/Apple/Developer tools
folder, 5

- (minus sign) and breakpoints, 379

#pragma mark statement, 105

#! (she-bang) line, 518

/System folder, 5

~ (tilde) character, 199

/usr folder, 5

$ (VAR_NAME) syntax, 323

* (wildcard) operator, 179

A

About Xcode Tools.pdf document, 6
absolute reference, 58
Accessibility panel (Inspector palette, Interface
Builder), 215

Accounts pane, System Preferences, 43
action

adding to class manually, 220

atomic, 113

Automator, 529, 544

breakpoints and, 384-387

renaming, 223
action templates, 544

Index

active executable, choosing, 360-361
active NIB document, 194
active project, 45
Activity Viewer window, 35
ADC. See Apple Developer Connection Reference
Library
Add All button (New File window), 233
Add Breakpoint At Current Line command, 376
Add button (New File window), 233
Add Localization button (Info window), 136
Add to Project pop-up menu (New File assistant),
70-71
adding
action to class manually, 220
annotation node to class diagram, 244-245
breakpoint action, 384
build phase, 285
configuration file, 335
dependency to target, 296-298
dependent unit test, 452-453
Fetch Request, 260
fetched property to entity, 260
file to source control, 482
item to menu, 200
shared library, 404
unit test target, 448-453
aggregate file history, 107
aggregate target, 275, 279, 299
Align Consecutive // Comments options (Indentation
tab, Xcode Preferences window), 121
aligning objects, 205-206
All Configurations view (Build tab, Info window), 332,
334

Index




All-In-One layout style

All-In-One layout style
description of, 20, 21-22
details list and, 31
selecting source file and, 24
showing and hiding groups and, 27
Allow Separate Fonts option (Fonts & Colors tab, Xcode
Preferences window), 117
Always Save option (Build tab, Xcode Preferences win-
dow), 314, 315
annotation node, adding to class diagram, 244-245
annotation view, 487-488
Ant tool, 551
API documentation, 241
API Search mode (help window), 180-181
Appearance tab (Info window), 245
AppKit application, debugging, 417
Apple
Aqua interface, 547
Developer DVD Series, adding, 177-178
standard plug-in templates, 554-556
Apple Developer Connection Reference Library
bookmarks, 175
browsing, 171-174
documents, navigating, 174-175
extended documentation, 176-177
external links, 175
overview of, 1-2, 14-15
updating, 183-184
AppleScript action (breakpoints), 384, 386, 387
AppleScript debugger, 365
AppleScript dictionaries, 182-183
AppleScript, driving Xcode application programmatically
using, 528-530
AppleScript panel (Inspector palette, Interface Builder),
215
application
AppKit, debugging, 417
preparing for dependent unit testing, 451-452
running
changing data and code while, 399-402
choosing active executable, 360-361
overview of, 359-360
application target, 275, 277
application templates, 544-547
Aqua guides, 207-208
Aqua interface (Apple), 547
$ (ARCH) variants, 341-342
Architectures (ARCHS) build setting, 341
archiving, 191, 226
Arguments group (variables pane, Debug window), 369
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Arguments pane (General tab, Info window), 406, 407
array values, 393
Arrow tool (class model diagram), 239
Ask Before Building option (Build tab, Xcode Prefer-
ences window), 314, 315
AskUserForApplicationDialog tool, 527
AskUserForExistingFileDialog tool, 527
AskUserForExistingFolderDialog tool, 527
AskUserForNewFileDialog tool, 527
AskUserForStringDialog tool, 526
atomic action, 113
atomic update, 480
attaching to running executables, 365
attribute property, 257-258
attributes
data modeling and, 254
of project, 52-54
of references, 57-59
of source items
changing for multiple items, 79-80
overview of, 77-79
ridding targets of unwanted files, 80
Attributes panel (Inspector palette, Interface Builder),
209, 220
Auto Clear Logs setting, enabling, 507
auto-completion, 130-131. See also Code Sense
automatic save options, 315
Automatically Indented Characters option (Indentation
tab, Xcode Preferences window), 121
Automatically Insert Closing “}” option (Indentation
tab, Xcode Preferences window), 120
Automatically Open/Close Attached Editor option (Gen-
eral pane, Xcode Preferences window), 89
Automatically Suggest option (Code Sense tab, Xcode
Preferences window), 127-128
Automator actions, 529, 544

backing up NIB file when saving, 199
Balance command, 115
Based On setting (Info window), 334
Batch file options (Project Find window), 158-160
Batch Find Options window, 158-160
BBEdit
encoding and, 515
merging changes and, 487
source item and, 142
support for, 141



build styles and older versions of Xcode

beginning boundary, 339
BigTop tool, 443
/bin folder, 5
binaries, 341-342
binary encoding of character, 135
block delimiter, 110
block, selecting, 110
Bonjour set, 355
bookmark, creating, 175
Bookmarks control (navigation bar), 97
bookmarks menu (navigation bar), 105-106
Bookmarks smart group, 26
Boolean operators, 179, 248
boot volume, selecting, 2-3
breakpoints
actions and, 384-387
conditional, 381-384
continuation option, 387-388
deleting, 378
display of in gutter, 96
editor pane (Debug window) and, 368
enabling and disabling, 379
grouping, 378-379
importing and exporting, 388
overview of, 375
setting, 370, 372, 375-376
symbolic, creating, 380-381
templates, 388
types of, 377,378
Breakpoints command, 377
Breakpoints control (navigation bar), 97
breakpoints menu (navigation bar), 106
Breakpoints smart group, 26, 377-378
Breakpoints window, 377-378, 383
BSD templates, 282
Build and Go button, 359-360
Build command, 305, 306
build configurations
build location and, 315
editing, 332-333
overview of, 16, 325-326
for profiling, creating, 421
switching between, 331-332
of target, 275, 299
build flag, 308-309
build folder, 308, 318
Build Java Resources phase, 287
build location
changing, 316-318
overview of, 315-316

relative path and, 288
strategies for sharing between multiple projects,
318-319
build log pane (build window), 311
Build menu, 12
build phase of target
files in, 285-287
overview of, 12, 273, 274, 284-285
types of, 287-291
build results pane (build window), 311
Build Results Window options (Build tab, Xcode Prefer-
ences window), 314
build rules of target
custom, creating, 292-296
overview of, 274, 275, 291-292
build settings. See also build configurations; configura-
tion file
binaries and, 341-342
C compiler, 345
categories of, 343
changing, 322
creating and deleting, 330
deployment, 348-349
editing
overview of, 327-329
value, 330-331
environment variable, 336-337
evaluation, 322-325
Info.plist files, 343
informational, 349-351
Java compiler, 346
Kernel module, 347
linker settings, 346-347
moving, 335-336
overview of, 16, 319-321
passing to xcodebuild tool, 353
pre-compiled and prefix headers, 344-345
Products, 343
scope of, 321-322
search path, 344
switching between configurations, 331-332
system locations, 351
of target
debugging and, 264
editing, 274-275
layered hierarchy of, 319, 320-321
overview of, 273, 299, 364
titles of, 342-343
tools, 350
build styles and older versions of Xcode, 326




Build tab

Build tab
Info window
All Configurations view, 332, 334
Configuration pop-up menu, 331-332
editing build settings, 327-329
overview of, 53
Xcode Preferences window, 314-315, 316-317
Build window
errors and warnings, 311-313
opening and closing automatically, 313
opening manually, 24
overview of, 16, 310-311
Build->Allow ZeroLink, 342
Build=>Build and Debug, 305, 364
Build=>Build and Run, 305, 359
Build->Build Results, 306, 310
Build=>Compile, 309
building predicate, 267
building project
clean build, 306-308
controlling build of individual items, 308-309
customizing
binaries, 341-342
build settings, 342-351
cross-development, 338-340
overview of, 337
per-file compiler flags, 337-338
ZeroLink, disallowing, 342
for debugging, 361-364
distributed build, 353-356
inactive target, 309
overview of, 16
partial build, 309-310
progress, viewing, 305-306
selecting active target and build configuration, 309
steps for, 306
xcodebuild tool, 351-353
building settings (expert preferences), 503-504
Build=>Next Build Warning or Error, 312
Build->Preprocess, 309
Build=>Previous Build Warning or Error, 312
Build~>Show Assembly Code, 309, 310
Build=>Stop Current Build, 306
bundle, creating, 398
bundle templates, 547-548

C

C++,413
C compiler build settings, 345
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C interface, 209
C language, 458
C programming, 415-416
C++ unit tests, 458-464
call stack, viewing, 367
Call Stacks display (ObjectAlloc), 442-443
Carbon
Control panel, 216
Inspector palette panels, 209
Interface Builder windows and, 193
NIB files and, 191-192
object attributes, 209
target templates, 282
templates in Starting Point assistant, 196
Unit Test Bundle, 448
unit test hook for, 462
window objects, 201
Carbon Porting Guide, 51
category, definition of, 169
changing. See also customizing
attributes for multiple items, 79-80
build location for project, 316-318
build settings, 322
data and code while executing application, 399-402
format of NIB file, 225-226
indentation level of line, 122
syntax coloring for single file, 118
tracking, 243-244
character
binary encoding of, 135
control, 98
selecting, 110
space, 98, 118
Check Spelling as You Type option (Spelling menu), 134
checking out or checking in file, 471, 473-474
checksum, rolling, 426
child entity, 256
choosing active executable, 360-361
CHUD.pkg installer package, 421-422
class. See also class model; custom classes (Interface
Builder)
DataBlock, 394-396
hiding in class diagram, 246
optimizing using Shark, 426-428
for unit testing, 462
Class Browser window
navigating, 165-167
option sets, 168-169
overview of, 13, 14, 165
shortcuts, 170
class definitions, 219



command line layer of build settings

class model. See also class model diagram
creating, 232-234
editing
adding annotations, 244-245
changing tracking, 243-244
customizing colors and fonts, 245-246
hiding classes and members, 246-250
moving nodes, 241-243
overview of, 241
page layout, 243
class model browser, 235-236
class model diagram
navigating, 239-241
nodes, 236-238
overview of, 236
tools, 238-239
class model pane, 233-234
class modeling
data modeling compared to, 253
overview of, 13, 14, 231
Quick Model, creating, 234-235
Classes~>Add Action to classname, 220
Classes-~>Add Outlet to classname, 220
Classes->Create files for classname, 224
ClasscvInstantiate classname, 221
Class->Read Files, 223
Clean All Targets command, 307
clean build, 306-368
clicking. See also double-clicking
bookmark, 175
breakpoint, 96
menu, 200

clipboard, moving build settings and, 335-336

closing. See also opening
build window automatically, 313
editor pane, 91
predicate builder, 268
project, 45
project window, 19

Cocoa
auto-sizing springs of objects, 213
Bindings, 213
command event handling, 212
Connections panel, 210-212
environment variables, 416-417
Inspector palette panels, 209
Interface Builder windows and, 192
NIB files and, 191-192
object attributes, 209
outlet, 210
Predicate framework, 264
target templates, 283

Targets/Actions panel, 212

templates in Starting Point assistant, 196

Unit Test Bundle, 448

window objects, 200-201
code. See listings; source code
Code Sense

index, rebuilding, 129-130

invoking code-completion, 123-129

overview of, 122-123

text macros and, 131
Code Sense index, 53, 109
Code Sense tab (Xcode Preferences window),

126-128, 502

code view (Shark), 428-429, 431
code-completion, invoking, 123-129
CodeWarrior, migrating from, 51-52
column, selecting, 109-110
column selector and Expressions window, 395
com.apple.Xcode.plist file, 499, 500
combining target dependencies, 299
Command+=

jump to next build warning or error, 312

Size to Fit, 204
Command+\ (Add Breakpoint At Current Line com-

mand), 376

Command+’ (Close Split View), 95
Command+; (spelling checker), 133
Command+B

Build, 305

Stop Current Build, 306
Command+Control+- (Zoom Out), 239
Command+Control+A (Add Attribute), 257
Command+Control+B (Hide/Show Model Browser), 233
Command+Control+E (Add Entity), 256
Command+Control+N (new empty file), 72
Command+Control+R (Add Relationship), 257
Command+Control+Shift+= (Zoom In), 239
Command+Control+W (close project), 45, 91
Command+D (Add to Bookmarks), 106
Command+double-click (Jump to Definition), 170
Command+Down Arrow (Go To Next Difference), 485
Command+E (Use Selection for Find), 161
command event handling in Cocoa, 212
Command+F (Find window), 143
Command+G (Find Next), 161
Command+l (open Info window), 33
Command+J (Jump to Selection), 103
Command+K

Compile, 309

Show Keyboard Check, 218
Command+L (Go To Line), 110
command line layer of build settings, 320

Index



command-line target

command-line target, 275, 277
command-line tools, xcodebuild, 320, 351-353, 529
command-line utility templates, 548-549
Command+Option+A
Add Action to classname, 220
add to project, 73
Command+Option+B (Breakpoints), 377
Command+Option+C (Compare), 433
Command+Option+F (Create files for classname), 224
Command+Option+0 (Add Outlet to classname), 220
Command+Option+P (Pause), 371
Command+Option+R
Read Files, 223
Run Executable, 359
Stop Executable, 359
Command+Option+S (save all), 91, 112
Command+Option+Shift+? (documentation window),
171
Command+Option+Up arrow (Switch To Header/Source
File), 108
Command+Option+Y (Debug Executable), 364
Command+P (Print), 139
Command+Q (quit), 203
Command+R (Build and Run), 305, 359
commands. See also specific commands
debugger, 370-372
for launching program, 359
Prune menu, MallocDebug, 437-439
search, 13
Command+S (save), 91, 112
Command+Shift+_ (Add Horizontal Guide), 208
Command-+Shift+| (Add Vertical Guide), 208
Command+Shift+. (Continue), 371
Command+Shift+? (help window), 171
Command+Shift+= (jump to previous build warning or
error), 312
Command+Shift+” (Split filename Vertically), 95
Command+Shift+A (Alignment panel), 205
Command+Shift+B (Build Results), 306
Command+Shift+C (Class Browser window), 165
Command+Shift+D (Open Quickly), 90
Command+Shift+E (Zoom Editor In/Out), 89
Command+Shift+F (Project Find window), 155
Command+Shift+G (Go To window), 404
Command+Shift+l (Step Into), 371
Command+Shift+K (Clean Build), 307
Command+Shift+L (Update to Latest), 483
Command+Shift+M
Make Initial First Responder, 218
Show Advanced Settings, 432
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Command+Shift+0 (Step Over), 371
Command+Shift+Option+G (Unpack Subview), 207
Command+Shift+Option+l (Step Into Instruction), 371
Command+Shift+Option+0 (Step Over Instruction), 371
Command+Shift+Option+S (Save a Copy As), 112
Command+Shift+P (Page Setup), 139
Command+Shift+R (Run Log), 360
Command+Shift+S (Save As...), 112
Command+Shift+6 (Show Control Characters), 98
Command+Shift+T (Step Out), 371
Command+Shift+V (SCM Results), 479
Command+Shift+Y (Debugger window), 365
Command+U (Revert to Saved), 112
Command+Up Arrow (Go To Previous Difference), 485
Command+W (close window), 91
Command+Y (Build and Debug), 305, 364
comment, entering when committing changes,
480-481
//Comments options (Indentation tab, Xcode Prefer-
ences window), 121

Comments tab (Info window), 53, 54, 78, 79
committing changes, 480-481
community, Xcode, 186-187
comparing

file revisions, 484-485

Shark sessions, 433-434
compatibility checking, 226-227
Compile AppleScripts phase, 287
Compile command, 309
Compile Sources build phase, 284
compiler phases

build rules and, 291

overview of, 287
Compiler Sources phase, 287
compiling build settings, 322-325
compound expressions and predicate builder, 266
computer

configuring for remote debugging, 410-413

sharing to compile files for other developers, 353-356
Concurrent Versions System (CVS), 471
Condensed layout style

description of, 20, 21

details list and, 31-32

showing and hiding groups and, 27
conditional breakpoints, 381-384
conditional statement, configuring, 247-248
configuration file

adding, 335

overview of, 333-334

using, 335



CVS (Concurrent Versions System)

Configurations pane (details pane of data model), 262
Configurations tab (Info window), 53, 54, 332-333
configuring
computer for remote debugging, 410-413
dependent unit test, 450-452
independent unit test, 449-450
project for source control, 474-476
confirmation dialog box and replacing text, 158
conflicts in versions of file, resolving, 488-489
Connections panel (Inspector palette, Interface
Builder), 210-212
constructor methods, 455
container
selecting, 202
subviews and, 206-207
content modes (MallocDebug), 437
content of source group, altering, 26-27
Continue Building After Errors options (Build tab, Xcode
Preferences window), 315
Continue button (installer utility), 2, 3
Continue command (debugger), 371, 372
control characters, 98
Control+. (Next Completion), 125
Control panel (Inspector palette, Interface Builder), 216
Control+l (Re-indent), 122
Control+/ (Select Next Placeholder), 127
Control+dragging between objects, 211
controlling build of individual items, 308-309
Control+1 (file history menu), 106
Control+R (Execute Script), 132
Control+3 (included files menu), 107
Convert button (File Encoding window), 134
Copy Bundle Resources phase, 286, 287
Copy Files phase, 287-288
Copy Headers phase, 287
Copy Items into Destination Group’s Folder option
(NewSources dialog box), 75
copying file from one build phase to another, 286
Core Data, 253
Counterpart control (navigation bar), 97
Create Backup File When Saving option (General tab,
Interface Builder preferences), 199
Create Folder References for Any Added Folders button
(NewSources dialog box), 76-77
Credits.rtf file, 547
Cross-Develop Using Target SKD setting (Info window),
52-53
cross-development, 338-340
cross-project reference, 297, 316
current text selection, 93
cursor movement, 101-102

cursor, text insertion, 93
custom build rule, creating, 292-296
Custom Class panel (Inspector palette, Interface
Builder), 214
custom classes (Interface Builder)
creating, 220-221
importing and exporting, 222-225
overview of, 218-219
custom script
anatomy of, 520
menu script definitions, 520-524
overview of, 517-518
StartupScript, 518-520
tools, 526-528
variables, 524-526
custom Shell script phase, writing, 290-291
Customize button (installer utility), 3
customizing. See also changing; Xcode Preferences
window
build
binaries, 341-342
build settings, 342-351
cross-development, 338-340
overview of, 337
per-file compiler flags, 337-338
Zerolink, disallowing, 342
class diagram, 245-246
class model browser display, 236
editor pane, 98-101
executable, selecting, 408-409
expert preferences
building settings, 503-504
debugging settings, 505-506
distributed builds settings, 505
documentation setting, 507
editing settings, 501-502
functions menu settings, 502
overview of, 499-500
projects and files settings, 500
source code management settings, 506
Interface Builder, 227-229
overview of, 491
program to compare files, 486
syntax coloring, 117-118
templates
file templates, 508-509
overview of, 508
project templates, 512-516
target templates, 516-517
template macros, 509-512
CVS (Concurrent Versions System), 471
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Darwin kernel

D

Darwin kernel, 553
data formatters
creating, 395-397
enabling and disabling, 369
overview of, 393-395
plug-in, creating, 398
problems when creating, 397-398
data mining, tools for, 13-14
data model browser, 261
data model, creating
entity, creating, 256-257
fetch request, adding, 260
fetched property, adding, 260
overview of, 255
property, creating, 257-260
data model diagram, 262-263
data modeling
class modeling compared to, 253
exporting class methods, 271-272
instant interface, creating, 268-270
interface
data model browser, 261
data model diagram, 262-263
details pane, 261-262
predicate builder, 264-268
tools, 263
NSManaged Object subclasses, creating, 270-271
overview of, 253
technology, 253-254
terminology, 254
data schema, 253
DataBlock class, 394-396
DataFormatterPlugin.h file, 398
Debug build configuration settings, 362-363
Debug configuration, 326
Debug menu, 12, 365
Debug Visualizer window, 375, 387
Debug>Attach, 365
Debug->Attach-=>Process ID, 365
Debug=>Console Log, 402
Debug>Debug Executable, 364
Debug->Debugger, 365
Debug>Enable Guard Malloc, 414
Debug>Fix, 401
debugger
AppleScript, 365
controlling, 370-374
gdb, 365, 386, 410
overview of, 17, 359
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redefining command keys for, 495-496
shared library window and, 403-404
toolbar
Console button, 402
Fix button, 401
types of, 365
Debugger () command, 414
Debugger Command action (breakpoints), 384, 385
Debugger Console window, 402-403
Debugger pane (Xcode Preferences window), 409-410
debugger symbols, 362, 403-404
Debugger toolbar, 34
Debugger window
Debug Visualizer window compared to, 375
editor pane, 99, 367-368
overview of, 365-366
threads pane, 366-367
variables pane, 368-370, 389
debugging. See also breakpoints; debugger
altering data and code while application is executing
and, 399-402
AppleScript application, 530
build configurations and, 326
building project for, 361-364
data formatters and, 397
executables, 364-365
function behavior, 385
remote, 410-413
tools
for catching catch, 413
Debugger () and DebugStr () commands, 414
Guard Malloc library, 414-415
variables, 415-418
unit test, 464-466
watchpoints and, 399
Debugging pane (General tab, Info window), 407-408
debugging settings (expert preferences), 505-506
Debugr>Launch Using Performance Tool->MallocDebug,
435
Debugr>Launch Using Performance Tool->Shark, 421
Debug->Pause, 370
Debug=>Run Executable, 359
Debug=>Run Log, 360
Debug>Stop Executable, 359
Debug>Stop on C++ Catch, 413
Debug>Stop on C++ Throw, 413
Debug->Stop on Debugger() /DebugStr(), 414
DebugStr () command, 414
Debug->Toggle Debugger Layout, 366
Debugr>Toggle Disassembly Display, 367
Debugr>Tools->Expressions..., 392



disassembly view

Debugr>Tools>Global Variables, 391
Debugr>Toolsc>Shared Library, 403-404
Debugr>Variables View, 390
Debugr>Variables View~>Edit Summary Format, 394
Debug->Variables View->Enable Data Formatters, 369
Debug->Variables View->Print Description to Console,
399
Debugr>Variables View->Show Types, 370
Debugr>Variables View~>View As Memory, 390-391
Debugr>Variables View~>View Value As command, 390
Debug->Variables View->View Variable as Expression,
392

Debugr>Variables View->Watch Variable, 399
declaration and functions menu, 105
Default layout style

description of, 20

details list and, 31

selecting source file and, 24

showing and hiding groups and, 27
default references, 60-61
defaults command, 499
definition, jumping to, 108
Definition option (Project Find window), 156
Delete command and groups, 28
Delete Rule for relationships, 259
deleting

bookmark, 175

breakpoint, 370, 378

build configuration, 333

build folder, 318

build setting, 330

entity, 257

expression, 393

file under source control, 482

group, 26-27

guide, 208

item from menu, 200

object in NIB file, 203

shared library, 404

simple smart group, 30-31

source item, 85

subview, 207

target, 284

text, 111
dependencies of target

adding, 296-298

overview of, 274, 275

strategies for, 298-299

unit testing and, 448

Index

dependent unit test
adding, 452-453
configuring, 450-452
debugging, 464-465
overview of, 447-448
deployment settings, 348-349
Deployment Target build setting, 339, 340
Design menu, 12
Design=>Alignment=>Align, 241
Design->Automatic Layout, 241
Design->Class Model->Add Comment, 244
Design~>Class Model-~>Go to Declaration, 240
Designr>Class Model->Go to Definition, 240
Designr>Class Model~>Go to Documentation, 241
Design->Class Model~>Quick Model, 234
Design=>Collapse All Compartments, 237
Design=>Data Model=>Add Attribute, 257
Design->Data Model->Add Entity, 256
Designr>Data Model->Add Fetched Property, 257
Design->Data Model=>Add Relationship, 257
Design>Data Model=>Copy Method Declarations to
Clipboard, 272
Design->Data Model->Copy Method Implementation to
Clipboard, 272
Designr>Diagram->Hide Page Breaks, 243
Design=>Diagram=>Lock, 242
Design~>Diagramr>Sizer. Size to Fit, 242
Design->Diagram=>Turn Grid Off, 243
Design=>Diagram=>Turn Grid On, 243
Designr>Diagram->Unlock, 242
Design->Expand All Compartments, 237
Design->Hide/Show Model Browser, 233
details list
columns, viewing, 32
editor pane and, 88-89
overview of, 31-32
searching, 162-163
details pane
Breakpoints window, 377
data model, 261-262
SCM column, 478-479
/Developer folder, 5, 6
development region, 136
Direct Dependencies list (General tab, Info window),
296
disabling. See also enabling
breakpoints, 379
data formatters, 369
disassembly view, 368



discarding changes

discarding changes, 481-482
Display Connection Warning Icons option (Interface
Builder preferences), 227
display modes (MallocDebug), 437
displaying. See also hiding
documentation for class in editor pane, 166
errors in gutter, 93, 96
distributed build, 353-356
distributed builds settings (expert preferences), 505
divider, adding to source code, 105
divider bar, double-clicking, 89
document
About Xcode Tools.pdf, 6
active NIB, 194
class model and, 232
converting to Unicode, 135
project
description of, 37
moving, 48
source control management and, 489-490
document collection page, 173
documentation
API, 241
for class, displaying in editor pane, 166
custom, adding, 185-186
documentation browser
description of, 171, 172
using help window as, 171-174
documentation setting (expert preferences), 507
Documentation tab (Xcode Preferences window), 176
double-angle quotes (<< and >>), 509
double-clicking. See also clicking
breakpoint, 96, 378
divider bar, 89
error or warning, 311
favorites item, 35
group, 31-32
item in details list, 32
jumping to source code by, 240
source breakpoint, 378
source item, 11
word, 108
downloading disk image of Xcode Developer Tools, 1
drag-and-drop technique
adding file to project and, 73
text selection and, 111-112
duplicating
entities and properties, 264
targets, 284
dynamic library
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loading, 416
templates for, 549-550
unit testing, 451

E

Easy Install button (installer utility), 5
Edit menu, 12
Edit Value command, 400
Edit=>Duplicate, 201
editing. See also editor pane; editors; text editor
atomic action and, 113
breakpoint action, 384
build configuration, 332-333
build setting
overview of, 327-329
value, 330-331
class model
adding annotations, 244-245
changing tracking, 243-244
customizing colors and fonts, 245-246
hiding classes and members, 246-250
moving nodes, 241-243
overview of, 241
page layout, 243
compiler flags, 337
external editor, using, 140-142
Info.plist file, 302
menu key bindings, 494-496
name or address of symbolic breakpoint, 378
object in Interface Builder
guides, 207-208
Inspector palette and, 208-217
moving and resizing, 203-206
overview of, 203
subviews, 206-207
tab order, 217-218
preferences file, 43-45
source code
deleting text, 111
drag-and-drop technique and, 111-112
plain text editor and, 112
selecting text, 109-110
spell checking
finding one word, 133-134
interactive, 132-133
overview of, 132
while typing, 134
string, 331



expert preferences

syntax-aware
Code Sense, 122-130
indenting, 119
overview of, 115
syntax coloring, 115-118
target, 274
text key bindings, 496-499
title of menu, 200
editing settings (expert preferences), 501-502
Editing tab (Interface Builder preferences), 212, 227
Editing window, 19
Edit~>Insert Text Macro, 130
Edit-=>Next Completion, 125, 131
editor pane
build window, 311-313
closing and saving, 91-92
Debugger window, 99, 367-368
display options, 98-101
displaying documentation for class in, 166
elements of, 92-93
gutter, 93, 96, 99
Jam-based target and, 300-301
navigation bar, 96-97
overview of, 87-91
printing, 139
of project window, 88-90
scroll bar controls, 93-94
split-pane editing, 94-95
Editor Uses Tabs option (Info window), 78, 79
editors. See also text editor
changing, 140
external, using, 140-142
overview of, 12-13
support for, 141-142
Edit=>Select All, 157, 212
Edit=>Select Next Placeholder, 127, 131
Edit->Spelling->Check Spelling, 133
Edit=>Spelling=>Spelling, 132
Edit=>Undo, 113
Emacs commands, 102-103
empty project templates, 543-544
enabling. See also disabling
Auto Clear Logs setting, 507
breakpoints, 379
data formatters, 369
syntax-aware indenting, 119
enclosing-group reference
description of, 58
Filec>New Group command and, 60-61
rearranging folders and, 84

encoding
binary, of character, 135
description of, 191
file, 134-136, 509
UTF-8, 515, 518, 520
end boundary, 338
entity
adding properties to, 257-260
creating, 256-257
definition of, 254
duplicating, 264
relationships and, 258-259
environment layer of build settings, 321, 322, 336-337
environment variables
for C programming, 415-416
Cocoa, 416-417
dynamic libraries and, 416
passing to custom build script, 293-294
environment variables pane (General tab, Info window),
406
environment.plist file, 336
Errors and Warnings group, 12, 25, 312, 314
errors, display of in gutter, 93, 96
examining data
expressions, 392-393
global variables, viewing, 391-392
overview of, 389-391
Executable Path option (General tab, Info window), 406
executable script. See custom script
executables
active, choosing, 360-361
Arguments pane, Info window, 406, 407
attaching to running, 365
custom
overview of, 404-405
selecting, 408-409
debugging, 364-365
Debugging pane, Info window, 407-408
General tab, Info window, 405-406
Jam-based target editor and, 303
Executables smart group, 12, 25
Execute Script command, 132
executing C++ unit test, 461-464
expand/collapse control, 31
expert preferences
building settings, 503-504
debugging settings, 505-506
distributed builds settings, 505
documentation setting, 507
editing settings, 501-502

Index



expert preferences (continued)

expert preferences (continued)
functions menu settings, 502
overview of, 499-500
projects and files settings, 500
source code management settings, 506
exporting
breakpoint, 388
class, 224-225
class methods, 271-272
expression
in data formatter, 393-394
evaluation of, and debuggers, 365
predicate builder and, 264-265, 267-268
regular, 146-150, 153-154
side effects of, 383
Expressions window, 392-393, 395
external dependency, 275
external editor, using, 140-142
external target, 276, 278
Extreme Programming movement, 445

F

Favorites bar, 35
features, undocumented, 491
fetch request, 255, 260
fetched property, 255, 260
file. See also Info.plist file; NIB file; source file
adding to source control, 482
annotation view, 487-488
in build phase, 285-287
changing syntax coloring for, 118
com.apple.Xcode.plist, 499, 500
configuration
adding, 335
overview of, 333-334
using, 335
Credits.rtf, 547
DataFormatterPlugin.h file, 398
environment.plist, 336
header
parsing, 224
switching to, 108
localizing, 136-139
locking and unlocking, 97
MainMenu.nib, 547
menu separator, 520
moving, 81-82, 286
multi-architecture binary (MAB), 341
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multiple, searching
Find Results smart group and, 156-157
Project Find window, using, 155-156
MyDocument.nib, 547
navigating between
aggregate file history, 107
file history menu, 106-107
included files menu, 107-108
jumping to definition, 108
opening into editor window, 77, 90-91
preferences
editing, 43-45
per-user basis of, 352
project.pbxproj, 489, 514-515
read-only, opening, 100
renaming, 513, 514
replacing text in multiple, 157-158
resolving conflicts in versions of, 488-489
ridding targets of unwanted, 80
saving, 112-113
searching
overview of, 143-144
for pattern, 144-146
for regular expression, 146-153
sharing computer to compile files for other developers,
353-356
under source control
comparing revisions of, 484-485
deleting, 482
renaming, 483
updating, 483-484
tab settings for single, 122
Templatelnfo.plist, 508, 513
working copy of, 471
file encoding, 134-136, 509
File Encoding attribute (Info window), 78-79
file extension
.moved-aside, 71, 72
.pbxuser, 489
.pch, 344
.xcconfig, 334
File History control (navigation bar), 97
file history menu, 106-107
file item references, viewing, 78
File menu, 12
File Name field (New File assistant), 70
file references in project templates, 514-515
file template bundles, 508
file templates, 508-509
File Types tab (Xcode Preferences window), 140



functions

File>Close, 91
Filec>Close File filename, 91
Filec>Close Project, 91
File=>Compare, 433
File=>Compatibility Checking, 226
File=>Get Info, 33, 238
Filec>Group, 26, 378-379
Filec>Hide Inspector, 33
File=>Import=>Import Resource Fork, 197
FileMerge utility, 484, 487
File=>New Empty File, 72
File=>New File, 69, 72, 232
Filec>New Group, 26, 378-379
Filec>New Project, 37
File=>New Smart Group menu, 29
File=>Open, 90
File=>Open As, 140
File=>Open Dictionary, 182
Filec>Open Localizations, 197
Filec>Open Quickly, 90-91
File=>Open Recent, 197
Filec>Page Setup, 243
File=>Recent Projects, 490
File->Save, 91
Filec>Save a Copy As, 141
File=>Save All, 91
File=>Show Inspector, 33
FilesToRename property, 513, 514-515
File=>Test Interface, 203
Filter Files Using regex Patterns option (Batch Find
Options window), 160

filtering class diagram, 247-249
Find menu, 12
Find Results smart group

description of, 12, 25

searching multiple files and, 156-157
Find=>Add to Bookmarks, 106, 175
Find<>Find In Project, 155
Find=>Go To Line, 110
Find=>Go To Next->Difference, 485
Find=>Go To Previous->Difference, 485
Find=>Jump to Definition, 108, 170
Find=>Jump to Selection, 103
Find=>Single File Find, 143
First Responder object, 212, 220
Fix & Continue feature

limitations of, 402

overview of, 400-401
Fix & Continue setting (Debug build configuration),

362, 363

flag operators, 149-150

folder
contents of, 11
creating new project and, 39
description of, 37
moving, 82-84
moving project document and, 48
source
description of, 60
source folder item compared to, 68-69
folder item references, viewing, 78
Font palette, 117
Fonts & Colors tab (Xcode Preferences window)
Allow Separate Fonts option, 117
editor pane and, 98
syntax coloring and, 115-117
Use Colors When Printing option, 139
For Unsaved Files option (Build tab, Xcode Preferences
window), 314
force-directed layout, 242
format
display, for values, 389-390
of NIB file
changing, 225-226
compatibility checking, 226-227
Format menu, 12
Format->Alignment>Alignment Panel, 205
Format->Balance command, 110
Format~>File Encoding, 134
Format->File Encoding->Reinterpret, 509
Format=>Font->Bigger, 178
Format->Font-=>Show Colors, 246
Format->Font-=>Smaller, 178
Format~>Line Ending, 134
Format->Re-indent, 120, 122
Format=>Show Control Characters, 98
Format~>Show Spaces, 98
Format->Syntax Coloring, 118
Format->Wrap Lines, 98
frame, 366
framework
adding to class model, 233
New Project Assistant and, 38
templates for, 550-551
unit testing, 451
framework item, 67, 69
framework target, 277
Full Path field (Info window), 77-78
Full-Text Search mode (help window), 178-179, 180
functions
debugging behavior of, 385
main () function, 461




Functions control (navigation bar)

Functions control (navigation bar), 97
functions menu
class diagram, 240
navigation bar, 104-105
functions menu settings (expert preferences), 502

G

gcc compiler and build settings, 345
GCC_UNROLIL_LOOPS variable, 299
gdb debugger, 365, 386, 410
General pane
details pane of data model, 262
Xcode Preferences window, Automatically Open/Close
Attached Editor option, 89
General tab
Info window
Arguments pane, 406, 407
Debugging pane, 407-408
Direct Dependencies list, 296
environment variables pane, 406
executable, 405-406
filters, 247
Full Path field, 77-78
Include in Index option, 129-130
Name field, 77, 78
overview of, 52-53
Path field, 77, 78
Path Type field, 77, 78
Rebuild Code Sense Index button, 129
reference attributes and, 59
Show Package option, 238
Show Property Type option, 238
Show Visibility option, 238
Interface Builder preferences
Create Backup File When Saving option, 199
Inside-Out Selection option, 202
overview of, 227, 228
Generate Debug Symbols setting (Debug build configu-
ration), 362, 363
Global Allocations tab (ObjectAlloc), 440-441
Global Breakpoints sub-group, 378
global build location, setting, 318-319
global variables, viewing, 391-392
Globals group (variables pane, Debug window), 369,
391
Go To window, 110, 404
grid, showing and hiding, 243
group, showing or hiding, 27
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grouping
breakpoints, 378-379
objects, 206
Groups & Files list, showing details in, 32
Groups & Files pane
Breakpoints window, 377
project window
overview of, 11, 24-25
project structure group, 25
SCM smart group, 477-478
Group/Ungrouped control (toolbar), 90, 97
Guard Malloc library, 414-415
Guess button (Spelling palette), 133
guides, 207-208
gutter (editor pane), 93, 96, 99

H

hammer icon (build flag), 308
Hand tool (class model diagram), 239
header file
parsing, 224
switching to, 108
headers, precompiled and prefix, 344-345
heap tool, 443
Help and Documentation window
APl Search mode, 180-181
bookmarks, 175
controlling text size, 178
documentation browser, using as, 171-174
documents, navigating, 174-175
external links, 175
Full-Text Search mode, 178-179, 180
operators for searching, 179-180
overview of, 171,172
project-specific commands and, 45-46
search field, 178
help features. See also Help and Documentation win-
dow
AppleScript dictionaries, 182-183
custom documentation, adding, 185-186
extended documentation, 176-177
man pages, 181-182
overview of, 14-15
Help menu, 12, 184
Help panel (Inspector palette, Interface Builder), 215
help window. See Help and Documentation window
Help~>Documentation, 171, 184
helper class, 246



Info window

HelpcoFind Selected Text in APl Reference, 184
Helpc>Find Selected Text in Documentation, 184
Help=>Open man page, 181
Help~>Show Expert Preferences Notes, 499
Help=>Xcode Help, 171, 184
hiding
class or member in class diagram, 246-247
column in details list, 32
details view, 31
editor pane, 95
Favorites bar, 35
grid, 243
group, 27
Inspector palette, 33
navigation bar, 96
SCM column, 478
status bar, 35, 97
user guide, 208
hierarchical layout, 241, 242
hierarchy, functional, organizing sources into, 63-64
History Capacity menu, 106-107
history graph (ObjectAlloc), 441
HotSpot interpreter (Java), 376
Human Interface Guidelines and layout decisions, 208

ICU (International Components for Unicode) Regular
Expression package, 153
Ignore Case option (Single File Find window), 144
importing
breakpoint, 388
class, 222-224
ProjectBuilderWO projects, 50-51
resources, 197-198
included files menu, 107-108
Includes control (navigation bar), 97
Indent // Comments options (Indentation tab, Xcode
Preferences window), 121
Indent Solo “{“ option (Indentation tab, Xcode Prefer-
ences window), 120
Indent Width option (Info window), 78, 79
Indent Width setting (Indentation tab, Xcode Prefer-
ences window), 118, 122
Indentation tab (Xcode Preferences window), 118-122
indenting text, 118-122
independent unit test
configuring, 449-450
debugging, 465-466
overview of, 447
indexing

Index

class modeling and, 232
Code Sense and, 126
Indicate When Completions Are Available option (Code
Sense tab, Xcode Preferences window), 126
Info window
Add Localization button, 136
Appearance tab, 245
Based On setting, 334
Build tab
All Configurations view, 332, 334
Configuration pop-up menu, 331-332
editing build settings, 327-329
overview of, 53
changing build location and, 317-318
Comments tab, 53, 54, 78, 79
Configurations tab, 53, 54, 332-333
Editor Uses Tabs option, 78, 79
File Encoding attribute, 78-79
General tab
Arguments pane, 406, 407
Debugging pane, 407-408
Direct Dependencies list, 296
environment variables pane, 406
executable, 405-406
filters, 247
Full Path field, 77-78
Include in Index option, 129-130
Name field, 77, 78
overview of, 52-53
Path field, 77, 78
Path Type field, 77, 78
Rebuild Code Sense Index button, 129
reference attributes and, 59
Show Package option, 238
Show Property Type option, 238
Show Visibility option, 238
Indent Width option, 78, 79
item type and, 78
Line Endings attribute, 78
Make File Localizable button, 136
overview of, 19-20, 33
project attributes and, 52
properties and, 33-34
Properties tab, 301-302
references and, 59
Remove All Localizations button, 138
SCM tab, 476-477
simple smart group, 29
Tab Width option, 78, 79
target, 292
Targets tab, 78, 79
Tracking tab, 243-244




Info.plist file

Info.plist file
application templates and, 547
build settings, 343
targets and
build settings, 299
native targets, 277
properties, 301, 302
INFOPLIST FILE variable, 299
informational build settings, 349-351
inheritance and class model diagram, 237
inlining, 430
Insert Argument Placeholders For Completion option
(Code Sense tab, Xcode Preferences window), 127
Insert ‘Tabs’ Instead of Spaces option (Indentation tab,
Xcode Preferences window), 118
inserting logical operators into predicate expression,
266
Inside-Out Selection option (General tab, Interface
Builder preferences), 202
Inspector palette
Interface Builder
Accessibility panel, 215
AppleScript panel, 215
Attributes panel, 209, 220
Bindings panel, 213-214
Connections panel, 210-212
Control panel, 216
Custom Class panel, 214
Help panel, 215
Layout panel, 217
overview of, 192, 193, 208-209
Sherlock panel, 216
Size panel, 213
overview of, 33
project attributes and, 52
references and, 59
Install button (installer utility), 5, 6
Installation Directory setting (Build tab, Info window),
329
installer utility
running, 2-6
upgrading using, 7
installing
cross-development SDK, 338
running installer utility, 2—-6
Subversion client, 472-473
Xcode Developer Tools suite, 1
INSTALL_MODE_FLAG setting, 322-323
Instance Browser tab (ObjectAlloc), 441-442
instance, relationship between class and, 219
instant interface, creating from data model, 268-270
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interface
instant, creating from data model, 268-270
of Interface Builder, 192-194
source control, 476-477
testing, 203
Interface Builder. See also Interface Builder preferences
creating object
menu, 199-200
other, 201
window, 200-201
custom class
creating, 220-221
importing and exporting, 222-225
overview of, 218-219
customizing, 227-229
deleting object, 203
description of, 189
editing object
guides, 207-208
Inspector palette and, 208-217
moving and resizing, 203-206
overview of, 203
subviews, 206-207
tab order, 217-218
Inspector palette
Accessibility panel, 215
AppleScript panel, 215
Attributes panel, 209, 220
Bindings panel, 213-214
Connections panel, 210-212
Control panel, 216
Custom Class panel, 214
Help panel, 215
Layout panel, 217
overview of, 192, 193, 208-209
Sherlock panel, 216
Size panel, 213
integration with Xcode, 192
interface of, 192-194
NIB document window
description of, 192, 193, 194
multiple, 194-195
NIB file
browsing classes defined in, 219
class definition and, 224
Cocoa versus Carbon, 191-192
creating, 195-197
format of, 225-227
making backup when saving, 199
opening existing, 197
overview of, 189-191



keyboard shortcuts

saving, 198
serialization and, 191
Objects palette, 192, 194
resources, importing, 197-198
selecting object, 201-203
Starting Point assistant, 195-197
Interface Builder preferences
Display Connection Warning Icons, 227
Editing tab, 212, 227
General tab
Create Backup File When Saving option, 199
Inside-Out Selection option, 202
overview of, 227, 228
Palette/Info Panel Are Utility Windows option, 227
Palettes tab, 228
Test Interface tab, 228
intermediate files location, 315-316
internal dependency, 275
International Components for Unicode (ICU) Regular
Expression package, 153
inter-test initialization, 454-455
inverse relationship, definition of, 254

J

Jam-based target
editor, 300-301
overview of, 277-278, 284
Java
analysis tools and, 423
application, profiling, 422
compiler build settings, 346
debugger, 365
HotSpot interpreter, 376
project, organizing, 63
target templates, 283
templates, 551-553
join pane control, 27-28
jumping
to definition, 108
to source code, 240-241

K

Kernel Extension templates, 284, 553-554
Kernel module build settings, 347
key bindings, 101
Key Bindings tab (Xcode Preferences window)
Menu Key Bindings, 493-496
overview of, 492-493

Text Key Bindings, 496-499

Keyboard Check mode, 218
keyboard shortcuts

Command+=
jump to next build warning or error, 312
Size to Fit, 204
Command+\ (Add Breakpoint At Current Line com-
mand), 376
Command+’ (Close Split View), 95
Command+; (spelling checker), 133
Command+B
Build, 305
Stop Current Build, 306
Command-+Control+- (Zoom Out), 239
Command+Control+A (Add Attribute), 257
Command+Control+B (Hide/Show Model Browser), 233
Command+Control+E (Add Entity), 256
Command+Control+N (new empty file), 72
Command+Control+R (Add Relationship), 257
Command-+Control+Shift+= (Zoom In), 239
Command-+Control+W (close project), 45, 91
Command+D (Add to Bookmarks), 106
Command-+double-click (Jump to Definition), 170
Command+Down Arrow (Go To Next Difference), 485
Command+E (Use Selection for Find), 161
Command+F (Find window), 143
Command+G (Find Next), 161
Command+l (open Info window), 33
Command+J (Jump to Selection), 103
Command+K
Compile, 309
Keyboard Check mode, 218
Command+L (Go To Line), 110
Command+Option+A
Add Action to classname, 220
add to project, 73
Command+Option+B (Breakpoints), 377
Command+Option+C (Compare), 433
Command+Option+F (Create files for classname), 224
Command+Option+0 (Add Outlet to classname), 220
Command+Option+P (Pause), 371
Command+Option+R
Read Files, 223
Run Executable, 359
Stop Executable, 359
Command+Option+S (save all), 91, 112
Command+Option+Shift+? (documentation window),
171
Command+Option+Up arrow (Switch To Header/Source
File), 108
Command+Option+Y (Debug Executable), 364
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keyboard shortcuts (continued)

keyboard shortcuts (continued)
Command+P (Print), 139
Command+Q (quit), 203
Command+R (Build and Run), 305, 359
Command+S (save), 91, 112
Command+Shift+_ (Add Horizontal Guide), 208
Command+Shift+| (Add Vertical Guide), 208
Command+Shift+. (Continue), 371
Command+Shift+? (help window), 171
Command+Shift+= (jump to previous build warning or
error), 312

Command+Shift+” (Split filename Vertically), 95
Command+Shift+A (Alignment panel), 205
Command+Shift+B (Build Results), 306
Command+Shift+C (Class Browser window), 165
Command+Shift+D (Open Quickly), 90
Command+Shift+E (Zoom Editor In/Out), 89
Command+Shift+F (Project Find window), 155
Command+Shift+G (Go To window), 404
Command+Shift+] (Step Into), 371
Command+Shift+K (Clean Build), 307
Command+Shift+L (Update to Latest), 483
Command+Shift+M

Make Initial First Responder, 218

Show Advanced Settings, 432
Command+Shift+0 (Step Over), 371
Command+Shift+Option+G (Unpack Subview), 207

Command+Shift+Option+| (Step Into Instruction), 371
Command+Shift+Option+0 (Step Over Instruction), 371

Command+Shift+Option+S (Save a Copy As), 112
Command+Shift+P (Page Setup), 139
Command+Shift+S (Save As...), 112
Command+Shift+6 (Show Control Characters), 98
Command+Shift+T (Step Out), 371
Command+Shift+V (SCM Results), 479
Command+Shift+Y (Debugger window), 365
Command+U (Revert to Saved), 112
Command+Up Arrow (Go To Previous Difference), 485
Command+W (close window), 91

Command+Y (Build and Debug), 305, 364
Control+. (Next Completion), 125

Control+| (Re-indent), 122

Control+/ (Select Next Placeholder), 127
Control+1 (file history menu), 106

Control+R (Execute Script), 132

Control+3 (included files menu), 107

for deleting text, 111

editing for menu, 200

for moving cursor in text, 101-102

navigation bar controls, 104

Option+click in gutter (“Run to Here” command), 371
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Option+double-click (Find Selected Text in API Refer-
ence), 184
for scrolling, 103
for searching, 160-162
keyed archive, 226

L

launching program. See also opening
commands for, 359
MallocDebug, 435
Shark, 421
layers of build settings, 319-320
layout. See also layout style
force-directed, 242
hierarchical, 241, 242
reusing, 28
visual, 19-20
Layout panel (Inspector palette, Interface Builder), 217
layout style
All-In-One, 21-22, 24
changing, 22-24
Condensed, 21
Default, 20-21, 24
details list and, 31-32
editor pane and, 88
overview of, 20
showing and hiding groups and, 27
Layout->Alignment, 206
Layout->Group, 206
Layout->Guides=>Enable/Disable Aqua Guides, 208
Layout~>Guides—>Lock/Unlock Guides, 208
Layout->Guides=>Show/Hide Guides, 208
Layout->Keyboard Navigation->Clear Keyboard Loop,
218
Layout->Keyboard Navigation->Hide Keyboard Check,
218
Layout->Keyboard Navigation->Make Initial First
Responder, 218
Layout->Keyboard Navigation~>Show Keyboard Check,
218
Layout->Make Subview Of, 207
Layouts tab (Interface Builder preferences), 228
Layout->Same Size, 204
Layout->Size to Fit, 204
Layout=>Ungroup, 206
Layout=>Unpack Subview, 207
leaks tool, 443
legacy templates, 284
library target, 275



modifying build rules for target

/Library/Application Support/Apple/Developer tools
folder, 5
licensing agreement, 2
Line Encodings (Text Editing tab, Xcode Preferences
window), 100-101
Line Endings attribute (Info window), 78
line, selecting, 110
Line tool
class model diagram, 239
data model diagram, 263
line wrapping, 98
Link Binary With Libraries phase, 287
linker settings, 346-347
list, searching, 162-163
list view of Interface Builder, selecting object in,
202-203
listing pane (Debugger window), 367-368
listings
Bad Loop, 400-401
C++ Test Case example, 459
C++ Test Registration, 460
C++ Tests example, 459-460
C++ Unit Test sample, 453
Cocoa Application Target Template, 516-517
Compiled Source Code, 361-362
Controlling Text Selection, 525-526
Custom Script with Four Commands, 523
DataBlock Subclass, 395-396
MyDocument.h Source File, 222
Nested Function Calls, 372
Objective-C, 190
Objective-C Test Case example, 456
Objective-C Tests example, 456
Objective-C Unit Test Using setUp and tearDown
methods, 454
Sample Class, 393
Skeletal Header and Implementation Files, 224, 225
Test Item Template Files, 511
Unit Test Build Log, 446
Unit Test Hook for Carbon Application, 462-463
Unit Test Hook for main (), 461
loadable bundle templates, 554
localizing file, 136-139
Locals group (variables pane, Debug window), 369
Location field (New File assistant), 70
location for new project, selecting, 39-40
Lock All Connections option (Editing tab, Interface
Builder preferences), 212
Lock control (navigation bar), 97
locking node, 242
Log action (breakpoints), 384

x
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login, pre-authorized on remote computer, creating,
410-412
.Iproj folder, 198

MAB (multi-architecture binary) file, 341
Mac 0S X 10.4,1
“Mac 0S X Debugging Magic” technical note, 418
Macintosh Programmer’s Workshop (MPW), 132
macros
C++ test, 460
Objective-C test, 457-458
project templates and, 513-514
template, 509-512
text, 130-131
Maghnifying Glass tool (class model diagram), 239
mailing lists
Performance Analysis and Optimization, 434
Xcode users, 187
main () function, 461
MainMenu object, 199
MainMenu.nib file, 547
Make File Localizable button (Info window), 136
MallocDebug tool, 435-439
man pages, 181-182
ManagedObjectDataFormatter project, 398
mark (Emacs), 103
marshalling, 191
member, hiding in class diagram, 246
memory browser window, 391
memory leak, 435
Menu Key Bindings, 493-496
menu script definitions, 520-524
menu separator file, 520
menus. See also specific menus
creating in Interface Builder, 199-200
overview of, 12
merging
changes, 486-487
Shark sessions, 434
methods
constructor, 455
setUp and tearDown, 454
migrating to Xcode
from anything else, 52
from CodeWarrior, 51-52
minimizing NIB document window, 195
minus sign (-) and breakpoints, 379
modifying build rules for target, 291-292




modularizing project

modularizing project, 298
MONSster tool, 443
.moved-aside file extension, 71, 72
moving
build setting, 335-336
file
from one build phase to another, 286
to organize project, 81-82
folder, 82-84
group in hierarchy, 26, 27
node in class diagram, 241-243
object
in Interface Builder, 203-206
between subviews, 207
MPW (Macintosh Programmer’s Workshop), 132
multi-architecture binary (MAB) file, 341
Multiple Item Info window, 79-80
MyDocument.nib file, 547

N

Name field (Info window), 77, 78
naming. See also renaming
project, 39-42
variable, 336
native targets, 276, 277
NATIVE_ARCH fixed-build setting, 341
navigating
build window, 311-313
Class Browser, 165-167
class model diagram, 239-241
between files
aggregate file history, 107
file history menu, 106-107
included files menu, 107-108
jumping to definition, 108
help documents, 174-175
in source code
cursor movement, 101-102
Emacs commands, 102-103
jumping, 103-106
scrolling, 103
navigation bar (editor pane)
bookmarks menu, 105-106
breakpoints menu, 106
controls, 103
file history menu, 106-107
functions menu, 104-105
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keyboard shortcuts for controls, 104
overview of, 96-97
nested function calls, 372
New Empty File command (File menu), 72
New File assistant, 69-71, 455, 508
New File window buttons, 232-233, 255
New Project assistant, 37-38
New Target assistant, 279-280, 449
NewSources dialog box
Copy Items into Destination Group’s Folder option, 75
Create Folder References for Any Added Folders button,
76-77
overview of, 74-75
Recursively Create Groups for Any Added Folder button,
76-77
Reference Type option, 75-76
targets list, 77
Text Encoding option, 76
Next button (New File assistant), 70
NIB document window (Interface Builder)
Classes tab, 219
description of, 192, 193, 194
multiple, 194-195
Nib tab, 225-226
NIB file
browsing classes defined in, 219
class definition and, 224
Cocoa versus Carbon, 191-192
creating, 195-197
format of
compatibility checking, 226-227
overview of, 225-226
making backup when saving, 199
opening existing, 197
overview of, 189-191
saving, 198
serialization and, 191
nodes
of class model diagram
description of, 236-238
locking, 242
moving, 241-243
resizing, 242
of data model diagram, 262
non-native targets, 276
Note tool (class model diagram), 239
NSCalendarDate object, 369
NSManagedObject subclass, creating, 270-271
NSManagedObjects, 253-254, 256



packages

o

object
converting into textual representation, 399
creating in NIB file
menu, 199-200
other, 201
overview of, 189-191
window, 200-201
deleting, 203
description of, 219
editing in Interface Builder
aligning, 205-206
grouping, 206
guides, 207-208
Inspector palette and, 208-217
moving and resizing, 203-206
overview of, 203
subviews, 206-207
tab order, 217-218
MainMenu, 199
NSCalendarDate, 369
selecting, 201-203
ObjectAlloc tool
Call Stacks display, 442-443
Global Allocations tab, 440-441
history graph, 441
Instance Browser tab, 441-442
overview of, 439-440
Objective-C language
Interface Builder and, 189, 190
Java and, 551
Shark and, 427
unit test macros, 457-458
unit tests, 455-456

Objects palette (Interface Builder), 192, 194
Omit Braces in Selection option (Text Editing pane,

Xcode Preferences window), 100, 110
Open in Separate Editor command, 87
open source project, 467
Open with Finder command, 140-141
OpenGL Profiler tool, 443
opening. See also closing

Activity Viewer window, 35
Build window

automatically, 313

manually, 24, 310
Class Browser, 165
Debug Visualizer window, 387
Debugger Console window, 402
Debugger window, 365
editor pane, 87

existing NIB file, 197
file into editor window, 77, 90-91
Go To window, 404
Help and Documentation window, 171
Info window, 33
MallocDebug, 435
man pages, 181
project, 10-11, 45-47
Project Find window, 24
read-only file, 100
Shark, 421
OpenStep project, 229
operators, searching and, 148-150, 179
Optimization Level setting (Debug build configuration),
362, 363
optimized code, maintenance of, 420
optimizing class using Shark, 426-428
Option key, closing editor windows and, 91
Option+click in gutter (“Run to Here” command), 371
Option+double-click (Find Selected Text in APl Refer-
ence), 184
Option+Return key and automatic indenting, 119
order of execution of target dependencies, 299
ORGANIZATIONNAME template macro definition, 43-45
organizing
build into multiple targets, 298
project structure group, 25
sources
bad references and, 66-67
default references, 60-61
into functional hierarchies, 63-64
outside box, 64-66
overview of, 59-60
by type, 61-62
osascript tool, 530
outlet
Cocoa and, 210
creating classes and, 220
renaming, 223
overriding global values for indentation, 122
Overwrite Selected Files button (Template Files Already
Exist dialog box), 71, 72

P

packages
CHUD.pkg installer, 421-422
description of, 547
ICU (International Components for Unicode) Regular
Expression, 153

Index



packages (continued)

packages (continued) compiler optimization and, 424
NIB files as, 191 hot spots, 429
upgrading and, 7 merging sessions, 434
Xcode Developer Tools, 4-5 optimizing class with, 426-428
page layout of class diagram, 243 overview of, 421-423
Page Setup command, 139 profile view, 423-425, 432-433
Palette/Info Panel Are Utility Windows option (Inter- refining analysis, 432-433
face Builder preferences), 227 saving and comparing sessions, 433-434
Palettes tab (Interface Builder preferences), 228 stack view, 431-432
parent entity, 256 statistical sampling and, 425
parsing header file, 224 Performance Analysis and Optimization mailing list, 434
partial build, 309-310 Place Build Products In setting (Build tab, Xcode Pref-
path attribute, 57 erences window), 317
Path field (Info window), 77, 78 Place Intermediate Build Files In setting (Build tab,
Path Type field (Info window), 77, 78 Xcode Preferences window), 317
pattern, searching for Place options (Build tab, Xcode Preferences window),
overview of, 144-146 314
in regular expression, 146-148 placeholder targets, 281-282
Pause command (debugger), 370, 371, 372 plug-in templates, 554-556
PBXAIlIText variable, 524-525 POSIX immutable flag, 100
PBXArgument definition, 522 POSIX write permissions, 100
PBXIncrementalDisplay definition, 522 #pragma mark statement, 105
PBXInput definition, 521-522 pre-compiled headers, 344-345
PBXKeyEquivalent definition, 521 precompiling system headers, 307
PBXName definition, 521 predicate builder
PBXNewScript definition, 522 building predicate, 267
PBXOutput definition, 522 closing, 268
PBXSelectedText variable, 524-525 compound expressions, 266
PBXSelection variable, 525-526 fetched properties and, 260
PBXSelectionEnd variable, 525 overview of, 264
PBXSelectionLength variable, 525 simple expressions, 264-265
PBXSelectionStart variable, 525 textual expressions, 267-268
PBXTextLength variable, 525 Predictive Compilation, 310
.pbxuser file extension, 489 preferences file
PBXUtilityScriptsPath variable, 526 editing, 43-45
PC (program counter) indicator, 368 per-user basis of, 352
.pch file extension, 344 prefix headers, 344-345
perceived performance, 420 preparing
per-file compiler flags, 337-338 application for dependent unit testing, 451-452
Perforce source control system, 471 for performance analysis, 421
performance analysis for unit testing, 446-448
MallocDebug, 435-439 Preprocess command, 309
ObjectAlloc, 438-443 Print command, 139
other tools for, 443-444 printing editor pane, 139
overview of, 419-421 product location, 315-316
preparing for, 421 product of target, 274, 275, 303
Sampler, 434-435 product references
Shark Copy Files phase and, 288
advice button, 429 cross-project, 297, 316
advice, using, 429-431 description of, 59
code view, 428-429, 431 Products and Products group, 25
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Pseudo Terminal, run window as

profile view (Shark), 423-425, 432-433
program counter (PC) indicator, 368
progress of build, viewing, 305-306
project. See also building project

active, 45

adding to source control, 473-474

attributes of, 52-54

build settings, 321, 322

closing, 45

configuring for source control, 474-476

creating new, 37-38

naming, 39-42

open source, 467

opening, 10-11, 45-47

OpenStep, 229

overview of, 9

ProjectBuilderWO, importing, 50-51

relocating, 48

renaming, 48

switching, 46-47

upgrading, 48-49
Project Breakpoints sub-group, 377
Project Builder Projects, 516
Project control (toolbar), 34
project document

description of, 37

moving, 48

source control management and, 489-490

Project Find window
Batch file options, 158-160
opening, 24
Return key and, 160
search history, 157
searching using, 155-156
project group, 11
Project menu, 12
project structure group, 24, 25
Project Symbols smart group, 12, 26, 163
project templates
action, 544
application, 544-547
bundle, 547-548
command-line utility, 548-549
descriptions of, 543
dynamic library, 549-550
empty, 543-544
file references in, 514-515
framework, 550-551
Java, 551-553
kernel extension, 553-554

loadable bundle, 554

macros and, 513-514

overview of, 512-513

portability of, 516

problems with, 515-516

standard Apple plug-ins, 554-556

static library, 556-557

WebObjects, 557
project window

All-In-One layout style and, 21-22

Condensed layout style and, 21

Default layout style and, 20-21

details list, 31-32

editor pane of, 88-90

Errors and Warnings smart group, 312

Groups & Files pane, 11, 24-31

layout style and, 20, 22-24

overview of, 9-10, 19
Project->Add Current File to Project, 77
Project->Add to Project, 73, 297
ProjectBuilderWO projects, importing, 50-51
Project->Class Browser, 165
Project->Edit Active Target ‘TargetName,” 274
Project->Edit Project Settings, 52, 129, 474
Project->New Custom Executable, 405
Project=>New Target, 279, 448
project.pbxproj file, 489, 514-515
project-relative reference, 58
projects and files settings (expert preferences), 500
Project->Set Active Build Configuration, 309, 326, 331
Project->Set Active Executable, 360, 408
Project->Set Active Target, 309, 337
Project->Update All Targets in Project to Native, 277
Project->Upgrade to Native Target, 277
properties

attribute, 257-258

creating, 257-260

data modeling and, 254

data schema and, 253

duplicating, 264

of entities, 256

FilesToRename, 513, 514-515

Info window and, 33-34

targets and, 301-302
Property List Editor

changing expert preferences and, 499

deleting simple smart groups and, 30
Prune commands (MallocDebug), 437-439
Pseudo Terminal, run window as, 360



Quartz Debug too

Q

Quartz Debug tool, 443
Quick Model command, 234-235

R

RCEnvironment utility, 336
read-only file, opening, 100
Rebuild Code Sense Index button (Info window), 53,
129
recursive references, 325
Recursively Create Groups for Any Added Folder button
(NewSources dialog box), 76-77
redefining command keys for debugger, 495-496
Redo command, 113-115
Reference Library
bookmarks, 175
browsing, 171-174
documents, navigating, 174-175
extended documentation, 176-177
external links, 175
overview of, 14-15
updating, 183-184
reference types
overview of, 57-59
selecting items to add to project and, 75-76
Reference window, 20
references
absolute, 58
attributes of, 57-59
bad, sources and, 66-67
build setting, resolving, 323-324
cross-project, 297, 316
data formatters and, 393
default, 60-61
enclosing-group, 58, 60-61, 84
file item or folder item, viewing, 78
product, 59, 288, 297, 316
in project templates, 514-515
project-relative, 58
recursive, 325
to source files, 48
source tree, 58, 469-471
registering C++ tests, 460
Registers group (variables pane, Debug window), 369
regular expression
replacing text using, 153-154
searching for
operators, 148-150
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overview of, 146-147
patterns, 146-148
Regular Expression mode (Single File Find window),
144,146
Regular Expression search mode, 162
re-indenting text, 120, 122
reinstalling Xcode, 8
Reinterpret button (File Encoding window), 135
relationship
in data model diagram, 263
definition of, 254
entity and, 258-259
relative path
of build phase, 288
problem with, 66
Release configuration, 326, 364
relocating project, 48
remote debugging, 410-413
Remove All button (New File window), 233
Remove All Localizations button (Info window), 138
Remove button (New File window), 233
Remove Old then Create button (Template Files Already
Exist dialog box), 71, 72
removing
build phase, 285
localization from file, 138
source file from target, 286
Xcode, 8
renaming. See also naming
action, 223
build configuration, 333
build setting, 331
file
in project, 513, 514
under source control, 483
group, 26
outlet, 223
product or project document, 42
project, 48
source group, 77
symbolic breakpoint, 378
target, 42, 274
reordering
build phases, 285
items in menu, 200
reorganizing sources
fast technique for, 84-85
files, moving, 81-82
folders, moving, 82-84
overview of, 80-81
Replace field (Single File Find window), 153



SCM=>Discard Changes

replacing text
in multiple files, 157-158
overview of, 153
regular expressions, using, 153-154
repository
adding project to, 473-474
changes to
committing, 480-481
discarding, 481-482
saving before committing, 481
creating, 473
description of, 471
resizing
column in details list, 32
Debugger window panes, 366
node, 242
object in Interface Builder, 203-206
resolving
build setting references, 323-324
conflicts in versions of file, 488-489
resources, importing, 197-198
Restart command (debugger), 371
restarting computer after reinstalling Xcode, 8
Restore To Factory Default button, 28
Return key
automatic indenting and, 119
Single File Find or Project Find windows and, 160
reusing layout, 28
Reveal In Finder command, 78, 141
revealing. See displaying; showing
Revert to Saved command, 112-113, 114
reverting build setting to previous value, 331
rolling checksum, 426
RTF (styled text) editor, 112
Run button, 359
run log window, 360
Run Script phase, 288-291
“Run to Here” command, 371, 374
running
application
changing data and code while, 399-402
choosing active executable, 360-361
overview of, 359-360
installer utility, 2-6
Runtime Configuration Guidelines, 301

S

Same Size command, 204
Sampler, 434-435

x
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sampler tool, 425. See also Shark
Saturn tool, 443
Save options (Text Editing pane, Xcode Preferences
window), 100
Save Window State option (Xcode Preferences win-
dow), 45
saving
automatic save options, 315
changes made in editor pane, 91-92
before committing changes, 481
directly to .Iproj folder, 198
file, 112-113
NIB file, 198
Shark session, 433-434
SCM (source control management)
changes
committing, 480-481
discarding, 481
merging, 486-487
comparing revisions, 484-485
creating repository, 473
customizing compare, 486

file
adding, 482
deleting, 482

renaming, 483
updating, 483-484
going offline, 489
installing Subversion client, 472-473
interface, 476-477
overview of, 467, 468, 471
project
adding, 473-474
configuring, 474-476
project document and, 489-490
resolving conflicts, 488-489
saving before committing, 481
SCM smart group, 477-480
viewing annotations, 487-488
SCM menu, 12, 476
SCM smart group, 26, 477-480
SCM tab
Info window, 476-477
Xcode Preferences window, 481, 486
SCMc>Add to Repository, 482
SCM->Commit Changes, 480
SCM=>Commit Entire Project, 480
SCM-=>Compare With, 484
SCMc>Compare With->File, 485
SCM->Diff With, 484
SCMc>Discard Changes, 488




SCM=>Get Annotations For

SCM~->Get Annotations For, 487
SCMc>Go Offline, 489
SCM=>Go Online, 489
SCM->Refresh Entire Project, 479, 484
SCM-=>Resolved, 489
SCMc>SCM Results, 479
SCM-=>Update Entire Project, 484
SCM-=>Update To->Latest, 483, 484, 488
SCM-=>Update To->Revision, 483
SCM-=>Update To->Specific Revision, 484
scope of build settings, 321-322
script, custom
anatomy of, 520
menu script definitions, 520-524
overview of, 517-518
StartupScript, 518-520
tools, 526-528
variables, 524-526
scroll bar controls (editor pane), 93-94
scrolling, key combinations for, 103
search commands, 13
Search Groups list (Reference Library), 173
search history
Project Find window, 157
Single File Find window, 155
Search in Open Projects option (Batch Find Options
window), 159
Search Kit framework, 180
search path settings, 344
searching
Batch Find Options window and, 158-160
Help and Documentation window and, 178-181
keyboard shortcuts for, 160-162
lists, 162-163
multiple files
Find Results smart group and, 156-157
Project Find window, using, 155-156
text files
overview of, 143-144
for pattern, 144-146
for regular expression, 146-153
Secure Shell (ssh), 410
Select to Matching Brace option (Text Editing pane,
Xcode Preferences window), 99-100, 110
selecting
active target and build configuration, 309
block, 110
boot volume, 2-3
class node, 239-240
column, 109-110
container, 202
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executable, 408-409
items to add to project
NewSources dialog box, 74-77
overview of, 73-74
line or character, 110
location for new project, 39-40
objects in NIB document, 201-203
source file, 24
text, 109
sequential archive, 226
serialization, 191
Services, 139
SetMenu tool, 527-528
setUp method, 454
Share My Computer for Building With option (Dis-
tributed Builds pane), 354-355
shared library window, 403-404
sharing. See also source control management (SCM)
build location between multiple projects, 318-319
computer to compile files for other developers,
353-356
source files
overview of, 467-468
source trees and, 468-471
subfolder, 61-62
Shark
advice button, 429
advice, using, 429-431
code view, 428-429, 431
compiler optimization and, 424
hot spots, 429
merging sessions, 434
optimizing class with, 426-428
overview of, 421-423
profile view, 423-425, 432-433
refining analysis, 432-433
saving and comparing sessions, 433-434
stack view, 431-432
statistical sampling and, 425
she-bang (#!) line, 518
Shell Command action (breakpoints), 384, 386-387
Shell field of Run Script phase, 288-291
shell script, 132, 336
Sherlock panel (Inspector palette, Interface Builder),
216
shortcuts. See keyboard shortcuts
Show Arguments in Pop-up List option (Code Sense tab,
Xcode Preferences window), 126
Show Assembly Code command, 309, 310
Show Column Position (Text Editing pane, Xcode Prefer-
ences window), 99



source file

Show Declarations setting (Code Sense tab, Xcode
Preferences window), 502
Show Gutter in the Text Editing pane (Xcode Prefer-
ences window), 96
Show Gutter (Text Editing pane, Xcode Preferences win-
dow), 99
Show Line Numbers (Text Editing pane, Xcode Prefer-
ences window), 99
Show Package option (General tab, Info window), 238
Show Page Guide (Text Editing pane, Xcode Prefer-
ences window), 99
Show Property Type option (General tab, Info window),
238
Show Visibility option (General tab, Info window), 238
show warnings button (build window), 311
showing. See also displaying
control characters, 98
details in Groups & Files list, 32
Favorites bar, 35
grid, 243
group, 27
Inspector palette, 33
navigation bar, 96
SCM column, 478
spaces, 98
spatial relationship between objects, 202
status bar, 35, 97
user guide, 208
shrinking object, 204
simple expressions and predicate builder, 264-265
Simple Filter smart group, 29
Simple Regular Expression smart group, 29
simple smart group
creating, 29-30
deleting, 30-31
simple string sheet, 330-331
Single File Find window
Find field, 143-144, 146
Replace field, 153
Return key and, 160
search history, 155
size of text, controlling, 178
Size panel (Inspector palette, Interface Builder), 213
Size to Fit command, 204
Skip Panel If Selection Is File Name option (Open
Quickly preferences), 91
smart group. See also specific smart groups
creating simple, 29-30
deleting simple, 30-31
description of, 11-12, 24, 25-26
showing or hiding, 27

Index

software development, 467
Sound action (breakpoints), 384
source breakpoints, 377
source code
editing
deleting text, 111
drag-and-drop technique and, 111-112
plain text editor and, 112
selecting text, 109-110
navigating in
cursor movement, 101-102
Emacs commands, 102-103
jumping, 103-106
scrolling, 103
optimized, maintenance of, 420
stepping through, 373-374
source control management (SCM)
changes
committing, 480-481
discarding, 481
merging, 486-487
comparing revisions, 484-485
creating repository, 473
customizing compare, 486

file
adding, 482
deleting, 482

renaming, 483
updating, 483-484
going offline, 489
installing Subversion client, 472-473
interface, 476-477
overview of, 467, 468, 471
project
adding, 473-474
configuring, 474-476
project document and, 489-490
resolving conflicts, 488-489
saving before committing, 481
SCM smart group, 477-480
viewing annotations, 487-488
source control management settings (expert prefer-
ences), 506
source file. See also breakpoints; source control man-
agement (SCM)
adding to class model, 233
build flag and, 308-309
building project and, 306-307
creating new, 69-73
description of, 60
per-file compiler flags and, 337-338




source file (continued)

source file (continued)
sharing
overview of, 467-468
source trees and, 468-471
switching to, 108
source file item, 67
source folder
description of, 60

source folder item compared to, 68-69

source folder item, 67, 68-69
source group
adding to class model, 233
altering, 26-27
description of, 11, 24, 25, 60
showing or hiding, 27
source group item, 67-68
source item
attributes of
changing for multiple items, 79-80
overview of, 77-79
ridding targets of unwanted files, 80
description of, 60
types of, 67-69
source tree
defining, 469
overview of, 467-469
references, 58, 469-471
sources
adding existing to project, 73-77
adding open file, 77
NewSources dialog box, 74-77
organizing
bad references and, 66-67
default references, 60-61
into functional hierarchies, 63-64
outside box, 64-66
overview of, 59-60
by type, 61-62
overview of, 57
reorganizing
fast technique for, 84-85
files, moving, 81-82
folders, moving, 82-84
overview of, 80-81
source-tree reference, 58, 469-471
space character, 98, 118
spell checking
finding one word, 133-134
interactive, 132-133
overview of, 132
while typing, 134
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Spelling palette, 132
Spin Control tool, 443
split pane control, 27-28
split-pane editing, 94-95
ssh (Secure Shell), 410
stack frame, 366, 368
stack view (Shark), 431-432
Starting Point assistant (Interface Builder), 195-197
StartupScript, 518-520
static library templates, 556-557
status bar, 35, 97
Step Into command (debugger), 371, 372-373
Step Into Instruction command (debugger), 371, 374
Step Out command (debugger), 371, 373
Step Over command (debugger), 371, 372-373
Step Over Instruction command (debugger), 371, 374
stepping through code, 373-374
stopping build, 306
String Matching search mode, 162
strings, editing, 331
Strip Debug Symbols From Binary Files setting (Build
tab, Info window), 329
Strip Debug Symbols setting (Debug build configura-
tion), 362, 363
structure, examining contents of, 390
subfolder, sharing, 61-62
Subversion source control system
installing client, 472-473
overview of, 471
putting project in, 475-476
repository, creating, 473
subviews, 206-207
subword, definition of, 102
Summatry field (variables pane, Debug window), 369
switching between
build configurations, 331-332
projects, 46-47
split editor panes, 95
targets, active executable and, 361
symbolic breakpoints
creating, 380-381
description of, 377
Sync With Debugger command (debugger), 371, 374
syntax coloring, 99, 115-118
syntax-aware editing
Code Sense
index, rebuilding, 129-130
invoking code-completion, 123-129
overview of, 122-123
text macros and, 131
indenting, 119



Test Driven Development (TDD)

overview of, 115

syntax coloring, 115-118
/System folder, 5
system headers, precompiling, 307
system location build settings, 351
System Preferences, Accounts pane, 43

T

Tab Indents option (Indentation tab, Xcode Preferences
window), 119-120
tab order, 217-218
tab stop, indenting with, 118
Tab Width option
Indentation tab, Xcode Preferences window, 118, 122
Info window, 78, 79
Target SDK setting, 338-339, 340
target templates, 516-517
targets
active, selecting, and build configuration, 309
aggregate, 275, 279, 299
application, 275, 277
build phase
files in, 285-287
overview of, 12, 273, 274, 284-285
types of, 287-291
build rules, 274, 275, 291-296
build settings
debugging and, 264
editing, 274-275
layered hierarchy of, 319, 320-321
overview of, 273, 299, 364
building and, 16
command-line, 275, 277
components of, 273-276
creating, 279-281
deleting, 284
dependencies, 274, 275, 296-299, 448
description of, 273
duplicating, 284
editing, 274
executables and, 303, 408-409
external, 276, 278
framework, 277
inactive, building, 309
Jam-based, 277-278, 284, 300-301
native, 276, 277
non-native, 276
placeholder, 281-282
products of, 274, 275, 303

Index

properties, 301-302
ridding of unwanted files, 80
switching between, active executable and, 361
template groups, 281-284
types of, 276-279
targets group, 12
Targets list
New File assistant, 71
NewSources dialog box, 77
Targets smart group, 25
Targets tab (Info window), 78, 79
Targets/Actions panel (Cocoa Inspector palette), 212
Task control (toolbar), 34
TDD (Test Driven Development), 445
team for software development, 467
tearDown method, 454
Template Breakpoints group, 388
Template Files Already Exist dialog box, 71, 72
Templatelnfo.plist file, 508, 513
templates
action, 544
application, 544-547
bundle, 547-548
choosing, 38-39
command-line utility, 548-549
customizing
file templates, 508-509
overview of, 508
project templates, 512-516
target templates, 516-517
template macros, 509-512
descriptions of, 543
dynamic library, 549-550
empty project, 543-544
framework, 550-551
Java, 551-553
kernel extension, 553-554
loadable bundle, 554
Managed Object Class, 270-271
New Project Assistant and, 38
source file, 69-70
standard Apple plug-ins, 554-556
Starting Point assistant, 195-196
static library, 556-557
target, 281-284
upgrading and, 49-50
variable fields and, 42-43
WebObjects, 557
terminating running program, 359
terminology and debugger, 366
Test Driven Development (TDD), 445



test harness

test harness, 426 debugger
Test Interface tab (Interface Builder preferences), 228 Console button, 402
testing interface, 203 Fix button, 401
text Group/Ungrouped control, 90, 97
deleting, 111 overview of, 34
indenting, 118-122 Run button, 359
re-indenting, 120, 122 tools
replacing build settings for, 350
in multiple files, 157-158 in class model diagram, 238-239
overview of, 153 custom script, 526-528
regular expressions, using, 153-154 in data model diagram, 263
selecting, 109 performance analysis
size, controlling, 178 debug symbols and, 421
Text Editing tab (Xcode Preferences window) list of, 443
Omit Braces in Selection option, 110 MallocDebug, 435-439
options, 99-101 ObjectAlloc, 438-443
Select to Matching Brace option, 110 overview of, 419
text editor Sampler, 434-435
description of, 12 Shark, 421-434
editor pane xcodebuild, 351-353
closing and saving, 91-92 to-one relationship, 258
Debugger window, 99 Tracking tab (Info window), 243-244
display options, 98-101 troubleshooting
elements of, 92-93 class model construction, 244
gutter, 93, 96, 99 data formatters, 397-398
navigation bar, 96-97 Type menu, 257-258

overview of, 87-91

of project window, 88-90

scroll bar controls, 93-94 U
split-pane editing, 94-95

Text Encoding option (NewSources dialog box), 76 umbrella framework, 550

text file, searching Undo facility, 113-115
overview of, 143-144 Ungroup command, 27
for pattern, 144-146 Unicode, converting document to, 135
for regular expression, 146-153 unit testing
text insertion cursor, 93 adding unit test target, 448-453
Text Key Bindings, 496-499 creating unit test
text macros, 130-131 F:++ tests., 458‘—4(3?4
textual expressions and predicate builder, 267-268 Inter-test initialization, 454-455
Textual mode (Single File Find window), 144 Objective-C test macros, 457-458
Thread Viewer tool, 443 Objective-C tests, 455-456
threads pane (Debugger window), 366-367 overview of,‘ 453
tilde (~) character, 199 debugging unit test, 464-466
Toggle Disassembly Display command (Debug menu), dependent unit test, 447-448
367-368 example of, 446
to-many relationship, 258-259 independent unit test, 447
toolbars overview of, 445
Build and Go button, 359-360 preparing for, 446-448
build buttons, 305 target dependency, 448
build window, 311 universal binaries, 341-342
Class Browser window, 166 unlocking file, 97
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Web sites

updating
file under source control, 483-484
NIB file, 223-224
Reference Library, 183-184
Upgrade button (installer utility), 7
upgrade dialog box, 49
upgrading
Jam-based targets, 277-278
project, 48-49
templates and, 49-50
Xcode, 7
Use Colors When Printing option (Fonts & Colors tab,
Xcode Preferences window), 139
Use For Standard Input/Output option (General tab,
Info window), 406
Use Predictive Compilation options (Build tab, Xcode
Preferences window), 315
Use Suffix When Loading Frameworks option (General
tab, Info window), 406
User guides, 208
User Info pane (details pane of data model), 262
/usr folder, 5
UTF-8, 515, 518, 520

Vv

VALID_ARCHS build setting, 341
value
of build setting, editing, 330-331
examining contents of, 390
variables
changing value of, 400
creating new project and, 42-45
custom script, 524-526
debug, 415-418
environment, 293-294, 336-337, 415-417
global, viewing, 391-392
INFOPLIST FILE, 299
naming, 336
watchpoints and, 399
variables pane (Debugger window)
Arguments group, 369
Globals group, 391-392
groups, 368-370
overview of, 389
$ (VAR_NAME) syntax, 323
version control. See source control management (SCM)
Version Control with Subversion, 471
View menu, 12
Viewr>Clear File History, 107

Index

Viewr>Close Split View, 95
Viewr>Detail View Column menu, 32
View>Groups & Files Columns menu, 32
Viewr>Hide Navigation Bar, 96
View=>Hide/Show Status Bar, 35
viewing

call stack, 367

columns in details list, 32

connections, 210-211

file or folder item references, 78

global variables, 391-392

memory, 391

progress of build, 305-306
View=>Open In Separate Editor, 156
Viewr>Reveal in Class Browser, 170
Viewr>Show Advanced Settings, 432
View=>Show menu, 22
View=>Show Navigation Bar, 96
Viewr>Show/Hide Favorites Bar command, 35
Viewr>Split filename Vertically, 95
View>Switch to Header/Source File, 108
Viewr>Zoom Editor In/Out, 89, 311
visual layout, 19-20
Visualize action (breakpoints), 384, 387
vmmap tool, 443
volume on operating system to install to, selecting, 2-3

w

warnings
Breakpoints window, 383
build window, navigating, 311-313
Clean All Targets command and, 307
display of in gutter, 93, 96
editor and, 141
encoding conflict, 135, 136
Reinterpret button and, 135
watchpoints, 399
weak linking, 340
Web sites
accessibility issues, 215
Apple Developer Connection, 176
bundles, 547
CHUD.pkg installer package, 422
Cocoa Bindings documentation, 213
Cocoa Predicate framework, 264
Core Data, 253
CVS (Concurrent Versions System), 471
dynamic libraries, 549
Enterprise Objects, 557



Web sites (continued)

Web sites (continued) Distributed Builds pane, 354-355
frameworks, 551 Documentation tab, 176
gdb debugger, 386 File Types tab, 140
Human Interface Guidelines, 208 Fonts & Colors tab
Java support, 551 Allow Separate Fonts option, 117
kernel extensions, 553 editor page and, 98
“Mac 0S X Debugging Magic” technical note, 418 syntax coloring and, 115-117
ManagedObjectDataFormatter project, 398 Use Colors When Printing option, 139
OpenStep project, 229 General pane, Automatically Open/Close Attached Edi-
Perforce source control system, 471 tor option, 89
RCEnvironment utility, 336 Indentation tab, 118-122
Runtime Configuration Guidelines, 301 Key Bindings tab
Search Kit framework, 180 Menu Key Bindings, 493-496
Sherlock Channels, 216 overview of, 492-493
Subversion, 472 Text Key Bindings, 496-499
WebObjects, 557 Save Window State option, 45
Xcode-users mailing list, 187 SCM tab, 481, 486
ZerolLink release notes, 364 Show Gutter in the Text Editing pane, 96
WebObjects templates, 557 Source Tree tab, 469
white space, 119 tabs, 492
wildcard (*) operator, 179 Text Editing tab
Wildcard Pattern search mode, 162 Omit Braces in Selection option, 110
window. See also specific windows options, 99-101
active project and, 45-46 Select to Matching Brace option, 110
creating in Interface Builder, 200-201 Xcode Reference Guide, 340
Window menu, 12, 45 xcodebuild tool
Windowsc>Activity Viewer, 35 compatibility, 353
Windows>Tools>Details, 31 layers of build settings and, 320
Window=>Tools menu, 22 overview of, 351, 529
word using, 352-353
definition of, 102 Xcode->Preferences, 22

double-clicking, 108
word boundaries, searching on, 145-146
working copy, 471 Z

Wrap Around option (Single File Find window), 144
ZeroLink

breakpoints and, 379
data formatters and, 398

X disallowing, 342
.xcconfig file extension, 334 ZerolLink setting (Debug build configuration), 362,
Xcode application icon, 90 363-364
Xcode Defaults key binding set, 101 Zonelnspector window (MallocDebug), 438
Xcode Developer Tools suite Zoom Editor In/Out command, 89

installing, 1 Zoom Editor In/Out Fully command, 89

packages, 4-5 Zoom In command, 239

script helpers and, 526 Zoom Out command, 239

Xcode Preferences window
Build tab, 314-315, 316-317
changing layout style and, 22-23
Code Sense tab, 126-128, 502
Debugger pane, 409-410

590


















