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The great thing is that you only need to create and assign worksets to a limited number of 
objects that you’re using in your project. Revit is managing the worksets assigned to every-
thing else.

If you want to review any of the content from this portion of the chapter, you can download 
the c02_Organization.rvt file from the Chapter 2 folder. This file will allow you to investigate 
the complex 3D forms that were created using reference planes, hosted relationships, edited 
elevation profiles, and more.

Interface Organization
The interface has continued to evolve since 2010 and displays real finish and elegance. 
Persistence of command location is the key. So even though functions remain contextually 
exposed or hidden depending on what you’re working on, the majority of those contextual com-
mands are in the same place.

Figure 2.64 shows the Revit 2012 UI. To illustrate some different project views, we’ve tiled 
four view types: plan, elevation, 3D, and sheet.

Application Menu
The Application menu (Figure 2.65) allows you to access commonly used commands: New, 
Open, Save, Print, and so on. You can also export your project to a number of 2D and 3D formats 
from this menu. This menu is also where you manage licensing information. The Publish option 
lets you publish RFA files to Autodesk Seek.

Figure 2.64 
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Quick Access Toolbar
The Quick Access toolbar (QAT) allows you to create a group of frequently used tools in one 
selection area (Figure 2.66).

Right-clicking a command in one of the tabs allows you to add elements to the QAT 
(Figure 2.67).

By clicking the small, down-facing arrow to the far right of the QAT, you’ll find that com-
mands may be further customized, grouped, and removed from the toolbar (Figure 2.68). You 
also have the option to show the QAT below the ribbon.

Figure 2.65 
Application menu

Figure 2.66 
Quick Access  
toolbar

Figure 2.67 
Adding commands 
to the QAT
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InfoCenter
To the far right of the QAT is the InfoCenter (Figure 2.69).

From left to right, you have the ability to search, access the Subscription Center, access the 
Communication Center, save Favorites, and get help.

Properties
The Properties palette contains the instance parameters of whatever you’re currently working 
on. From this palette you can access the Type Selector, filter properties, and edit type parameters 
(Figure 2.70).

Figure 2.68 
Customizing the 
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Figure 2.69 
InfoCenter

Figure 2.70 
Properties palette Type Selector

Properties Filter

Display Type
Properties

Instance Properties

937495c02.indd   50 4/18/11   10:18:32 PM



Interface Organization |  51

Project Browser
The Project Browser (Figure 2.71) is a project tree of all the views, legends, schedules, sheets, 
families, groups, and links in your Revit project. You can collapse and expand the project tree by 
selecting the + or – icon.

The Project Browser can also be filtered and grouped into folders based on a number of user-
defined parameters. To access the type properties of the Project Browser, simply right-click the 
Views portion at the top of the palette (see Figure 2.72). 

Figure 2.71 
Project Browser

Figure 2.72 
Project Browser’s 
type properties
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Status Bar
The status bar provides useful project information on files that are opening or already open 
(Figure 2.73). Project information such as worksets, design options, and filters is immediately 
accessible from the status bar.

Drawing Area
The drawing area is the window into your design space. In this example, we’ve tiled four view 
types: plan, elevation, 3D, and sheet (Figure 2.74). Rather than jump between expanded drawing 
areas that obscure each other, it’s sometimes helpful to tile many views in the same area.

When you do this, you’ll only be able to zoom into the extents that are defined by the draw-
ing area. If you want to get around this limitation, here’s a helpful tip.

Create a new sheet, but then delete the sheet (keeping the view). This is your “working” 
space for any view of the project. Now you can create duplicate views of any of your project 
views and assemble them in this working space (Figure 2.75). Zooming in and out is much more 
fluid, and you’re not limited to the extents of one drawing area. You can create a keyboard short-
cut to activate and deactivate views, which is helpful as well.

Figure 2.73 
Status bar

Figure 2.74 
Drawing area
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View Control Bar
The View Control Bar is at the bottom of every view and is contextual, based on the type of view 
that you’re working in (Figure 2.76). Some views (like sheet views) won’t have them. Perspective 
views won’t show a scale.

From left to right you have Scale, Detail Level, Visual Style, Sun Path (On/Off), Shadows 
(On/Off), Rendering Show/Hide (only in 3D views), Crop (On/Off), Show Crop (Show/Hide), 
Temporary Hide/Isolate, Reveal Hidden Elements, and in 3D views Lock 3D (On/Off).

One of the nice features in Revit is the ability to see realistic colors from the visual style 
(Figure 2.77).

The difference is subtle, but when combined with other graphic features, it will likely lead to 
users not rendering project views that are part of the document set. Rather, they’ll opt for hav-
ing real-time views.

Figure 2.75 
Working sheet 
view

Figure 2.76 
View Control Bar

Figure 2.77 
Realistic option
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Graphic Display Options
Selecting the Graphic Display Options from the View Properties bar opens a dialog box that lets 
you further embellish your project view on a per view basis (Figure 2.78), such as adding silhou-
ette edges and real-time shadows.

New in Revit 2012 is the ability to add global transparency to all solid elements in a view by 
selecting the Ghost Surfaces option (Figure 2.79).

The results of selecting this option are seen in Figure 2.80.

Figure 2.78 
Graphic Display 
Options dialog box

Figure 2.79 
Ghost Surfaces 
option
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Work Plane Viewer
New in Revit 2012 is the Viewer option located on the Work Plane panel of the Home tab 
(Figure 2.81). This viewer is available from all model views when you’re in the project 
environment. 

By default, the work plane is based on the active work plane of the last active view. But when 
you enter Sketch mode, the active work plane is that of the sketch (Figure 2.82). So even if the 
project window shows a 3D view, the viewer shows the plane of the sketch.

Figure 2.80 
Ghost surfaces

Figure 2.81 
Viewer option on 
the Work Plane 
panel

Figure 2.82 
Sketch mode with 
active work plane
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ViewCube
You’ll find the ViewCube in 3D views (Figure 2.83).

Hovering over the ViewCube reveals the Home option (the little “house” above the 
ViewCube), which you click to return to your home view. Right-clicking the ViewCube opens a 
menu that allows you to set, recall, and orient your view (see Figure 2.84).

Selecting Options from the context menu takes you directly to the ViewCube options in the 
Options dialog box (see Figure 2.85).

Figure 2.83 
ViewCube

Figure 2.84 
ViewCube options

Figure 2.85 
ViewCube options
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Navigation Bar
The navigation bar contains the Navigation Wheel, View Zoom, and Pan controls (Figure 2.86).

Ribbon
The ribbon contains all of the Revit functionality for designing and documenting your Revit 
project (Figure 2.87). There are specific portions of the ribbon you should be familiar with.

Tabs

Tabs are used to select from among the various groups of functionality in Revit. There are nine 
tabs in the Revit ribbon (Figure 2.88).

We’ll take a moment to briefly describe these tabs.

Home ​  ​ The Home tab is used to create or place content (both system and component fami-
lies) as well as datum (Figure 2.89).

Insert ​  ​ The Insert tab is used to link external files (2D, 3D, image, and Revit file types) as 
well as search for external content via Autodesk Seek (Figure 2.90).

Figure 2.86 
Navigation bar

Figure 2.87 
The Revit ribbon

Figure 2.88 
There are nine tabs 
in the ribbon.

Figure 2.89 
Home tab

Figure 2.90 
Insert tab
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Annotate ​  ​ The Annotate tab contains many of the tools necessary to annotate, tag, dimen-
sion, or otherwise graphically document your project (Figure 2.91).

Structure ​  ​ The Structure tab contains the tools necessary to add elements, which can be 
structurally analyzed in Revit Structure (Figure 2.92). You can also add datum from this tab.

Massing & Site ​  ​ The Massing & Site tab contains the tools necessary to add massing- and 
site-related elements (Figure 2.93).

Collaborate ​  ​ The Collaborate tab contains the tools that you’ll use to coordinate and man-
age the project within your own team as well as across other teams and their linked files 
(Figure 2.94).

View ​  ​ The View tab contains the tools that you’ll use to create all your project views, 2D and 
3D, as well as schedules, legends, and sheets. You can also modify your user interface from 
this tab, including your keyboard shortcuts (Figure 2.95).

Manage ​  ​ The Manage tab contains all your project standards and other settings 
(Figure 2.96). This tab also contains your design option and phase tools. 

Figure 2.91 
Annotate tab

Figure 2.92 
Structure tab

Figure 2.93 
Massing & Site tab

Figure 2.94 
Collaborate tab

Figure 2.95 
View tab

Figure 2.96 
Manage tab
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One of the most important settings that you’ll use during your project is Object Styles on the 
Manage tab. Selecting this option will allow you to manage the global visibility settings for 
just about everything in your project: how it projects, how it cuts, and its associated color and 
pen weight. 

Modify ​  ​ The Modify tab contains the tools you’ll use to manipulate all the content that 
you’re creating in your Revit project (Figure 2.97).

Contextual Modify ​  ​ Contextual Modify tabs are revealed as part of an addition to the 
Modify tab when specific elements are selected (Figure 2.98). Contextual tabs are located to 
the far right of all the other panels in your ribbon.

Panels

Panels identify areas of grouped functionality in the ribbon. They can also be pulled out of tabs 
and arranged so that functionality is persistently exposed. To relocate a panel, click and drag 
the panel portion out of the ribbon (Figure 2.99).

The panels will snap together if you hover over a previously placed panel. To return a panel 
to the ribbon, click the down arrow in the upper portion of the right gray bar in the panel set.

Options Bar

The Options Bar is a contextually sensitive area that gives you feedback as you create and mod-
ify content (Figure 2.100).

Figure 2.97 
Modify tab

Figure 2.98 
Contextual tabs

Figure 2.99 
Panels identify 
areas of grouped 
functionality.

Figure 2.100 
Options Bar
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The Bottom Line

Understand Revit project organization. ​  ​ Revit has been available for about 10 years, and 
yet, after a decade, it remains unique in its approach to “whole-building BIM.” The compel-
ling advantage of being able to design, document, and manage your project across multiple 
disciplines—the architect, structural, and mechanical disciplines—is something that you can 
only do in Revit, and understanding project workflow in Revit is key to getting off on the 
right foot.

Master It ​  ​ Thinking back to the Revit organization chart shown in Figure 2.1, what are 
the main components of a Revit project, and how can you apply them to your design pro-
cess? How do these categories directly affect your design workflow?

Understand Revit interface organization. ​  ​ In addition to understanding how your project 
is organized, to use Revit well you must understand how the user interface is organized. 
Once you grasp both these concepts, you’ll be ready to move ahead.

Master It ​  ​ The “big” areas of the Revit UI are the ribbon, properties, the Project Browser, 
and the drawing area. How do these areas work together, and what tabs correspond to an 
iterative design process?
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