Chapter 1
Introducing FileMaker Pro

In This Chapter
Why FileMaker?
Knowing what to use FileMaker for
Choosing a version of FileMaker
Using toolbars
Configuring FileMaker

H ow many times have you heard the phrase “information is power”? The
ability to keep and manage information accurately is indeed powerful,
especially when that information is vital to your business or personal life.
FileMaker places that power in your hands by giving you the ability to easily
create, manage, and view vital (and sometimes not so vital) information. The
good news is that a certificate from High Tech U is not required to tap into all
that power!

Why Use FileMaker?

Yes, you can choose from a lot of products designed for keeping track of
information. Just off the top of my head, I can think of Microsoft Access,
Oracle, Microsoft SQL Server, Acius 4D, FoxBase, MySQL, and dBASE (Yes,
it’s still around). So, with all these other products out there, why should
you use FileMaker? Here are just some of the reasons:

v Through the use of layouts, FileMaker provides a point-and-click inter-
face for designing databases without requiring you to have prior data-
base experience.

v FileMaker allows for cross-platform databases for Microsoft Windows
and Mac OS X. You can design your database in one environment and
run it on both platforms.

» You can publish your database to the Web in just a few clicks, which
means that users on any platform with a compatible browser can use
your database — even Linux users.
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v FileMaker lets you save data as an Adobe PDF, a Microsoft Excel spread-
sheet, an XML document, and many other formats for importing and
exporting data.

v FileMaker comes with 30 Starter Solutions databases that you can put to
work right away, or you can examine their script code, layouts, and data-
bases to find more about FileMaker development.

» You can easily use FileMaker for storing and showing pictures and movies,
playing sounds, and linking with many different multimedia file types.

v FileMaker provides full, multiuser support for up to five users without
requiring the user to add any additional licenses or patches. (FileMaker
Server supports up to 250 users.)

v~ FileMaker has a powerful point-and-click script programming environment
for creating sophisticated applications, while it preserves an easy-to-use
list of robust functions that can be assigned to buttons and layout objects.

With over 10 million licensed copies sold, FileMaker is a significant database
design and development tool for use by novices and seasoned developers.

Common uses for FileMaker

Now that you have the power of FileMaker in your hands, what are the types
of things that you can use FileMaker for? Here are some common databases
that have been designed with FileMaker:

1 Contact management: That’s a fancy way of saying an address book.
This is one of the most prevalent uses for FileMaker. In fact, one of the
sample applications that comes with FileMaker is named Contact
Manager. It’s perfect for tracking your personal and business contacts.

v+ Inventory control: Need a place to track all your products? Many devel-
opers design inventory control applications with FileMaker. And with the
integration with e-mail, you can use FileMaker to automatically e-mail
your vendors when your products on hand are getting low.

v Project management: This is another great example of the type of things
that people are doing with FileMaker. They track their projects, tasks
associated with the projects, and the people assigned to handle those
tasks and projects.

v Time and billing: This is one way my employer and I use FileMaker. As
we do projects for our customers, we keep track of how much time we
put into a project. Then FileMaker generates invoices and reports for
billing our customers.

v Tracking newspaper ads: This is how the USA Today folks use FileMaker.
They keep track of all the newspaper ads in the newspaper, their locations
in the paper, and the date they are to be included in the print run. Plus,
the information is shared with their AS/400 computer via SQL. Now that’s
power!
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Picking the Version That's Best for You

The full range of FileMaker products is designed to fit the needs of any data-
base, but you most likely want FileMaker Pro or FileMaker Pro Advanced.
Although FileMaker Pro is the base version of FileMaker, don’t think that it
lacks power. It provides all the tools necessary for creating, customizing,
and managing databases for use as stand-alone, multi-user, or Web-based
databases.

However, FileMaker Pro Advanced comes with extra features that you’ll find
especially useful in database design and scripting. Along with the features

of FileMaker Pro, FileMaker Advanced supports tooltips, custom menus,
advanced script debugging with data viewing, a built-in calendar control, and
the ability to create runtime FileMaker applications. Tooltips make it easier
to blend seamless hints and reminders on using your database application.
Custom menus let you tailor a database solution to your particular clientele,
eliminating unnecessary menus and providing menus and menu items spe-
cific to your solution and client. Although FileMaker Pro’s scripting is one of
the easiest-to-use programming environments around, scripting is still pro-
gramming and the ability to step through a script to ascertain why it is doing
something you don’t expect (or not doing something you do expect) is very
helpful in getting your scripts just right.

A version to suit every purpose

In addition to FileMaker Pro and FileMaker Pro
Advanced, you can get FileMaker in a few other
ways, too. The following versions suit more spe-
cialized uses of FileMaker:

v+~ FileMaker Mobile 8 helps you extend your
FileMaker databases to the Palm OS and
Pocket PC PDA devices, and it lets you syn-
chronize your data with all the FileMaker 8
products. In this hand-held world, you and/or
your clients are prone to be tethered to a
PDA. Being able to access your FileMaker
Pro data from your PDA is an obvious step.

v+~ FileMaker Server 8 is used in larger, multi-
user environments. It offers support for up to

250 users, along with the necessary tools for
security, automated backups, and remote
administration. If you develop for a corporate
or institutional user, five simultaneous users
just won't cut it. Deploying your solution via
FileMaker Pro Server is the next step up.

v+~ FileMaker Server 8 Advanced has the same
features as FileMaker Server 8; plus, it sup-
ports up to 100 Web-based users, 50
0DBC/JDBC users, and 250 FileMaker 7 and
FileMaker 8 users. The top rung on the
FileMaker Pro ladder is for those of you with
really heavy usage requirements.

11
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The Happy Modes of FileMaker

The word mode makes me think of the word mood. I guess I'm just weird

that way. However, notice the following similarity. The mood of your spouse,
friend, or coworker can determine what you're going to ask for, just as the
mode that FileMaker is in dictates what you can ask it to do. I'm just glad that
all the modes of FileMaker are happy modes. Each of the four modes helps
you get something done by offering different types of functionality. If you're
new to FileMaker, I'm happy to introduce them:

v Layout is the mode where you’ll spend much of your time because it’s
for designing the layouts and reports your customers see and employ
(in the Browse and Find modes) when entering, perusing, and searching
for data.

+* Browse mode is for browsing and editing the data in the database. This
is the mode where you can check out your final product, and it’s the
mode that your users will likely use most often.

v Find mode is for searching for specific data within the database. This
is where your customers search for records in your database, so you
should make sure to design layouts that facilitate searching.

+ In Preview mode, what you see is what you get! It’s for previewing what
the printed layout or report will look like before your customer actually
prints it.

Q‘&N\BEB So, where will you spend most of your time? Initially, if you’re designing a
> database application, you do most of your work in Layout mode as a devel-
oper. After you complete the application, you spend most of your time in
Browse mode as an application user with an occasional jaunt into the Find
and Preview modes.

To move in and out of the different modes, you can use the Tool palette.
Although most of the tools on the palette change as you move between the
modes, you always see the following buttons, which you click to move to a
different mode:

Browse mode
Find mode
Layout mode

Preview mode

I |=# |0 |=
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|
Figure 1-1:
Viewing the
database in
Browse
mode.
|

Dealing with data in Browse mode

[ was in a bookstore a little while back, and one of the store clerks asked if
they could help me find anything. My reply was, “No thanks. 'm just brows-
ing.” Then it hit me. I was standing in the middle of a huge database in browse
mode. Every book was a record in a huge, physical database. And as I moved
around the store, I was changing my view and stepping through different
records in the database. FileMaker Pro mimics that real-world process with
the Browse mode. When you design your layouts and create your scripts,
keep in mind that your customers will be using them to facilitate this brows-
ing, so make them easy to navigate and use. Cluttered layouts are like a store
whose aisles form a maze — they frustrate the customer.

Browse mode is primarily for viewing, editing, sorting, hiding, and deleting

database records. Figure 1-1 shows a sample application (the FileMaker
Contact Management example) in Browse mode.

Slider

r
71 Contact Mpnagement

T ol7iy| |COntact Management

Nates;

Main Address Second Address

100] ol E Bromwes | < | |

The Tool palette in Browse mode is simple and easy to use. Here’s what each
tool does:

v Layout drop-down list: Shows a list of available layouts. Select one to
view and use that layout. Some layouts might be designed for data entry,
some for reports, and still others for searching; so name them appropri-
ately for their purpose.

1 Book icon: Navigates a database page by page. Click the left page to go
to the previous record, or click the right page to go to the next record.

13
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v~ Slider: Navigates a database more quickly than the Book icon. Use this
to slide through multiple records in the database instead of clicking
through each record with the arrows on the Book icon.

1 Record: Shows the current record number. The user can go to a specific
record by typing the record number in this box (but he usually doesn’t
know the number because it varies based on search criteria and sorting
order).

v Found: Displays the number of matching records resulting from a Find
(not shown in Figure 1-2).

v+ Total: Shows the total number of records in the currently active table.

v Sorted/Unsorted: Shows the current sort state of the active table.

Searching in Find mode

“Finders, keepers. Losers, weepers!” It’s amazing that this phrase from my
childhood can have so much of a correlation to searching for data. It’s true!
When you know the data you're looking for is in the computer among thou-
sands of records, trying to find it can sometimes be a frustrating experience.
FileMaker presents an easy-to-use approach to help you find data. It’s called
the Find mode.

The FileMaker Find mode, shown in Figure 1-2, presents a layout view of the
table fields. By entering what you want to search for in any of the presented
fields, you can search for data. The tools in the Tool palette can also help
you track down the data you’re looking for.

Here’s a brief explanation of each tool, which I explain how to use in more
detail in Chapter 6:

v Layout selector: Shows a list of available layouts. Select one to view that
layout.

+” Book icon: Navigates a database page by page. As in Browse mode, click
the left page to go to a previous record, or click the right page to go to
the next record. This icon isn’t active until results are returned from the
Find request.

v Slider: Navigates a database more quickly than the Book icon. Use this
to slide through the records in the database. The slider isn’t active until
results are returned from the Find request.

v Request: Displays the ID number of the Find request that you are cur-
rently working with.

v Total: Displays the total number of records in the result of the Find
request.
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|
Figure 1-2:
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v Omit: Tells FileMaker that you want to omit an item from the search.
Activate this feature by clicking the Omit check box. See Chapter 6 for
more information.

v Symbols: These are logical relations (for example: greater than, not
equal, and so on) that you can employ when specifying your search cri-
teria. See Chapter 6 for more information.

v Find: Executes the Find and then places FileMaker in Browse mode.

Taking a look in Preview mode

Isn’t it nice when you order something and you get exactly what you
ordered? In FileMaker, the Preview mode, shown in Figure 1-3, is a great
method for taking a sneak peek at a report before you print it so that you can
make sure you get the printout you asked for.

As in the Browse and Find modes, you see the Layout drop-down list and the
Book icon for navigating through pages of your review. The Page text box dis-
plays the current page number, and Total shows how many pages are in your
preview.

Laying out the layouts in Layout mode

The Layout mode is the primary mode for designing the layouts (dialog
boxes) used in FileMaker. In Figure 1-4, you can see that the Tool palette has
some icons that also appear in the other modes. The Layout drop-down list
lets you select a layout, and you can use the Book icon to navigate to the next
or previous layout. You also see the layout number in the Layout box and the
total number of layouts in the current database.

15
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You might notice that Layout mode offers a lot more tools than the other
FileMaker modes — all of which are quite easy to use, as | explain in Table 1-1.
You find out all the details about creating great custom layouts in Part II.
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Table 1-1

Tool Palette Tools in Layout Mode

Icon

Name

Description

h

Selector tool

Select objects on the layout. By
holding down the Shift key while
using the Selector tool, you can
select multiple objects. Or you can
select multiple objects by dragging
a box around them.

Text tool

Insert text labels on the layout.

Line tool

Draw lines on the layout. Lines can
be used for borders, or as separa-
tors between areas on the layout.

Box tool

Create boxes and rectangles on the
layout. Boxes can be used for
making borders or visually section-
ing off areas of the layout.

Round Box tool

Create boxes with round corners
(so you don't hurt yourself). Round
boxes make good borders and
visual sections.

Circle tool

Draw circles and ellipses.

@0 o) Ojlz B

Button tool

Create buttons. You'll be using this
one a lot when designing layouts.
You assign a function or a script to
the button, which executes when a
user pressed the button.

r

Tab Control tool

Create folderlike tabs on your
layout to group data fields that you
can hide when they're not needed.

Field =

Portal tool View data from a related table by
E using the sub-form that this very
powerful tool provides. See Chapter
8 for more information.
| Field tool Place a field from the current table

onto the layout. See Chapter 6 for
more information.

(continued)

17
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Table 1-1 (continued)

Icon Name Description
Part &, Part tool Add a new part to the layout. The
layout can be divided into parts
(sections).
Fill controls Set the fill color, pattern, and the
@_ object effects for the currently

selected object(s) on the layout.
This set of tools is grouped with the
paint bucket that lies just above
them, left-justified. The first tool on
the left is the Fill Color tool.

Pen controls Set the pen color, pattern, and the
|_l pen (or line) effects for the cur-
rently selected object(s) on the
layout. These tools are grouped
with the Peniicon.

What's on the Menu?

\3

Like almost any application, FileMaker has a number of menus along the top
of the application window, and each holds commands to help you use this
powerful program. Unfortunately, there’s no Chinese menu among them for
those nights when you’re up late designing a database and get hungry. But
this section introduces the many menus, so that as you're creating layouts or
scripts, you know what tools are available and have an idea of where to find
them. I point out the tools that are especially useful for creating layouts and
scripts along the way.

If you don’t like using a mouse, you can use keyboard shortcuts for opening
menus and executing commands. These keyboard shortcuts vary slightly
from PC to Mac.

On a PC, holding down the Alt key reveals underscored letters on the main
menu bar. You can open a menu by pressing Alt and the underscored letter.
Alt+F opens the File menu. Likewise, you can choose an item within the menu
by pressing Alt and the key that’s underscored. For example, you can choose
New Database in the File menu by pressing Alt+N. If a particular menu item
doesn’t have an underscored letter, that means that menu item doesn’t have
a keyboard shortcut.
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So, you see that when you choose a menu option, you might be presented
with more choices. But, for now, I give you an overview of the primary
menus.

v File menu: The primary purpose of the File menu is to help you manage
the current FileMaker database file with commands for starting a new
database, opening a database, printing, importing and exporting
records, and more.

v Edit menu: The Edit menu offers the standard cut/copy/paste/find fea-
tures along with the ability to edit FileMaker application settings. 'm
still waiting for the Edit Weather function, which should help my golf
game.

v View menu: The View menu provides functions specific to the current
mode. For example, in Figure 1-5, you can see how the menu changes in
Layout mode versus Browse mode.

For the most part, this menu offers check mark options that you can

a\ . ) AP
select or deselect, depending on the options you want to view. Similarly,
when you see the black dot, then that menu option is currently active,
and the other menu options it is grouped with are not. And if you see a
little can of Red Bull, then you’ve been up too late. Quit working and go
to bed!

v Insert menu: Like the View menu, the Insert menu’s options change
depending on FileMaker’s current mode. In Layout mode, you can find
a more varied selection of items to insert — such as field controls, but-
tons, and pictures — than in other modes. Outside of Layout mode, you
can insert the date, time, and username. Part II of this book covers how
you use the layout options in more detail.
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Figure 1-6:
You get to
know the
Arrange
menu very
well as you
edit layouts.
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v Format menu: Anytime [ see the word format, | have flashbacks to the
time when I accidentally reformatted my hard drive when I thought [ was
formatting a floppy disk. (Shiver!) Don’t worry though — nothing that
dangerous here. The Format menu provides the ability to format (or
make orderly) the current layout objects.

+” Records menu (Browse mode): The functions within the Records menu
enable you to navigate and manage the database records. This menu is
available only in Browse mode.

1 Requests menu (Find mode): The functions within the Requests menu
help you search for data within the records. This menu is available only
in Find mode.

v Layouts menu (Layout mode): The functions within the Layouts menu
are for navigating and managing the layouts. This menu is available only
in Layout mode.

v Arrange menu (Layout mode): [, personally, use these functions a lot
when designing and editing a layout. You find that you’ll soon have the
shortcuts memorized. The functions within the Arrange menu, shown in
Figure 1-6, provide functions for arranging the placement of objects on
the layouts. This menu is available only in Layout mode.

v Scripts menu: There’s only one static item on this menu — ScriptMaker.
ScriptMaker is the editing environment for creating and editing FileMaker
scripts (programs), and its shortcut is Ctrl+Shift+S (88+Shift+S on a Mac). If
other items appear on this menu, they are scripts that have been written
and provided as part of the FileMaker database. Those are easily selected
via Ctrl+ the index number of the script (or 8+ the index number on a
Mac). You can find more information about the ScriptMaker in Chapter 8.

+* Tools menu (FileMaker Pro Advanced only, in Layout Mode): The
Tools menu is basically the menu for all functions and tools that don’t
really fit anywhere else — kind of like that old, rusty, red toolbox that I
keep next to the garage door, with the tools that I use the most. On this
menu, you find script debugging tools and developer utilities, among
other things.
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B}, 8ring to Front Cirl+alt+[
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B, Send to Back Cirl+alt+]
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Getting Help in FileMaker

| always need help of one type or another. In
fact, my wife says | need help — but | think she
means in a different way. At least FileMaker has
an extensive help system.

You can access FileMaker Help in various ways.
The initial way to get into FileMaker Help is via
the F1 key (Windows), the Help key or 88+?
(Mac), or by selecting FileMaker Pro Help from
the Help menu.

One of the most common methods of using the
FileMaker Help system is to drill down into the
topic that you want to see. Just click any linked
topic to see that topic’s help page.

You can print the topic by clicking the Print
button on the toolbar (Windows) or choosing
FilecoPrint (Mac).

If you're using the Windows version and you
find yourself referring to a specific topic often,

you can save it as a favorite. Click the Favorites
tab at the top of the left pane. Click the Add
button at the bottom of the left pane to add the
current topic to your Favorites list. Now, when
you want to revisit this topic, just go to the
Favorites tab, select the topic that you want to
see, and then click the Display button at the
bottom of the left pane. (Mac users can use the
Integrated Spotlight functionality to quickly find
anything in the FileMaker Help contents.)

Personally, | like using the Search feature of
FileMaker Help. It allows me to find topics when
| don't quite know how to find the topic via the
drill-down process. To use Search, click the
Search tab at the top of the left pane. In the
Search box, enter a topic that you want to
search for and click the List Topics button. You
can then select topics that appear in the results

21

v Windows menu: The Windows menu helps you place and view the win-
dows on the FileMaker desktop.

+ Help menu: When all else fails, use the Help menu, which provides help
and general information about FileMaker. [ cover your resources for help
in more detail later in this chapter.

The Right Toolbar for the Job

I'm a very visual person. In fact, I think most people are. That’s why toolbars
are such a good idea. Finding a picture that represents what you want to do
is easier than looking through a bunch of menu items. (Though I'm sure my
menu guide makes this a lot easier.) FileMaker Pro has the following four sets
of toolbars:

v Standard

v Text Formatting

v Arrange

v Tools
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|
Figure 1-7:
The
Standard
toolbarin
Layout
mode.
|

To view or hide any of these toolbars, simply choose View=>Toolbars and
select or deselect its name from the Toolbars submenu. The following sec-
tions introduce each toolbar.

The Standard toolbar

The Standard toolbar is the most common set of tools in just about any soft-
ware product. Some of the tools — such as New Database, Open, Print, Copy,
and Paste — may be familiar to you already. Others are unique to FileMaker
and change depending on FileMaker’s mode. Figure 1-7 shows the toolbar in
Layout mode.

File options Copy New Layout Revert
/Report  Layout

New Spell Format Delete Define
database | check Painter Layout | Database

|£T QL& @LTDAHTJ %L@lTl

Open ‘ Cut Undo Save Layout | Help

Print Paste Duplicate Define
Layout Value Lists

The Text Formatting toolbar

In the beginning there was Text. The Text was readable and everyone was
pleased with the Text. Then a Text Artist came along and created Fonts,
Styles, Sizes, and Colors. The world was thrown into a state of panic and
chaos. The greatest minds in the world got together and created the Text
Formatting toolbar. And once again, the world was at peace.

Yes, the Text Formatting toolbar serves a great purpose by helping you manage
the many different combinations of text formatting. Take a look at the toolbar
in Figure 1-8. Later in this chapter, you find out how to set preferences for
default fonts and more.



Chapter 1: Introducing FileMaker Pro 23
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The Arrange toolbar

What do florists and software developers have in common? They both like to
make arrangements. Well, in this case, FileMaker provides a toolbar for
arranging the objects on a layout form. Therefore, the Arrange toolbar is
available only in Layout mode. You can see it in Figure 1-9.

Bring to Front Rotate  Align Right

Lock Send Align
to Align Top
I— Group Back Left |Edges
Figure 1-9: EL J} }l Align
The Arrange @ 0y @ %% &% B & & 8 sp ] — Bottom
toolbar. | | | Edges

Send Align  Align
Backward| Center on Vertical
Unlock Centers

— (jngroup

Bring Forward Select Objects by Type

The Tools toolbar

The “Tools toolbar”? Isn’t that kind of like a double negative? Shouldn't it just
be “The Toolbar”? But then, it would be just a blank toolbar. Which would
then be called, “The Bar.” And that’s where one goes for drinks. Anyway, in
FileMaker Pro, it’s the Tools toolbar. This toolbar, shown in Figure 1-10, is a
duplication of the tools that are available on the Tool palette when in Layout

mode.
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Figure 1-10:
The Tools
toolbar.
|

This toolbar works a little differently, however, in the sense that whichever
tool is selected becomes the active tool controlled with your mouse.

You may not be familiar with some terms that FileMaker uses. A control is a
generic term for an interface element such as a check box, radio button, or
text box; a portal is FileMaker’s term for a subtable; part is a layout feature
such as a header or footer. I introduce all these elements in more detail in
Part I, which explains the ins and outs of designing a FileMaker layout.

Selection Add Field or Control

Round | Add Tab
Line Rectangle | Control

i Part

Text
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| |
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Rectangle Add Button Insert Field

Configuring Your FileMaker Installation

\\3

Come on! You know you want to tweak your installation of FileMaker Pro.

If you think that you can just install FileMaker and then start cranking out
databases, then — well, I guess you can. However, you would be missing
some of the really cool features of FileMaker that you wouldn’t normally
see with the default installation.

To see what some of these features are, just choose Edit=>Preferences to
open the Preferences dialog box. The options are organized into five tabs,
and the following sections describe the options available on each one.

Setting general preferences

On the General tab, you find the following options:

v Allow Drag And Drop Text Selection: When selected, provides the abil-
ity to drag and drop text from other FileMaker fields or from other appli-
cations. I leave this on (the default), but if you don’t like drag and drop,
feel free to turn it off.
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v Show Templates In New Database Dialog Box: Did you notice that,
when you first started FileMaker, the opening dialog box had a list of
predefined templates? If you don’t want to see this list, just uncheck this
check box. Then when FileMaker loads, it automatically displays the
Open File dialog box. I turn this off, but the default is to leave it on.

+* Show Recently Opened Files: In the File menu, in the Open Recent
option, a list of recently opened files is listed. This selection allows you
to set how many of the recently opened files you want to see in the list.
The range is from 1 to 16. Personally, [ would like to see 42 — but that’s
just me.

v Enlarge Window Contents To Improve Readability (Windows version
only): When selected, this makes the text on the layout easier to read by
increasing the size of all the layout objects. I leave this off, but if you're
vision-impaired or your database layouts include a lot of fine print, feel
free to turn it on.

1 Reset Dialog Sizes And Positions: One of the nice features about
FileMaker is that all the dialog boxes that appear can be resized, and
FileMaker remembers what size you used and keeps that size. However,
if you decide that you want to reset all the dialog boxes back to their
original sizes, you can click the Reset button.

v User Name: This is the default username that you want to use with
FileMaker. Mac users can choose their system login name or specify
another.

v User Interface Language (Windows only): If you want to change the
default language that FileMaker uses for the interface, select the lan-
guage that you want to see. Capisca? Mac users handle this via the
OS X Language tab of the International System Preferences pane.

+* Font Smoothing Style (Windows only): This allows you set the style of
font smoothing for making the fonts look better. What you choose here
depends on your personal preferences and the type of display you're
using (CRT or LCD). Mac users make this setting in their Display System
Preferences.

Choosing your layout preferences

On the Layout tab, you have the following choices:

1 Always Lock Layout Tools: Select this option to make your tool choice
stick; otherwise, the Select (arrow) tool will be reselected after any tool
is used. I leave this off because double-clicking a tool locks it, and I tend
to use the Select tool to reposition layout objects after I create them.
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v Add Newly Defined Fields To Current Layout: When selected,
FileMaker automatically adds fields to the current layout when they are
added to the database table. The default setting is on, and that’s how I
leave it.

1 Save Layout Changes Automatically (Do Not Ask): When you’re making
changes to the layout, your changes are automatically saved if this
check box is selected. The default setting is off, and that’s probably
safest.

1 System Subset (88 Colors): If selected, FileMaker provides an 88-color
palette for color selections. The 88-color palette is a subset that the
graphic artists and user-interface folks at FileMaker think makes a good
base set. This is the default choice, and I usually leave it there.

v~ Standard System Palette (256 Colors): This sets the color palette to
the system-standard 256 colors (which is different between Mac and
Windows). In addition to the platform differences, it is sometimes diffi-
cult to tell the difference between one shade of a color and another
when trying to match a previous selection.

1 Web Palette (216 Colors): If you want your application colors to be
common for both the Windows platform and the Mac, select this option.
This option isn’t as useful in this day of thousands or millions of colors
as it was when 8-bit color was the norm (early to mid '90s), but if you're
going to deploy your solution on the Web and you think some of your
users might be employing older operating systems and browsers, the
Web palette is a safe baseline.

Practicing memory control

Controlling how memory is used in FileMaker probably won’t make you feel
like a mad scientist attempting mind control. (You can decide for yourself
whether that’s a good thing.) But tweaking these settings can definitely make
you feel better about FileMaker’s performance — and about not losing your
data, if you're worried about those things. You find the following settings on
the Memory tab:

v Attempt To Set File Cache To: While you work in FileMaker, it temporar-
ily keeps track of your changes in cache memory. As a default, this is
set to 8MB. You can enter a different value to see if it improves perfor-
mance. When you change this setting, it takes effect after you restart
FileMaker. The larger the cache, the more data is memory-resident,
resulting in fewer disk accesses. However, increasing the cache takes
memory away from other tasks and setting it higher than the amount
of data in your file doesn’t gain anything.
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v~ Save Cache Contents: The default is to save during idle time. However,
if you want to save your cached changes more often, select the Every
radio button and enter the time segment. The shorter the duration, the
less likely you are to lose data in the event of a power failure. If you're
using a laptop and are concerned with battery life, setting a higher time
segment reduces the drain on the battery.

Plugging (and unplugging) plug-ins

A plug-in is a module that provides additional functionality to FileMaker. For
example, one plug-in allows you to launch a script file at a specific time. You
can get plug-ins from FileMaker, from third-party software companies, or from
your friendly neighborhood C++ programmer. Plug-ins can be developed in
the C or C++ programming language and with FileMaker Pro Advanced.

Any plug-ins that you see in the list are plug-ins that are installed. (See the
instructions that come with the plug-in for installation.) When the check box
is selected, that plug-in is available for use. When highlighted, you can see

a brief description of what that plug-in does. And if the Configure button
becomes active, you can set configuration options for that plug-in. Check
out Chapter 14 for examples of some plug-in sources.

Fiddling with fonts

On the Fonts tab, FileMaker lets you make a few choices about which fonts
you prefer and how you like them to behave:

v Default Font For Each Input Type: You can select the type of font that
you want to use for each language input type (in case you are working
with Cyrillic, Kana, Simplified Chinese, or some other language and its
related, data-input methodology). Just select the Input Type that you
want to change, and then select the font that you want to use in the
Specify Font list box.

v Synchronize Input Method With Font On Field Entry: When selected,
the font shown when users enter data is the font that has been defined
specifically for the field. (To define that font, you use the field’s Field/
Control, Behavior option when in Layout mode.) Synchronization is off
by default.

v Use Font Locking: This is an interesting option. When selected, if you
have a character in a field that doesn’t have a corresponding character
in the selected font, the character continues to be displayed in its origi-
nal font. This is specifically handy when you are supporting multiple lan-
guages, such as Japanese and Roman, in the same field. Font Locking is
selected by default.
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