


Chapter 1

To avoid confusion, you should probably not customize the IDE’s basic menus and toolbars too much.
Removing the help commands from the Help menu and adding them to the Edit menu will only cause
confusion later. It’s less confusing to leave the menus more or less alone. Hide any toolbars you don’t
want and create new customized toolbars to suit your needs. Then you can find the original standard
toolbars if you decide you need them later. The section “Customize” later in this chapter has more to say
about rearranging the IDE’s components.

This chapter describes the Visual Studio IDE. Before you can understand how to use the IDE to manage
Visual Basic projects and solutions, however, you should know what projects and solutions are.

Projects and Solutions

A project is a group of files that produces some specific output. This output may be a compiled exe-
cutable program, a dynamic-link library (DLL) of classes for use by other projects, or a custom control
for use on other Windows forms.

A solution is a group of one or more projects that should be managed together. For example, suppose that
you are building a server application that provides access to your order database. You are also building a
client program that each of your sales representatives will use to query the server application. Because
these two projects are closely related, it might make sense to manage them in a single solution. When
you open the solution, you get instant access to all the files in both projects.

Both projects and solutions can include associated files that are useful for building the application but
that do not become part of a final compiled product. For example, a project might include the applica-
tion’s proposal and architecture documents. These are not included in the compiled code, but it is useful
to associate them with the project.

When you open the project, Visual Studio lists those documents along with the program files. If you
double-click one of these documents, Visual Studio opens the file using an appropriate application.
For example, if you double-click a file with a .doc extension, Visual Studio normally opens it with
Microsoft Word.

To associate one of these files with a project or solution, right-click the project in the Solution Explorer
(more on the Solution Explorer shortly). Select the Add command’s Add New Item entry, and use the
resulting dialog to select the file you want to add.

Often a Visual Basic solution contains a single project. If you just want to build a small executable pro-
gram, you probably don’t need to include other programming projects in the solution.

Another common scenario is to place Visual Basic code in one project and to place documentation (such
as project specifications and progress reports) in another project within the same solution. This keeps the
documentation handy whenever you are working on the application but keeps it separate enough that it
doesn’t clutter the Visual Studio windows when you want to work with the code.

While you can add any file to a project or solution, it’s not a good idea to load dozens of unrelated files.
While you may sometimes want to refer to an unrelated file while working on a project, the extra clutter
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brings additional chances for confusion. It will be less confusing to shrink the Visual Basic IDE to an icon
and open the file using an external editor such as Word or WordPad. If you won't use a file very often
with the project, don’t add it to the project.

IDE Overview

Figure 1-1 shows the IDE immediately after starting a new project. The IDE is extremely configurable, so
it may not look much like Figure 1-1 after you have rearranged things to your own liking.

If you don’t have a reason to modify the IDE’s basic arrangement, you should probably leave it alone.
Then when you read a magazine article that tells you to use the Project menu’s Add Reference com-
mand, the command will be where it should be. Using the standard IDE layout also reduces confusion
when you need to consult with another developer. It’s a lot easier to share tips about using the Format
menu if you haven’t removed that menu from the IDE.
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Figure 1-1: Initially the IDE looks more or less like this.
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The key pieces of the IDE are labeled with numbers in Figure 1-1. The following list briefly describes
each of these pieces.

Q

(1) Menus — The menus contain standard Visual Studio commands. These generally manipu-
late the current solution and the modules it contains, although you can customize the menus as
needed. Visual Studio changes the menus, and their contents depending on the object you cur-
rently have selected. In Figure 1-1, a Form Designer (marked with the number 4) is open so the
IDE is displaying the menus for editing forms.

(2) Toolbars — Toolbars contain tools that you can use to perform frequently needed actions.
The same commands may be available in menus, but they are easier and faster to use in tool-
bars. The IDE defines several standard toolbars such as Formatting, Debug, and Image Editor.
You can also build your own custom toolbars to hold your favorite tools. Visual Studio changes
the toolbars displayed to match the object you currently have selected.

(3) Toolbox — The Toolbox contains tools appropriate for the item that you currently have
selected and for the project type that you are working on. In Figure 1-1, a Form Designer is
selected in a Windows Forms application so the Toolbox contains tools appropriate for a Form
Designer. These include Windows Forms controls and components, plus tools in the other
Toolbox tabs: Crystal Reports, Data, and Components (plus the General tab is scrolled off the
bottom of the Toolbox). You can add other customized tabs to the Toolbox to hold your favorite
controls and components. Other project types may display other tools. For example, a Web proj-
ect would display Web controls and components instead of Windows Forms components.

(4) Form Designer — A Form Designer lets you modify the graphical design of a form. Select a
control tool from the Toolbox, and click and drag to place an instance of the control on the form.
Use the Properties window (marked with the number 6) to change the new control’s properties.
In Figure 1-1, no control is selected, so the Properties window shows the form’s properties.

(5) Solution Explorer — The Solution Explorer lets you manage the files associated with the cur-
rent solution. For example, in Figure 1-1, you could select Form1.vb in the Project Explorer and
then click the View Code button (the icon third from the right at the top of the Solution Explorer)
to open the form’s code editor. You can also right-click an object in the Solution Explorer to get a
list of appropriate commands for that object.

(6) Properties — The Properties window lets you change an object’s properties at design time.
When you select an object in a form designer or in the Solution Explorer, the Properties window
displays that object’s properties. To change a property’s value, simply click the property and
enter the new value.

(7) Error List — The Error List window shows errors and warnings in the current project. For
example, if a variable is used and not declared, this list will say so.

If you look at the bottom of Figure 1-1, you'll notice that the Toolbox and Error List windows each have
a series of tabs. The Toolbox’s other tab displays the Document Outline window, which displays an out-
line view of a project showing its forms and components.

The Error List window’s Output tab shows output printed by the application. Usually an application
interacts with the user through its forms and dialogs, but it can display information here to help you
debug the code. The Output window also shows informational messages generated by the IDE. For
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example, when you compile an application, the IDE sends messages here to tell you what it is doing and
whether it succeeded.

The following sections describe the major pieces of the IDE in more detail.

Menus

The IDE’s menus contain standard Visual Studio commands. These are generally commands that manip-
ulate the project and the modules it contains. Some of the concepts are similar to those used by any
Windows application (File\New, File\Save, Help\Contents), but many of the details are specific to
Visual Studio programming, so the following sections describe them in a bit more detail.

The menus are customizable, so you can add, remove, and rearrange the menus and the items they con-
tain. This can be quite confusing, however, if you later need to find a command that you have removed
from its normal place in the menus. Some developers place extra commands in standard menus, particu-
larly the Tools menu, but it is generally risky to remove standard menu items. Usually it is safest to leave
the standard menus alone and make custom toolbars to hold customizations. For more information on
this, see the section “Customize” later in this chapter.

Many of the menus’ most useful commands are also available in other ways. Many provide shortcut key
combinations that make using them quick and easy. For example, Ctrl-N opens the New Project dialog
just as if you had selected the File\New Project menu command. If you find yourself using the same
command very frequently, look in the menu and learn its keyboard shortcut to save time later.

Many menu commands are also available in standard toolbars. For example, the Debug toolbar contains
many of the same commands that are in the Debug menu. If you use a set of menu commands fre-
quently, you may want to display the corresponding toolbar to make using the commands easier.

Visual Studio also provides many commands through context menus. For example, if you right-click on
a project in the Solution Explorer, the context menu includes an Add Reference command that displays
the Add Reference dialog just as if you had invoked Project\ Add Reference. Often it is easier to find a
command by right-clicking an object related to whatever you want to do than it is to wander through
the menus.

The following sections describe the general layout of the standard menus. You might want to open the
menus in Visual Studio as you read these sections, so you can follow along.

Note that Visual Studio displays different menus and different commands in menus depending on what
editor is active. For example, when you have a form open in the form editor, Visual Studio displays a
Format menu that you can use to arrange controls on the form. When you have a code editor open, the
Format menu is hidden because it doesn’t apply to code.

File
The File menu, shown in Figure 1-2, contains commands that deal with creating, opening, saving, and
closing projects and project files.
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Figure 1-2: The File menu holds commands that deal with the solution and its files.

Following is a description of the commands contained in the File menu and its submenus:

Q

New — The New submenu shown in Figure 1-2 contains commands that let you create a new
Visual Basic project, Web site project (generally ASPNET or a Web Service), or file (text file,
bitmap, Visual Basic class, icon, and many others). The Project From Existing Code command cre-
ates a new project and puts all of the files in a directory in it, optionally including subdirectories.

New\File — The New submenu’s File command displays the dialog shown in Figure 1-3. The
IDE uses integrated editors to let you edit the new file. For example, the simple bitmap editor
lets you set a bitmap’s size, change its number of colors, and draw on it. When you close the file,
Visual Studio asks if you want to save the file and lets you decide where to put it. Note that this
doesn’t automatically add the file to your current project. You can save the file and use the
Project\ Add Existing Item command if you want to do so.

Open — The Open submenu contains commands that let you open a project or solution, Web
site, or file. The Convert command displays the Convert dialog shown in Figure 1-4. From this
dialog, you can launch the Visual Basic 2005 Upgrade Wizard, which can help you convert
Visual Basic 6 programs to Visual Basic 2005.

Close — This command closes the current editor. In Figure 1-2, Forml is open in the form
designer editor. This command would close this editor.
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Figure 1-3: The File\New\File command displays this dialog to let you select the new file’s type.
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Figure 1-4: The File\Open\Convert command displays this dialog
to help you convert Visual Basic 6 applications to Visual Basic 2005.

Close Project — This command closes the entire project and all of the files it contains. If you
have a solution open, this command is labeled Close Solution.

Save Form1.vb — This command saves the currently open file, in this example, Form1.vb.
Save Form1.vb As — This command lets you save the currently open file in a new file.
Save All — This command saves all modified files.

Export Template — This command displays the dialog shown in Figure 1-5. The Export Template
Wizard lets you create project or item templates that you can use later.
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Figure 1-5: The File\Export Template command displays this dialog to help you create project or
items templates that you can easily use in other projects.

Q  Page Setup and Print — The Page Setup and Print commands let you configure printer settings
and print the current document. These commands are enabled only when it makes sense to
print the current file. For example, if you are viewing a source code file or a configuration file
(which is XML text), you can use these commands. If you are viewing bitmap or a form in
design mode, these commands are disabled.

Q  Recent Files and Recent Projects — The Recent Files and Recent Projects submenus let you quickly
reopen files, projects, and solutions that you have opened recently.

Edit
The Edit menu, shown in Figure 1-6, contains commands that deal with manipulating text and other

objects. These include standard commands such as the Undo, Redo, Copy, Cut, and Paste commands
that you've seen in other Windows applications.

Following is a description of other commands associated with the Edit menu:

Q  Cycle Clipboard Ring — The clipboard ring contains the last several items that you copied into
the clipboard. This command copies the previous clipboard ring item to the current location.
By using this command repeatedly, you can cycle through the items until you find the one
you want.
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Also notice that comments before a subroutine are not collapsed with the subroutine. You can make
reading collapsed code easier by placing a short descriptive comment before each routine.

Tooltips

56

If you hover the mouse over a variable at design time, the editor displays a tooltip describing the vari-
able. For example, if you hover over an integer variable named num_actions, the tooltip would display
“Dim num_actions As Integer.”

If you hover over a subroutine or function call, the tooltip displays information about that method. For
example, if you hover over the RandomizeArray subroutine (which takes an array of integers as a
parameter), the tooltip says, “Private Sub RandomizeArray(arr() As Integer).”

At run time, if you hover over a variable, the tooltip displays the variable’s value. If the variable is com-
plex (such as an array or structure), the tooltip displays the variable’s name and a plus sign. If you click
or hover over the plus sign, the tooltip expands to show the variable’s members.

In Figure 1-56, the mouse hovered over variable arr. The editor displayed a plus sign and the text arr
{Length = 100}. When the mouse hovered over the plus sign, the editor displayed the values shown in
the figure. Moving the mouse over the up and down arrows at the top and bottom of the list makes the
values scroll.
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Figure 1-56: You can hover the mouse over a variable at run time to see its value.
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If a variable has properties that are references to other objects, you can hover over their plus signs to
expand those objects. You can continue following the plus signs to drill into the variable’s object hierar-
chy as deeply as you like.

IntelliSense

If you start typing a line of code, the editor tries to anticipate what you will type. For example, if you
type “Me.” then the editor knows that you are about to use one of the current object’s properties or
methods.

IntelliSense displays a list of the properties and methods that you might be trying to select. As you type
more of the property or method, IntelliSense scrolls to show the choices that match what you have typed.

In Figure 1-57, the code includes the text me . Set, so IntelliSense is displaying the current object’s meth-

ods that begin with the string Set.

While the IntelliSense window is visible, you can use the up and down arrows to scroll through the list.
While IntelliSense is displaying the item that you want to use, you can press the Tab key to accept that
item. Press the Escape key to close the IntelliSense window and type the rest manually.
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Figure 1-57: IntelliSense displays a list of properties and methods that you might be trying to type.
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After you finish typing a method and its opening parenthesis, IntelliSense displays information about
the method’s parameters. Figure 1-58 shows parameter information for a form object’s SetBounds
method. This method takes four parameters: x, y, width, and height.

IntelliSense shows a brief description of the current parameter x. As you enter parameter values,
IntelliSense moves on to describe the other parameters.

IntelliSense also indicates whether there are overloaded versions of the method. In Figure 1-58, IntelliSense
is describing the first version of two available versions. You can use the up and down arrows on the left to
move through the list of overloaded versions.

Code Coloring and Highlighting

The code editor displays different types of code items in different colors. You can change the colors used
for different items by selecting the Tools menu’s Options command, and opening the Environment\Fonts
and Colors option page. To avoid confusion, however, you should probably leave the colors alone unless
you have a good reason to change them.

@0 EditorStuff - Microsoft Visual Studio
File Edit View Project Build Debug Data Tools Window Community Help
G- S @ % a9 S-F | p Debug  ~ AnyCPU - | :
— = = oD = e e
E b oa|EE =22 08383883860,
)3‘ ~Formiub* - X E
§_' I = {Form1 Events) j I = Load - g
EJ 10 Public Class Forml — (g
2!} m
x
E 3 Priwvate 3Jub Forml Load(ByVal sender As System.Cbject, ByVal e As System.Eventi %
= 4 ' Make an array holding the nunkbers 1 throuagh 100, I
§ 5 Dim numbers(99) Lz Integer
‘é"’ [ For i Ais Integer = 0 To nurbers.Length - 1 [g
=l 7 nuwbers (i) = i -
& | g Mext i g
=] Me.3etBounds (| E}
10 «10of 2+ SetBounds (x As Integer, ¥ As Integer, width As Integer, height As Integer) 3
11 x: The new System.Windows. Forms. Control. Left property value of the contral.
1z Jaf=NiTs n) (R RI=P:N b mf= A1l B AAEI ((1a]=dinf=]
13
14 ' Display the result.
15 For i As Integer = 0 To nunbers.Length - 1
i l=stNumbers. Items. Add (nuwbers (1))
17 MNext i
1ai - End Zub
i9
20 ' Randomize an array of integers.
z21ig Private Sub Randomizelrrav (ByVal arr()] is Integer) =
4 b|
/] Task List| >_] Command Window | &} Error List| 2 Bookmarks | =] Output |i=]Immediate Wimlow]
Ready Ln9 Col 22 Ch 22 INS 4

Figure 1-58: IntelliSense displays information about a method’s parameters.
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The following table describes some of the default colors that the code editor uses to highlight different
code elements.

Item

Comment
Compiler error

Other error

Highlighting

Green text
Underlined with a wavy blue underline

Underlined with a wavy green underline

Keyword Blue text
Preprocessor keyword Blue text
Read-only region Light gray background

Stale code Purple text

User types Navy text

User types, delegates Navy text

User types, enums Teal text

User types, interfaces Navy text

User types, value types Teal text

Warning Underlined with a wavy purple underline

A few other items that may be worth changing have white backgrounds and black text by default. These
include identifiers (variable names, types, object properties and methods, namespace names, and so
forth), numbers, and strings.

When the code editor finds an error in your code, it highlights the error with a wavy underline. If you
hover over the underline, the editor displays a tooltip describing the error. If Visual Studio can guess
what you are trying to do, it adds a small flat rectangle to the end of the wavy error line to indicate that
it may have useful suggestions.

The assignment statement i = "12" shown in Figure 1-59 has an error because it tried to assign a string
value to an integer variable and that violates the Option Strict On setting. The editor displays the wavy
error underline and a suggestion indicator because it knows a way to fix this error.

If you hover over the suggestion indicator, the editor displays a tooltip describing the problem and an
error icon. If you click the icon, Visual Studio displays a dialog describing the error and listing the
actions that you may want to take. Figure 1-60 shows the suggestion dialog for the error in Figure 1-59. If
you click the text over the revised sample code, or if you double-click the sample code, the editor makes
the change.

59
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Figure 1-59: If the code editor can figure out what's wrong, it displays a suggestion indicator.

Code Snippets
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A code snippet is a piece of code that you might find useful in many applications. It is stored in a snip-
pet library so that you can quickly insert it into a new application.

Visual Studio comes with hundreds of snippets for performing standard tasks. Before you start working
on a complicated piece of code, you should take a look at the snippets that are already available to you.
In fact, it would be worth your time to use the Snippet Manager available from the Tools menu to take a
good look at the available snippets right now before you start a new project. There’s little point in you
reinventing methods for calculating statistical values if someone has already done it and given you

the code.

Snippets are stored in simple text files with XML tags, so it is easy to share snippets with other develop-
ers. Go to this book’s Web page, www . vb-helper.com/vbprogref . htm, to contribute snippets and to
download snippets contributed by others.
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Figure 1-60: The error suggestion dialog proposes likely solutions to an error.

The following sections explain how to use snippets in your applications and how to create new snippets.

Using Snippets

To insert a snippet, right-click where you want to insert the code and select Insert Snippet to make the

editor display a list of snippet categories. Double-click a category to find the kinds of snippets that you
want. If you select a snippet, a tooltip pops up to describe it. Figure 1-61 shows the editor preparing to
insert the snippet named “Create a public property” from the “VbProgRef CodeSnippets” category.
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Figure 1-61: When you select a code snippet, a pop-up describes it.

Double-click on the snippet to insert it into your code. The snippet may include values that you should
replace in your code. These replacement values are highlighted with a light green background, and the
first value is initially selected. If you hover the mouse over one of these values, a tooltip appears to
describe the value. You can use the Tab key to jump between replacement values.

Figure 1-62 shows the inserted code for this example. The text An Integer Property is highlighted and
selected. Other selected text includes Integer, 0, and MyProperty. The mouse is hovering over the
value An Integer Property, so the tooltip explains that value’s purpose.
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Figure 1-62: Values that you should replace in a snippet are highlighted.

Creating Snippets

To create a new snippet, you need to build an XML file containing the property tags to define the snippet
and any replacements that the user should make. The following code shows the “Create a public prop-
erty” snippet used in the previous section. The outer CodeSnippets and CodeSnippet tags are stan-
dard and you should not change them.

Use the Title tag in the Header section to describe the snippet.

Inside the Snippet tag, build a Declarations section describing any literal text that the user should
replace. This example defines DataType, Description, DefaultValue, and PropertyName symbols.
Each literal definition includes an 1D, and can include a ToolTip and Description.

After the declarations, the Code tag contains the snippets source code. The syntax <! [CDATA[...]]>

tells XML processors to include any characters including carriage returns between the <! [CDATA[ and
the 11> in the enclosing tag.
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<CodeSnippets xmlns="http://schemas.microsoft.com/VisualStudio/2005/CodeSnippet">
<CodeSnippet Format="1.0.0">
<Header>
<Title>Create a public property</Title>
</Header>
<Snippet>
<Declarations>
<Literal>
<ID>DataType</ID>
<ToolTip>The property's data type.</ToolTip>
<Default>Integer</Default>
</Literal>
<Literal>
<ID>Description</ID>
<ToolTip>The property's description.</ToolTip>
<Default>An Integer property.</Default>
</Literal>
<Literal>
<ID>DefaultValue</ID>
<ToolTip>The property's default value.</ToolTip>
<Default>0</Default>
</Literal>
<Literal>
<ID>PropertyName</ID>
<ToolTip>The property's name.</ToolTip>
<Default>MyProperty</Default>
</Literal>
</Declarations>
<Code Language="VB">
<! [CDATA[
' SDescription$
Private m_$PropertyName$ As sDataType$ = sDefaultValue$
Public Property $PropertyName$ () As $DataType$
Get
Return m_$PropertyName$
End Get
Set (ByVal value As S$DataType$S)
m_$PropertyName$ = value
End Set
End Property

</Code>
</Snippet>
</CodeSnippet>
</CodeSnippets>

Save the snippet’s XML definition in a snippet directory. To add the directory to the list of usable
snippet locations, select the Tool menu’s Code Snippets Manager command to display the tool shown
in Figure 1-63. Click the Add button, browse to the new snippet directory, and click OK. Now the direc-
tory and the snippets that it contains will be available in the Insert Snippet pop-ups.
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Figure 1-63: The Code Snippets Manager lets you add and remove
shippet directories.

The Code Editor at Run Time

The code editor behaves slightly differently at run time and design time. Many of its design time fea-
tures still work. Breakpoints, bookmarks, IntelliSense, and snippets still work.

At run time, the editor adds new tools for controlling the program’s execution. Right-click on a value
and select Add Watch or QuickWatch to examine and monitor the value. Use the Stop Into, Step Over,
and Step Out commands on the Debug menu or toolbar to make the program walk through the code.

Right-click on a statement and select Show Next Statement to move the cursor to the next statement that
the program will execute. Select Run To Cursor to make the program continue running until it reaches
the cursor’s current line.

Right-click and select Set Next Statement to make the program jump to a new location. You can also
drag the yellow arrow indicating the next statement to a new location in the left margin. There are some
restrictions on where you can move the execution position. For example, you cannot jump out of one
routine and into another.

You can discover other run-time features by exploring the editor at run time. Right-click on different
parts of the editor to see which commands are available in that mode.
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Summary

The Visual Studio integrated development environment provides many tools for writing and debugging
applications. It provides code snippets that make saving and reusing code easy. It lets you add, remove,
and disable complex breakpoints that check conditions and hit counts, and that can perform customized
actions. You can use regions and bookmarks to organize and find pieces of code, and you can step
through the code line by line at execution time.

The IDE is extremely flexible. You can show, hide, and rearrange windows; add and remove items from

menus and toolbars; and write macros to automate simple chores. Context menus attached to all sorts of
objects provide help, tools, and other features that make sense for their particular objects and under dif-
ferent situations.

This chapter describes some of the most useful parts of the IDE, but listing every last nook and cranny
would be tedious and not terribly useful. Rather than reading about the IDE further, you would be better
off experimenting with it. Spend a few hours really examining all of the menus. Create a snippet with
some replacement values and then insert it into your code. Step through a small program and try the
Immediate and Command windows.

While you do all this, and while you're developing real applications, right-click on things to see what
sort of context menus they provide. The IDE is packed with so many tools that it is sometimes hard to
find the one you want. Because context menus are tied closely to the objects that you click to display
them, they often provide more appropriate and focused commands than the toolbars or menus.

After you have used the IDE for a while and are comfortable with it, customize it to match your prefer-
ences. Build custom toolbars and menus to make using your favorite tools easier. When you have the
tools that you use most at your fingertips, you will see just how productive Visual Studio can be.

Once you have become familiar with the IDE, you can start building applications. One way to begin is to
design the application’s user interface: the forms, labels, text boxes, and other controls that the user sees
and manipulates to control the application. Chapter 2, “Controls in General,” describes controls in gen-
eral terms. It explains what controls are, how you can add them to a form, and how you can control and
interact with them at design time and run time.
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