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Have you seen some of the mock switcher commercials that are floating around the
Internet? There’s one in particular that I like a lot, called pissed, about a young guy,

a self-proclaimed “Mac person,” who installs OS X for the first time. As he restarts his
computer into this new OS, his first words are “What the #%*@?!”

Apple’s release of OS X on January 5, 2000 brought strong reactions (positive and nega-
tive) from people. Everyone liked the stuff going on under the Unix hood. But few people
fell in love with the interface right away.

Traditionalists hated the new interface. And loyalists were cautiously optimistic that they
would eventually “learn to love it.” I didn’t like it at all. I didn’t know where anything was
and I had lost my ability to color label items (brought back to us in this version of OS X).

As a Macintosh service provider, I found more people who didn’t like the new OS than
those who did. And that didn’t change much until Jaguar was released (on August 23,
2002 at 10:20 pm around the country). That’s when I found the OS friendly enough to
switch over from OS 9.2.2 to OS 10.2.1. (Yes. Unlike this time, I was smart enough then 
to wait for a .1 revision of the OS before I joined the rest of bleeding edge upgraders.)

And I still missed labels. And I hated switching to Suitcase because my ATM Deluxe didn’t
work any more. And . . . . Well let’s suffice it to say that I had a myriad of rants that kept me
feeling self-righteous for hours at a time. But over time, I started to like some of the cool
new features. I liked the navigation by panes. I liked that I could hide the Dock. I liked that
I had a screen saver with a password. And I liked how stable it was. (Yes. I find that having
the desktop up and running can be considered a nice interface feature as well.)

Six months later I found myself among the converted. I was one of those people who did
learn to love it. And as a Macintosh service provider, I found myself actually dreading
having to work on my customer’s Macs who were still working in pre–OS X computers. A
little over a year later I found myself nervous about giving up my tame Jaguar for a not-
yet-housebroken Panther. But I did it under the same assumption that I would eventually
learn to love it.

This time it didn’t take a few months. I was hooked right away. All of the really cool stuff
that I liked about Jaguar was there, plus some improvements in the Finder and the other
iApps. I went from Jaguar to Panther without batting an eye (or a whisker).

They even brought back my color labels. And when I launched my Panther version for the
first time and saw that my OS 9 (and earlier) files with color labels on them were showing
up in Panther with the labels intact, I could have sworn my computer purred (or maybe
that was me).

Dissecting the Finder
“Dissecting” is such a loaded word. It brings forth images of high school biology class and
frogs. It start things off with the assumption that we are going to explore this way past the
level where normal people would consider comfortable or interesting. I promise that we’ll
try not to live up to that expectation — too much. This won’t be an awful experience.

What is the Finder? Some people say that the Finder is the desktop. That’s not accurate.
The desktop is actually just a part of the Finder. The Finder is your common user interface

�4 Part I: Dissecting Mac OS X � � � 

06_542281 Ch01.qxd  6/4/04  10:42 AM  Page 4



to deal with the Mac OS in a graphic context. It’s a program, just like any other that’s run-
ning. But, you can’t deal well with the others in the GUI unless the Finder is running.

In this chapter, I break the Finder down into bite-sized components. We’ll look at the
Finder windows, the Finder preferences, the other menus, the contextual menus, the files
themselves, a cool little interface enhancement called Fast User Switching, and a few
other features of the Finder.

The Dock and the Apple Menu are large enough “new” features that I’ve set aside
Chapters 2 and 3 (respectively) to explore those parts of the Finder.

This all sounds like a lot to go through. But I keep things clear and concise. And I use a lot
of figures to help illustrate what I’m talking about. (Okay class . . . first take your frogs out
of the jars. . . .)

The New User-Centric Experience
If you haven’t yet moved to any version of OS X yet, you will find that there are some sig-
nificant changes in where things are kept. For instance, the Desktop folder is actually four
levels down on your hard drive (HD). And it changes depending on how you log in.

The Main Screen
You also don’t have the same old pre–OS X system folder (called System Folder in pre–
OS X). It has been replaced with a folder called System at the top level of your HD. There
is also a folder called Library at the top level of your HD that isn’t to be confused with the
Library folder in the System or in four directories down (in your User folder) at the same
level as your desktop (shown in Figure 1-1). Confused? You’re not the first.

So why, you may ask, have things changed so much? The reason for this is Apple’s (and
Unix’s) user-centric approach to the OS. PC people have had this kind of thing for years.
And we need to give them their due. It’s a good idea — not only for security but also for
preserving a customized user experience. (Hmm. You’d think PCs would have better
security if they’ve been able to have this kind of thing for years.)

Everything you do is centered on you as a user. Your specific settings and preferences are
all kept in your User folder, which you can lock down and not share with anyone. And
Apple’s upgrade system is designed to help in moving your User folder(s) forward into
new versions of the OS.

Before you get distracted by it, the row of icons along the bottom of the screen is called
the Dock. We’re not going to talk about that here. If you’re in a hurry to know more about
the Dock, skip ahead to Chapter 3.

Let’s get back to the Finder. As you can see from Figure 1-1, the desktop consists of a
number of elements that might be familiar to you.

The hard drive icon is shown in the upper-right corner of the desktop. The open window
that you see (in Figure 1-1) is the open hard drive shown in a Finder window. We’ll get to
the items shown on the top and side of this window shortly. Items on the desktop are
shown here (in Figure 1-1) on the desktop and in the Desktop folder in the logged-in User
folder.

� � � Chapter 1: The Elements of Mac OS 10.3�5
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Figure 1-1: Down, down, down, and down again to the Desktop folder. Welcome to 
your new desktop and OS environment.

First Look at a Finder Window
The Finder windows treat your information more like a browser than traditional Classic
Finder windows. Clicking on a folder or volume opens a window. Clicking on folders
within an open window replaces the open window with the new window. According to
Apple, this saves users from having to continually close windows after themselves.

Two new browser-like features of the Finder window are the Forward and Back buttons
(represented by two arrows) in the upper-left corner (shown in Figure 1-2).

Figure 1-2: Use the Forward and Back buttons (two arrows in the upper-left of the Finder
window) to navigate like you would in a browser.

Command-Click for a New Window
If you’re not a fan of windows that open to replace the previous one, or you just want to
open a folder into a new Finder window, hold the Command key down when you double
click on a folder or volume.
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At the top of every window or document, you will also see three little colored icons
(shown in Figure 1-2). The green button maximizes the window. The red button closes the
window. And the yellow button minimizes the window or document into the Dock (as
shown in Figure 1-3). If you haven’t tried that one yet, do. It’s quite a kick.

Figure 1-3: This is the ultra cool genie effect.

Selected icons also react differently in OS 10.3.x. Figure 1-4 shows an icon on the desktop
that is not selected. Clicking one time on that same icon (shown in Figure 1-5) shows a
new raised label and gives a button-like appearance to the icon itself.

Figure 1-4: A folder icon. It looks innocent enough, doesn’t it?

Figure 1-5: The same folder icon is selected and feeling special.

Double-clicking on that selected icon opens a familiar window (shown in Figure 1-1 ear-
lier in this chapter).

� � � Chapter 1: The Elements of Mac OS 10.3�7
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Using the Document Name to Find Out Where You Are
All of the new directories can be confusing. Here’s a secret to help you know and go
where you want from where ever you are.

The path or directory information for any document can be gotten by holding the
Command key down while clicking and holding on the name at the top of the window
(shown in Figure 1-6). A menu will pull down showing the complete directory to the top
level. Click on any of the folders or directories in that pull-down menu (shown in Figure
1-7) and you will cause a Finder window to open into that directory.

Figure 1-6: One simple Ô-click on a window can show four levels down.

Figure 1-7: A close-up of the pull-down from the window shows the Directory Path.
Choose any folder and you’re there.

This also works on documents open in other applications. The OS will switch the Finder
into a new window to show the directory chosen from the document.

Looking at the Information in Different Views
We have examples of data in different views as we progress in this chapter. So, for now, I
just point out that there are three different views in a window. Use the three buttons
(Figure 1-8) next to the arrow buttons to control the views in the Finder window.
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Figure 1-8: It’s not a traffic light on its side. It’s the new Window controls for Mac OS X.

� Icon view is depicted in Figure 1-9. Icons float freely with only the icon and name
showing. You can turn a window to icon view by clicking on the first button above
the View text (shown in Figure 1-8).

� List view is depicted in Figure 1-23. This view allows for the viewing of date,
size, kind, and any other information available when the Show View Options
menu item is selected from under the View menu. (We get into more depth for
those options in the next section.) You can turn a window to list view by clicking
on the second button above the View text with four horizontal lines on it on the
top of a Finder window (shown in Figure 1-8).

� Column view is the new OS X way of viewing information (shown in the first fig-
ure in this chapter, Figure 1-1). This is the new way of listing and navigating
directories in OS X. This is the way that you will see most Finder windows shown
throughout this book. Gone are the different kinds of ancillary information that is
available in list view. But the icon and name information are still available just
like in icon view. You can turn a window to Column view by clicking on the on
the third button above the View text with three vertical panels on it on the top of
a Finder window (shown in Figure 1-8).

We Interrupt This Chapter . . . 

I think Column view is one of the coolest things about OS X. It offers file and preview
information right in the window (shown in Figure 1-56). But critics such as Pieter seem
to see it as decidedly un-Mac Like.

Pieter: List view or icon view? Personally, I prefer list view because I like to customize
the various columns that are displayed and use that capability to sort the various files in
the directory. Likewise, I like being able to change the width of these columns because
I tend to use long, very descriptive filenames that can be a problem in Column view.
Icon view is okay, but seems inefficient when you have a limited amount of screen
space in which to work.

Benjamin: The best reason to at least try Column view is that Change Is Good. Column
view gives you the best way to navigate through directories and drill down to a single
file. And thanks to Quartz and QuickTime, PDFs, QuickTime movie clips, MP3s, and a
number of other file formats can be played and/or previewed in the Column view. It’s
great! 

If you like one of the other window views, great. Use them/it. But you should give
Column view a try. If you refuse to try something this useful just because it’s new, then
you are probably on the wrong platform. The mantra, lest we forget, is “Think Different.”
(Just my not-so-humble opinion.)

� � � Chapter 1: The Elements of Mac OS 10.3�9

06_542281 Ch01.qxd  6/4/04  10:42 AM  Page 9



Figure 1-9: The default insertion point is at the bottom of the sidebar list.

More New Features of the Finder Window
Opening a new (Finder) window quickly presents you with a number of new things —
both from the Classic window and from previous versions of OS X windows. There are
new icons across the top of the window and familiar icons (if you’ve upgraded from
Jaguar) along the left side of the window.

The Sidebar
The left side of the window is a major step toward a user-centric OS from the previous ver-
sion of the OS. Many of these icons were default icons on the toolbar of the Finder win-
dow in Jaguar. The main difference here is that you can choose to add items to the left
side of the Finder windows.

Adding an item to the top or side of a Finder window makes those items show up in all
Finder windows.

By moving a folder to the left, from within the window, you get an insertion point that can
be moved up or down (as shown in Figure 1-9). The folder will then be set at the insertion
point (shown in Figure 1-10).
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Figure 1-10: This folder, added to the sidebar, can be moved up the list, or removed by
selecting the folder and hitting the delete key.

The Finder window and the Finder menus are closely linked. And we’ll get into those in
more depth later in this chapter, but to show you how to further customize the sidebar, we
need to break out of the window and deal with the Finder’s preferences.

The Finder Preferences
This is new stuff! The Finder has gotten complex enough to now need a separate set of
dialog boxes to control the way that you deal with a Finder window. I’m not a fan of more
dialog boxes, but these are relatively simple (Mac-like) and easy to use.

To get at the Finder preferences, select Preferences from the Finder menu (shown in
Figure 1-11).

Figure 1-11: Ô-, (Command-comma) will open the new Preference options for the Finder.

General Finder Preferences
The General panel (shown in Figure 1-12) presents itself first when the Finder
Preferences are opened.
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Figure 1-12: What you see on the desktop, the behavior of new windows, and control of
spring-loaded folders are set in the General preference panel.

The default settings are to show the Hard disks, CDs, DVDs, and iPods, and Connected
servers on the desktop.

New Finder windows (Ô-N) are set to open to the home folder by default. You also have
the option here to always open folders in a new window (in case you hate the browser-like
way that windows open by default). And you can choose to always have windows open in
column view.

Spring-loaded folders (if you use that feature) are also controlled here.

Labels Finder Preferences
If you haven’t noticed by now in either my opening text or in some of the screen shots,
labels are back! (Hooray!!!) Okay. I just needed a minute there.

I show you labels later in this chapter, but we’re in the Finder Preferences, so I have to
show you how to change the label names here.

The second panel in the Finder Preferences is the Labels panel (shown in Figure 1-13).
You don’t have a lot of control here, but you can change the text associated with the col-
ors available to you.

Sidebar Finder Preferences
Here’s where we needed to get when I took us off course. The third panel in the Finder
Preferences is the Sidebar panel (shown in Figure 1-14). This panel allows you to check or
uncheck items that you want or don’t want (respectively) in the sidebar.

If you feel like having any of these items not appear in the sidebar, feel free to uncheck
them. (I won’t hassle you or lecture you about it.)
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Figure 1-13: You can’t change the colors to custom colors, but there’s still reason to celebrate.
Labels are back!

Figure 1-14: All the items, except the Computer, are checked by default.

Advanced Finder Preferences
The most useful Preference panel is the Advanced preference panel (shown in Figure 1-15).

It’s the most useful because it allows you to turn off the warning you get before you empty
the Trash. (I find that particular warning annoying enough that I think whether you want
to turn it off should be a question asked in initial set-up of the User when the OS is
installed so that intelligent people don’t have to be irritated with it ever again.)

� � � Chapter 1: The Elements of Mac OS 10.3�13
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Figure 1-15: Be smart. Turn the Trash warning off and just pay attention when you empty
the trash.

You can also choose to show all the file extensions, usually hidden because we are smart
enough to be on a Mac.

The Select button offers multiple languages for searching for file contents. If you have
need of additional languages, check them here.

The Toolbar
Jaguar and OS 10.1.x had navigation aids on the top bar of Finder windows. And as I said
before, the idea here is to create a more browser-like window to view and navigate
through your files.

In Jaguar, I got used to it, but often found it just a little too much. It’s been simplified now,
by moving some of the items like the Applications and home folder to the sidebar. We’ve
already covered the three colored buttons, the Back and Forward buttons, and the three
View buttons in previous sections of this chapter. And I’ll get to the new Action pull-down
menu that looks like a gear (shown below in Figure 1-16) to the right of the View buttons
later.

Figure 1-16: The standard new buttons on the top bar.

These buttons as well as the Search field on the far right at the top of a Finder window
(shown in Figure 1-17) are the default options for Finder windows. In these next few sec-
tions, I show you how to customize your top bar.

Adding Your Items
Almost anything can be added to the top bar of a Finder window. Let me show you how to
add your items to complete the user-centric experience.

Drag an application or a folder from the desktop or Finder window (as shown in Figure 1-17).
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Figure 1-17: Dragging the Safari application to the top bar.

If you have problems moving items to the top bar, it’s because the space there is flexi-
ble. To avoid problems in putting applications, folders, and/or documents in the top bar,
drag them just to the right (as close as possible) of the new Action menu.

If you do it right, your application will appear on the toolbar (as shown in Figure 1-18).

Figure 1-18: Safari is now conveniently accessible from the toolbar.

There isn’t a lot of room on the top bar, so don’t junk it up with stuff you don’t need.
Sometimes less is more.tip

tip
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The Action Menu
As nonlinear as the OS (and this book) is, I have to try to put things in some kind of order.
So before I go into more detail about how to customize the top bar, I need to make another
slight detour into the Action menu.

The Action menu is a new, contextually sensitive menu that Apple has added to the
Finder window in Panther (shown in Figure 1-19).

Figure 1-19: The little arrow and gear icon that looks like a button is actually a menu.

The cool thing about the Action menu is that it changes, depending on the view and/or
what is selected in the window, to give you possible Finder actions for those views and/or
item(s).

Selecting an alias in a Finder window and then clicking and holding on the Action menu
gives all of the options available for that alias (as shown in Figure 1-20).

Figure 1-20: Among the contextual possibilities for a selected alias is the option to Show
Original. All of the other options would be available for any other kinds of non-alias files.

Many of these contextual options are also available from the from the menu bar at the top
of the screen. And for those of you who dabble in the PC world, this may look decidedly
PC-like. My advice is to get over it and take advantage of the new features.

Some of the most useful that are fairly new to the Mac are the Copy “name of document”
and the Create Archive of “name of document” (as shown in Figure 1-20). By far the one
that I’m the most excited about is the Color Label option (shown in Figure 1-21). This, of
course turns a file or folder to the color chosen (as shown in Figure 1-22).
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Figure 1-21: Copy, Open, Label, Trash, etc. . . . Actions-a-plenty.

Figure 1-22: In living color. Labels are back!

Later on in this chapter, I show you how to get at these same contextually aware options
right from the file itself without the Action menu.

View Options
The Action menu is a great place to take us back to more customization of your Finder
windows. From any Finder window view choice, but without selecting any file(s) within
the window, you can click on the Action menu and get the Show View Options choice (as
shown in Figure 1-23). You can also get at the View Options by selecting the Show View
Options (Ô-J) under the View menu (as shown in Figure 1-24).

Depending on which view your topmost (or selected) Finder window is in, you will get
some variation of the View Options (shown Figure 1-25). If you are in List view you will
get options that apply to List view Finder windows. Likewise, you will get corresponding
choices in Column or Icon view.

� � � Chapter 1: The Elements of Mac OS 10.3�17
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Figure 1-23: Show View Options is also an Action menu choice.

Figure 1-24: And when all else fails you can try the Finder’s View menu.

Figure 1-25: These options tell you that your Finder window is in List view. If you don’t see the
options you want, then you’re in the wrong view in your uppermost Finder window.
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In all of the views, you have the choice to affect all windows (in the selected view
mode) or just the forward Finder window. You should decide that before you start
changing the icon or text sizes, or any of the other View Options.

If you don’t know how you want your windows to look and you want to experiment
for a while, make sure you choose the This window only option at the top of the View
Options palette (shown in Figure 1-25).

More View Option Choices in Icon View
With View Options, you can use a picture background in icon view Finder windows. This
choice is available in Finder windows in icon view only.

To place an image in the background of your Finder window, follow these steps:

1. Open a Finder window and put it in icon view.
2. Select Show View Options from either the Action menu on the Finder window or

from the bottom of the View menu at the top of the screen.
3. When the View Option palette opens, choose Picture at the bottom of the dialog

box under the Background section.
4. Click on the Select button to the left of the Picture option in the View Option

palette. This will open up a Select a Picture dialog box (as shown in Figure 1-26).

Figure 1-26: Any picture can be the background to your Finder windows.

5. Navigate through the Select a Picture window to the image you want as your
background and then click on the Select button in the Select a Picture window.

Now the picture you chose in the Select a Picture window (in Step 5) will show up in the
Finder window (shown in Figure 1-27).

tip
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Figure 1-27: Your icons floating against your background in your Finder window.

A Few Tips for Choosing Images for Your Desktop
Large pictures and busy pictures don’t always work very well for background. Here are a
few simple rules for background pictures for your Finder windows.

Photos usually work best if they are simple and screened back. If you open your photo
in a photo editor and screen the opacity back to 20 or 30%, you may find the image eas-
ier to take as the background behind the data you want to get at.

Large images and very small images don’t always look very good. You may need to
reduce or enlarge your images to make them work better as Finder window back-
grounds.

And most importantly, be original. Apple gives you this option to express yourself. Don’t
use a background image that comes with the OS like I did with the example shown in
Figure 1-27. If you’re going to spend the time customizing your Finder windows, make
them either interesting or personal.

A Few Remaining Things You Can Do 
to Your Finder Windows
At this point, you’re probably wondering what the heck else there could possibly be to do
to customize a Finder window. Mercifully, there’s not too much more. I’ll be brief.

Earlier in this chapter, I showed you how to put your own items in the top bar of a Finder
window. Apple also has some ideas about other things you may (or may not) want to add
to the top bar of your Finder window.

Just like the other things you add to the sidebar or top bar, these things will appear on all
windows regardless of the view chosen. To get at the these choices, open a Finder win-
dow and choose, Customize Toolbar from the View menu (in the Finder) at the top of the
screen (shown in Figure 1-28).
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Figure 1-28: The Customize Toolbar option is only available under the View menu if there is a
Finder window open and to the front.

When you select that menu option, a pane drops down from under the toolbar. This pane
gives you Apple’s extra choices for items you may want to add to the toolbar like an icon
to add a new folder (shown in Figure 1-29).

Figure 1-29: This is a place where less can be better. Choose what you want here. Don’t add
everything.

You also have the option to show the items on the toolbar as Icons Only, Text Only, or as
Icons and Text. You can click the Use Small Size check box to let you get more items on
the toolbar.

Add, Delete, or Move Items on Your 
Finder Window Toolbar
If you find that you have too many things on the toolbar or need to rearrange items on
the top bar, all you have to do is hold down the Command key and either drag them off
or around the toolbar.
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Stop the Insanity
If you’re a died-in-the-wool pre–Mac OS X person and you just can’t cope with all of the
new options along the top or the bottom, Apple has thought of you too.

By clicking on the small oval icon in the upper-right corner of a window you will collapse
the toolbar and the sidebar, leaving you with a window in whatever view it was before
you collapsed them (shown in Figure 1-30).

Figure 1-30: Longing for the Good Old Days of Mac OS 9? This is as close as we get.

And that’s it for the Finder window.

Working from the Menus
You’ve seen some of the menus already, and more are covered in detail later. But just to
be thorough, let’s take a survey of the menus across the top of the screen when you are in
the Finder.

Let’s start at the left side of the screen and move to the right.

The Apple menu
On the far left is the Apple menu (Shown in Figure 1-31). Chapter 2 covers the Apple
menu so we won’t get into the options under the Apple right now.

The Application Menu
The immediate right of the Apple menu you will find the application menu. This menu
can be called the Finder menu when the Finder is the forward application.
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Figure 1-31: It’s not the same Apple menu you knew from your Classic days.

Use Application Switching to Move between Applications
and the Finder
If the application name is not the Finder (to the right of the Apple), then you will need to
switch from the application you are in to the Finder.

A quick way to do this is to hold the Command and Tab keys down at the same time. An
Application Switcher will appear hovering over the top application (shown in Figure 1-32).

Figure 1-32: Command-tabbing the Application Switcher is a great way to see what
applications you have running.

Then you click on the Finder (or other application you want to switch to) and that appli-
cation will become the forward application.

After you get to the Finder as the forward application, you can click and hold the Finder
menu (shown in Figure 1-33). We’ve already been to this menu (earlier in the chapter)
when we accessed the Finder preferences.
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Figure 1-33: The Application menu is the place where you can choose (among other things) to
hide the application you are currently in.

A new feature to the Finder menu is the Secure Empty Trash option — which does exactly
what you think it does. It securely empties the trash. It works like a virtual shredder.

It’s also important to note that this is where you can access the Mac OS services. We’ll get
into the services later on in this book.

The File Menu
The File menu (found to the immediate right of the Application menu) is probably famil-
iar to Mac users of any genre. Many of the standard File menu options are available in
this menu (as shown in Figure 1-34). You might notice that some of the old key command
combinations have changed.

Figure 1-34: The File Menu. Have I mentioned that labels are back?

Some of the new options (other than labels) from the old Classic File menu, that you can
find under this menu are the Open With, Create Archive, Move to Trash, Eject, and Burn
Disc. Some of these used to be under the old Classic Special menu. Some, like Create
Archive, are brand new to Panther.
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The Edit Menu
Just to the right of the File menu, you will find the Edit menu. This is also a familiar menu
to Mac users. Clicking on the Edit menu will allow you to get at those common actions
like Cut (Ô-X), Copy (Ô-C), Paste (Ô-V), and Select All (Ô-A) that you are used to using
all the time (shown in Figure 1-35).

Figure 1-35: If you make mistakes as much as I do, you’ll want to remember the Undo
command (Ô-Z) under the Edit menu.

Special Characters is also one of the new OS X options under the Edit menu.

The View Menu
Just to the right of the Edit menu (while you’re in the Finder) you’ll find the View menu.
We’ve been in this menu earlier in this chapter when we customized the toolbar and
when we accessed the Show View Options. Clicking on this menu gives us other choices
for organization as well (shown in Figure 1-36).

Figure 1-36: Now that Labels are back you have one more choice in how to arrange your data.

At the top of this menu, you can choose to view your data as Icons (Ô-1), as a List (Ô-2),
and as Columns (Ô-3).

The Go Menu
The Go menu, located just to the right of the View menu (while you’re in the Finder) is
new to OS X. This menu replaces some of the features of the Classic Chooser and some of
the features of the Classic Apple menu. By clicking on the Go menu you will see that you
have access to all the places that your Mac can take you (shown in Figure 1-37).
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Figure 1-37: Recent applications and documents are in the Apple menu. But if you need to get
at the folders that you’ve been to recently, you will find that option here in the Go menu.

Many of these options you can access through the sidebar in the Finder window. But if
you’ve turned those features off, here’s another place you can reach them.

New to this version of the OS is an expanded iDisk submenu that allows you to access
more than just your own iDisk. You can also choose to access an Enclosing Folder, which
is a new Go menu feature.

You can access network volumes via the Connect to Server (Ô-K) menu option. We’ll
explore the Connect to Server options and dialog boxes in Chapter 29.

The Window Menu
The Window menu, to the right of the Go menu (while you’re in the Finder), will allow you
to access any open Finder window. Clicking on a window name (shown in Figure 1-38) will
bring that window to the front.

Figure 1-38: This specialized menu provides another way to minimize a selected Finder window.
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The Help Menu
The Help menu, to the right of the Window menu (while you’re in the Finder) has one
option only. You can choose Help (Ô-?). When you are in the Finder this will show up as
Mac Help (shown in Figure 1-39).

Figure 1-39: The Help menu changes depending on which application is forward.

We look at the Help feature(s) in more depth later in Chapter 7.

The AirPort Menu
If you don’t have any third-party software installed on your computer (like Norton
AntiVirus, QuickKeys, StuffIt Deluxe, Remote Desktop, Timbuktu, etc.) that add menus to
the top of your top menu bar, then the first menu you will encounter (to the right of the
Help menu) will be the AirPort menu (shown in Figure 1-40).

Figure 1-40: The signal strength of your AirPort connection is indicated by the curved signal
bar in the AirPort menu icon itself. Four solid bars indicate a strong signal.

If your AirPort is turned off or if you don’t have an AirPort card installed on your com-
puter, the icon for the AirPort menu will look like an empty outline of the signal bars. You
can also open the Internet Connect.

Multiple available AirPort networks will be listed by name (if they are published) under
this menu if the AirPort is on. The network that you are on will be shown with a check
next to it (shown in Figure 1-40).

The iChat Menu
If you have set up your .Mac account or an AIM account through iChatAV, then you will
have an iChat menu available to the right of the AirPort menu. In this menu, you have
access to most of your iChat AV settings and options (shown in Figure 1-41).
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Figure 1-41: Accessing the Buddy List at the bottom of the iChat menu will cause iChat AV to
connect and log in.

The Available and Unavailable status messages are available in the menu. And if iChat
AV is connected, the available people in your Buddy List will appear in the menu with
their AV options.

We Interrupt This Chapter . . . 

A short dispute about the “handiness” of this menu popped up during editing. 

Benjamin: Through out this book, you will find that I have a “problem” when Apple
offers overly redundant options. The iChat menu is one of those not-too-useful options.
To use iChat well, you need to have it open. When you have it open, all of the options
are available to you. This menu just provides you with more ways to accidentally con-
nect iChat to the Internet.

Sometimes less is more. This menu is one of those cases.

Pieter: While this menu is a tad cluttered, okay, very cluttered, iChat gives you many
options to customize the way that you communicate with your friends and co-workers
over the Internet. Personally, I kinda like the ability to select different away messages to
let people know what I am doing and why I am not answering their messages as if they
were the most important people in the world. However, Ben is right in that it is simple
to make an accident and turn on iChat without meaning to. On the other hand, in this
very connected world, why would you ever want to turn off iChat? Just kidding.

The Volume Menu
The volume can be controlled using the Volume slider menu to the right of the iChat
menu (shown in Figure 1-42). Drag the slider up and down to control the volume.
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Figure 1-42: The rounded volume bars on the icon of the Volume menu also indicate the
volume. Two bars indicate half (approximately) volume.

Turn the Volume Up, Down, or Mute the Volume 
from the Keyboard
The Volume menu is not nearly as useful as F3 (Mute), F4 (Volume Down), and F5
(Volume Up) keys. You will know if you are affecting the sound by a slightly transparent
speaker symbol with a level indicator below it. You will also hear a sound rising and
falling as you turn the sound up or down (respectively).

The Keyboard Input Menu
The Keyboard Input menu, located to the right of the Volume menu, allows for direct
access to some of the features in the International settings in the System Preferences
(shown in Figure 1-43).

Figure 1-43: The flag icon itself actually represents the language that is set for the keyboard.

Selecting the Show Character Palette option under the Keyboard Input menu will open
the Character palette where you can view and select characters in a variety of sets and
categories (shown in Figure 1-44).

Figure 1-44: Extensive work with text and unusual characters make this palette very useful.
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Choosing the Keyboard Input menu again gives you the choice of hiding the Character
palette without closing it, as shown in Figure 1-44.

Closing the Character palette is not available if you have more than one language
palette installed.

The Battery Menu
If you have a laptop, you will find another menu to the right of the Keyboard Input menu.
This menu’s icon will show up as a plug inside a battery (shown in Figure 1-45). When the
PowerBook is plugged into an AC source, the icon looks like status bar within a battery
indicating the level of charge.

Figure 1-45: The menu allows different views for the battery as well as direct access to the
Energy Saver controls in System Preferences.

The Date & Time Menu
This menu is located to the right of the Battery menu. The Date & Time menu shows the
Date just below it by clicking on the time itself (shown in Figure 1-46).

Figure 1-46: The menu offers Analog and Digital views of the time. The bottom choice offers
direct access to the Date & Time controls in System Preferences.

Push (or Drag) Your Icon Menus Around
If you don’t like the arangement of your icon pull-down menus (to the right of the Help
menu) you can hold down the Command Key while you click on those Icons and move
them around to change the order.

While your at it, you can also drag the menus off the top bar by holding down the
Command key and dragging them down. You’ll have to go into the appropriate System
Preference or launch the appropriate application to get those menus back.
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The User Menu
The last menu (that comes with the OS) is the User Menu, located in the upper-right cor-
ner of the screen (if you have Fast User Switching enabled in the System Preferences).
Clicking on this menu lists all the users available on the computer (shown in Figure 1-47).

Figure 1-47: The check marks in front of the user pictures and names indicate that the
accounts are active and have been logged into.

This menu is new to OS X in Panther. It allows for quick access to the Login window, but,
more importantly, it allows for a new Panther feature, Fast User Switching. In Panther, it
is possible to be logged into more than one account at a time. If you are, you can switch
between the users by select the users in this menu.

We get into more depth about users and Fast User Switching in Chapter 6.

Contextually Speaking . . .
Contextual menus seem to make a lot of Mac people uncomfortable. Perhaps they seem
too PC-like to use. Maybe people find them too new.

But contextual menus are not new. In fact, Apple has had contextual menus in the Finder
since OS 8.x. And most applications now are contextually aware. In fact, if you’ve used
FinalCut Pro or FinalCut Express, you will find that using the contextual menus are
almost essential to do what you want to do.

The idea of contextual menus did start in the world of the PC. (You’ve got to give the Devil
his due!) The idea was that for any object there were certain actions or commands that
either applied or didn’t apply. And because those actions could be known by the OS, it
could present a list of options that apply.

Assume that you are working with a Mac, right out of the box, bundled with the Apple
Pro Mouse that came with the computer. In order to access a contextual menu you will
need to Control-click (Control key and mouse click) on an object. When you Control-click
on an object the cursor will appear with a small ladder next to it, indicating that you are
about to access a contextual menu.

Clicking one time on an object before you Control-click on it will select the file, folder,
volume, or application (shown in Figure 1-48) prior to accessing the contextual options of
that object.
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Figure 1-48: The highlighted icon shows a selected document ready for contextual access.

Holding down the Control key and clicking again on that same file will open up a menu
with the available OS actions and commands (shown in Figure 1-49), as well as contextual
options from third-party programs that add contextual modules (shown in Figure 1-50).

Figure 1-49: Among all the things that contextual commands can do, you can choose to open
a document in various applications and of course to add a color label.
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Figure 1-50: StuffIt Deluxe adds contextual modules so you can access all of StuffIt’s features
by Control-clicking on an item(s).

Items on the desktop also have contextual menus available to them (as shown in
Figure 1-51).

Figure 1-51: You can now copy files and folders by Control-clicking on a file or folder and
choosing Copy “item name.”
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We Interrupt This Chapter . . . 

This started as a note about giving the Devil his due with regards to two-button mice . . .

Benjamin: What I’m about to say may sound very Un-Mac-like. Apple is famous for its
sleek design and easy functionality. But the Apple Pro Mouse has not evolved with the OS. 

The reason that Mac users don’t use (and most often don’t know about) contextual
menus is that the mouse is a one-button mouse. Although I understand the standpoint
of making the experience easy, this mouse design is stunted and parochial. PC users
have had two-button mice for years to take advantage of the contextual menus.
Another handy thing, the scroll bar, is a great way to read through e-mail pages and
look at Web sites.

And there are lots of third-party mice that have at least two buttons with a scroll wheel —
so if you want it, you can get it. I just don’t understand why Apple hasn’t come out with a
two-button mouse like every other computer manufacturer. Perhaps Apple doesn’t think
we’re smart enough to handle all the options that they’ve given to us through the OS. 

This is a case where Apple should think of function over form.

Pieter: Personally, I use a two-button mouse and love it, but then again I also use
Windows- and Unix-based computers daily, so I am used to it. The original idea that
Steve Jobs and the original Lisa and Macintosh engineers had was for a computer that
required as little training as possible. Thus, the engineers felt that producing a mouse
with two buttons would create an interface element that required a user to learn what
each button does. Not exactly a point-and-click experience. Microsoft looked at what
Apple did with one button and what workstation makers did with three buttons and
settled on what they felt was a compromise, the two-button mouse. However, this did
entail a higher cost of training, because users were forced to learn what each button
did; and then there was the whole issue of how to deal with left-handed people, like Bill
Gates. In the end, all sides have stuck with their style of mouse. Even three-button mice
are still popular in the workstation market, simply because users that grew up with
each operating system are used to them.

Searching Like a Pro
Much to-do has been made about searching in the Mac OS. And I have seen articles that
are just too darn long about how to search for items on you computer. We’re not going to
do that. This section of the chapter is short.

Unlike Classic, finding files no longer happens in Sherlock. That application is now exclu-
sively used for various Internet searches. We talk about Sherlock in Chapter 12.

To search for files in Panther, you have two options. You can search for files through the
Finder window or you can choose Find from under the File menu (Ô-F) in the Finder.

If you want to look for a file within a specific folder or directory, you would be best served
searching for the file(s) using the Search field in a Finder window’s toolbar. To search in a
directory or folder, open a Finder window to the directory (or folder) that you want to
search and type the name of the file, folder, or application you want in the Search field in
the upper-right corner of a Finder window’s toolbar (shown in Figure 1-52).
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Figure 1-52: The fast searching feature of the window search will cause the results to update as
you continue to type, changing those results.

The default setting for the window search is for the selected directory. If you do not find
the file you are looking for in the selected directory, you can pull down a menu from the
small magnifying glass icon that expands your search to the Home folder, the Local Disks,
or Everywhere (as shown in Figure 1-52).

When you expand Finder window searches to any of the other directory choices, the
search criteria at the top of the Finder window do not change to help you remember
where you started the search from.

Clicking on any of the search results shows a directory path in the bottom panel. The
search window is also just like any Finder window. You can drag, copy, delete, and launch
any document from the search results.

The other method for searching for files is by typing Ô-F and launching the Find applica-
tion. Find (shown in Figure 1-53) allows you to search in the same places as the Finder
window search.

Figure 1-53: The Find dialog box can be as simple to use as the window search option.
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The Find dialog box has a lot of expanded features that the Finder window search does
not. You can choose to search by ten different categories and multiples of those to help in
your search (as shown in Figure 1-54). This is the method you’ll want to use if you need to
“Search like a Pro.”

Figure 1-54: The search possibilities are extensive. The search permutations are large enough
that I don’t care to work them out.

Digging into the Files
Looking at the files in more depth will help you understand and use the Finder more like
an expert. Having said that, I can tell you that what we cover here is a real snooze fest to
all but the biggest Mac geeks. But the material needs to be covered, and this is as good a
place as any to cover it, so let’s press on.

Info in Column View
If you look at a file or application in the Column view, you will be able to see a lot of infor-
mation about that file or application (shown in Figure 1-55). Data shown includes the
item’s icon or preview, its name, kind, size, date created, date modified, and version.
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Figure 1-55: Icons show up in the Column view for applications and some files.

Beside the usual information, you will see previews of some files such as PDFs, some text
files, QuickTime clips, and lots of image file types (shown in Figure 1-56).

Figure 1-56: Previews show up in the Column view for many kinds of data files.

Get Info
After you have a file selected, you can choose to get a lot more information about them by
either Control-clicking the document to access the Get Info option in the contextual menu
(shown in Figure 1-57) or by selecting Get Info (Ô-I) in the File menu.
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Figure 1-57: Accessing the Get Info option.

File Info
Now that you have the File info open, you will be confronted with a lot of options. The
Info dialog box is broken down into six parts: General, Name & Extensions, Open with,
Preview, Ownership & Permissions, and Comments.

General Info
The first thing you see when you open up the Get Info panel is the document name on the
top (shown in Figure 1-58). The General info shows the icon preview (not the image pre-
view), the size of the document, the location of the document, the date the document was
created, the date that the document was last modified, the Stationery Pad option, and the
ability to lock the document so that it can’t be modified further.

Figure 1-58: The General info is almost identical to the information available through the
column view file info.
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Using the Stationery Pad Option to Protect Your Files
There is a little-used option in the General info section of the document info called
Stationery Pad. When you click on the Stationery Pad check box you give that document
Stationery properties. This becomes apparent the first time you try to double-click on a
file that has this Stationery Pad option checked and a copy of the document is immedi-
ately created in the same directory (as shown in Figure 1-59).

Figure 1-59: The Stationery Pad option treats the file like a master file and makes
usable copies of it.

You should be careful with this feature. Every time you double-click on a document with
the Stationery Pad option selected, a new copy will be created.

Name & Extension
By turning the little disclosure triangle to the left of the Name & Extension section of the
document Info box, you get the name of the document with the extension and the option
to hide (or not) the file extension (shown in Figure 1-60).

Figure 1-60: You can also use this name field to change the name of the document.
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Open with
Just below the Name & Extension section of the document Info box, you will find the
Open with section of the document Info box. In this part of the Info box you can choose
which application you want to set to open the document by pulling down the application
choice menu (shown in Figure 1-61).

Figure 1-61: Sometimes the applications that the Mac OS thinks may work well to open your
document may not work so well.

Many of the choices that the OS understands will appear in the menu. If the application
you want to use doesn’t appear in the list, you can select the Other option at the bottom of
the menu and choose the application you want to use to open the document (shown in
Figure 1-61).

The only other thing that the Open with feature of the document Info box will do is allow
you to specify the newly selected application to open all documents like the one that
you are getting the Info about. To do that, click on the Change All button (shown in
Figure 1-62).

The ability to make all documents open with the application you select (by clicking on
the Change All button in the Open with selection in the document Info box) is a very
powerful option. In fact, it’s almost too powerful. You can cause a lot of problems for
yourself if you don’t know what you are doing.

If you don’t have a reason to do this (and even sometime when you do), you should
avoid using this feature.

caution
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Summary
So, we looked at the desktop and learned that it wasn’t as close to the surface as we
thought. We also found that a desktop, like a lot of things in this user-centric OS, can be
distinctly you.

We explored some of the new Finder window views and options. And when we were done
with that, we explored the Finder window options some more. We looked at the new
options on the toolbar and explored the entirely new sidebar. We even showed you how to
add a picture to the background of a Finder window in icon view. And if you didn’t catch
my enthusiasm about the labels being back, then you just weren’t reading. If you read
through these sections, you can now consider yourself an expert in Finder window use.

We explored the menus at the top of the screen, contextual menus, and searching for files.

After that, we dug into the files themselves and learned how to learn more about any file on
your computer. This includes some time spent on messing around with file permissions. If
you read all the way through that section, you’re not an expert, but you’re a better person
that I am. (I wrote it and I don’t want to read it all the way through.)

But we ended the chapter well by looking at my favorite OS haxie that gives us back the
Classic-like application menu.

In the next chapter, we go through what the Apple menu is and what the Apple menu
can be.
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