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4 CHAPTER1 GETTING STARTED WITH VB.NET

So, what's the distinction between Visual Studio NET and the language? Visual Studio NET is
the environment that provides all the necessary tools for developing applications. The language is
only one aspect of a Windows application. The visual interface of the application isn't tied to a spe-
cific language, and the same tools you'll use to develop your application’s interface will also be used
by all programmers, regardless of the language they'll use to code the application.

The tools you'll use to access databases are also independent of the language. Visual Studio pro-
vides tools that allow you to connect to a database, inspect its objects, retrieve the information you're
interested in, and even store it in objects that can be accessed from within any language.

There are many visual tools in the IDE, like the Menu Designer. This tool allows you to Visuaﬂy
design menus and to set their names and basic properties (such as checking, enabling, or disabling
certain options). Designing a menu doesn’t involve any code, and it’s carried out with point-and-
click operations. Of course, you will have to insert some code behind the commands of your menus,
and (again) you can use any language to program them.

To simplify the process of application development, Visual Studio NET provides an environment
that's common to all languages, which is known as integrated development environment (IDE). The purpose
of the IDE is to enable the developer to do as much as possible with visual tools, before writing code.
The IDE provides tools for designing, executing, and debugging your applications. It's your second

desktop, and you’ﬂ be spending most of your productive hours in this environment.

The Start Page

When you run Visual Studio for the first time, you will see the window shown in Figure 1.1. On the
My Profile tab, you will set your personal preferences by specifying your language. Select Visual
Basic Developer in the Profile box, and the other two boxes will be filled automatically. You can
leave the other fields to their default values. The ComboBox control at the bottom of the page, the
At Startup control, is where you define what you want Visual Studio NET to do when it starts.
The choices are the following:

Show Start Page Every time you start Visual Studio .NET, this page will appear.

Load Last Loaded Solution ~ Once you start working on a real project (a project that will take
you from a few days to a few months to complete), select this option so that the project will be
loaded automatically every time you start Visual Studio NET.

Show Open Project Dialog Box Every time you start Visual Studio NET, the Open Project

dialog box will appear, where you can select a project to open.

Show New Project Dialog Box  Every time you start Visual Studio .NET, the New Project

dialog box will appear, where you can specify the name of a new project—a setting to avoid.

Show Empty Environment This option instructs Visual Studio .NET to start a new empty
solution, and you're responsible for adding new or existing projects to the solution and new or
existing items to a project.

The actions are self-explanatory, and the most common setting is to show the Start Page. The
Start Page displays the four most recently opened projects, as well as the New Project and Open
Project buttons. To see the Start Page, select the Get Started option.
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controls on the form and setting their properties you're implementing a lot of functionality before
coding the application. The TextBox control with the settings discussed in this section is a func-
tional text editor.

Project Types

Before moving on, let me mention briefly all the types of projects you can build with Visual Studio
in addition to Windows applications. All the project types supported by Visual Studio are displayed
on the New Project dialog box, and they’re the following:

Class library A class library is a basic code-building component, which has no visible interface
and adds specific functionality to your project. Simply put, a class is a collection of functions that
will be used in other projects beyond the current one. With classes, however, you don’t have to
distribute source code. Class libraries are equivalent to ActiveX DLL and ActiveX EXE project
types of VB6.

Windows control library A Windows control (or simply control), such as a TextBox or Button,
is a basic element of the user interface. If the controls that come with Visual Basic (the ones that
appear in the Toolbox by default) don’t provide the functionality you need, you can build your
own custom controls. People design their own custom controls for very specific operations to
simplify the development of large applications in a team environment. If you have a good idea for
a custom control, you can market it—the pages of the computer trade magazines are full of ads
for advanced custom controls that complement the existing ones.

Console application A Console application is an application with a very limited user interface.
This type of application displays its output on a Command Prompt window and receives input
from the same window. You'll see an example of a simple Console application later in this chap-
ter, and that will be the last Console application in this book. The purpose of this book is to
show you how to build Windows and Web applications with rich interfaces, not DOS-like appli-
cations. However, the product’s documentation uses Console applications to demonstrate specific
topics, and this is why I've included a short section on Console applications in this chapter.

Windows service A Windows service is a new name for the old NT services, and they're long-
running applications that don’t have a visible interface. These services can be started automatically
when the computer is turned on, paused, and restarted. An application that monitors and reacts
to changes in the file system is a prime candidate for implementing as a Windows service. When
users upload files to a specific folder, the Windows service might initiate some processing (copy
the file, read its contents and update a database, and so on). We will not discuss Windows serv-
ices in this book.

ASP.NET Web application  Web applications are among the most exciting new features of
Visual Studio. A Web application is an app that resides on a Web server and services requests
made through a browser. An online bookstore, for example, is a Web application. The applica-
tion that runs on the Web server must accept requests made by a client (a remote computer with
a browser) and return its responses to the requests in the form of HTML pages. Web applica-
tions are not new, but ASP.NET hides many of details of building Web applications and makes

e

11









2877c0l.gxd

11/11/01 4:14 PM Page 14 $

14 CHAPTER1 GETTING STARTED WITH VB.NET

At the top of the main pane of the Designer, you will see two tabs named after the form: in
Figure 1.9, they’re the Form1.vb [Design] tab and the Form1.vb tab. The first tab is the Win-
dows Form Designer (where you build the interface of the application with visual tools) and the
second is the code editor, where you insert the code behind the interface. At the top of the code
editor, which is what you see in Figure 1.9, are two ComboBoxes. The one on the left contains
the names of the controls on the form. The other one contains the names of events each control
recognizes. When you select a control (or an object, in general) in the left list, the other list’s con-
tents are adjusted accordingly. To program a specific event of a specific control, select the name
of the control in the first list (the Objects list) and the name of the event in the right list (the
Events list).

The Click event happens to be the default event of the Button control, so when you double-
click a Button on the form, you're taken to the Button1_Click subroutine. This subroutine is an
event handler. An event handler is invoked automaticaﬂy every time an event takes place. The event
is the Click event of the Button1 control. Every time the Button1 control on the form is clicked, the
Button1_Click subroutine is activated. To react to the Click event of the button, you must insert the
appropriate code in this subroutine.

The name of the subroutine is made up of the name of the control, followed by an underscore
and the name of the event. This is just the default name, and you can change it to anything you like
(such as EvaluateLanguage, for this example, or StartCalculations). What makes this subroutine an
event handler is the keyword Handles at the end of the statement. The Handles keyword tells the
compiler what event this subroutine is supposed to handle. Button1.Click is the Click event of the
Button1 control. If there were another button on the form, the Button2 control, you’d have to write
code for a subroutine that would handle the Button2.Cl1ick event. Each control recognizes many
events; for each control and event combination, you can provide a different event handler. Of course,
we never program every possible event for every control.

NOTE  As you will soon realize, the controls have a default bebavior and handle the basic events on their own. The
TextBox control knows how to handle keystrokes. The CheckBox control (a small square with a check mark) changes state
by biding or displaying the checkmark every time it’s clicked. The ScrollBar control moves its indicator (the button in the
middle of the control) every time you click one of the arrows at the two ends. Because of this default bebavior of the controls,
you need not supply any code for the events of most controls on the form.

Rename Button1_Click subroutine to EvaluateLanguage. However, you shouldn’t change the
name of the event this subroutine handles. If you change the name of the control after you have
inserted some code in an event handler, the name of the event handled by the subroutine will be
automatically changed. The name of the subroutine, however, won't change.

Let’s add some code to the Click event handler of the Button1 control. When this button is
clicked, we want to examine the text on the control and, if it’s “Visual Basic”, display a message; if
not, we'll display a different message. Insert the lines of Listing 1.1 between the Private Sub and
End Sub statements. (I’m showing the entire Iisting here, but there’s no reason to retype the first and
last statements.)
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LISTING 1.1: PROCESSING A USER-SUPPLIED STRING

Private Sub EvaluatelLanguage_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles Buttonl.Click
Dim Tanguage As String
Tlanguage = TextBox1l.Text

If language = "Visual Basic" Then
MsgBox("We have a winner!")
Else
MsgBox(language & " is not a bad Tanguage.")
End If
End Sub

Here’s what this code does. First, it assigns the value of the TextBox1 control to the variable lan-
guage. A variable is a named location in memory, where a value is stored. This memory location can
be read later in the code or set to a different value. Variables are where we store the intermediate
results of our calculation when we write code. Then the program compares the value of the language
variable to the literal “Visual Basic”, and depending on the outcome of the comparison, it displays
one of two messages. The MsgBox() function displays the specified message in a small window with
the OK button. Users can view the message and then click the OK button to close the message box.

Even if you're not familiar with the syntax of the language, you should be able to understand
what this code does. Visual Basic is the simplest NET language, and we will discuss the various
aspects of the language in detail in the following chapters. In the meantime, you should try to under-
stand the process of developing a Windows application: how to build the visible interface of the
application, and how to program the events to which you want your application to react.

Making the Application More Robust

The code of our first application isn't very robust. If the user doesn’t enter the string with the exact
spelling shown in the listing, the comparison will fail. We can convert the string to uppercase and
then compare it to “VISUAL BASIC” to eliminate differences in case. To convert a string to upper-
case, use the ToUpper method of the string class. The foﬂowing expression returns the string stored
in the language variable, converted to uppercase:

Tlanguage.ToUpper

We should also assume that the user may enter “VB” or “VB.NET”, so let's modify our code as
shown in Listing 1.2.

LISTING 1.2: A MORE ROBUST STRING COMPARISON TECHNIQUE

Private Sub EvaluatelLanguage_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles Buttonl.Click
Dim Tanguage As String
Tanguage = TextBox1l.Text
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Tlanguage = Tanguage.ToUpper
If Tanguage = "VISUAL BASIC" Or _
language = "VB" Or _
Tanguage = "VB.NET" Then
MsgBox("We have a winner!")
Else
MsgBox(language & " is not a bad Tanguage")
End If
End Sub

The If statement is a long one, and for clarity T've inserted the underscore character to break it
mnto rnultiple text lines. As you enter the code, you will either enter an underscore character and then
press Enter to move to the following line, or ignore the underscore character and continue typing on
the same line. You will see later how you can instruct the code editor to automatically wrap long
lines of code.

Run the application, enter the name of your favorite language, and then click the Button to evalu-
ate your choice. It's an extremely simple project, but this is how you write Windows applications:
you design the interface and then enter code behind selected events.

In the following section, we'll improve our application‘ You never know what users may throw
at your application, so whenever possible we try to limit their response to the number of available
choices. In our case, we can display the names of certain languages (the ones we're interested in)
and force the user to select one of them. One way to display a limited number of choices is to use a
ComboBox control. In the following section, we'll revise our sample application so that the user
won't have to enter the name of the language. The user will be forced to select his or her favorite
language from a list, so that we won't have to validate the string supplied by the user.

Making the Application More User-Friendly

Start a new project, the WindowsApplication2 project. If there’s already a project by that name in
your VB projects folder, name it differently or specify a different location. Click the Browse button
on the New Project dialog box and select a new folder. You can also create a new folder like
“MyProjects” or “VB.NET Samples” and select this as the default folder for your next few projects.
Every time you create a new project, this folder will be suggested by default. When you're ready for
your own projects, specify a different location with the Browse button.

When the form of the project appears in the IDE, set the form’s Font property. Locate the Font
item in the Properties window and click the button with the ellipsis (three dots). The usual Font
dialog box will appear, and you can set the form’s font. This time, set it to Comic Sans MS, 11
points. All the controls you'll place on the form from will inherit this font.

Open the Toolbox and double-click the icon of the ComboBox tool. A ComboBox control will
be placed on your form. Now place a Button control on the form and position it so that your form
looks like the one shown in Figure 1.10. To see the properties of a specific control in the Properties
window, you must select the appropriate control on the form. Then set the button’s Text property
to “Evaluate my choice” (just enter this string without the quotes in the box of the Text property in
the control’s Properties window).

e
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You can run the project now and see how the ComboBox control behaves. Press F5 and wait for
a few seconds. The project will be compiled, and you'll see its form on your desktop, on top of the
Visual Studio window. This is the same form we've been designing so far, but in runtime (in effect,
what the users of the application will see if you decide to distribute it).

I'm sure you know how this control behaves in a typical Windows application, and our sample appli-
cation is no exception. You can select an item on the control either with the mouse or with the keyboard.
Click the button with the arrow to expand the list, and then select an item with the mouse. Or press the
arrow down and arrow up keys to scroll through the list of items. The control isn’t expanded, but each
time you click an arrow button, the next or previous item in the list appears on the control.

We haven't told the application what to do when the button is clicked, so let’s go back and add some
code to the project. Stop the application by clicking the Stop button on the toolbar (the solid black
square) or by selecting Debug > Stop Debugging from the main menu. When the form appears in
design mode, double-click the button and the code window will open, displaying an empty Click event

handler. Insert the statements shown in Listing 1.3 between the Private Sub and End Sub statements.

LISTING 1.3: THE REVISED APPLICATION

Private Sub EvaluatelLanguage_Click(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles Buttonl.Click
Dim Tanguage As String
Tanguage = ComboBox1.Text

If Tanguage = "Visual Basic" Then
MsgBox("We have a winner!")
Else
MsgBox(language & " is not a bad language.")
End If
End Sub

When the form is first displayed, a string that doesn’t correspond to a language is displayed in the
ComboBox control. We must select one of the items from within our code when the form is first
loaded. When a form is loaded, the Load event of the Form object is raised. Double-click some-
where on the form, and the editor will open the form’s Load event handler:

Private Sub Forml_Load(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles MyBase.load

End Sub
Enter the following code to select the item “Visual Basic” when the form is loaded:

Private Sub Forml_Load(ByVal sender As System.Object, _
ByVal e As System.EventArgs) Handles MyBase.Load
ComboBox1.SelectedIndex = 3
End Sub

Now that we select an item from within our code, you can reset the ComboBox’s Text property
to an empty string.

e
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As you realize, the controls on the Toolbox are more than nice pictures. They encapsulate a lot
of functionality, and they expose properties that allow you to adjust their appearance and their func-
tionality. Most properties are usually set at design time.

The IDE Components

The IDE of Visual Studio.NET contains numerous components, and it will take you a while to
explore them. It’s practically impossible to explain what each tool, each window, and each menu
does. We'll discuss specific tools as we go along and as the topics we discuss get more and more
advanced. In this section, I will go through the basic items of the IDE, the ones we’ll use in the fol-
lowing few chapters to build simple Windows applications.

The IDE Menu

The IDE main menu provides the following commands, which lead to submenus. Notice that most
menus can also be displayed as toolbars. Also, not all options are available at all times. The options
that cannot possibly apply to the current state of the IDE are either invisible or disabled. The Edit
menu is a typical example. It's quite short when you’re designing the form and quite lengthy when
you edit code. The Data menu disappears altogether when you switch to the code editor—you can’t
use the options of this menu while editing code.

FILE MENU

The File menu contains commands for opening and saving projects, or project items, as well as the
commands for adding new or existing items to the current project.

EDIT MENU

The Edit menu contains the usual editing commands. Among the commands of the Edit menu are
the Advanced command and the IntelliSense command.

Advanced Submenu

The more interesting options of the Edit > Advanced submenu are the following. Notice that the
Advanced submenu is invisible while you design a form visually and appears when you switch to the
code editor.

View White Space  Space characters (necessary to indent lines of code and make it easy to

read) are replaced by periods.

Word Wrap When a code line’s length exceeds the length of the code window, it's automati-
cally wrapped.

Comment Selection/Uncomment Selection Comments are lines you insert between your
code’s statements to document your application. Sometimes, we want to disable a few lines from
our code, but not delete them (because we want to be able to restore them). A simple technique
to disable a line of code is to “comment it out” (insert the comment symbol in front of the line).
This command allows you to comment (or uncomment) large segments of code in a single move.
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TOOLS MENU

This menu contains a list of tools, and most of them apply to C++. The Macros command of the
Tools menu leads to a submenu with commands for creating macros. Just as you can create macros
in an Office application to simplify many tasks, you can create macros to automate many of the
repetitive tasks you perform in the IDE. I'm not going to discuss macros in this book, but once you
familiarize yourself with the environment, you should look up the topic of writing macros in the
documentation.

WINDOW MENU

This is the typical Window menu of any Windows application. In addition to the list of open win-
dows, it also contains the Hide command, which hides all Toolboxes and devotes the entire window
of the IDE to the code editor or the Form Designer. The Toolboxes don’t disappear completely.
They’re all retracted, and you can see their tabs on the left and right edges of the IDE window. To

eXpand a TOO”DOX, just hover the mouse pointer over the corresponding tab.

HELP MENU

This menu contains the various help options. The Dynamic Help command opens the Dynamic
Help window, which is populated with topics that apply to the current operation. The Index com-
mand opens the Index window, where you can enter a topic and get help on the specific topic.

The Toolbox Window

Here you will find all the controls you can use to build your application’s interface. The Toolbox
window is usuaﬂy retracted, and you must move the pointer over it to view the Toolbox. This win-
dow contains these tabs:

Crystal Reports
Data

XML Schema
Dialog Editor
Web Forms
Components
Windows Forms
HTML
Clipboard Ring
General

The Windows Forms tab contains the icons of the controls you can place on a Windows form,
and we’'ll work exclusively with this tab in the course of the next few chapters. Likewise, the Web
Forms and HTML tabs contain the icons of the controls you can place on a Web form. The con-
trols on these tabs are examined in Part VI of the book.
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The Data tab contains the icons of the objects you will use to build data-driven applications, and
they’re explored in Part V of the book. The items on the Data tab are objects with no visible inter-
face. The XML Schema tab contains the tools you’ﬂ need to work with schema XML files. We'll
touch this topic in Part V of the book, but you don’t really need to understand XML to use it.
You'll see how to create XML files with visual tools.

The Solution Explorer

This window contains a list of the items in the current solution. A solution may contain multiple
projects, and each project may contain multiple items. The Solution Explorer displays a hierarchical
list of all the components, organized by project. You can right-click any component of the project
and select Properties in the context menu to see the selected component’s properties in the Proper-
ties window. If you select a project, you will see the Project Properties dialog box. You will find
more information on project properties in the following chapter.

If a project contains multiple forms, you can right-click the form you want to become the startup
form and select Set As StartUp Object. If the solution contains multiple projects, you can right-click
the project you want to become the startup form and select Set As StartUp Project. You can also add
items to a project with the Add Item command of the context menu, or remove a component from
the project with the Exclude From Project command. This command removes the selected compo-
nent from the project, but doesn’t affect the component’s file on the disk. The Remove command
removes the selected component from the project and also deletes the component’s file from the disk.

The Properties Window

This window (also known as the Property Browser) displays all the properties of the selected com-
ponent and their settings. Every time you place a control on a form, you switch to this window to
adjust the appearance of the control on the form, and you have already seen how to manipulate the
properties of a control through the Properties window.

Many properties are set to a single value, like a number or a string. If the possible settings of a
property are relatively few, they're displayed as meaningful constants in a drop-down list. Other
properties are set through a more elaborate interface. Color properties, for example, are set from
within a Color dialog box that’s displayed right in the Properties window. Font properties are set
through the usual Font dialog box. Collections are set in a Collection Editor dialog box, where you
can enter one string for each item of the collection.

If the Properties window is hidden or you have closed it, you can either select the View > Proper-
ties Window command or right-click a control on the form and select Properties. Or you can simply
press F4 to bring up this window. There will be occasions where a control may totaﬂy overlap another
control, and you won’t be able to select the hidden control and view its properties. In this case, you
can select the desired control in the ComboBox part of the Properties window. This box contains the
names of all the controls on the form, and you can select a control on the form by selecting its name
on this box. Use this technique to set the properties of a control that's covered by another control.

The Output Window

The Output window is where many of the tools, including the compiler, send their output. Every time
you start an application, a series of messages is displayed on the Output window. These messages are

e
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generated by the compiler, and you need not understand them at this point. If the Output window is
not visible, select the View > Other Windows > Output command from the menu.

You can also send output to this window from within your code with the Console.WriteLine
method. Actually, this is a widely used debugging technique—to print the values of certain variables
before entering a problematic area of the code. As you will learn in Chapter 17, there are more elab-
orate tools to help you debug your application, but printing a few values to the Output window is a
time-honored practice in programming with VB to test a function or display the results of interme-
diate calculations.

In many of the examples of this book, especially in the first few chapters, I use the Console.Write-
Line statement to print something to the Output window. To demonstrate the use of the DateDiff()
tunction, for example, I'll use a statement like the following:

Console.WriteLine(DateDiff(DateInterval.Day, #3/9/2001#, #5/15/2001#))

When this statement is executed, the value 67 will appear in the Output Window. This statement
demonstrates the syntax of the DateDiff() function, which returns the difference between the two
dates in days.

The Command Window

While testing a program, you can interrupt its execution by nserting a breakpoint. ‘When the break-
point is reached, the prograrn’s execution 1s suspended and you can execute a statement in the Com-
mand window. Any statement that can appear in your VB code can also be executed in the
Command window.

The Task List Window

This window is usually populated by the compiler with error messages, if the code can’t be success-
tully compiled. You can double-click an error message in this window, and the IDE will take you to
the line with the statement in error—which you should fix.

You can also add your own tasks to this window. Just click the first empty line and start typing.
A task can be anything, from comments and reminders, to URL:s to interesting sites. If you add tasks
to the list, you're responsible for removing them. Errors are removed automatically as soon as you fix
the statement that caused them.

Environment Options

The Visual Studio IDE is highly customizable. I will not discuss all the customization options here,
but I will show you how to change the default settings of the IDE. Open the Tools menu and select
Options (the last item in the menu). The Options dialog box will appeat, where you can set all the
options regarding the environment. Figure 1.15 shows the options for the font of the various items
of the IDE. Here you can set the font for various categories of items, like the Text Editor, the
dialogs and toolboxes, and so on. Select an item in the Show Settings For list and then set the font
for this item in the box below.
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Controls expose methods, too, which act on the control. The Hide method, for example, makes the
control invisible. Properties, methods, and events constitute the programmatic interface of the con-

EI'OI and are COIICCEiVer kI’lOWl’l as the COHCI‘OI’S membfrs.

All controls have a multitude of properties, which are displayed in the Properties window, and

you can easily set their values. Different controls expose different properties, but here are some that

are common to most:

Name The control’s name. This name appears at the top of the Properties window when a con-
trol is selected on the form and is also used in programming the control. To set the text on a
TextBox control from within your code, you will use a statement like the foﬂowing:

TextBox1l.Text = "My TextBox Control"
You will see how to program the controls shortly.

Font A Font object that determines how the text of the control will be rendered at both design
and runtime.

Enabled By default, all controls are enabled. To disable a control, set its Enabled property to
False. When a control is disabled, it appears in gray color and users can’t interact with it. Dis-
abling a control isn’t as rare as you may think, because many controls are not functional at all
times. If the user hasn’t entered a value in all required fields on the form, clicking the Process but-
ton isn’t going to do anything. After all fields have been set to a valid value, you can enable the
control, indicating to the user that the button can now be clicked.

Size  Sets, or returns, the control’s size. The Size property is a Size object, which exposes two
properties, the Width and Height properties. You can set the Size property to a string like “320,
80" or expand the Size property in the Properties window and set the Width and Height proper-
ties individually.

Tag Holds some data you want to associate with a specific control. For example, you can set the
Tag property to the control’s default value, so that you can restore the control’s default value if the
user supplies invalid data (a string in a TextBox control that expects a numeric value, or a date).

Text The text (a string) that appears on the control. The Label control’s caption can be set (or
read) through the Text property. A control that displays multiple items, like the ListBox or the

ComboBox control, returns the currently selected item in the Text property.

TabStop  As you know, only one control at a time can have the focus on a form. To move the
focus from one control to the other on the same form, you press the Tab key (and Shift+Tab to
move the focus in reverse order). The TabStop property determines whether the control belongs
to the so-called tab order. If True (which is the default value), you can move the focus to the con-
trol with the Tab key. If False, the control will be skipped in the tab order.

Tablndex A numeric value that determines the position of the control in the Tab order. The con-
trol with the smallest TabIndex value is the one that has the focus when the form is first loaded. If
you press Tab once, the focus will be moved to the control with the next larger TabIndex value.

Visible Sometimes we want to make a control invisible. We do so by setting its Visible prop-

erty to False (the default value of the property is True).
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A Few Common Events

As you have already seen, and will also see in the coming chapters, much of the code of a Windows
application manipulates the properties of the various controls on the form. The code of the applica-
tion resides in selected event handlers. Each control recognizes several events, but we rarely program
more than one event per control. In most cases, most of the controls on the form don’t have any
code behind them. The events that are most frequently used in programming Windows applications
are shown next.

Click This is the most common event in Windows programming, and it’s fired when a control

is clicked.
DoubleClick Fired when the control is double-clicked.
Enter Fired when the control received the focus.

Leave Fired when the control loses the focus. We usuaﬂy insert code to validate the control’s
content in this event’s handler.

MouseEnter Fired when the mouse pointer enters the area of the control. This event is fired once.
If you want to monitor the movement of the mouse over a control, use the MouseMove event.

MouseLeave This is the counterpart of the MouseEnter event, and it’s fired when the mouse
pointer moves out of the area of the control.

XXXChanged Some events are fired when a property changes value. These events include
BackColorChanged, FontChanged, VisibleChanged, and many more. The control’s properties can
also change through code, and it’s very common to do so. To set the text on a TextBox control
from within your code, you can execute a statement like the following:

TextBox1.Text = "a new caption"

You may wish to change the background color of a TextBox control if the numeric value dis-
played on it is negative:

If Val(TextBox.Text) < 0 Then
TextBox1l.BackColor = Color.Red
End If

A Few Common Methods

In addition to properties, controls also expose methods. A method acts upon the control by per-
forming a specific task. Windows controls don’t provide many methods, but the objects we’ll
explore in the following chapters provide many more methods. You have already seen the ToUpper
method, which converts a string to uppercase and returns it as a new string. In VB.INET, a string is
more than a series of characters: it’s an object, and so is just about everything in NET. Even a num-
ber is an object and exposes a few properties and methods of its own.

A String variable exposes the methods Length (it returns the string Iength>, ToUpper (it converts
the characters in the string to uppercase and returns a new string), and ToLower (it converts the
characters in the string to lowercase and returns a new string). To see these methods in action, create
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a new application, place a Button control on the form and enter the following statements in its Click
event handler:

Console.WriteLine("Visual Basic".Length)
Console.WriteLine("Visual Basic".ToUpper)
Console.WriteLine("Visual Basic".TolLower)

Then press FS to run the application, and you will see the following in the Output window (this
is where the Console.WriteLine statement sends its output):

12
VISUAL BASIC
visual basic

NOTE  If the Output window is bidden, select View > Other Windows > Output.

Here are a few methods that are common to most controls. In later chapters, where we'll explore
the Windows controls in detail, you'll learn about the methods that are unique to individual con-
trols. The following methods apply to most of the Windows controls.

Focus This method moves the focus to the control to which the method applies, regardless of
the control that has the focus at the time. Your validation routine could move the focus to the
control with an erroneous entry with the following statement:

TextBox1.Focus

It’s also possible to “trap” the focus to a specific TextBox control until the user enters a valid value,
by calling the Focus method from within the Leave event. The following code segment doesn’t allow
users to move the focus to another control while TextBox1 doesn’t contain a valid numeric value:

Private Sub TextBoxl_ Leave(ByVal sender As Object, _
ByVal e As System.EventArgs) Handles TextBoxl.Leave
If Not IsNumeric(TextBoxl.Text) Then TextBoxl.Focus()
End Sub

The function lsNumericO returns True if its argument (the value in parentheses following the
function’s name) is a numeric value, like 35 or 244.01.

Clear Many controls provide a method to clear their contents, and this s the Clear method. When
you call the Clear method on a TextBox control, the control’'s Text property is set to an empty string.

Hide / Show The Hide and Show methods reveal or conceal the control. The two methods are
equivalent to setting the Visible property to True and False respectively.

PerformClick It’s rather common to invoke the Click event of a button from within our code.
To do so, call the PerformClick method of the Button control. There are no equivalent methods
for other events.

Scale This method scales the control by a value specified as argument. The following statement
scales the TextBox1 control down to 75 percent of its current size:

TextBox1.Scale(0.75)

e
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LISTING 1.4: A CONSOLE APPLICATION

Module Modulel
Sub Main()
Console.WriteLine("Enter your favorite language")
Dim Tanguage As String
Tlanguage = Console.ReadLine()
Tanguage = language.ToUpper
If language = "VISUAL BASIC" Or language = "VB" Or language = "VB.NET" Then
Console.WriteLine("We have a winner!")
Else
Console.WritelLine(language & " is not a bad Tanguage.")
End If
Console.WriteLine()
Console.WriteLine()
Console.WriteLine("PRESS ANY KEY TO EXIT")
Console.ReadLine()
End Sub
End Module

This code is quite similar to the code of the equivalent Windows applications we developed ear-
lier, except that it uses the Console.WriteLine statement to send its output to the Command
Prompt window instead of a message box.

A Console application doesn’t react to events, because it has no visible interface. However,
it's easy to add elements of the Windows interface to a Console application. If you change the
Console.WriteLine method calls into the MsgBox() function, the message will be displayed ona
message box.

The reason to build a Console application is to test a specific feature of the language without
having to build a user interface. Many of the examples in the documentation are Console applica—
tions; they demonstrate the topic at hand and nothing more. If you want to test the DateDiffO func-
tion, for example, you can create a new Console application and enter the lines of Listing 1.5 in its
Main() subroutine.

LISTING 1.5: TESTING THE DATEDIFF() FUNCTION WITH A CONSOLE APPLICATION

Sub Main()
Console.WriteLine(DateDiff(DateInterval.Day, #3/9/2000#, #5/15/2004#))
Console.WriteLine("PRESS ANY KEY TO EXIT")
Console.ReadlLine()

End Sub

The last two lines will be the same in every Console application you write. Without them, the
Command Prompt window will close as soon as the End Sub statement is reached, and you won't
have a chance to see the result.
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Console applications are convenient for testing short code segments, but Windows programming
is synonymous with designing functional user interfaces and you won'’t find any more Console appli-
cations in this book.

Summary

This chapter was a quick introduction to the environment you'll be using to design your applica-
tions. It’s a very rich environment, and it will take you a while to become quite comfortable with it.
Keep in mind that you won’t need most of the menus and toolbars in building simple Windows
applications.

What you must get accustomed to is how we design Windows applications. We start with the
application’s visual interface, which is designed with visual tools. This is done with the Windows
Form Designer. After completing the design of the interface, you must add some code to the appli—
cation. Windows applications are event driven. The user interacts with your application through the
mouse and keyboard. Every time the user does something with an element of the interface, an event
is raised. As a programmer, you must decide what events your application should react to and insert
the appropriate code in the handlers of these events.

In the following chapter, you're going to build more simple applications and drill into the con-
cepts of event-driven programming, which is at the core of programming with Visual Studio NET
and Visual Basic NET.



