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Page title - and subtitle

Loram ipsum dolor sit amet, consectetuer adipiscing elit, sed diam
nonummy nibh euismod tincidunt ut lacreet dolore magna aliquam erat
volutpat. Ut wisi enim ad minim veniam, quis nostrud exerci tation
ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat. Duis
autem val aum iriure dolor in hendrerit in vulputate velit esse molestia
consequat, vel illum dolore eu feugiat nulla facilisis at vero eros et
accumsan et lusto odio dignissim gul blandit praesent luptatum zzril
delenit augue duis dolore te faugait nulla facilisi.

Heading goes here
Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam

nonummy nibh euvismod tincidunt ut laoreet dolore magna aliguam erat
volutpat.

Loram ipsum dolor sit amat, consectatuar adipiecing alit, sed diam
nonummy nibh euismod tincidunt ut lacreet dolore magna aliquam erat
wvolutpat. Ut wisi enim ad minim veniam, quis nostrud exerci tation
ullamecorper suscipit lobortis nisl ut aliquip ax ea commodo consequat. Duis
aubtem val eum iriure dolor in hendrerit in vulputate velit esse molestie
consequat, vel illum dolore eu feugiat nulla facilisis at vero eros et
accumsan et lusto odio dignissim qui blandit praesent luptatum zzril
delanit augua duls dolore ta faugait nulla facilisi.

Heading goes here

Loarem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam
nonummy nibh euvismod tincidunt ut lacreet dolore magna aliguam erat
volutpat.

Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam
nonummy nibh euismod tincidunt ut lasreat delore magna aliguam arat
volutpat. Ut wisi enim ad minim veniam, quis nostrud exerci tation
ullamcorper suscipit lobortis nisl ut aliguip ex ea commodo consequat. Duis
autem val aum irtura dolor in hendrerit in vulputate velit asse molastia
consaquat, val illum delore au feugiat nulla facilisis at vero aros at
accumsan et iusto odio dignissim qui blandit praesent luptatum zzril
delenit augue duis dolore te feugait nulla facilisi.



PHOTOSHOP 10
DREAMWEAVER

For the longest time, Web designers lived in a schizophrenic world. On one side, Adobe Photoshop ruled the artists’
roost with the most powerful graphics program available. On another side, Macromedia Dreamweaver was the Web pro-
fessional’s choice for clean code output and feature-rich visual layout. Not only did these two programs not work togeth-
er easily, but their parent companies actively competed against each other with rival products. While some designers
kept to one company or the other, there was a constant drumbeat from those who craved the best of both worlds.

With the release of Adobe Creative Suite 3 Web, the disparate worlds of Photoshop and Dreamweaver were united.
For the first time, Photoshop and Dreamweaver were available in one package—and, best of all, engineered to work to-
gether. Web designers everywhere can now benefit from the enhanced workflow and smoothly move from comp to Weh
page or from Web layout to graphics editor and back again.

There are two major pathways between Photoshop and Dreamweaver. First graphics saved in Photoshop’s native
file format, PSD, can now be opened by Dreamweaver. Dreamweaver converts the Photoshop file into a Web-ready for-
mat (GIF, JPEG, or PNG) through a user-controlled interface titled Image Preview.

The other path from Photoshop to Dreamweaver lies through the clipboard. A selection copied or cut in Photoshop
can bhe pasted in Dreamweaver and doing so invokes the Image Preview dialog for optimizing the exported image.

Given the iterative nature of the design process for most Web designers, it is essential that the workflow between
Photoshop and Dreamweaver be a two-way street. Once a Photoshop-generated image is placed in a Dreamweaver
design, it can be sent to Photoshop for further modification. Again, the clipboard serves as the conduit from Photoshop to
Dreamweaver; however, the altered graphic is automatically saved with the previously chosen Web-oriented settings, so
there is no need to repeat the export process.

In the following chapter, you'll begin by creating a comp (a.k.a. a composition) in Photoshop. Designers new to this
program will learn numerous essential techniques including working with layers and extracting a figure from its back-
ground. On the Dreamweaver site, the basic operations—such as establishing a site and creating a new page—will be
enhanced with the development of a Cascading Style Sheet (CSS)-based, Web standards—compliant layout. Subsequent
chapters in this part of the book will cover the integration of hoth Photoshop-created foreground and background images
into the Dreamweaver design.



THE FLOW: PROTOSROP T0 DREAMWEAVER

As noted earlier, there are two distinct ways for moving graphics from Photoshop to
Dreamweaver. Here's an overview of the first approach (see Figure I-1):

1. Create your graphic comp in Photoshop.

2. Save any individual component (primarily foreground images) as a na-
tive Photoshop (PSD) file.

3. Open PSD file in Dreamweaver and convert it to Web-ready format.

FIGURE I-1

The second method (Figure I-2) requires the following steps:

1. Select desired image in Photoshop.

2. Copy or cut the selection to the clipboard.

3. Paste the clipboard in Dreamweaver and convert the image to a Web-
ready format.

FIGURE [-2

To modify an image placed in a Web page in Photoshop (Figure I-3), you'll follow
these steps:

1. Selectthe image in Dreamweaver and, from the Property inspector,
choose Edit (the Photoshop icon).

2. Image opens in Photoshop for modifications.

3. Select and copy the modified image.

4. In Dreamweaver, paste the copied image.

EIGURE -3




Adobe Photoshop is rightly well known for uses in digital photography, print preparation, and even, with the introduc-
tion of Photoshop Extended, medical imagery. Although lesser known, Photoshop’s Weh capabilities are equally robust.

Factor in the ubiquity of Photoshop in design houses around the world and its newly introduced Dreamweaver connectiv-
ity, and you have a tool ready to create a comp for almost any Web site.

Given its full-featured implementation as a graphics editor, it's no wonder that Photoshop is often overwhelming
to those new to the software. This chapter—and the others following it in this part—takes a learn-by-doing approach.
Here, you'll build up a sample composition in Photoshop to be converted to a Web page in Dreamweaver. As you move
through the design process, you'll encounter core techniques essential to working in Photoshop. The core Photoshop

techniques covered in this chapter are:

e Working with layers
e Making a selection
e Extracting images from the background

Later chapters in this part build on the design foundation you put down in Photoshop and extend your work to its
ultimate goal: a Dreamweaver Web site.

CREATING THE COMP




INITIALIZING THE COMP

While there is no direct interaction between Photoshop and Dreamweaver detailed

in this chapter, that doesn’t mean there is no workflow between the two. Part of any
design process is the initial visualization of the project and, whether you sketch out
your ideas on paper or in a graphics tool, it's always good to consider your end result.
If your site requirements demand an HTML-based site rather than a Flash-based one,
your design direction is going to be influenced by what's possible with modern Web
standards—compliant implementations. For example, a race car spinning onto the mid-
dle of your homepage and then zooming off to reveal the previously hidden content is
probably better suited for a Flash presentation, even though it could possibly be done
with advanced JavaScript techniques.

When considering a design for an HTML-based page, it's a good idea to keep
these questions in mind:

e Where are the natural divisions in this design that will translate into a
CSS layout?

e Which figures are in the foreground and can be inserted as <img> tags?

e Which graphics are best displayed as background images and defined in a

CSS style?

As | go along, I'll point out where these considerations would occur to me so you
can get a sense of how to apply them to your own work.

The example comp created during this exercise is for a fictitious Web design
company called Chocolate Dipped Design. You can start the comp in Photoshop by
creating a new page:

1. From Photoshop’s main menu, choose File » New.

2. When the New dialog box (Figure 1-1) opens, enter Chocolate Dipped
Comp in the Name field.

Although not critical, it's a good idea to name your pages upfront when
defining them in Photoshop. The name appears in the document title bar,
which is handy when working with a number of open files. Moreover, the

Throughout this
book, | use the term
HTML to refer to both
HTML and XHTML-
coded pages. XHTML
is the most recent
incarnation of the
HTML language and
incorporates a
standards-based
coding approach;

the default document
type (or doctype) for
Dreamweaver CS3

is XHTML 1.0 Tran-
sitional. As HTML
encompasses all
variations, you’ll find
it used consistently in
these pages.
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name becomes the suggested filename that appears in the Save dialog box—a minor timesaver, true, but in
the often hectic world of Web design, every little bit helps.

From the Preset menu, select Webh.

The Web preset provides a variety of common Web page sizes, including 800 x 600 and 1024 x 768, in addi-
tion to the standard sizes for Web banner ads such as Leaderboard and Wide Skyscraper.

From the Size menu, choose 1024 x 768.

FIGURE 1-1
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% Advanced 2.25M

What size Web page is often the first decision a Web designer faces. The answer depends on a number

of factors, primarily related to the client’s needs and experience. If the visitor logs in from a previous or
existing site, you'll be able to get an idea of the screen resolution employed by your client’s audience. If the
vast majority is using a lower resolution, such as 800 x 600, you'll need to work within those restraints.

If, on the other hand, a significant proportion is viewing the site with 1024 x 768 or higher, you can safely
increase your design space to those dimensions. The trend in computing is definitely toward larger monitors
with higher resolutions, but it's always vital to put the client’s interest first.

Leave Resolution set to 72 pixels per inch and Color Mode to RGB 8 bit.
These default settings reflect standard monitor output.
From the Background Contents menu, choose White and click OK.

What color you start your comp with is a personal choice; some designers prefer transparent over white.
| typically choose white because that is the default background color for rendered Web pages.

Choose File »> Save As. When the Save As dialog opens, navigate to a folder to store your images or
create a new one. Keep the suggested name as well as the default options and click OK.
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Photoshop opens your new document full size with the magnification set to as
close to 100 percent as possible given your program window size. You can change the
magnification as needed by using the Zoom tool.

SETTING PREFERENCES

To better allow you to work the way you want to work, Photoshop has a full comple-
ment of preference settings: ten entire categories of them, in fact. Although Photo-
shop offers a great number of optional settings, when you are creating Web comps,
there is one change that is highly recommended. Web pages are presented primarily
in a pixel-based medium, and it's a good idea to switch Photoshop’s basic unit of
measurement to pixels. This setting instructs Photoshop to display all positioning—
on rulers as well as X and Y coordinates in the Info panel—and dimensional—uwidth
and height—information the way browsers render the page: in pixels. Additionally,
Web designers should set the type unit of measurement to pixels. While print design-
ers used to working with points may be thrown off their game, pixels are one of more
frequently used units of measurements in CSS for text.

To establish the proper preferences for working on the Web, follow these steps:

1. Choose Edit P> Preferences P Units & Rulers (Windows) or Photoshop P
Preferences P Units & Rulers (Mac). See Figure 1-2.
2. From the Rulers menu, choose pixels.

3. From the Type menu, choose pixels.

FIGURE 1-2

4. Click OK.

Photoshop is rife with
keyboard shortcuts,
and | recommend
memorizing those
that will increase
your productivity the
most. Among those |
use most frequently
are Ctrl+Alt+0 (Win-
dows) or Cmd+0pt+0
(Mac) for setting

the magnification to
100 percent and its
companion, Ctrl+0
(Windows) or Cmd+0
(Mac), for seeing the
entire image.
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If you worked with
previous versions of
Photoshop to create
Web designs, you
may be wondering
whatever happened
to ImageReady.
ImageReady, a Web-
oriented bitmap edi-
tor previously paired
with Photoshop, has
been discontinued.
For similar—and
arguably more
advanced—function-
ality, turn to Adobe
Fireworks, part of the
Adobe CS3 Web suite
and covered else-
where in this book.

Photoshop to Dreamweaver

WORKING WITH LAYERS

| remember the first time | opened an example file from an experienced Photoshop
designer. The image before me was a relatively simple-appearing logo with a curved
framed and highlighted lettering. Okay, | thought, he’s got text surrounded by a round-
ed rectangle against a textured background; | suspected the figure was comprised

of 4, maybe 6, separate objects total. | opened the Photoshop Layers palette to take
a look at how it was made and almost fainted when the 43 different elements were
revealed. Layers are essential in Photoshop.

Every object—whether text string, rectangle, or digital image—is placed on
its own layer in Photoshop in the Layers palette. Layers are stacked above or below
one another and easily rearranged if necessary. You can hide or display layers or lock
them against further editing. As you'll see later in this chapter, layers can even have
effects applied to them.

Layer groups are used to keep the potential multitude of layers orderly. A layer
group is represented by a folder icon and can contain other layer groups as well as
layers. Layer groups can also be hidden or locked as needed.

While both layers and layer groups can, and often are, created on the fly, it's a
good idea to prime the canvas as it were and create your basic structure. You can
start by creating the three primary layer groups:

1. Choose Window P> Layers or, from the docked palette group, click
Layers to expand the Layers palette (Figure 1-3).

FIGURE 1-3
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. Click the folder icon in the bottom of the Layers palette to create a new group.

A new Layer group appears titled Group 1 (Figure 1-4). You can easily rename your layer groups with more
appropriate labels.

FIGURE 1-4
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. Double-click the Group 1 name and rename it Footer.
. Repeat steps 2 and 3 twice more to create group layers named Gontent and Header.

You'll note that new layer groups are added above the currently selected one. Layers can be easily moved
from one position to another.

. Drag the Header layer group down below the Content layer group. Release your mouse button when you
see a black line appear below Content.

Layer groups can be stacked above or below another layer group or within it. Again, Photoshop gives you a
visual indicator.

. Drag the Footer layer group into the Content layer group. When you see a black border surrounding Content,
release your mouse button (Figure 1-5).

FIGURE 1-5
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3. Choose Select P> Inverse Selection.

Because you want to select the strawberries rather than the background, the selection is reversed. Al-
though it may appear to you that little has changed, note that the marquee previously surrounding the outer
border is now gone and only the strawberries are selected (Figure 1-27).

FIGURE 1-27
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Another approach to create the selection is to use the Quick Select tool (found in the Magic
Wand group) to paint over the strawberries, being careful not to move into the shadow. With
this method, there’s no need to invert the selection.
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4. Press Q to create a Quick Mask.

The nonselected background is now tinted red to indicate the application of the Quick Mask (Figure 1-28).

FIGURE 1-28

8 strawbery_bgjpg g1mm

Masking is a key concept in Photoshop. As the name implies, a mask is used to hide part of what lies be-
neath, which, in Photoshop, is an image. What is hidden in Photoshop can't be altered, so masks are also
used to protect parts of a graphic. Entering into Quick Mask mode changes whatever is selected into a tem-
porary mask. When you exit the Quick Mask mode, the temporary mask is reverted to the selection.

5. From the Tools palette, select the Brush tool, located in the second tool grouping on the palette.

The real power in the Quick Mask technique comes from using the Brush tool to fine-tune the selection by
drawing with either black or white. When abstracted, a mask is shown in black and white; the mask itself
is black, while the unmasked portion is white. In Quick Mask mode, you use black to extend the mask and
white to extend the unmasked, or selected, area.
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6.

10.

Make sure that the foreground color is black and begin painting over the shadow surrounding the strawber-
ries. You might find it helpful to zoom in on the section you're working on by pressing Gtrl++ (Windows) or
Cmd++ (Mac) (Figure 1-29).

FIGURE 1-29

Continue to work your way around the strawberries. If you extend the mask into the desired figure, switch
the foreground color to white by clicking the curved two-headed arrow above the foreground and back-
ground color swatches and apply your brush from within the strawberries.

Understanding the relationship between drawing with black to extend the mask and drawing with white
to push back the mask was my “Oh, wow!” moment with this technique. By zooming in and changing the
brush size (in the Options bar), I'm able to precisely control the boundaries of the mask and, thus, the
selection.

To see the results of your progress, press @ to exit Quick Mask mode and review the current selection
marquee. Press @ again to continue refining the mask.

When you're done, press Q a final time to leave Quick Mask mode. With your selection finalized, press
Ctrl+C (Windows) or Cmd+G (Mac) to copy it to the clipboard.

Since it's a signature element in the design, you may want to reuse it at some later point, so it's a good
idea to save the isolated image separately.

Choose File > New to create a new PSD file. In the New dialog, keep the default dimensions Photoshop
picked up from the clipboard and change the Background Contents to Transparent. Click OK.
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11. When the new file opens, press Gtrl+V (Windows) or Cmd+V (Mac) to paste it to the clipboard
(Figure 1-30).

FIGURE 1-30
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You'll notice the image appears, minus the background. Now, take one more step to clean it up before
saving.

12. Choose the Grop tool, fourth from top of the Tools palette, and drag out a rectangle from the top-left cor-
ner that encloses the strawberries. Double-click inside the cropped area to confirm your choice.

13. Choose File » Save As and store the file in your Chapter 1 folder as just_strawberries.psd.

14. Select the Ghocolate Dipped Gomp document and, in the Layers palette, select the Header layer group.
Drag the just_strawberries image onto the Chocolate Dipped Comp document (Figure 1-31).

Naturally, you could have used the copy/paste method, but in this circumstance dragging from one docu-
ment to the other is just as effective and a bit faster.

The strawberries are a bit too big for the comp, so you'll want to scale the image down.
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FIGURE 1-31
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15. In the Options bar, make sure Show Transform Controls is selected. Click the lower right corner of the
bounding box around the strawberries, press Shift to constrain the aspect ratio and drag toward the upper
left corner, rescaling the image. Release your mouse when the W and H values are approximately 60%.

16. Drag the rescaled strawberries into the header area, about 200 pixels from the left and 50 from the top.
Double-click inside the strawberries to confirm the move.

17. Press Gtrl+S (Windows) or Cmd+$ (Mac) to save your changes. Figure 1-32 shows the final result.

FIGURE 1-32
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CORE TECHNIQUES

EXTRACTING AN IMAGE
EROM THE BACKGROUND
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Figures isolated from their normal background provide powerful
imagery and are often incorporated into Web designs. In addi-
tion to copying and pasting a selection, Photoshop offers three
key methods for extracting an image from the background: the
Extract filter, Background Eraser, and Quick Mask.

The Extract filter is Photoshop’s dedicated user inter-
face for the task of isolating an image from its back-
ground. Choose your image and select Filter > Extract.
When the Extract filter appears, select the Edge High-
lighter tool and draw around the portion of the image
you want to keep. Then click the Fill tool and click within
the desired section. Click Preview to see the results and
fine-tune the background selection with the Cleanup tool
and the foreground with the Edge Touchup tool.

The Background Eraser tool changes any pixels it en-
counters to transparent. You simply draw over the un-
wanted portion of your image to remove the background.

The Quick Mask technique (used in this section’s ex-
ercise) converts a selection into a mask that can then
be easily adjusted and returned to a selection. When in
Quick Mask mode, draw with black using the brush tool
to extend the mask (and consequently, the background)
or white to extend the unmasked area (the foreground).
You can easily go back and forth between the Quick
Mask and selection by toggling the letter Q.
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In this chapter, you got a solid
foundation for creating the basic
graphic elements of a comp. In the
next chapter, you'll complete the
comp with other elements, includ-
ing decorative and content-orient-
ed text before moving on to con-
struct the layout in Dreamweaver
in the final chapter of this part.
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