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Chapter 5: Customizing
Vour Browser Settings

In This Chapter

1 Choosing a home page

»» Working with the cache of temporary Internet files
1+~ Adjusting History settings

1+~ Speeding up your browser

1+ Synchronizing Web pages for offline viewing

1+ Using AutoComplete

In preparation for your extensive travels on the World Wide Web via Inter-
net Explorer, you might need to make some minor adjustments. This
chapter is the place to look for information on everything from how to
change the way Web pages are displayed on your screen to ways to tweak
your browser’s performance.

Changing Your Home Page

Each time you start the Internet Explorer (IE) browser, it opens a specially
designated page, which it calls the home page. The home page is also where
IE goes when you click the Home button on the toolbar. (For more on IE,
read Book [, Chapter 4.)

If your computer isn’t connected to the Internet when you click Home, IE
loads the home page locally from the cache. The cache is an area of a com-
puter’s hard drive used to store data recently downloaded from the Internet
so that the data can be redisplayed quickly. If the page doesn’t happen to be
in the cache at the time (because you deleted its files before quitting the
browser the last time), IE gives you an error message and displays an empty
Web page called about:blank. To return to your home page, you must go
online again and click the Home button.

To change the home page on your computer, follow these steps:
1. Launch the IE browser and go to the Web page that you want to make
the new home page.
2. Choose Tools=>Internet Options.

The Internet Options dialog box appears. Click the General tab if it isn’t
already selected.
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3. In the Home Page section of the dialog box, click the Use Current
button to make the current page your new home page.

You can also type the URL of the page that you want to designate as
your home page in the Address text box.

4. Click OK to close the Internet Options dialog box.

After you designate the page of your choice as your home page, you can
return to that page at anytime by clicking the Home button.

If, for the sake of speed, you want a blank Web page to be used as the home
page, click the Use Blank button. IE then enters about:blank (the name of

its standard blank page) in the Address text box. You also can click the Stop
button on the navigation bar as soon as Internet Explorer starts loading the

page.

Changing the Way Web Pages Look
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A Web page, depending on the computer displaying it, can appear in a vari-
ety of fonts and colors and can use various characters and symbols for dif-
ferent languages of the world. The combination of the Web browser settings
and the design of the individual pages control how Web pages look in IE.

The changes that you make to the IE settings only affect the way Web pages
look on your screen. You don’t have to worry that you're actually changing
somebody’s Web page.

Changing the text size

You can customize your copy of IE so that you get larger, easier-to-read text,
or you can choose a smaller font size that lets you see more text at a time on
the screen. To change the display size of text in Web pages, follow these steps:

1. Choose View>Text Size.

A submenu appears with the following size options: Largest, Larger,
Medium, Smaller, and Smallest. The Largest, Larger, Smaller, and
Smallest font sizes are all relative to the Medium font size (which is the
default size used by IE).

2. Choose the Largest or Larger option to make the text on the current
Web page appear bigger. Choose the Smaller or Smallest option to
make the text appear smaller.

Selecting a different font

Many Web pages do not specify a font for the proportional and fixed-width
(or monospaced) text on the Web page, leaving that determination to IE.
When you first start browsing the Web with IE, it uses Times New Roman to
render nonspecifically defined proportional text and Courier New for all
fixed-width text. If you prefer other fonts for rendering the proportional and
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Figure 5-1:
You can
change the
default fonts
via the Fonts
dialog box.

Changing the Way Web Pages Look

fixed-width text, you can modify one of the IE character sets (different
styles of the alphabet and other symbols).

To choose other fonts, follow these steps:

1. Choose Tools=>Internet Options.
The Internet Options dialog box appears.
2. Click the Fonts button on the General tab.

The Fonts dialog box opens, as shown in Figure 5-1.

Fonts HE

The Fonts vou select here are displayved on Web pages and
documents that do not have a specified text Font,

Language script:  |[REalylateta=)

Web page Fonk: Plain texk fonk:

Swlfaen ;I

Tahoma Lucida Console
Tempus Sans ITC —1 |Lucida 5ans Typeswriter

Tirnes Mew Rorman

Latin ‘ Latin

[o]4 I Cancel |

3. To change the font used to render proportional text, choose a font in
the Web Page Font list box.

Your particular choices depend upon which fonts you have installed on
the computer.

4. To change the font used to render fixed-width text, choose a font in
the Plain Text Font list box.

5. Click OK twice to close the Fonts dialog box and the Internet Options
dialog box.

Changing the text and background colors

If you have problems reading the text on a Web page because of its text
color and background, you might be able to modify these colors (assuming
that the Web page author hasn’t specified his or her own colors). By default,
IE chooses black for the text color and battleship gray for the background
(page) color. To set custom colors for your Web page background and text,
follow these steps:

1. Choose Tools=>Internet Options.
The Internet Options dialog box appears.
2. Click the Colors button on the General tab.

Book |
Chapter 5
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The Colors dialog box appears, as shown in Figure 5-2. In this dialog
box, you can set colors for the text and background as well as the
colors for visited and unvisited hyperlinks.

Colors HE
Figure 5-2: Colors Links
Change the @ Iext; _ vsted:
color of Background: | Uniisiced: [ ]
Web page [+ Use Windows colors [~ Use hover color:
text and the e
background
color. Cancel |

3. In the Colors section of the Colors dialog box, deselect the Use
Windows Colors check box.

Deselecting this check box enables you to specify your own colors.

4. To change the text color, click the Text button in the Colors dialog
box to open the Color dialog box, and then select a new color from
the Basic Colors palette. Then click OK.

5. To change the background color of the page, click the Background
button in the Colors dialog box to open the Color dialog box, and
then select a new color from the Basic Colors palette. Then click OK.

6. When you finish setting the text and background colors that you want
to use, click OK twice to close the Colors dialog box and the Internet
Options dialog box.

When the Internet Options dialog box closes, IE displays the current Web
page in the text and background colors that you selected. If it doesn’t, this
means that the author of this Web page has explicitly set a style for the page,
which takes precedence over the browser default settings that you set.

Changing the way your browser displays hyperlinks

Hypertext links (hyperlinks) are a special form of text that, when clicked,
take you to a new location on the current page or to another page alto-
gether. Traditionally, blue underlined text on-screen indicates the hypertext
links that you haven’t yet followed. When you follow a hypertext link and
later return to the original page, IE lets you know that you've followed the
link by displaying the same hyperlink in purple underlined text. People
often refer to these links as unvisited and visited links. To modify the color
of hypertext links in IE, follow these steps:

1. Choose Tools=>Internet Options.
The Internet Options dialog box appears.

2. Click the Colors button on the General tab.
The Colors dialog box appears.

7
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3. To change the color for visited hyperlinks, click the Visited button Book I
and choose a new color from the palette in the Color dialog box. Click Chapter 5
OK to close the Color dialog box.

4. To change the color for unvisited hyperlinks, click the Unvisited @ o
button and choose a new color from the palette in the Color dialog s&
box. Click OK to close the Color dialog box. 2 2,
In addition to customizing the visited and unvisited hypertext colors, §=§
you can choose to assign a hover color: that is, the color that hyper- 2 '=o<

N =

linked text becomes when you position your mouse pointer over it.

5. To have text hyperlinks turn a special color whenever your mouse
pointer hovers above them, select the Use Hover Color check box. If
you don’t like the default color of red, click the Hover button and
choose a new color from the palette in the Color dialog box. Click OK
to close the Color dialog box.

6. When you’re finished changing the link colors, click OK twice to close
the Colors dialog box and the Internet Options dialog box.

Customizing Toolbars

IE contains several toolbars, which you can customize to your liking. You
can change the display size of toolbars, hide toolbars, and add buttons to
toolbars. Refer to the Book I, Chapter 4 if you need a refresher on the tool-
bars included with IE.

Changing the size of toolbars

You can minimize the amount of space that the toolbar takes up by putting
Internet Explorer in full screen view. To do so, choose Vieww>Full Screen or
press F11. The full screen view shrinks the amount of space given to the
toolbars — IE hides all the toolbars except the Standard Buttons toolbar,
which now uses smaller icons.

When IE is in full screen mode, the browser adds an Auto-Hide command to
the shortcut menu that appears when you right-click the remaining
Standard Buttons toolbar. Selecting the Auto-Hide command causes the
entire toolbar to slide up until it’s off the screen. To redisplay the toolbar,
move the mouse pointer up to the top of the IE window. When the mouse
pointer rolls over the area where the toolbar would normally be, the toolbar
magically (and temporarily) reappears.

To again fix the Standard Buttons toolbar on the screen, choose the Auto-
Hide command from the toolbar’s shortcut menu. You can also take IE out
of full screen mode by pressing F11.

Hiding and unhiding a toolbar

You can hide the Standard Buttons toolbar, the Address bar, or the Links bar.
To do so, choose View=>Toolbars. From the submenu that appears, click to
remove the check mark next to the toolbar that you want to hide. You can

67,
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also right-click any empty area of the toolbar and choose the appropriate
name (Standard Buttons, Address bar, or Links) from the toolbar shortcut
menu. To display the hidden toolbar again, reverse this procedure.

Adding a button to the toolbar

You can add a button to the Standard Buttons toolbar to make the button’s
command more accessible. Follow these steps:

1. Choose View->Toolbars->Customize or right-click the Standard
Buttons toolbar and choose Customize from the shortcut menu.
The Customize Toolbar dialog box appears.

2. In the Available Toolbar Buttons list box, click the button you want to
add to the toolbar, and then click Add.

IE adds the button to the end of the list in the Current Toolbar Buttons
list box.

3. (Optional) To change the position of the newly added button on the
toolbar, click the button in the Current Toolbar Buttons list box; then
click the Move Up button one or more times.

4. Click the Close button to close the Customize Toolbar dialog box.

Changing the History Settings

When you come across a wonderful Web page, you can save the page to your
Favorites list or create a shortcut to the page to make returning there easy.
(See Book I, Chapter 4 for more details.) However, if you forgot to save a Web
page to your Favorites list at the time it was displayed in the IE browsing
window, you can still get back to it by finding its link in the History folder.

By default, the Internet Explorer History folder retains links to the pages
that you visited during the last 20 days, but you might want to change the
length of time that links remain in your History folder. For example, you can
increase the time so that you have access to Web pages visited in the more
distant past, or you can decrease the time if you're short on hard drive
space. You can also purge the links in the History folder to free up space on
your hard drive and restore all hyperlinks to pages that you've visited to
their unvisited state (and colors).

To change the History settings, follow these steps:

1. Choose Tools=>Internet Options.
The Internet Options dialog box appears.

2. In the History section, type a new value in the Days to Keep Pages in
History text box or click the up or down arrows to select the desired
value.

3. Click OK.
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To purge the links in the History folder, follow these steps: Book |
Chapter 5

1. Choose Tools=>Internet Options.

The Internet Options dialog box appears.

(=~ N
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2. Click the Clear History button on the General tab. % é‘
3. Click Yes in the Internet Options alert box that appears, which asks a 5.
whether you want to delete all items from your History folder. §‘_°<
)

@ s

4. Click OK to close the Internet Options dialog box.

Specifying Mail, News, and Internet Call Programs

IE can work with other programs to add to its functionality and capabilities.
Microsoft has created certain programs that it intends to work so closely
with IE that it refers to them as members of the Internet Explorer Suite.

The auxiliary programs that are included with IE as part of the suite depend
upon which type of installation you perform:

4+ Custom: This installation lets you select which auxiliary programs are
installed along with the browser and Outlook Express.

4+ Minimal: This installation gives you the Microsoft Internet Connection
Wizard along with IE.

4+ Typical: This installation includes the browser plus Outlook Express,
Windows Media Player, and a few multimedia enhancements.

One of the most practical of these many auxiliary programs is Microsoft
Outlook Express, which adds e-mail and news-reading capabilities to IE. If
you do the typical installation and your computer is equipped with sound
and video hardware, such as a microphone and video camera, you can use
NetMeeting to make Internet calls or set up video conferencing. Even if you
don’t have such hardware, you can use Chat (originally known as Comic
Chat) as part of NetMeeting to participate in online chat sessions.

To see which programs are configured to run from IE (such as the Mail, News,
and Internet call programs) and (if necessary) change them, follow these
steps:

1. Choose Tools->Internet Options; then click the Programs tab (see
Figure 5-3).

2. To change the program listed in the HTML Editor, E-Mail,
Newsgroups, Internet Call, Calendar, or Contact List text boxes, select
a new program by using the drop-down list boxes.

3. After you finish checking over the programs and making any changes
to them, click OK.

6.,
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Internet Options 21
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installing IE, you can click the Reset Web Settings button in this dialog box to
restore your original IE default settings for search pages and your home page.
Clicking this button also restores the prompt to ask you whether you want to
make IE your default browser each time you launch Microsoft’s browser.

Speeding Up the Display of Web Pages

You can speed up the display of Web pages on your computer, but unless you
do it by getting a faster connection (with a modem upgrade, a DSL or ISDN
line, or a cable modem), the increase in speed comes at the expense of hard
drive space or viewing content. You can also dramatically speed up the dis-
play of Web pages by turning off the display of most pictures, animations,
videos, and sounds. To make this kind of change to IE, follow these steps:

1. Choose Tools->Internet Options; then click the Advanced tab.

2. In the Multimedia section of the Settings list box, deselect the check
boxes of as many of the items as you want to disable to get a suffi-
cient speed boost.

These items include Play Videos, Play Sounds, Smart Image Dithering,
Show Pictures, and Play Animations.

3. Click OK to update the new settings and close the Internet Options
dialog box.

Now when you open new Web pages, weird (but fast) generic icons replace
the multimedia contents that you’'ve disabled. If you still see graphics on
the Web pages that you visit, click the Refresh button on the Internet
Explorer toolbar to remove their display.

After disabling the Show Pictures and Play Videos settings, you can still
choose to display a particular graphic or play a particular video. Just

50
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right-click the icon placeholder and choose Show Picture from its shortcut Book |
menu. IE then downloads and displays the particular graphic or video that Chapter 5
you selected.

To restore the multimedia items that you disabled, click the Advanced tab g" g
of the Internet Options dialog box again and mark the check boxes to select )
the desired Multimedia items (or simply click the Restore Defaults button). 2 E
Then click OK to save your changes and close the Internet Options dialog §§
box. Remember that you have to use the Refresh button on the Internet El '=°<

N =

Explorer toolbar to see and hear multimedia items on pages that were
downloaded to the cache when these items were disabled.

Synchronizing Offline Web Pages

\\3

To make sure that you have the most current data from an Active Channel
or a Favorites Web site that you've made available for browsing offline, you
might want to update the contents of your cache — a process known as syn-
chronization. To synchronize individual Active Channels or favorite Web
sites, follow these steps:

1. Choose Tools=>Synchronize.
The Items to Synchronize dialog box appears.

2. In the Select the Check Box for Any Items You Want to Synchronize
list box, make sure that the check box for each offline Web page you
want updated is selected. Deselect the check box of any offline Web
page you don’t want updated.

3. Click the Synchronize button.

IE then connects you to the Internet and begins the process of checking
each selected offline Web page for updated content, which is then automati-
cally downloaded into your computer’s cache. Synchronizing enables you
to browse the updated contents (using the Favorites Explorer bar) when
you’re not connected to the Internet.

If you connect to the Internet over a local area network (LAN) or via a cable
modem, digital subscriber line (DSL), or Integrated Services Digital Network
(ISDN) connection (you can therefore go online at anytime), you might want
to specify when and under what conditions particular offline Web pages are
synchronized. (Read all about the different Internet connection types in
Book I, Chapter 1.) To do this, choose Tools>Synchronize. Then with the
Offline Web Pages folder selected, click the Setup button. When you click this
button, Internet Explorer opens the Synchronization Settings dialog box.

The Synchronization Settings dialog box contains three tabs: Logon, On
Idle, and Scheduled:

4+ Logon/Logoff tab: Use this tab to select the offline pages that you want
synchronized whenever you log onto or log off a networked computer.
Select the check boxes for the offline pages to be synchronized when
you log onto your computer; then select the When I Log On to My
Computer check box.

51,
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On Idle tab: Use this tab to select the offline pages that you want syn-
chronized whenever your computer is idle for a particular period of
time. Select the check boxes for the offline pages to be synchronized
when your computer is idle for a particular period, and then select the
Synchronize the Selected Items When My Computer Is Idle check box.
To specify how long an idle period to use, click the Advanced button
and change the settings in the Idle Settings dialog box.

Scheduled tab: Use this tab to set up a custom schedule by which
selected offline pages are routinely synchronized. To create a new sched-
ule to be used, click the Add button and use the Scheduled Synchroniza-
tion Wizard to take you through the steps of creating and naming a new
custom schedule for certain offline Web pages. To edit the settings for a
particular default schedule, click the name of the schedule (such as CNN
Desktop Scores Recommended Schedule); then click the Edit button to
open a dialog box in which you can modify the current settings. (The
name of the dialog box and its tabs and options vary depending on the
particular synchronization schedule that you're editing.) This tab is
useful for downloading Web sites you like to read when a connection is
unavailable, like, for example, when you are on a long plane trip.

Customizing Your AutoComplete Settings

The AutoComplete feature makes it easier to fill out addresses, forms, and
passwords by providing a drop-down list of suggestions as you type, based
on your previous entries. IE has added the capability to customize the Auto-
Complete settings. To customize your AutoComplete settings, follow these
steps:

1.
2.

3.

Choose Tools~>Internet Options and click the Content tab.
Click the AutoComplete button.
The AutoComplete Settings dialog box appears.

Select the check boxes for the items for which you want to use
AutoComplete.

Select the Web Addresses check box to have AutoComplete suggest URLs
for previously visited Web pages. Select the Forms check box if you want
AutoComplete to match the field values from the most recently submit-
ted form. Select User Names and Passwords on Forms if you want Auto-
Complete to retain your user ID and password for sites that require them.

. (Optional) To delete the form information that AutoComplete retains,

click the Clear Forms button. To delete the list of user IDs and pass-
words that AutoComplete retains, click the Clear Passwords button.

To delete the list of Web addresses that AutoComplete keeps on file, you
must click the Clear History button on the General tab of the Internet
Options dialog box.

5. Click OK twice to close both dialog boxes.
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Stopping Script Debugging

How many times have you run across a pop-up
message that asks whether you want to debug a
Web page? Debugging is one of the most annoy-
ing so-called features in |E. If there’s a bug in a
Web page — that is, if the person who created
the Web page made a mistake — why would you
want to fix it? Relax if you're worried that you are
at fault for triggering these unwanted Debug
messages. You didn’t do anything. The messages
occur because IE can't figure out how to read a
Web page. The person who wrote the Web page
screwed up. Not you.

Fortunately, it's easy to turn the blasted error
messages off, permanently:
1. Start Internet Explorer.

2. Choose Tools=>Internet Options:>
Advanced.

The Internet Options dialog box appears.

Select the Disable Script Debugging
check box (if it's not selected by default),
in the Browsing section.

It's probably not selected, and that's why
you see the Do You Wish to Debug?
messages.

Deselect the Display a Notification About
Every Script Error check box.

It's probably not selected already, but you
should make sure it stays that way.

Click OK.

You'll never be asked to debug a script
again.
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