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Chapter 1

Handling Web Graphics Tasks

In This Chapter

Graphic language for the Web
Using Paint for Web graphics
Creating GIF and JPEG files

Graphics are the key to making the Web interesting and useful. Before the
Web became popular, users employed the Internet largely to send text
messages back and forth. In the early 90s, Marc Andreesen added the <IMG>,
or image, tag to the first widely used Web browser, Mosaic. Suddenly, the
Web came to life.

Text alone is boring, but add graphics and it becomes interesting. Think of
the difference between a traditional text-only book and a magazine or news-
paper. Text-only books are vitally important, of course, but newspapers and
magazines catch and hold the eye. Now more and more books, such as the
one you are holding in your hand, use graphics and sophisticated layouts to
make them more readable and fun.

Graphics clearly make the Web fun for users, but what do they mean to
people who create Web pages? Most Web page creators know how to write
fairly presentable text for Web pages. However, people are taught the three
R’s — reading, writing, and arithmetic — and there’s no G for graphics or D
for design in the three R’s. So, although most people can create a Web page
with fairly interesting text, they might have trouble using graphics to make
the page look good or to help make a point.

This book closes that gap by showing you the basics for using graphics in
your Web pages and designing them so that they make a positive impression
on all your Web page users — even you!
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Words for the Web-Wise

You probably know quite a few Web graphics terms; in fact, you may not even
realize how many of them you do know. Although widely used, many of these
terms are poorly understood. So we take a moment to explain them. In doing
so, we can also begin to communicate some of our philosophy about how to
create great Web graphics.

A few Web words

Before you do anything on the Web, the first word you need to know is HTML —
HyperText Markup Language. HTML is a mix of ordinary text with special
commands called tags.

Because HTML tells computers what to do, it’s referred to as code, even
though it’s not a full programming language. However, HTML is much easier
to read than computer programming languages are. Here’s a snippet of HTML
code:

<H2>Fun with Clowns</H2>
Here's an example of an image within a Web page: a clown!<P>
<IMG SRC="clown.jpg">

Figure 1-1 shows the code snippet, along with the Web page it produces. As
you can see, “Fun with Clowns” is a heading. Here’s a simplified description
of what all the pieces in the HTML snippet do:

1 <H2> tag: Tells the Web browser to display the following text as a
header.

v “Fun with Clowns”: This text is displayed as a header because it is pre-
ceded by the <H?> tag.

v </H2>: Tells the Web browser to stop displaying text as a heading and to
put the next text or graphic on a new line.

v “Here’s an example . . .”: More text. No tags affect it, so it is displayed
normally.

v <P>: End of a paragraph. Put the next text or graphic on a new line.
v <IMG SRC="clown.jpg">: Display an image. The file to display is
clown.Jjpg.

Don’t be afraid to go over this code a few times. Compare the HTML code to
the Web page it produces. After you understand how the code works, you’ll
know much of what you ever need to know about HTML.

o
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In addition to understanding the role of HTML, you need to know what a Web
server is. A Web server is a computer that actually stores the files that make
up Web pages. When you type a Web address, such as www.dummies.com, a
request goes out over the Internet for the Web server that has the name
www.dummies.com. Eventually, the request reaches the Web server with that
name, and the server responds by sending back an HTML page stored at the
base directory, or root, of the Web server’s file system.

Through a bit of trickery, a single Web server can contain multiple domains.
Each domain is mapped to a separate subdirectory on the server. It can be a
bad day for several people when one of these Hydra-headed Web servers
goes down!

When you use the Web, in general here is what happens: A request from the
user causes a Web server to send a particular file to the user. A Web page
consists of an HTML file plus all the graphics files referred to within the
HTML file. For more information on this topic, check out the sidebar “One is
the loneliest number,” later in this chapter.

Finally, you need to understand download time, the time it takes a file to be
transferred from a Web server to your computer. Download time includes the
time it takes your computer to request an HTML file and then request each
graphics file, along with the time it takes the Web server to start transferring
the files and the time it takes all the files to arrive at your computer.

o
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As you can probably see, having a slow connection to the Web at any point
greatly increases the download time for a Web page. Some users, of course,
have fast connections such as a shared corporate data line, or a cable line
and cable modem, or a DSL phone line and DSL modem. Others have a slow
connection — a regular phone line and a 28.8 Kbps, 33.6 Kbps, or 56 Kbps
modem.

A slow user connection makes download time longer, but so does a slow or
busy Web server, or a slow connection between the Web server and the
Internet, or congestion on a corporate user’s Local Area Network (LAN), or
on the Internet as a whole. Web pages can take a long time to download for
many reasons.

However, the biggest limiting factor on download speed is still the user’s con-
nection. It takes about 1 second to download 3K of data over a typical
modem connection, so a 30K graphic takes 10 seconds to download. That’s a
long time for the user to sit and wait! This book will give you many tips and
techniques for achieving good-looking results while minimizing the user’s
waiting time.

To summarize, HTML is the code in which Web pages are written. You may
already know how to use HTML. If not, HTML 4 For Dummies, 4th Edition, by
Ed Tittel and Natanya Pitts (Wiley Publishing, Inc.) is a good place to start —
or use a tool such as FrontPage or Dreamweaver to create the Web page with-
out dealing directly with HTML.

A Web server sends HTML files and the graphics files associated with them to
the user’s computer. Each Web page is one HTML file plus the graphics to
which the HTML file refers (except for framed pages, described in the sec-
tion, “A few Web design words™). The total amount of time it takes for all the
files to be sent over the Internet is the download time of the page.

Some graphic language

In our explanation of how HTML works, you may have noticed that the image
of a clown’s face was stored in a file called c1own. jpg. This image is a JPEG
file, a term you’ve no doubt heard before. Check out the upcoming sidebar,
“Convention-al filenames,” for information on naming HTML, JPEG, and GIF
files.

JPEG stands for Joint Photographic Experts Group. Many years ago, a group
of experts joined together to specify a way to compress photographic images
so that they would take up much less space when stored in a computer file,
with as little loss of quality as possible. JPEG is the answer they came up
with, and it’s a good one.

o



d525956 ChOl.gxd 2/28/03

8:48 AM Page 13 $

Chapter 1: Handling Web Graphics Tasks

As you may already know, JPEG is used almost exclusively for compressing
photographs. It’s lossy compression — you actually lose information when
you store an image in JPEG format. The beauty of JPEG is that you keep most
of the impact of the original photograph while storing the image in a file
that’s much smaller than the original.

The complement to a JPEG file is a GIF file (GIF standing for Graphics
Interchange Format). Several people invented GIF — the argument over just
whom is still going on — and was popularized by the CompuServe online ser-
vice about 20 years ago.

GIF is good for storing images that don’t have lots of colors in them, which
includes most images created from scratch on a computer. GIF files are used
for storing just about any image that didn’t originate as a photograph. Most
of the little graphics in a Web page are GIF files.

GIF also supports three neat tricks that you won’t usually find in JPEG files:
interlacing, transparency, and GIF animation. Interlacing allows a GIF file to
download in bands so that a blurry version of the image appears quickly and
then sharpens as the rest of the image data downloads. Transparency allows
you to drop the background around an image so that it appears to be embed-
ded directly in the page, not surrounded by a rectangular window. GIF anima-
tion is also the easiest way to create animated images on your Web pages.
You find more on all these features in Chapter 2.

Special effects such as interlacing, transparency, and animation are impor-
tant, but the most important thing about HTML, GIF, and JPEG files is that
they’re the only file types recognized by nearly every Web browser (this dif-
fers greatly from typical PCs and Macintosh computers, which are likely to
have scores of different file types). If you understand how HTML, GIF, and
JPEG files work, you've already gone a long way toward understanding how
Web pages function.

A few Web design words

There are libraries of books on page layout for printed pages, with specific
coverage of layout for books, magazines, newspapers, and other kinds of
printed material. The Web is a relative newcomer here; the art of page design
for the Web is still in its infancy.

However, some good ideas are emerging, and we include them in our recom-
mendations for how to do things. You do, however, need to know a few terms
in order to participate in the discussion.

13
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Convention-al filenames

If you just want to trust us, you can read the rest
of this paragraph, follow the conventions (that
is, rules) it describes, and go on: Always simplify
your filenames to an 8-character filename with
no uppercase letters, spaces, or special char-
acters — just the 26 letters of the alphabet and
the 10 digits, 0-9. Always end your filenames
with . htm for HTML files, . gi f for GIF files, or
. jpg for JPEG files.

Some of you, however, will want to know why
these rules, or conventions, should be followed.
Here's a brief description.

Users are likely to employ four computer sys-
tems to transfer and store Web files, in this
order of preference: PCs running Windows;
Unix systems; Macintosh computers; and PCs
running DOS.

Each of these computer systems has different
rules for handling filenames. PCs and Macs
ignore uppercase versus lowercase differ-
ences; Unix systems treat BIGFILE.htm and
bigfile.htmasdifferentfiles. PCs, Unix sys-
tems, and Macs all have different lists
of special characters that they support,
whereas PCs running DOS (or early versions of
Windows) recognize only “8.3” filenames — an
eight-character filename followed by a three-
character extension.

The big problem is that when you send your file
to be hosted on a Web server, you may not know

the kind of system it will end up on. Your hosting
provider may even move your Web site from,
say, Windows to Unix without telling you. In
addition, your file may be stored temporarily on
any kind of system on its way to a long-term
home on another kind of system.

Because different systems use different file-
name conventions, putting the wrong filename
on the wrong kind of computer — even briefly,
as the file is moved around — can actually
cause the filename to be changed. All links to
such files will instantly break. Note that naviga-
tion or the display of graphics on your Web site
can stop working for reasons that are hard to
determine after the fact.

The safest bet is to keep your filenames short
and simple, as previously described. If you just
can't stand short filenames, though — and
they're harder to manage than long ones — at
least follow these looser rules: Keep the main
part of the filename to 30 characters or less; use
three-letter, not four-letter, extensions; never
use spaces; avoid special characters; and
never use capital letters.

If you follow these rules, your files are much
more likely to behave well as they travel through
cyberspace — and to have the same filenames
that you expect them to have when they finally
end up in their long-term home on a server.

The first, and most important, term is page weight. Page weight is the total

size, in kilobytes (K), of all the files in a Web page, which means the HTML file
that makes up the Web page plus all the graphics referred to in the HTML file.

Figure 1-2 shows a typical Web page as it downloads. The Web page was cap-
tured partway through downloading to dramatize the fact that most users
don’t see the whole page at once; they see part of it and have to wait for the
rest.

o
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Smart Web page developers set a maximum page weight for all the pages in
their sites. A typical page weight for a commercial Web site is 30K, or a 10-
second download time for a typical user on a slow modem connection.

Smart Web page developers also break the page weight rule sometimes. For
example, it may be a good idea to put a high-resolution photo of the hot new
bicycle you're selling on your Web page, even if it’s more than 30K. Fair
enough — but provide a thumbnail version first so the user can get an idea of
what the bike looks like before deciding whether he or she wants to click the
thumbnail or a link to see a larger version of the picture and wait for the
download.

Another key Web design term is tables. A table is an organizational tool that
Web page developers use to divide a Web page into rectangular pieces. Each
piece has different content.

You may have visited a badly designed Web page that didn’t have a table-
based format. If so, you first saw text appearing without graphics. Then, just
as you started reading the text, it lurched alarmingly to one side. A graphic
then started to appear where some of the text had been. With a really poorly
designed page, this can happen two or three times as various graphics
appear on-screen.

o
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The good news is that a properly designed table-based page locks all the
pieces into place. (You have to specify the size of table cells and images in
your HTML file for this to work correctly.) Text flows into the space where it
belongs, graphics appear where they should, and nothing lurches. The user
can start reading even before the graphics appear. So tables are a good thing.

Frames, on the other hand, are not necessarily a good thing. Frames are like
table cells on steroids. Each frame is a totally separate area in the Web page
with its own separate HTML file and, potentially, its own scrollbars. Having
separate scrollbars can sometimes be confusing for users. Framed pages give
you a lot of options, but they tend to burden the poor user with more deci-
sions than they may really want to make on a Web page.

Frames can be used intelligently, and we talk a bit about how in Chapter 6.
For an example of a positive use of frames, see Figure 1-3, a page created by
one of the authors (Bud Smith). Notice there’s only one scrollbar — the fact
that the page was created with frames is almost invisible to the user. In most
cases, that’s the way to do it.
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Keep in mind that page weight is an important part of managing how long
users will have to wait for your Web pages to download. Tables and frames
are important page layout tools to make your pages look and work better —
tables are almost always good, whereas frames can be used effectively or
ineffectively.

P To see all the files in a Web page, save the Web page using a recent version of
Internet Explorer. The HTML file will be saved as a document, and all the
images in the Web page will be saved in a folder with the same name as the
document. Look in the folder to see all the graphics files associated with the
Web page. Right-click any file or folder to see just how large it is in kilobytes.
Divide the total of all the file sizes by 3, and you’ll see how many seconds it
takes a typical modem user to receive the entire Web page.

Using Paint for Web Graphics

You can create lots of useful images using a free program that comes with
every Windows PC: the Paint program. Using newer versions of Paint, you can
even save graphics in GIF or JPEG format. The quality of the results won’t be
very good, but Paint is a great tool to have handy when you’re using a
random PC in someone else’s office, or at an Internet café, or in a hotel busi-
ness area.

Paint is also great when you’re just trying out ideas or are in too big a hurry
to boot up a more capable program, and it saves files in Windows bitmap
format (the filename ends with . bmp). Bitmap format uses lossless compres-
sion — it doesn’t compress your file, so you can edit it and save it again and
again without losing image quality.

Although bitmap format preserves image quality, when you resave a file in a
GIF or JPEG format, you may lose some image quality (this is a possibility
with GIF and a certainty with JPEG). Also, Paint does a lousy job of saving
files, so you may want to reopen your original file in a better program later
and save a superior GIF or JPEG version. Always keep a bitmap original of
your Paint graphics so you can start with a pristine version before saving the
final version to GIF or JPEG for display on the Web.

In this section, we give you step-by-step instructions on how to use Microsoft
Paint to select a portion of a screen shot. Along the way, we provide several
tips and tricks that you'll find useful no matter what image-editing program
you're using.

You may have some experience with Paint or other graphics programs

already, or you may be new to this kind of program. In either case, walk
through these steps. You’'ll almost certainly discover something new.

o
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Follow these steps to capture a screen shot using Paint:

1.

Open the Windows Paint program by choosing Start>Programs->
Accessories= Paint.

The Paint program may be in a different folder on your system — look
around until you find it, and then open it.

. Open an interesting file on-screen.

You can open a graphics file, a word-processing document, or a spread-
sheet. You can fire up a Web browser and go to a Web page you like. Or
just leave the Paint program in the foreground.

You can use any content you want for this exercise, because you don’t
end by putting something on the Web. However, always be careful when
you capture content that may be protected by copyright. Don’t publish
such content on the Web without permission.

. Press the PrtScrn, or Print Screen, key.

It may have a slightly different name on your keyboard, such as PrtSc,
but the key should still be recognizable. We refer to it as the PrtScrn key
for consistency in this book.

Pressing PrtScrn makes a copy of the current screen contents — in
bitmap format — and puts the image in the Windows Clipboard.

. Bring the Paint program to the foreground, if it isn’t already.

A blank drawing area appears in Paint.

. Choose Edit=>Paste (Ctrl+V).

The screen image is pasted into the Paint drawing area. It will be larger
than the window size of the Paint program.

Now choose part of the image to make into a GIF file.

. Reinitialize the selection rectangle by clicking the Eraser icon and

then the rectangular Select icon (the dashed-box icon in the upper-
right corner).

When you first paste an image into Paint, the selection rectangle is
drawn around the entire pasted image. To select part of the image,
rather than the whole thing, you have to deselect the entire image by
clicking somewhere else. But, because the screen image fills the entire
Paint window, the best place to click is in the tools area.

. Scroll to an interesting area of the screen, and using the selection rec-

tangle, click and drag to select the area you’ll use for your graphic.
Select an area about 250 x 250 pixels in size.

Figure 1-4 shows how the screen looks during this process.

o
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8. Copy the selection to the clipboard by choosing Edit=>Copy or by

10.

11.

12.

pressing Ctrl+C.
. Clear the current image by choosing Filex>New or pressing Ctrl+N.

A dialog box appears to ask, “Save changes to untitled?” You've already

copied the only piece of the captured screen image that you want, so
click No.

Press N or click the No button to bypass saving the file and close the
dialog box.

The drawing area is cleared.

Make the drawing area smaller by grabbing the lower-right corner of
it and dragging it up and to the left — leave an inch or so in the
upper-left corner of the screen.

When you do this and then paste the selection, the drawing area will
automatically expand to fit the selection.

Paste the selection into the drawing area by choosing Edit=>Paste or
by pressing Ctrl+V.

The selection will appear in the drawing area.

o
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13. Save your file (in bitmap format) by choosing File=>Save or pressing
Ctrl+S.

Because the document has not previously been saved, the Save As
dialog box appears.

14. Use the dialog box to navigate to the folder of your choice on your
hard disk or to the desktop. Then press Alt+S or click Save to save the
file and close the dialog box.

Your file is saved in bitmap format.

Creating GIF and JPEG Files

SMBER
ég“

GIF files are really cool. You can do all sorts of neat things with them.
However, for now, we’re just going to explain the basics on how GIF works,
how to create a GIF file, and how to use a GIF file in a Web page.

As we mentioned previously, GIF stands for Graphics Interchange Format. It
has been around for a long time and supports neat tricks such as interlacing,
transparency, and GIF animation.

The GIF format is very limited — and very efficient. No GIF graphic can have
more than 256 different colors in it. This means that GIF graphics can be very
small files, can be created easily, and can be displayed quickly.

Photographs, however, tend to have hundreds or thousands of different
colors in order to accommodate subtle shadings found in natural images. So
GIF is not usually a good choice for photographic images.

GIF is perfect, though, for most of the graphics that people create on comput-
ers, because most of us lack the patience or talent to use anything like 256
colors in the graphics we create. All the bullets, dingbats, business graphics,
American and other flags, and cartoonish-looking images you see on the Web
are stored and transferred as GIF files (or should be!).

JPEG, on the other hand, is perfect for photographs. Photos use hundreds or
thousands of different colors to accommodate subtle shades. When you or |
look at a photograph, we see a few colors — brown hair, a red sweater, a
green lawn. But the photograph actually uses hundreds or thousands of shad-
ings of hair color, or of the folds of a sweater, or of the rise and fall of a grassy
hill to communicate depth and other subtle features of the image.

The JPEG file format uses some fairly tricky technology to assign color pat-

terns to groups of pixels in a photograph. These patterns can be stored much
more compactly than individual pixel colors. JPEG also allows you to control

o
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What about the Mac (and Unix)?

This book focuses on the Windows versions of
various programs such as the free Microsoft
Paint utility, Paint Shop Pro, and Photoshop
Elements. This is for two reasons. The first
reason is, of course, that many more people use
a PC than a Macintosh. Focusing on PC users
makes it much easier for us to give simple,
straightforward steps for solving common
graphics problems.

The other reason is more subtle: Most
Macintosh users already know how to perform
basic graphic tasks. The Macintosh is very pop-
ular among graphics pros. Relatively few Mac
users are novices when it comes to graphics in
general, or Web graphics in particular.

One of us (Peter Frazier) is a graphics pro who
uses a Mac whenever possible; the other (Bud
Smith) worked at Apple for five years and still
uses a Mac on occasion. Both of us are aware
of Mac-specific concerns. But we're also aware
that providing instructions for multiple platforms
makes it harder for everyone to follow what
should be simple steps.

Also, we're both aware that creative people
who use a Mac or Unix for most of their work
need a Windows PC with Web access for test-
ing their output before it goes up on the Web.
So, if you have a Windows PC available, please
consider using it to run the programs mentioned
in this book.

If you are a Mac user who's a graphics novice
and lack even occasional PC access, please
use available Macintosh programs — the Mac
Notepad, the excellent BBEdit text editor, Claris
Draw and Paint, and others — to duplicate the
steps given here. Similarly, if you're a Unix user,
utilize programs available to you to create plain
text files and simple graphics. Or get access to
a Windows PC to run the programs mentioned
in this book, as well as to test your graphics and
Web pages before putting them up on the Web.
We aren't able to provide specific steps for
Macintosh or Unix in this book, but we hope
that, if you use these platforms, you'll be able to
use your system or a borrowed Windows PC to
follow along with the main concepts of the book.

how much the various shades in a photograph are averaged out into each
other. You can have a crisp, high-resolution image that’s stored in a fairly
large file, or a bumpier, blotchier image that’s quite small in file size.

In this section, we describe how to create a GIF file using a captured image.
Then we show you how to create a JPEG file as well. Afterward, we demon-
strate how to combine the GIF and JPEG files in a Web page.

Saving a Paint file in GIF format

In the section, “Using Paint for Web Graphics,” earlier in this chapter, we

show you how to capture a screen image and bring it into Paint. You can also

open an existing bitmap image or a GIF or JPEG file in Paint.

o
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One is the loneliest number

It's hard for most people to understand why
graphics files take up so much space, espe-
cially compared to text. Here's a brief explana-
tion of the answer.

Atext file is made up of 26 characters — the let-
ters of the alphabet — plus digits, capital let-
ters, and punctuation in various combinations.
A single text character or punctuation mark
accounts for many, many pixels on the screen,
generally at least 5 pixels across by 9 pixels high
for a single character, plus many pixels of white
space around each character.

A graphics file is much more complex. Every
pixel has its own color. In a GIFfile, a single pixel
can be one of 256 colors. In other graphics for-
mats, each pixel can be any of thousands of
colors.

Here's the first tricky part. A computer stores
information in bits — each bit is either a 0 or a
1. Eight bits are combined into one byte. With 8
bits available, each setto 0 or 1, a byte can con-
tain up to 256 separate possible values.

Text characters are stored one character per
byte. So a single byte holds a character that
takes up about 45 pixels on the screen. But
graphics images need many more bytes. A GIF
image requires one byte for every pixel — 45
times more bytes per pixel than a typical text
character. Other graphics formats use two,
three, or four bytes per pixel — and require that
much more storage than a GIF image.

A Web page full of text requires only about 2,000
bytes (2K) when stored. A Web page filled by a
GIF image will require about 240K — or one-
fourth of a megabyte (MB) — when stored. An
image that uses more colors will be 2, 3, or 4
times as large — up to 1MB in size.

Here's the second tricky part. A typical phone
modem can download about 3 kilobytes per
second. That's more than a full page of text in 1
second. But the same phone modem would
require nearly 2 minutes to download a full-
page GIF image and 4, 6, or 8 minutes to down-
load a full-page graphic in some other format.

Even worse, for technical reasons, the Internet
is much better at transmitting lots of small files
than it is at sending a few big ones. Small files
are requested and sent quickly; if one is held up,
others are easily transferred around it. Big files
tend to cause bottlenecks all along the line,
slowing transmission further. In many cases, big
files don't download correctly the first time and
need to be retried one or more times before they
finally make it to the user.

This is why Web pages need to be text-heavy;
they would take far too long to send as all-
graphics or graphics-heavy pages. If you
become frustrated by all the work it takes to
downsize and compress your graphic images,
just think how frustrated users would be if they
had to wait two minutes or more every time they
clicked a link to a Web page.

When you open a file in Paint, you can save it as a GIF file. Follow these steps:

1. If you have not already done so, start Microsoft Paint by choosing
Start-> Programsr> Accessoriesc> Paint.

2. Press Ctrl+O or choose Filew>Open to open an existing graphics file.

o
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Figure 1-5:
The GIF that
keeps on
giving.

Chapter 1: Handling Web Graphics Tasks 23

Use a file created with a screen capture, as described in the “Using Paint
for Web Graphics” section, or open an existing graphics file on your hard
drive.

You can use Starte>Searche>For Files or Folders to bring up the Search
dialog box. Search for bitmap (. bmp), GIF (. gif) or JPEG (. jpg) files.
Open the file you choose in Paint.

. To begin saving the file in GIF format, choose Filec>Save As.

The Save As dialog box appears.

. From the Save as Type drop-down list, select Graphics Interchange

Format (*.gif), as shown in Figure 1-5.

Save As
Save n |ﬁ My Pictures ﬂ Lol £ B
> &
3
@
AN

=

A

J

| »
File name [250:250 | Save
=] Cancel

<

Save as bype: |Graph|:s Interchange Format [ *.aif |

\\3

The * represents the filename you’ll enter. . gi f represents the exten-
sion that Windows will add to the filename to identify it as a GIF file.

Windows often hides the filename extension when you’re looking at or
selecting files. However, Windows uses an extension to identify the file
type, what icon to use to display the location of the file in a folder, and
so on. Understanding all this information can be important when, for
example, you want to save a file you create in a text editor (normally

a .txt file) as an HTML file (which ends in . htm). Simply saving the file
with a name ending in . htm forces Windows to save it with that file
extension, ensuring that it will be recognized as an HTML file.

5. Enter the filename in the File Name text box.

6. Press Alt+S or click the Save button to save the file.

A dialog box appears with the following message: “Saving into this
format may cause some loss of color information. Do you want to con-
tinue?” You continue, even if you may lose information in doing so,
because you've already saved the file in a lossless format.

o
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When you see a dialog box of this type in the future, always make sure
that you have saved the file in a lossless format, such as Windows
bitmap format or native Paint Shop Pro or Photoshop format, before
proceeding.

. Press the Y key or click Yes to save the file.

The file is saved. You'll probably notice that the image in the drawing
area changes colors. This change in color is caused by Paint’s conversion
of the file to the GIF format. When converting the file to GIF, other pro-
grams use techniques that are less likely to cause dramatic shifts in color.

. If you want to go on to the next section and save the same image as a

JPEG file, leave Paint open for now. Otherwise, close Paint by press-
ing Alt+F4 or by choosing File=> Exit to exit the program.

Saving a Paint file in JPEG format

The preceding section shows you how to save a file in GIF format. This sec-
tion shows you how to save a file in JPEG format. In Paint, the process of
saving in GIF or JPEG is nearly identical. Other programs give you many more
options for saving a file as GIF versus JPEG; we look into those in Chapter 3.

Follow these steps to save a file from Paint into JPEG format:

1. If you have not already done so, start Microsoft Paint by choosing

Start=> Programs=> Accessories=> Paint.

. Press Ctrl+O or choose Filez>Open to open an existing graphics file.

Use a file created with a screen capture, as described in the “Using Paint
for Web Graphics” section, or open an existing graphics file on your hard
disk.

You can use Starte>Search=>For Files or Folders to bring up the Search
dialog box. Search for bitmap (. bmp), GIF (. gif) or JPEG (. jp9g) files.
Open the file you select in Paint.

. Choose Filer>Save As to begin the process of saving the file in JPEG

format.

The Save As dialog box appears.

. From the Save as Type drop-down list, select JPEG File Interchange

Format (*.jpg, *.jpeg).

The * represents the filename you enter. . jpg represents the extension
that Windows adds to the filename to identify it as a JPEG file. Windows
and Paint also treat a file as a JPEG file if it ends with the extension . jpeg.
However, we recommend that you use the shorter . jpg extension.

o
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The process of saving a file as a JPEG image in Paint is much simpler
than in other programs. Normally, you have to choose a level of com-
pression for the image, which determines both the quality of the image’s
appearance and the size of the file needed to store the image. The higher
the image quality, the larger the file. Paint automatically uses a moderate
level of compression.

5. Enter the filename in the File Name text box.

6. Press Alt+S or click the Save button to save the file.

Unlike the process of saving a file as a GIF, you don’t get a warning telling
you that you'll lose information when saving the file as a JPEG. This is
odd, because there are circumstances in which you may not lose infor-
mation when saving to GIF, but you always lose information when saving
from a lossless format to JPEG.

When you see a dialog box of this type in the future, always make sure
that you have saved the file in a lossless format, such as bitmap format
or native Paint Shop Pro or Photoshop format, before proceeding.

. Press the Y key or click Yes to save the file.

The file is saved. You'll probably notice that the image in the drawing
area gets a bit fuzzier. This change is caused by Paint’s conversion of the
file to the JPEG format. Other programs give you control over the degree
of compression to use when creating the JPEG file.

Programs also differ in the quality of their JPEG compression and the
size of the resulting files at various compression levels. Experimentation
is the only way to be certain of usable results.

. Close Paint by pressing Alt+F4 or choosing File=> Exit to exit the

program.
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