
The Maya Interface

The Maya interface can be a bit intimidating, and it’s not fair to expect

yourself to pick it right up and remember where everything is. As you will see throughout

this book, the best way to learn Maya is to put it to task, and you can use this chapter as a

reference to the interface and the many windows and functions you will find yourself

using in your work.

Try not to rush it, and don’t be overly concerned with customizing the keys and using

shelves or the hotbox for now; just access your commands and functions through the menus.

Of course there are a few exceptions to this, as we’ll see in Chapter 2, “Quick Start: Creat-

ing an Animation in Maya 8.5,” but for the most part it is highly recommended that you

familiarize yourself with where everything roughly should be through the menu system.

This chapter is a look at how to access functions and a fairly complete rundown of the

often-used windows in Maya to get you familiar with their workings. Without further ado,

let’s get to the interface that makes Maya what it is.

■ The interface

■ Getting around

■ Scene windows

■ Window layouts

■ The hotbox

■ Menus and shelves

■ The Outliner and the Hypergraph

■ The Channel Box and the Attribute Editor

■ The Timeline

■ The Command line, the Feedback line, and the Script Editor

■ Customizing the interface
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The Interface
You can perform almost every task in Maya in more than one way. The most common

way to access functions and tools is through the menu. In addition to menus, you can

access functions through icons in the shelf, through hot keys, through marking menus,

and through the hotbox. This is one of the charms of Maya and helps make it one of the

most powerful CG creation tools on the market. Its adaptability to individual work flows

makes it an essential tool for artists. This can be a double-edged sword for beginners

though, since they often find themselves overwhelmed as to where to go or how to pro-

ceed. You will see all these options throughout the book and a rundown of them in this

chapter. We recommend you familiarize yourself with the menus first and then get into

the productivity-enhancing shortcuts.

If you are already experienced with other CG software and find it easy to get around in

Maya, you can just use this chapter as a reference to come back to when you’re already

steeped in your scene. Artists who used other packages say that Maya’s work flow and inter-

face are important to learn because they can offer a faster, more efficient way of working.

If you’re new to Maya and have not had a chance to set any defaults for yourself, reset

the interface to the default settings to make sure everything lines up between your work

and the exercises in this book. Choose Window ➔ Settings/Preferences ➔ Preferences. In

the Preferences window, choose Edit ➔ Restore Default Settings. This should restore set-

tings to their original state. Be careful not to reset someone else’s settings, though, if you

are on a multiuser computer.

Let’s take a look at what elements make up the default Maya screen, which is shown in

Figure 1.1.

The reason we specifically mentioned the default Maya screen is that Maya has a highly

customizable interface that you can tailor to the way you like to work. As you become

experienced with Maya, you will begin customizing the interface for yourself easily. As an

inexperienced user, it’s best to leave everything at the default to have a level playing field.

In addition, for those systems that have multiple displays, Maya fully supports using a

secondary display as long as your video card is capable. Keep in mind that both displays

should be set to the same resolution and refresh rate for best OpenGL performance.

Experienced users should focus on the section “Customizing the Interface” later in

this chapter.

The Nickel Tour
Let’s take a look at the interface and identify the parts of the UI.

Running across the top of the screen (see Figure 1.1) are the main menu bar, the Status

line, and the shelf. These provide access to the many functions in Maya. Running vertically

to the left of the screen is the Tool Box, giving you fast access to common tools to manipulate

your objects. Across the screen are the Channel Box/Layer Editor and sometimes the

Attribute Editor. (The Attribute Editor is not displayed in Figure 1.1.) This part of the 
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C A M E R A  M O V E M E N T  T E R M I N O L O G Y

Every kind of camera move has a different name. The following lists the type of camera

moves you have and what each one means:

• Rotate (Tumble) view means to rotate the (perspective) camera; hold down the Alt key

and the left mouse button, and then drag in the perspective window to rotate the view.

This action physically moves the camera around the subject and can be effective only in

a perspective view panel.

• Move view means to move any camera; hold down the Alt key and the middle mouse

button, and then drag in any scene window. This will move the camera horizontally or

vertically in the scene, effectively panning the view.

• Dolly view means to scale—commonly called a zoom—any camera; hold down the Alt

key and the right mouse button (you can also hold down both the LM and MM), and

then drag in any scene window to zoom (or scale) the view in or out.

This setup allows a straightforward Alt key plus mouse button mapping of left=rotate,

middle=pan, and right=zoom.

In Maya, your exact menu choices depend on your current menu set. By switching

menu sets, you change your menu choices and the set’s corresponding toolset. It may seem

strange at first, but it makes the best sense to divide the menu headings into what kind of

task you are involved in. The menu sets in Maya Complete are Animation, Polygons, Sur-

faces, Dynamics, and Rendering; Maya Unlimited adds the Classic Cloth, nCloth, and

Maya Live menu sets to those four. The menu sets are available through the Status line,

which is discussed in the next section.

The first six items in the main menu are constant, no matter what menu set you are in:

File, Edit, Modify, Create, Display, and Window. The last menu, Help, is also constantly

displayed. Their functions are as follows:

File Contains file operations, from saving and opening to optimizing scene size and

export/import.

Edit Gives you access to the commands you use to edit characteristics of the scene, such

as, for example, deleting and duplicating objects or undoing and redoing actions.

Modify Lets you edit the characteristics of objects in the scene, such as moving or scaling

them or changing their pivot points.

Create Lets you make new objects, such as primitive geometries, curves, cameras, and so on.

Display Contains commands for adjusting elements of the GUI (graphical user interface)

in Maya as well as objects in the scene, allowing you to toggle, or switch on and off, the

display of certain elements as well as components of objects, such as vertices, hulls, pivots,

and so on.
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Attribute Display in the Channel Box

The following list shows the colors and their connections for the attributes in the

Channel Box:

I N P U T  C O N N E C T I O N C O L O R D E S C R I P T I O N

Keyframed Orange A keyframe is set for the attribute at some point in
the Timeline.

Yellow This attribute shares the same value as another
attribute on another object or has dynamic forces
affecting it.

Expression Control Purple A written expression controls the value of this
attribute.

Constraint Blue The attribute’s value is constrained to the value of
an attribute of another object.

Locked Gray You cannot change the value without first unlock-
ing the attribute.

Muted Animation Brown There is animation on the attribute, but it is currently
muted so it will not play back until it is unmuted.

Green The value of this attribute is blended with the value
of another attribute.

Nonkeyable Light Gray This attribute cannot be animated.

Editing Attribute Values in the Channel Box

When an object is selected, its name appears at the top of the Channel Box. You can click

the name and type a new name to rename the selected object. The channels (keyable attrib-

utes) for that object are listed vertically below with the attribute name to the left and the

attribute value to the right in text boxes. You can click in the text box to change the value

through the keyboard. You can also use a virtual slider in Maya by clicking a channel’s

name in the Channel Box and using the MM in a view panel to drag left or right to decrease

or increase the value of the selected channel.

If you RM click an attribute name in the Channel Box, you will see a context menu 

that gives you access to several common commands, such as keyframing or locking and

unlocking the selected channel or channels. You can animate any channel here by RM

clicking the attribute name and choosing Key Selected from the shortcut menu. RM click-

ing the value itself displays a shortcut menu from which you can cut and paste values.

Another useful shortcut menu command is Break Connections, which removes any

connections for the selected attributes and returns the value to a normal white color in the

Channel Box. For example, if you have keyframes on the Rotate X channel of an object (with

the text box shown in orange), clicking Rotate X in the Channel Box and right-clicking and

choosing Break Connections from the shortcut menu deletes the keyframes and returns the

text box to white. You will see more of this usage later in this book and as you learn how to

animate in Maya.

Blended (with another
attribute)

Connected (to another
attribute) or is dynamic
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Shaded, Textured, and Lighted Modes
You can select from varying degrees of shading detail, going as far as seeing your objects with

textures and lighting detail. You can cycle through the levels of detail by pressing 4, 5, 6,

and 7. Wireframe mode is 4, shaded mode is 5, texture shaded mode is 6, and lighted mode

is 7. Lighted mode will only work if you are already in mode 5 or 6. While in mode 6, press-

ing 7 will give you a lighted and textured mode. These modes give you a basic idea of lighting

and/or texture detail.

Texture shaded mode (6) displays the actual image textures that have been applied to

the object as long as Hardware Texturing is already enabled. (In the view panel, choose

Shading ➔ Hardware Texturing and make sure it is checked on.) Lighted mode (7) is a

hardware preview of the object or objects as they are lit in the scene. Its accuracy depends

on your graphics hardware. Here’s a summary:

K E Y F U N C T I O N

4 Toggles into wireframe mode

5 Toggles into shaded mode

6 Toggles into textured mode

7 Toggles into lighted mode

It is handy to toggle between modes 4 and 5 to get a good feel for the weight and shape

of your objects. Furthermore, lighted mode (mode 7) is useful for spotting proper light-

ing direction and object highlights when you first begin lighting a scene. It helps to see

the direction of lights within your scene without rendering frames all the time. The num-

ber of lights you see in the modeling window depends on your computer’s graphics and

overall capabilities.

You can display a higher-textured view of your models by enabling High Quality Ren-

dering view. In your view panel, choose Renderer ➔ High Quality Rendering. This will give

you a good idea of the texturing and lighting in your scene but at the expense of speed.

Display Shortcuts
In the view panel’s View menu, you will find two handy UI features, Frame All (hot key A)

and Frame Selection (hot key F), and a third slightly homely cousin, Look At Selection.

Frame All animates the camera or orthogonal views in or out to see all the objects in a

scene. Frame Selection animates the camera view to focus on the selected object or the

center of selected objects. Look At Selection snaps the selected object into the middle of

your view without moving in close to it.

If you find yourself wondering why pressing a hot key isn’t working, Caps Lock may be

enabled. Some hot keys have multiple meanings for the lower- and uppercase of the same

letter, so check the Caps Lock key.
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Double-clicking any of the names under the thumbnails lets you change the name of

the shader or render node. Clicking the thumbnails themselves selects the shader for use,

and double-clicking the thumbnail (and not the name) opens its Attribute Editor.

The Multilister is in two panels. Both panels let you select what type of shading/render

node is displayed. By default, the top panel displays all the shaders in the scene in the Gen-

eral tab—with materials, lights, and camera nodes under their respective tabs. The bottom

panel is typically used to display texture nodes that are in use or are already connected to

shaders.

You can add or edit tabs to filter just the nodes you need to work on. For example, if

you would like to view only the type(s) of nodes you want, pay a visit to the Display ➔

Tabs menu. There you can create new tabs with special filters using the Create Filtered

command from that menu.

Many of the commands accessible through the menu system are also available through

shortcut menus when you RM click the shaders in the Multilister panes. To assign a shader,

for example, select your object in Maya, click your desired shader to select it, and then RM

click and choose Edit ➔ Assign from the shortcut menu.

You can customize the look of the Multilister by clicking the option display icons of

the thumbnail size icons running down the left side of the window, shown in Figure 1.33.

Each thumbnail has a small arrow in the lower-right corner. Clicking this arrow expands

on that shader’s network of connection nodes, if you have textures or images attached.

The Multilister is good for fast shader management and assignment if you are connect-

ing and editing attribute connections, even more so than the Hypergraph. It does, how-

ever, lack the brawn of the Hypershade to get into serious shader network management.

The Hypershade
The Hypershade is accessed through Window ➔ Rendering Editors ➔ Hypershade (see

Figure 1.34) and displays the shaders and textures in your scene in a graphical flowchart

layout similar to the Hypergraph window. You connect and disconnect render node

attributes through the Hypershade to create shader networks from the simple to the

intricately complex. The Hypershade window has three main areas: the Create/Bins

panel, the render node display, and the work area. The three icons in the upper right let

you switch views.

The Create/Bins Panel

The Create/Bins panel on the left is divided into two tabs: Create and Bins. Selecting the

Create tab displays the icons to create several render nodes from materials such as Lam-

bert and Blinn to procedural textures such as ramps and fractal noise. To create a node,
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The window is in two halves. The top half is the Script Editor’s feedback history, and

the bottom half is its Command line, where new MEL commands can be issued. By high-

lighting text in the upper window, you can copy and paste the command back into the

Command line. Once you have some commands that are working for you, you can add

them to the shelf by highlighting the text and choosing File ➔ Save Script To Shelf.

Using the Script Editor is also a good way to check on error messages that are too long

to fully view in the Command line’s feedback box. If you see an error message pop up and

something goes wrong, open the Script Editor to see what sort of error(s) have scrolled by.

Customizing the Interface
You’ve probably noticed that we’ve run into the same tools more than once as we’ve gone

through the aspects of the user interface so far. Simply put, for everything you need to do

in Maya, there are not only a few ways to do so, but at least a couple of ways to access the

tools to do so.

Most of Maya’s commands and tools can be found in at least two places. This may be

confusing at first, but you’ll discover that in the long run it is most advantageous. It allows

for the greatest flexibility in individual work flow and in part accounts for Maya’s being

easily customized.

Once you are confident with your Maya know-how, you’ll develop your own ideas

about how to use all the other user interface methods to customize your work flow. You’ll

want to return to this section when you’re ready to do some serious customization.

User Preferences
To customize Maya, you use the Preferences window (choose Window ➔ Settings/Prefer-

ences), as shown in Figure 1.42.

The Preferences window is separated into categories that define aspects of the program.

• Interface options to change the main user interface:

• UI Elements lets you change which parts of the UI are displayed. You’ve seen in

this chapter how you can access these preferences through marking menus, but

you also have access here.

• Help lets you specify whether you want tooltip pop-up windows when you

mouse over icons or buttons, as well as how you view the HTML documentation

that comes with Maya.

• Display options to specify how objects are displayed in the workspace.
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