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Introducing DVD
Studio Pro 2

DVD Studio Pro 2 is a new, powerful and flexible
authoring tool for DVDs. DVD Studio Pro 2 belps
you transform plain video into interactive media,
complete with menus, subtitles, alternate tracks, and
more. In fact, DVD Studio Pro 2 provides many of
the professional features you’d normally find on
Hollywood-produced DVDs. DVD Studio Pro 2
helps you coordinate these capabilities, putting them

together to produce new ways of watching video.
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DVD Studio Pro 2 means more than just movies. With DVD Studio Pro 2, you
can create training materials, personal histories, interactive catalogs, event videos, and
more. If you have video, audio, and graphics that you want to combine to present an
interactive experience, DVD Studio Pro 2 will help you deliver that experience on the
DVD platform.

In this chapter, you’ll meet DVD Studio Pro 2. You’ll explore the DVD Studio
Pro 2 interface, learn how to customize your screen, and get started building your own
DVD projects.

Configuring DVD Studio Pro 2

The best way to learn any program is to use it. To get started with DVD Studio Pro 2,
you need to sit down at your computer and, in a metaphorical sense, get your hands
dirty and your feet wet. If you have not done so already, install your copy of DVD Stu-
dio Pro 2. Navigate to your OS X Applications folder. Locate the DVD Studio Pro 2
icon and double-click it.

If this is your first time using DVD Studio Pro 2, you’ll be greeted with the win-
dow that appears in Figure 1.1, which asks you to select a configuration.

Configurations tell DVD Studio Pro 2 how to select and arrange windows.
Each configuration specifies which windows to display and where to display them.
The introductory screen allows you to choose from Basic, Intermediate, and Advanced
layouts.

Each layout provides a different look. The Basic layout offers a bare minimum
of screens, to mimic the look of Apple’s iDVD. Intermediate adds a timeline. The
Advanced layout offers the greatest power and complexity. It contains all essential
DVD Studio Pro 2 windows, with all the power that DVD Studio Pro 2 has to offer
and is the configuration used throughout this book.

DVD Studio Pro 2 can be :;:md ina va:ely of ways.
e e evatad L o ti fare i Wk s
———— b
_E e o s s SO Figure 1.1 The first time you run DVD Studio Pro 2, the
Extendai: program asks you to choose an application configuration.
EE e cdna e sdenets Before clicking OK, select from the Basic, Intermediate,
——— dvanced: and Advanced configurations, and set your video standard
LR | T xposes 2l he s L VD Sl o2 s 0 ot (NTSC or PAL). Although DVD Studio Pro 2 offers easy
o T R ways to select configurations, you can revisit this dialog
Type: () NTSC at will: quit DVD Studio Pro 2, remove the DVD Studio
S E‘Fﬂ Pro 2 folder from ~/Library/Application Support,
and relaunch.
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NTSC (National Television Standards Committee) is the body that sets standards for television and video in
North America, Japan, and parts of South America. PAL (Phase Alternating Line) is the video standard used in @
Europe (with the exception of France), the United Kingdom, Australia, and New Zealand.

Running DVD Studio Pro 2 for the First Time

Follow these steps to get started with DVD Studio Pro 2.

1. Choose Advanced. Click the small screenshot button to the left of the word
Advanced. The Advanced configuration offers the most power and flexibility of
all the configurations.

If you are familiar with iLife programs, do not be swayed by the Basic configuration’s similarity to iDVD. DVD S g' /

Studio Pro 2 is not iDVD. The similarity between the Basic configuration and iDVD is, at best, flimsy.

2, Choose your video standard. Select either NTSC or PAL, depending on your
country of origin and the project you’re about to build.

3. Click OK. DVD Studio Pro 2 accepts your settings and opens a new project
using the Advanced configuration.

Choosing Configurations within the Program

After its first run, DVD Studio Pro 2 no longer displays the screen you saw in Figure 1.1.
Instead, DVD Studio Pro 2 starts new projects using the last-selected configuration. To
select a different configuration, follow these steps.

1. Choose Window > Configurations. DVD Studio Pro 2 opens a submenu that
offers Basic, Intermediate, and Advanced configurations. Figure 1.2 shows this
submenu.

2, Choose an Advanced layout. Select the Advanced option that matches the size of
your screen.

After selecting a configuration, DVD Studio Pro 2 resets the interface to the
specified layout.

During a long and busy editing session, you may move and resize many DVD Studio Pro 2 windows, making
changes you won't want to preserve. To quickly reset your windows to their original positions, choose Window > @
Configurations again, and choose the current configuration again.

o
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Minimize M
Zoom

Bring All to Front

Save Configuration...
Manage Configurations...

Configurations > 1 - Basic F1

2 — Extended F2  Figure 1.2 The Window > Configurations submenu
MoASSRIE Je 3 - Advanced F3 9 _ g
E““”m“’“s :g 4 - Advancid (Cinema) Fa  allows you to select a configuration that matches your
0g . . . -
¥ Menu Editor %4 monitor. This figure shows the default list of built-in con-
¥ Outline #5 X . . .
Script Editor — =2l figurations. DVD Studio Pro 2 allows you to add to this
Slideshow Editer ®7 list, introducing custom configurations to match your spe-
Story Editor %8 - . X .
« Track Editor %9 11 cific production needs. The configurations manager
Viewer *0 = (choose Window > Manage Configurations) lets you add
¥ Untitled urations and remove configurations as needed.

Choosing a Video Standard within DVD Studio Pro 2

As with configurations, DVD Studio Pro 2 defaults to the last-used video standard. Fol-

low these steps to set your video standard at any time.

1.

2.

Choose DVD Studio Pro > Preferences (Command-,). The Preferences win-
dow opens.

Click Encoding. The Encoding button appears on the top line, to the right of
Destinations.

Choose a video standard. Select either NTSC or PAL to match your project
to the country system in which it will be played.

Click OK. DVD Studio Pro 2 closes the window and updates your
preferences.

Each DVD Studio Pro 2 project can use either the NTSC or PAL system, but not both at the same time. DVD Stu-
dio Pro 2 offers no standards conversion tools: you must convert material to the proper system before import-
ing it. QuickTime Pro converts elementary video assets from one format to the other, with modest but usable
results. Final Cut Pro, which uses the QuickTime engine, lets you export to both NTSC and PAL, regardless of the
system used within your projects. By far the best conversion solution resides strictly on Windows: Canopus
ProCoder offers the highest quality conversion tools. The sample material provided on the DVD Studio Pro 2
Solutions companion DVD uses the NTSC format.
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Looking at the DVD Studio Pro 2 Interface

A careful look at the DVD Studio Pro 2 interface reveals how the program is structured
on your screen. By default, Advanced configurations include a main window and two
floating tool windows. Figure 1.3 shows a typical Advanced configuration. As you
examine the layout, notice the following;:

A tool bar appears at the top of the main window. This bar offers one-button access to
many of the most common functions in DVD Studio Pro 2. The tool bar lets you
bypass context-sensitive pop-up menus to get right to work.

The main window contains four subwindows. DVD Studio Pro 2 allows you to con-
trol the relative size of each subwindow, called a quadrant, so you can focus on the
task at hand with the window real estate you need.

Each quadrant contains tabs. Tabs include Outline, Story, Connection, and Menu,
among others. Each tab contains a different editor or information pane. Tabs allow
you to organize your work, reduce clutter, and fit a lot more information on screen at
one time.

Two floating windows appear above the main window. The Inspector and the Palette
always appear as the frontmost windows of your interface. The Inspector provides
context-specific controls for the program. For example, click a DVD menu, and the
Menu Inspector allows you to set its name, its background image, and more. The
Palette provides instant visual access to interface components such as buttons and
menu layouts. The Palette also holds collections of audio, video, and still assets.

Manipulating the Interface

All DVD Studio Pro 2 windows are fully customizable. You can hide them from view,
resize them, and more. DVD Studio Pro 2 offers you the power to configure the inter-
face exactly how you’d like it to get your work done. To accomplish this, you need to
master several interface manipulation techniques detailed here.

Working with Tabs

Tabs allow you to choose which editor or information pane to display in a quadrant.
Common tasks include the following.

Selecting Tabs Click any tab to bring it to the front and display it.

Reordering Tabs To reorder within a line of tabs, drag the tab into its new position.
DVD Studio Pro 2 makes space for the tab as it passes each of its quadrant mates.

HOVAYALNI FHL ONILVININVN B »n
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Figure 1.3 The default look of the Advanced configuration includes an attached tool bar ®, within a paned main window ®, and
two floating tools—the Inspector © and the Palette ®.

Tearing off Tabs DVD Studio Pro 2 lets you to “tear off” tabs so they appear in new
windows, as shown in Figure 1.4. These new windows do not “float.” They can appear
in front of or behind your main window, depending on window ordering. Use 88-" to

CHAPTER 1: INTRODUCING DVD STUDIO PRO2 B &

cycle through your windows and display any hidden ones.

N\l The Window menu places a check mark next to all selected tool tabs. When you find more than four checks in
@ the menu, you know that you're working with extra open windows.

Moving Tabs between Quadrants DVD Studio Pro 2 allows you to move tabs from
one quadrant to another and from one window to another. Place the cursor on any tab
and drag that tab to any other tab line. This method is shown in Figure 1.5.
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Figure 1.4 Tearing off tabs opens new DVD Studio Pro 2
windows. Control-click (right-click) any tab. Select Tear Off
Tab from the contextual pop-up. Alternatively, drag the tab
to some part of your screen other than the top tab lines of
your windows.

Here are some key points to remember about tabs:

J When you close a tab window, the tab does not revert to your main work win-
dow. Use the Window menu (and its shortcuts) to reopen that tab. If, for exam-
ple, you place the Outline tab in a new window and then close that window, you
must choose Window > Outline (88-5) to see it again.

] When you drag the sole tab from a one-tab window into another tab bar, the
window closes and the tab appears in that bar.

o Removing the last tab from a quadrant hides that quadrant. For example, you
can see this if you move the Story and Outline tabs from the top-left quadrant.
You must resize (discussed in the next section) to display the empty quadrant.

o To revert your display and restore your tabs, reload your configuration. Choose
Window > Configurations and select any configuration.

Curious about the built-in shortcuts? Choose Help > Keyboard Shortcuts to view a complete list.

Figure 1.5 DVD Studio Pro 2 allows you to move tabs by
dragging them to the top gray line of any quadrant. A blue
outline surrounds this line when the cursor enters.To
reorder tabs within a quadrant, drag the tab within the top
line into its new position.

o
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Adjusting Quadrants

DVD Studio Pro 2 allows you to resize the quadrants within your main window to give
them as much or as little space as needed. Use the following techniques to customize
your quadrant allocation.

o Move your mouse to any horizontal or vertical line between quadrants until you
see the resizing cursor. The cursor appears as two parallel or horizontal lines
with arrows on both sides. (When your horizontal and vertical lines meet, you’ll
see a plus-shaped cursor instead.) Unlike other resizing cursors used within the
program, this cursor has a slight blue tint. To reapportion space, drag in any
direction. If you drag entirely across, you may hide one or more quadrants.

N4 When quadrants align, either vertically or horizontally, they resize together. Pressing "\ allows you to resize
one quadrant independently of its mate.

o Hiding quadrants provides more screen space without opening new windows. To
detect hidden quadrants, examine the sides of your main DVD Studio Pro 2 win-
dow. Studio Pro slightly thickened window edges indicate hidden quadrants. In
addition, the resizing cursor appears over these thickened borders. To view a hid-
den quadrant (or quadrants), look for the resizing cursor to appear and then drag
to display the quadrant.

As with tabs, reselecting a configuration from the Window > Configurations
submenu instantly reverts your quadrants to default positions.

Other Interface Elements

The DVD Studio Pro 2 Inspector, Palette and Toolbar all offer important functionality
in addition to the main window and tabs. These interface elements extend the program,
offering flexible tools that help you work on your projects.

Manipulating the Floating Windows

The Inspector and Palette, when visible, float over all other windows in your interface.
(They have the highest window priority.) DVD Studio Pro 2 allows you to show, hide,
and resize these floating tools as follows:

o To show either window, choose View > Show Palette or View > Show Inspector.

o Choose View > Hide Palette or View > Hide Inspector to close each window.
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. Two keyboard shortcuts, 88-"C-1 (for Inspector) and 38-"C-P (for Palette) toggle
floating window visibility on and off. The Palette and Inspector buttons found at
the very right of the toolbar also toggle window visibility.

. Move the Inspector or Palette by dragging the title bar at the top of either window.

] Resize the Palette by dragging the lower-right corner. You cannot resize the
Inspector.

. To close a floating window, click the tiny close button (the X at the top-left

corner of the window).

Revealing Basic’s Hidden Quadrants

The Basic configuration hides a lot more than it shows. A little manipulation discloses the quad-
rants that you find in the Intermediate and Advanced configurations.

Dragging from the left reveals one new quadrant (below left). Dragging the bottom border
exposes the remaining quadrants (below right).
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Fast Facts about Configurations

e Torestore DVD Studio Pro 2 to its factory defaults, locate the DVD Studio Pro 2 folder in your
home ~/Library/Application Support folder. Quit DVD Studio Pro 2, drag this folder to
the desktop or the trashcan, and launch the program again.

o C(onfiguration files use .dspconfig extensions.

e (onfiguration files are based on XML (Extensible Markup Language). You can open .dspcon-
fig files in TextEdit and read through them. For better readability, you might want to globally
replace tabs with single spaces. (This does not affect performance or usability in any way.)

e When you use TextEdit to modify .dspconfig files, the changes do not appear until you
launch the program again.

The Configuration Manager allows you to add, remove, and rename your con-
figurations—including the DVD Studio Pro 2 defaults. Here are some of the ways you
can use the Configuration Manger.

DVD Studio Pro 2 does not provide Undo support for these changes.

Removing Configurations Select any configuration and click — (the minus button) to
remove it from the active set of configurations.

Renaming Configurations Double-click any configuration to open a text-edit field on
its name.

Reordering Configurations DVD Studio Pro 2 uses alphabetic sorting (0-9, A-Z) in
its Window > Configurations submenu. Name your configurations with this in mind.
Unfortunately, this sorting does not apply to new items in the Configuration Manager
window until you restart the program.

Viewing Configurations Click Apply after selecting a configuration to view it. Unfortu-
nately, in early versions of DVD Studio Pro 2, this action closes the Configuration
Manager. You must choose Window > Manage Configurations again to continue with
your edits.

Understanding the Interface

DVD Studio Pro 2 with its cluttered interface may intimidate first-time users. Numerous
windows—tabbed, paned, and floating—appear almost at random on your screen. Despite
a superficially messy appearance, a logical structure underlies this visual confusion, and

o
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Loading Assets

To build a house, you need bricks and wood. To build a DVD, you need properly
encoded data files. DVD Studio Pro 2 project development begins by collecting sound,
picture, and movie files called assets. Assets are the audio, still, and video files you use
to build your tracks, menus, and slideshows.

DVD Studio Pro 2 offers two ways to organize and use assets in your projects:
the Assets tab and the Palette. The Assets tab provides a list of folders and files that
you can edit. The Palette offers easy-to-use integration with your iTunes and iPhoto
libraries.

Using the Assets Tab

The Assets tab helps you import, organize, and understand your project assets.
Figure 1.10 shows what a typical session might look like.

Folders and subfolders help organize your assets into logical groups. You can
import entire folders (and their subfolders) at once, and DVD Studio Pro 2 will pre-
serve the folder structure. The columns help identify and describe your assets, provid-
ing information about each item in a structured table.

DVD Studio Pro 2 Assets

DVD Studio Pro 2 places certain requirements on your assets. When your assets do not initially
match these standards, DVD Studio Pro 2 will encode your files accordingly.

Video Standard DVD Studio Pro 2 supports both NTSC and PAL standards. All assets within any
single project must use the same standard, either NTSC or PAL.

Video File Types DVD Studio Pro 2 accepts both MPEG-1 and MPEG-2 elementary streams at up
to 1.856Mbps (MPEG-1) or 9.8Mbps (MPEG-2). All MPEG- 2 video must use a 4:2:0 chroma format.

Dimension DVD Studio Pro 2 MPEG-2 movies and full-screen still images occupy 720 x 480 pixels
(NTSC) or 720 x 576 pixels (PAL). MPEG-1 files use 352 x 240 pixels (NTSC) or 352 x 288 pixels
(PAL). DVD Studio Pro 2 supports both 4:3 and 16:9 aspect ratios.

Frame Rate For NTSC projects, use 29.97 frames per second. For PAL projects, use 25 frames per
second.

Audio Resolution DVD Studio Pro 2 accepts either 16-bit or 24-bit audio, using either 48 or
96kHz sampling.

Audio File Types DVD Studio Pro 2 supports Dolby Digital or AC-3 (64 to 448kbps), Stereo PCM
(16b/48kHz/1536kpbs or 24h/96kHz/4608kbps) and MPEG-1 Layer 2 audio.

o
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Inspector The Inspector (38-"C-I) allows you to examine and customize each of the
files that appear in your Assets tab. Until an asset is used in a project, the Inspector
shows only a general overview of that asset.

Viewer Double-click any asset (double-click its name) to preview it in the Viewer window.
(Alternatively, Ctrl-click or right-click and choose Preview Asset....) If the Viewer window
is hidden, DVD Studio Pro 2 will open the Viewer tab in a new floating window.

By default, when you import assets that have not previously been encoded, DVD
Studio Pro 2 automatically encodes them in the background with Compressor. This lets
you concentrate on authoring your disc rather than waiting for your computer to finish
encoding and catch up to you.

Compressor, which ships with DVD Studio Pro 2, Final Cut Pro 4, Final Cut Express 1 and later, is explored further
in Chapters 4 and 5.

Here are some key points to remember about background encoding;:
Status The Usability column helps identify the encoding status of certain audio and video
files. Yellow dots indicate that the files are, as yet, unencoded. Green dots reflect fully
encoded assets. (Red dots let you know that DVD Studio Pro 2 is busy parsing the asset.)

When DVD Studio Pro 2 “parses” an encoded file, it scans the file to recover certain information such as the
file's length, its type, and its overall integrity. When you import assets, DVD Studio Pro 2 creates small .par
filesin ~/Library/Caches/DVD Studio Pro Files.A typical parse file might be named Main-
Menu.m2v.par, adding the .par extension to the original asset name.

Enabling Background Encoding In DVD Studio Pro 2, background encoding is enabled
by default. To disable background encoding, Choose DVD Studio Pro > Preferences
(88-,). Click Encoding, and choose Encode On Build. Click OK. Choosing this option
delays encoding until you’re ready to build your disc.

Viewing Encoding Preferences Use the Encoding preferences panel to set the bit rate,
encoding method, and so forth for your background encoding. To view (and/or modify)
the current settings, choose File > Encoder Settings (38-E) or Ctrl-click (right-click) in
the Assets tab and choose Encoder Settings from the pop-up.

Finding MPEG Folders By default, Compressor stores your encoded files in a subfolder
entitled MPEG. This subfolder appears in the same folder as and at the same level of
your original asset, as described by Figure 1.13.
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. Changing an asset name does not override the built-in video- and audio-matching
feature that loads same-named audio tracks when you add a video to the Track Edi-
tor. With the above example, if you added main_movie.m2v as a new video stream,
DVD Studio Pro 2 would automatically add the matching audio file f92x194j.aif.

. Changing an asset name does not affect ordering. DVD Studio Pro 2 uses the
original asset name to determine alphabetic ordering.

To enable audio matching, open the Preferences dialog (DVD Studio Pro > Preferences. . . or 88-,). Click Track,
check Find Matching Audio When Dragging, and click OK.

Managing Folders

Asset folders work much as you’d expect, allowing you to group and organize your
assets. Some folder management techniques include the following;:

Adding Folders Click New Folder in the Toolbar to add a folder to your list of assets.
Alternatively, Ctrl-click (right-click) within the Assets tab and choose New Folder from
the Assets contextual pop-up menu, or choose Project > New Asset Folder (88-7\C-B).
New folders appear at the same level as the currently selected item.

Renaming Folders Double-click a folder to rename it.

Reparenting Folders Drag items either into or out of folders to reparent them. Re-
parenting in the Assets tab does not affect the way items are stored on your computer.

Removing Folders Select a folder and click Remove to remove the folder and all items
within it. You cannot remove items that are in use, nor can you remove their parent

folders.

Relinking Assets

On occasion, DVD Studio Pro 2 won’t be able to find an asset you’ve added to a proj-
ect. You might have deleted it from your computer; you might have renamed it; or you
might have moved it to a new folder.

When DVD Studio Pro 2 cannot find your files, it displays the asset name in
bright red in the Asset tab. DVD Studio Pro 2 uses live links to your files, so this
update happens in real time. (To see this at work, temporarily drag a file to a new
folder and select that asset. Return the file to its original location to restore the link.)
As Figure 1.14 shows, DVD Studio Pro 2 searches for, and occasionally detects, missing
files whenever you load projects.

Relinking allows you to reconnect the project asset with an actual file on the
computer. To do so, Ctrl-click (right-click) the asset name and choose Relink Asset.
The Relink dialog appears. Navigate to your asset file and click Relink.

o

N
N

SLASSY ONIOVNVIN B









4234c01l.gxd

CHAPTER 1: INTRODUCING DVD STUDIO PRO2 B &

12/9/03

1:01 AM Page 30 CE

Using the Media Tabs

The following tips will help you make efficient use of the Palette media tabs (Audio,
Stills, and Video):

Adding Folders Click the plus (+) button to add folders to the top pane of each media
tab. You can add sound folders as new play lists, image folders as new albums, and
video folders for viewing and use in your projects.

Your home Music folder (Audio), Pictures folder (Stills), and Movies folder (Video) appear by default in the top
pane of the appropriate tab.

Removing Folders Click the minus (-) button to remove selected folders, albums, or
play lists from the collection in the top pane. Removing items from the top pane won’t
affect sound and image libraries in iTunes or iPhoto.

Viewing Folder Contents Click any item in the top pane to view its contents in the bot-
tom pane.

Resizing Panes The resize handle (it looks like a long equal sign) lets you apportion
space between the top and bottom panes.

Searching Enter a search term in the space provided to search through your list. The
term matches all files that include the string you enter, whether it occurs at the begin-
ning, middle, or end of the filename. For example me matches both Mendelsohn.mp3
and Home.mp3.

Searching from the Palette does not look in or display subfolders.

Previewing Click the play button (right-pointing triangle button, Audio and Video tabs
only) to preview sound clips before using them in your project.

To use media from the Palette, drag an item or items onto the DVD Studio Pro 2
menus, tracks, or slideshows you’re editing. This lets you use media assets from the
Palette just as you would use assets from the Assets tab.

Once you add an asset to any part of your project, the file appears automatically
in the Assets tab with its In Use column checked. For example, if you drag an image to
a menu and use it as a background, the image file shows up in the Assets tab.

When you want to store assets for later use, rather than using them immediately
in the various editors, drag them directly from the Palette to the Assets tab. DVD Studio
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