A Photoshop image is like a building. The color channels are the foundation that ultimately determines the image’s core structure, just as the pixels are the building blocks of its visual elements. It may contain layers that are its multiple floors and it can have masks that act as windows.

Just as there are many different ways to construct a building, in Photoshop, the choices you make can also dramatically affect how an image appears, how it is edited, and ultimately how it is output. This chapter analyzes the elements that constitute the structure of a Photoshop image. It addresses how the elements are assembled and accessed and defines important terminology. Furthermore, this chapter demonstrates how to utilize these key features in the creation and manipulation of an image.

**Distinguishing Between Vector and Raster**

Two fundamentally different methods are used to create still images. Vector graphics are objects composed of mathematically defined points, curves, and shapes called objects. Raster images use a grid of colored squares, called pixels, to render variations of color.
**Vector graphics**

*Vector graphics* are composed of paths and points that define their shapes. The vector tools, such as the Pen tools, the Shape tools, and the Type tool are used to draw these objects. In Photoshop the vector tools can be used to select areas of an image or to produce type or shapes that when printed, produce clean, sharp lines and edges.

Vector objects are created by dragging a shape onto the Image window with one of the shape tools or by the technique of depositing points and line segments with the Pen tool. Both methods are shown in Figure 1.1. These paths are called *Bezier curves*, after Pierre Bezier who developed them for the European Automobile industry in the 1960s. Bezier curves can take the form of any combination of straight, curved, or scalloped paths and can be open ended or closed to form a shape but what makes them different from the pixels used by raster images is that that they are composed of mathematically defined points and segments.

Vectors are *resolution-independent*, which means that they automatically conform to the highest resolution of the device on which they are printed, whether it's a desktop inkjet printer, a laser printer, or a high-resolution imagesetter.

**FIGURE 1.1**

A shape drawn with the Custom Shape tool (left) and a Bezier curve drawn with the Pen tool (right).

---

**Raster images**

Although the vector tools are indeed quite handy, most of Photoshop's operations are designed to change the color of pixels. Raster images, sometimes called *bitmaps*, are different from mathematically defined vector images because they consist of a mosaic of little colored units called picture elements or *pixels*. 
These usually square-shaped areas of colored light are the smallest editable unit in a Photoshop image. Pixels are usually so small that, when seen on a monitor, the colors blend into what appears to be a continuous-tone image.

Each pixel is assigned a color based on the numerical constitution of binary information. The variation of colored pixels within the grid matrix of a digital image produces the variations of tone and color.

**Understanding Bit Depth**

The computer is a high-speed calculator that uses the binary number system to calculate and describe information. The binary number system uses zeros and ones to describe all numerical values. The smallest unit of binary information is called a *bit*, which is an acronym for binary digit. There are 8 bits in a byte, which is a row of eight zeros or ones. There are 256 possible combinations in a string of eight zeros and ones. There are 1,024 bytes in a kilobyte. There are 1,024 kilobytes in a megabyte, 1,024 megabytes in a gigabyte and so on. A pixel, however, is the smallest editable unit in a Photoshop image and each pixel contains a certain amount of color information depending on its bit depth.

**Bitmaps**

The simplest graphic images called *bitmaps*, are composed of pixels that are only one bit “deep.” In these images, only one binary digit of information describes each pixel. Think of each one-bit pixel as an on-off switch. There are only two alternatives — the light can be turned on or off. The binary number zero represents off or black, and the binary number one represents on or white. Bitmap images are frequently used to create black and white line art, as shown in Figure 1.2.

Graphic software for early PCs and Macs had the limited capability of editing bitmap images by replacing white with black or black with white. The scanners, video cards, and monitors that created and displayed the images on these early computers were also limited and could only process one-bit images.

**Grayscale**

In a *grayscale* image, each pixel is allocated eight bits of binary information. Each bit can either be on (black) or off (white). Eight bits of information produces 256 possible combinations ($2^8 = 256$). A grayscale image, therefore, contains a potential of 256 shades of gray where black is assigned a numerical value of zero and white 255. Grayscale is a mode that is most often used for editing and displaying black and white photographs, such as the one shown in Figure 1.3.
RGB color

Full-color RGB images are composed of three 8-bit primary color channels—red, green, and blue—which are actually similar to grayscale images and contain 256 shades per channel. When working with 8 bits per channel, RGB images the Photoshop Mode menu displays a check mark next to 8 bits/channel but they are more commonly called 24-bit color images. These three channels, when combined, produce a potential 16,777,216 colors ($2^{24} = 16,777,216$). Photographic images require 24-bit color to describe their smooth gradations and subtle tonal variations.
FIGURE 1.3

A grayscale image potentially composed of 256 gray tones.

Most scanners can produce images in 48-bit color. At this bit depth, the information is distributed into three 16-bit channels — red, green, and blue — each with a potential of 65,536 possible colors ($2^{16} = 65,536$). These channels, when combined, can produce trillions of possible colors. Some professional photographers and photo retouchers prefer these high-bit images because they offer an extended dynamic range and more subtle tonal variations. Photoshop can read images with 16 bits of information per channel, designated in the Mode menus as 16 bits/channel.
Calculating File Size

An image's file size can be calculated by multiplying its height and width in pixels by its bit depth, or the amount of memory each pixel consumes. For example, an RGB image that is 5 inches tall by 7 inches wide and has a resolution of 72 ppi (pixels per inch) is 504 pixels by 360 pixels.

Because the image is an 8-bit RGB, each pixel contains 24 bits of information. We must convert the bits to bytes to streamline the calculation. There are 8 bits in a byte; we divide 24 by 8 and get a factor of 3. We multiply the height by the width by the bit-depth factor (in bytes), or 504 × 360 × 3 = 544,320 bytes. Because there are 1,024 bytes in a kilobyte, we divide 544,320 by 1,024 to get 531.56, or 532 kilobytes when rounded off to the nearest whole number.

The value derived from this formula is the raw file size. The addition of layers, channels, paths, layer masks, Smart Objects, and annotations will increase the file size. The file size may be reduced when the image is saved to an image format with a compression scheme, such as JPEG or TIFF.

64-bit CMYK

A 64-bit CMYK color image actually has four channels of 16 bits per channels. The file sizes of these images are much larger. Many of the color combinations that 64-bit CMYK images can produce are a 4-color ink composite of black. It's debatable whether it's worth creating CMYK images with so much information when they are going to be output to four color process separations and printed with a system of inks with a significantly smaller color gamut than RGB.

Even though images with higher bit depths contain more color information, they are displayed on the monitor at the bit depth capability of your video card, which in most cases is 24 bits. To see an image in 24-bit color depth on a Macintosh, the monitor should be set to Millions Of Colors; in Windows, the setting should be True Color.

HDR images

Photoshop supports High Dynamic Range (HDR) images that represent the entire dynamic range of the visible world. The luminance values of an HDR image are stored in 32-bits-per-channel images. You can create an HDR image using multiple photographs, each captured at a different exposure, and merge them using the Merge To HDR command.

See Chapter 12 for more details on HDR images. All the luminance values in a real-world scene are represented and stored in HDR images. Adjusting the exposure of an HDR image in the Merge to HDR command image gives you the same range of exposure as when photographing a scene whereas 8- and 16-bit color targets only a small part of the visible spectrum. This capability has the potential to make your images look more realistic.
Understanding File Formats

Different file formats serve different purposes. Some formats compress data to make the file size smaller on the disk, while others are used to make a file compatible with another software program or the Web. The format you choose depends on how the image will ultimately be used. It is important to know what saving an image to a specific format will do. At worst, saving a file to the wrong format can lose important data that enables you to retain the images eligibility. At the very least, it could inconvenience you by losing the ability to place the document into another program.

Photoshop CS3 can open 32 different file formats and save to 21 different file formats. With the addition of plug-ins that attach to the Import and Export submenus, Photoshop supports even more, which means that it is a great program for converting files to make them compatible with other software programs.

When considering in which format to save your document, think about what features you want to preserve. The native Photoshop format (PSD) preserves all saved features of the document including channels, paths, layers, profiles, and annotations. Because the native format contains all Photoshop’s features, consider working in PSD format until it is time to publish it. Then choose Image ➪ Duplicate to quickly make a copy. Choose Save As or Save for Web to save the duplicate document to the new file format.

Determining Resolution and Size

A screen image is composed of pixels whereas a printed image may be composed of dots or lines. An image’s resolution is determined by the number of these visual units per linear inch in the display or print. Each one of these units is a building block. The more building blocks that the image has, the finer the detail that can be created and displayed and, therefore, the higher the quality of the image.

Resolution

There are several kinds of resolution. Each kind has specific characteristics that determine how an image is displayed or printed. When you create an on-screen image in Photoshop, the pixel information may be converted into a halftone screen or color separations when preparing files to print on a printing press or a stochastic screen when printing to an inkjet printer. It is important for you to understand the qualities of each type of resolution.

Image resolution

Image resolution is determined by the number of pixels that occupy a linear inch of a digital image, usually measured in pixels per inch, or ppi. You can clearly see the pixels in Figure 1.4. Image resolution is determined when you scan an image or shoot a digital photo at a given setting.
Monitor resolution

Monitor resolution is determined by the number of screen pixels that occupy a linear inch of a monitor screen (72 ppi for most Macintosh RGB monitors, 96 ppi for Windows VGA monitors). This resolution never changes, as it represents the physical matrix of screen pixels of the monitor. The actual size of what you see on-screen, however, is determined by the resolution settings of your monitor. You can choose specific display resolutions in which to view an image from your operating system's Control Panel ➔ Monitor (Windows) or from the System Preferences ➔ Displays (Mac). Depending on your monitor and video card, the smallest resolution available is 640 pixels wide x 480 pixels deep, which displays the image quite large on-screen. The largest setting depends on the size of the monitor and displays a much smaller on-screen image. When an image with the same resolution as the monitor's actual matrix is displayed in Photoshop at 100%, it appears at its physical size relative to the screen pixels and the monitor's display settings because at 100%, one image pixel equals one monitor pixel. If the image has a higher resolution, it will appear larger than its physical size. For example, a 3” x 4” image that is 288 ppi will appear four times larger at 100% than an image that is 3” x 4” at 72 ppi (4 × 72 = 288). If you copy and paste (or drag and drop) an image that is the same physical size but a lower resolution to a document of higher resolution, the pasted image will be proportionally reduced in physical size as in Figure 1.5).

If you want to see the image at the size it will be printed, choose Print Size from Photoshop’s View menu. The image displays at the size at which it will print, no matter what its resolution.

Printer resolution

Printer resolution is measured by the number of dots that can be printed per linear inch (dpi). These dots compose larger halftone dots on a halftone screen or stochastic (frequency modulated) dots on an inkjet printer.
Halftone resolution

Printing an image on paper with a printing press presents a unique set of problems. How does a machine such as a printer portray variations in color and tone? It needs a method that will produce color and tonal range without blending ink. To accomplish this task, the ink is distributed to individual dots of variable size within a grid called a *halftone screen* (see Figure 1.6). The dot density of a printed image is measured in lines per inch (lpi) or, in some instances, lines per centimeter (lpc) which describe the vertical and horizontal lines of the grid. On a traditional halftone screen used to print black-and-white images, the size of the dots determine the darkness or lightness of an area. Larger dots portray areas that are darker than areas with smaller dots which allow more of the paper to show through. With full-color images, four different colored halftone screens— one each of cyan, magenta, yellow, and black—called *color separations*, are registered on each other (see Figure 1.6). These tiny colored dots combined in varying densities on the paper force the eye to mix colors when viewed and produce a full range of color. The resolution of the halftone screen determines the amount of detail that can be printed. The finer the halftone screen, the more detail can be displayed. The line frequency of the halftone screen is determined by the type of printing that is being performed. Table 1.1 is a list of common frequencies used in various types of printing.

When you print an image from Photoshop to color separations on a laser printer or imagesetter, the values of the pixels are calculated by a hardware device or software called a RIP (Raster Image Processor) that converts the pixel information into dot densities. The printer uses this information to produce a single halftoned image or a series of color separations.
TABLE 1.1

Common Halftone Screen Values

<table>
<thead>
<tr>
<th>Frequency</th>
<th>Description and Commercial Uses</th>
</tr>
</thead>
<tbody>
<tr>
<td>60 lpi</td>
<td>A coarse halftone screen, suggested for screen printing.</td>
</tr>
<tr>
<td>85 lpi</td>
<td>Less course. The dots are visible to the naked eye. Commonly used for newsprint and porous paper stock.</td>
</tr>
<tr>
<td>133 lpi</td>
<td>Finer detail. The dots can only be seen with a magnifying glass. Used on web presses for printing medium-quality weekly magazines, books, and stationary on uncoated paper.</td>
</tr>
<tr>
<td>150–175 lpi</td>
<td>Very fine dots. These frequencies are suitable for brochures, pamphlets, and commercial printing on coated stock.</td>
</tr>
<tr>
<td>200–300 lpi</td>
<td>These frequencies produce the finest images with lots of detail and color depth. You might use this option when creating annual reports or fine art prints.</td>
</tr>
</tbody>
</table>

**Stochastic screen resolution**

Rather than using variable sized dots to portray color, an inkjet printer uses a system frequency of modulated dots whose quantities determine tonality and color density. Figure 1.6 shows close-ups of the same photograph. Inkjet printers deposit tiny droplets of ink through a system of micropiszo jets. Higher-end printers sometimes use multiple shades of cyan, magenta, and black to produce a greater range of color and sublimate the dots so that they bleed into each other producing a continuous tone effect.

**FIGURE 1.6**

A close-up of a halftone screen of a black and white photograph (left); a close-up of the colored dots produced by color separations (middle); and a close-up of the colored dots printed by an inkjet printer (right).
Determining resolution

When you scan an image, it is crucial to acquire enough information to produce good-quality halftones from your laser printer, imagesetter, or direct to plate device. If the image is insufficient in resolution it may appear soft or pixilated. Scan your images at two times the screen frequency of the halftone screen. That means if your image is going to be printed in a newspaper or in a newsletter, on an 85 lpi halftone screen, scan it at 170 pixels per inch. If your image will be printed in a glossy magazine, at 150 lpi, scan your image at 300 ppi. If you will be increasing the size, factor in the percentage of scale. Here is the formula:

\[ \text{scan resolution} = 2 \times \text{line screen} \times \% \text{ of scale.} \]

If you plan to print to an inkjet or large format printer, scan your images at a minimum of one-third the desired print resolution. For example, for a print resolution of 720 dpi, scan the image at 240 ppi or higher. If you are going to increase the size of the printed image, then you should scan at a higher resolution. This equates to common scan resolutions of 120 ppi, 240 ppi, and 480 ppi — although anything more than 360 ppi is probably overkill. In fact, an image scanned at 300 ppi and printed at 100% is usually quite sufficient for any printer.

Line art or bitmap content is different. Ideally, scan at the same resolution as the printer's dpi resolution or in evenly divisible units of the printer's resolution. For example, you would scan at 360 ppi for a 1,440 dpi print.

Sizing images

Resolution and size are interchangeable factors. You can enlarge the physical size of an image with no loss of quality if you reduce its resolution. If you scan a picture at 600 ppi and print it at 300 dpi, for example, you can double its physical size without compromising its quality. And of course, scanning an image at 300 ppi at 200% using the scanner software's sizing feature collects the same amount of information as scanning the image at 600 ppi. Avoid exceeding the scanner's optical resolution as it may produce disappointing results.

Photoshop's Image Size command changes the size and/or resolution of the entire image. The features in this dialog box provide extensive control over how the image is reconfigured. You can size an image simply by redistributing its pixels. Essentially you can reduce its resolution and increase its physical size (or vice versa). To do so, follow these steps:

1. Choose Image ➤ Image Size. The Image Size dialog box shown in Figure 1.7 appears. This particular image is 3" wide and 4" high, and has a resolution of 150 ppi.
2. Clear the Resample Image box, which also clears the Constrain Proportions box and grays out the option.
3. Type a new value into the Resolution field. In this example, change the resolution from 150 ppi to 300 ppi, doubling the resolution of the image but reducing its physical size to 1.5 x 2". Notice that the Pixel Dimensions remain the same because there is no addition or deletion of pixels.
4. Click OK to apply the changes.
When you clear Resample Image, as in the above example, you preserve the images pixels while changing its output size. When you check the Resample image box, you add or discard pixels. Use this feature to resize the image and retain or increase its resolution. Decreasing the size of the image or resampling down, usually doesn’t affect the image’s quality but be cautioned that enlarging the image by resampling up may produce a soft image with fuzzy edges and inferior contrast.

To resample an image, select the Resample Image box in the Image Size dialog box and pick from one of the five choices listed in the menu: Nearest Neighbor, Bilinear, Bicubic, Bicubic Smoother, and Bicubic Sharper. Each of the following algorithms programs how Photoshop adds or removes pixels from your image.

**FIGURE 1.7**

In the Image Size dialog box, you can redistribute pixels by deselecting the resample box or add and subtract pixels by checking it.

- **Nearest Neighbor**: Evaluates an adjacent pixel. Use this option for line art desktop icons, software interface screen captures, or any time that anti-aliasing creates artifacts.
- **Bilinear**: Averages the four pixels above, below, and on either side for smoother transitions.
- **Bicubic**: Averages the eight closest neighbors and adds a sharpening effect to increase the contrast.

Although scanning an image at its ultimate output resolution and size is always a better option, sometimes it is simply not possible. If you must, use these two interpolation algorithms to help reduce the diminished quality of enlargements. Bicubic Smoother and Bicubic Sharper do not add detail to an image. They increase edge contrast to subvert the softening effect of resampling up. You should experiment and compare the effects of each algorithm for best results.
- **Bicubic Smoother**: Slightly blurs the edges of areas to produce the most contrast when it adds pixels for a more sublimated continuous-tone look. Bicubic smoother is often used to enlarge images to smooth out any artifacts that are created.
- **Bicubic Sharper**: Adds an additional sharpening algorithm to better enhance edge contrast. Bicubic smoother is recommended to reduce image size to maintain sharpness.

**Constraining proportions**

When you resample an image, you can constrain its proportions. When selected, the Constrain Proportions box ensures that image height and width will maintain their proportions — changing one dimension automatically updates the other. When this option is inactive, the link icon between height and width disappears and you can increase the height and width independently of each other.

**Scale styles**

When the Scale Styles option is selected, any Layer Style will be resized proportionally (see the section “Working with Layers” in this chapter). Clearing this box results in the layer styles retaining their original size.

**Getting help with resizing images**

If you’re confused about resizing and image, choose the Resize Image Assistant (Macintosh) or Wizard (Windows) from the Help menu to guide you through the resizing process of choosing the best possible results for size and resolution. It automatically applies the resize command to duplicate the document so the original image is unaffected. To use it, choose Help → Resize Image and wait for the Resize Image Assistant /Wizard window to appear. Follow the directions and make the appropriate choices.

**Setting interpolation for the program**

Choose General Preferences (Edit/Photoshop → Preferences → General) to display the default interpolation settings for the entire program. These defaults affect the sizing functions when using the transformation commands from the Edit menu or the Move tool and several of the distortion filters and the Crop tool when cropping to a specific size. Similar to the Image Size dialog box the Interpolation methods are Nearest Neighbor, Bilinear, Bicubic, Bicubic Sharper, and Bicubic Smoother.

**Sizing channels and masks**

If you resize an image with the Image Size command, all the channels and masks including color channels, layer and vector masks, alpha channels, active quick masks, and paths are sized proportionately with the image. If you add canvas to the image the outer edges of the channels and masks are enlarged to accommodate the new size. When you crop an image so too are the masks and channels cropped at their outer edges however, paths and vector masks retain their original size, shape, and position and extend outside the Image window.
Transforming images

Transformation commands affect selected areas or layer content. Transformation operations offer the ability to scale, rotate, skew, or distort the perspective and warp an image. They are accessed through either the Edit menu or can be applied with the Move tool with the Show Transform Controls selected in the Options bar.

When you choose one of the transformation options, a bounding box surrounds the selected area or layer content. You transform the image by dragging one of the corner or center or corner points of the bounding box, or placing the cursor outside the box and dragging to rotate it. To complete any transformation you must click the check mark in the Options bar to commit it or the Cancel icon to abort it. Table 1.2 shows how to apply the transformation operations.

<table>
<thead>
<tr>
<th>TRANSFORMATION</th>
<th>MENU</th>
<th>OPERATION</th>
<th>MOVE TOOL: CHECK SHOW TRANSFORM CONTROLS IN THE OPTIONS BAR</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move</td>
<td>NA</td>
<td>Place the cursor anywhere inside the bounding box (except on the point of origin) click and drag.</td>
<td>Place the cursor anywhere inside the bounding box (except on the point of origin) click and drag.</td>
</tr>
<tr>
<td>Scale</td>
<td>Edit Transform</td>
<td>Click and drag the handles of bounding box inward or outward. Press the Shift key to constrain the proportions. Press the Opt/Alt to scale from center.</td>
<td>Click and drag the handles of bounding box inward or outward. Shift-click to constrain the proportions. Opt/Alt click to scale from center.</td>
</tr>
<tr>
<td>Rotate</td>
<td>Edit Transform</td>
<td>Drag cursor outside of the bounding box. Click and drag clockwise or counter clockwise. Click and drag the point of origin to change the fulcrum of the rotation.</td>
<td>Drag cursor outside of the bounding box. Click and drag clockwise or counter clockwise. Click and drag the point of origin to change the fulcrum of the rotation.</td>
</tr>
<tr>
<td>Skew</td>
<td>Edit Transform</td>
<td>Click and drag one of the corner points of the bounding box vertically or horizontally.</td>
<td>Ctrl+Opt/Alt click and drag a corner point vertically or horizontally</td>
</tr>
<tr>
<td>Distort</td>
<td>Edit Transform</td>
<td>Drag one of the corner points of the bounding box in any direction</td>
<td>Ctrl click and drag a corner point in any direction</td>
</tr>
</tbody>
</table>
Transformation Menu Operation Move Tool: Check Show Transform Controls in the Options bar

<table>
<thead>
<tr>
<th>Transformation</th>
<th>Menu</th>
<th>Operation</th>
<th>Move Tool: Check Show Transform Controls in the Options bar</th>
</tr>
</thead>
<tbody>
<tr>
<td>Perspective</td>
<td>Edit ➪ Transform ➪ Perspective</td>
<td>Drag one of the corner points of the bounding box in any direction</td>
<td>Press Shift+Ô/Ctrl and drag a corner point in any direction</td>
</tr>
<tr>
<td>Warp</td>
<td>Edit ➪ Transform ➪ Warp</td>
<td>Choose a Warp option from the menu in the Options bar and adjust the settings in the dialog box. or Choose Custom from the Warp Options menu, Click and drag a gridline or anchor point.</td>
<td>Click one of the points on the bounding box. Choose the Warp icon in the Options bar to display the grid. Click and drag a gridline or anchor point.</td>
</tr>
</tbody>
</table>

Other rotations and flipping

The Edit ➪ Transform submenu offers five standardized transformations. The options listed in Table 1.3 work the same as their Image ➪ Rotate Canvas counterparts, but they affect only the active selection or layer, and offer you one-click access to some of the most common image modifications:

<table>
<thead>
<tr>
<th>TABLE 1.3</th>
<th>Rotations and Flips</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command</td>
<td>Action</td>
</tr>
<tr>
<td>Rotate 180°</td>
<td>Rotates a selection or layer content by 180 degrees so that appears upside down.</td>
</tr>
<tr>
<td>Rotate 90° CW</td>
<td>Rotates a selection or layer content clockwise by 90 degrees.</td>
</tr>
<tr>
<td>Rotate 90° CCW</td>
<td>Rotates a selection or layer content counterclockwise by 90 degrees.</td>
</tr>
<tr>
<td>Flip Horizontal</td>
<td>Mirrors a selection or layer content across the vertical axis, creating a horizontal reflection.</td>
</tr>
<tr>
<td>Flip Vertical</td>
<td>Mirrors a selection or layer content across the horizontal axis, creating a vertical reflection.</td>
</tr>
</tbody>
</table>
Transformations can also be made numerically in the Options Bar. Choose a Transformation from the Edit ➪ Transform menu, or choose the Move tool and click the Show Transformation Controls box in the Options Bar. Click a segment or a corner point on the bounding box, and the Options bar will display numerical data, as shown in Figure 1.8. You can transform the bounding box by typing new values in the text boxes.

**FIGURE 1.8**
The Move Tool Options bar showing numerical values for transformations.

---

**Using the Crop Tool**

Sometimes it’s necessary to discard part of an image. The Crop tool can precisely discard unwanted image areas. You can also crop to a specific height, width, and resolution and use the Crop tool’s perspective feature to fit a portion of an image into a specific size. Follow these steps to perform a basic crop with the Crop tool:

1. Choose Image Duplicate to make a copy of the image.
2. Choose the Crop tool from the Tool palette.
3. Drag the mouse to define the bounding box. The area outside the crop will darken as shown in Figure 1.9.
4. Click and drag the handles of the bounding box to encompass more or less of the image. Drag bounding box by placing the cursor inside the boundaries and click and drag. Release the mouse when you are satisfied with the new position.

The Crop rotation option becomes active when the cursor is anywhere outside the crop selection; when the cursor is too close to the bounding box, a Crop Bounding Box Resize icon appears.

5. If you want to rotate the crop marquee, place the cursor outside the bounding box and click and drag clockwise or counterclockwise. Drag the mouse to rotate the bounding box. Make further adjustments by dragging any of the handles until you’re satisfied with the new, rotated crop.

After you’ve established the crop marquee, Shift-Click on a corner point drag and readjust the size of the crop while constraining the proportions. Opt/Alt click and drag to constrain the crop bounding box proportions as you radiate the marquee from its point of origin in the center of the marquee. Reposition the point of origin by clicking and dragging it.

6. To implement the crop, click Commit (the check mark in the Options bar) or press Return (Mac) or Enter (Win). You can also double-click inside the cropping area to commit your crop. If you decide to cancel the crop, press the Esc key or click the Cancel button.
Cropping to size

You can crop your image to a fixed size and new resolution by entering values for the height, width, and resolution in the Crop Tool Options bar, shown in Figure 1.10. When you drag the Crop bounding box it is automatically constrained. When you commit the crop, everything within the crop marquee will conform to the new specified size.

Most cropping is usually performed with the width, height, and resolution fields left blank. Click the Clear button on the Options bar to clear the number fields to restore manual operation. Click the Front Image button on the Options bar to automatically enter the current active document's width/height/resolution into the number fields.
Perspective cropping

You can distort an image to fit a particular area of the image content into a rectangular document of a specific size. After you’ve drawn a marquee, you can crop to perspective as in Figure 1.11. With the Perspective option selected in the Options bar you can adjust the corner anchor points of the bounding box independently. When you implement commit the crop, the image area distorts to conform to the new document’s height and width.

FIGURE 1.11
Use the Perspective option to fit a region of an image into a rectangular shape.

Sizing the canvas

Choose Image > Canvas Size to access the dialog box that allows you to expand or shrink your canvas. The Canvas Size dialog box, shown in Figure 1.12, creates more pixels around the image. When you perform this operation on an image that has background layer, by default, the new canvas is filled with the current background color. If there is no background layer, the new canvas extension will be transparent. You can choose a canvas extension color from within the Canvas Size dialog box. The Canvas Extension Color menu lets you choose the Foreground color, the Background color, White, Black, or Gray from the predefined color menu. Or click the swatch and choose a color from the Color Picker.

The Current Size field displays the current file size and the width and height of the image. Type a new overall width and height value in the New Size field to determine the new overall size or select the Relative box and enter the amounts you want to add to an existing canvas. You can choose from eight different units: percent, pixels, inches, centimeters, millimeters, points, picas, and columns in which to add canvas.
The anchor grid controls the position of the new canvas. Click the center cell, and the image will be framed on all sides by the new canvas. Click any of the cells to determine where the new canvas will be added.

FIGURE 1.12
The Canvas Size dialog box lets you specify color, size, and position of the new area added to the image.

Rotating the canvas
The Rotate Canvas submenu found under Image ➪ Rotate Canvas, offers options that you can use to reorient your entire document. Experiment with the following options:

- **180°**: Rotates the image so that it appears upside-down. The image retains its left-to-right orientation.
- **90° CW**: Rotates the canvas by 90 degrees clockwise.
- **90° CCW**: Rotates the canvas by 90 degrees counterclockwise.
- **Arbitrary**: Displays the Rotate Canvas dialog box. Specify an angle of rotation by typing a number in the Angle field. Choose CW or CCW (clockwise or counterclockwise), and click OK.
- **Flip Canvas Horizontal**: Mirrors the image across the vertical axis.
- **Flip Canvas Vertical**: Mirrors your image across the horizontal axis with vertical mirroring.

Working with Layers
Layers enable you to work dynamically in Photoshop. This means that image content can be saved to individual layers and edited independently. Layer content can be moved vertically or horizontally.
The stacking order of layers can determine the depth and position of visual elements within the picture plane. Working with layers gives you tremendous power and control over your image and keeps the editing process flexible and dynamic.

**The Layers palette**

The Layers palette, shown in Figure 1.13, is the control center where you perform most of the layer functions. The Layers palette is clustered with the Channels and the Paths palettes. If the Layers palette is not visible, choose Window ▶ Layers or press the F7 key.

Layers are stacked and each is separated from the one directly below it or above it by a thin line. Each layer contains a thumbnail of the layer’s contents, and the layer’s name appears to the right of the thumbnail. Layer styles, masks, or locks are indicated by icons. In the far-left column is the visibility icon which controls layers visibility.

![FIGURE 1.13](image)

The Layers palette displaying a background, two content layers, and a type layer.
Above the layer stack you can select from the four check boxes, which lock transparency, image pixels, position, or all. At the top-left of the Layers palette is a list of blending modes that can alter the color relationships of layers in the stack. And to the right of the blending modes is the Opacity slider, which controls the level of transparency of a targeted layer's contents. Fill Opacity control is just below the master opacity control.

You can access many layer operations from the Palette Options menu, shown in Figure 1.14. Click the small triangular icon on the top-right to reveal the list of options.

**FIGURE 1.14**
The Layers Palette Options menu.

---

**Working with the background**

When you scan or import an image and open it in Photoshop, the Layers palette displays one thumbnail, labeled Background. A background is the Photoshop's default layer. If you delete the contents of a selection or erase a portion of the image with the Eraser tool, the area fills with the background color specified in the Tools palette.

All layers float above the background. Unlike a layer, the background does not support transparency. No matter how many layers are in the document, the background is always at the bottom of the stack and cannot be dragged to a higher position. When a layer is created, its content always appears in front of the Background. By default, the Background is locked. If you want to move its contents, adjust its opacity, or reposition it in the Layers stack, you need to convert it to a layer. As with many of Photoshop's operations, there is more than one way to perform this task.
To convert a background to a layer, double-click the background or choose Layer ➪ New ➪ Layer from Background. The New Layer dialog box, shown in Figure 1.15, appears. Name the layer and click OK.

The New Layer dialog box presents options to color-code, specify opacity, and choose a blending mode. You can also group it with other layers if, for example, you’re using it to make a clipping group.

A layer can be converted to a background, too. Click once on the layer to highlight it. Choose Layer ➪ New ➪ Background from Layer. The new Background is automatically placed at the bottom of the stack. Any transparent areas will be filled with the current background color.

**Naming layers**

Name your layers! The default numbers that Photoshop assigns to new layers become quite anonymous when their content is too small to be recognized on the thumbnail or when there are several dozen of them in the document. Type a name that readily identifies it. Naming each layer with a descriptive title is a fast way to organize the components of your image for easy identification and to increase the efficiency of your workflow.

To name a layer, double-click the current name next to the thumbnail in the Layers palette. A box appears around it. Type in the new name. Or you can choose Layer Properties from the Layer Options menu and type a name in the Layer Properties dialog box, shown in Figure 1.16.
Viewing layer content

You can conceal the contents of a layer by clicking the visibility icon (the little eye) in the first column of the Layers palette. To see the contents, click it again. To reveal or conceal the contents of more than one layer at a time, click the eye next to each of the desired layers. To conceal all but one layer, Option/Alt click the visibility icon. With the same key held down, click the icon again to see all layers.

Choosing thumbnail size

A thumbnail is a miniature representation of a layer's content. Pick from three sizes of thumbnail, or no thumbnail at all. To specify a thumbnails size, click the Layers Palette Options arrow. Choose Palette Options to display the dialog box shown in Figure 1.17. Click the desired thumbnail size and then click OK.

FIGURE 1.17

The Layer Palette Options menu determines the size of the thumbnails that are displayed.

Highlighting layers

Before you can apply a command to affect the contents of a layer, you must highlight it first. A highlighted layer is targeted and ready to be edited. Click anywhere on the layer. A colored highlight appears on the layer. You can highlight more than one layer at a time by Shift-clicking on each layer to select contiguous layers or Option/Alt click to select noncontiguous layers. (See the section “Working with Layers” in this chapter.)
Understanding transparency

Transparency is indicated by a gray and white checkerboard. A transparent area can either be entirely void of pixels or the pixels are completely transparent. A layer is semitransparent when you can partially see the checkerboard or if you can see content from other layers through it. Figure 1.18 illustrates the difference between opaque and semitransparent images.

If the color of the image is predominantly gray and the checkerboard becomes difficult to see, the color and size of the checkerboard can be changed in Transparency & Gamut Preferences to better reveal the image.

Controlling opacity

Use the Opacity sliders to adjust the level of transparency of the pixels on a targeted layer. You can then see through layer content to the underlying layers in the stack. When you click the Opacity field on the Layers palette, a slider appears. Drag it to the right to increase, or left to decrease opacity, or enter a value from 0% to 100% directly into the box.

If any tool other than the painting and editing tools is active, you can type any number between 1 and 100 to change the Opacity value of the targeted layer.

Place the cursor to the right of the word Opacity in the Layers palette, click and drag to adjust the Opacity of the layer.

Understanding fill opacity

The Fill Opacity slider adds another opacity setting to a layer. Fill Opacity affects a layer's pixels without affecting the opacity of any Layer Styles that have been applied to the layer. (Layer styles are discussed later in this chapter.)

Changing stacking order

The stacking order in the Layers palette determines the plane of depth where the layer content appears. The content of the topmost layer in the Layers palette appears in the very front of the image. The further down in the stack a layer is, the farther back its content appears on the image, all the way back to the bottom-most layer, or the background.

You can change a layer's position in the stack and, consequently, its visual plane of depth in the image. In the Layers palette, click and drag the layer up or down to reposition it. As you placed the layer on a division line, it appears bold. The bold line indicates the new location where the layer will appear when the mouse is released.
Another method of changing the position of the layer in the stack is to choose an option under Layer ▸ Arrange, or use the equivalent key command. The Arrange submenu presents you with four options, as shown in Table 1.4.
TABLE 1.4

<table>
<thead>
<tr>
<th>Key Commands for Changing Stacking Order</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Position</strong></td>
</tr>
<tr>
<td>Bring Forward</td>
</tr>
<tr>
<td>Bring To Front</td>
</tr>
<tr>
<td>Send Backward</td>
</tr>
<tr>
<td>Send To Back</td>
</tr>
</tbody>
</table>

**Working with multiple layers**

There are several ways to affect two or more layers simultaneously. To highlight multiple layers, Shift-click each layer to select contiguous layers, or Ô/Ctrl click to select noncontiguous layers. When multiple layers are selected you can transform each layer's contents, you can do the following:

- Reposition layers in the stack
- Merge layers
- Align layer contents
- Lock layers
- Group layers into a Layer Group
- Create a Smart Object
- Create a clipping group
- Link layers

**Linking layers**

Linked layers are used primarily for the simultaneous transformations and repositioning of multiple layers. Linking layers is similar to selecting multiple layers but gives you the ability to reselect them quickly. After you’ve linked them, you need only to highlight and transform one of the layers and all the layers linked to it will also be affected. To link one or more layers, click one of the layers. From the Layers Palette Options menu, choose Link Layers. A chain icon appears to the right of the Layers name, as shown in Figure 1.19. Linked Layers can also be merged (see the section, “Consolidating Layers” later in this chapter).

You can apply other effects to multiple layers by using specific layer-based operations. (These effects are described in more detail in later sections of this chapter and in later chapters of this book.)
FIGURE 1.19
Linked layers are indicated by a chain icon.

These operations include the following:

- **Adjustment Layers**: Used for color and contrast adjustments and for color mapping.
- **Layer Masking**: Used to conceal and reveal portions of two contiguous layers.
- **Blending Modes**: Used to affect the relationship between the pixels on a layer and the layer immediately beneath it.
- **Layer Groups**: Used for organizing, controlling opacity, positioning two or more contiguous layers in the stack, and for transforming or moving layer content. (See the section on grouping layers in this chapter.)
- **Layer Comps**: Used for saving multiple versions of an image for efficient display.
- **Fill Layers**: Used to apply a solid color, gradient, or pattern to an independent layer.
- **Layer Content**: Used for changing the type of Adjustment or Fill layer.
- **Clipping Masks**: Used for the transparency of one layer to hide portions of a layer immediately below it in the stack.

**Grouping layers**
A Photoshop document can support an unlimited number of layers. You can consolidate layers into groups to better manage them. A Layer Group is indicated in the Layers palette by a folder icon as shown in Figure 1.20. Click the arrow to the left of the icon to expand the folder to see its contents.

By highlighting the folder, you can affect the layers as a group. The group can be revealed or concealed, repositioned in the stack, and similar to linked layers — moved and transformed.

You have several options for creating a new Layer Group:

- From the Layer menu choose **Layer ‡ New ‡ Layer Group**.
- From the Layers Palette Options menu, choose **New Layer Group**.
Layer Groups appear as a folder icon in the stack. When opened, the layers within the folder are indented.

- You can select multiple layers in the stack and then choose Layer ▸ New ▸ Group from Layers from the Layers menu or Group from Layers from the Layers Palette Options menu.
- Click the Layer Group icon in the Layers palette. By default, the layer set will be named Group 1, Group 2, and so on. With the first three commands, a dialog box shown in Figure 1.21 appears. You can name the layer set, color-code it, and specify the color channels that comprise the image.
- After you've created a new Layer Group, you can add layers to it by clicking and dragging individual or multiple highlighted layers to it, then, release the mouse.

Layer Groups and color channels

To change the characteristics of a highlighted Layer Group, choose Group Properties from the Layers Palette Options menu or from the Layers menu. In the dialog box shown in Figure 1.22, click the Red, Green, or Blue color checkboxes to determine the color information will be visible. The boxes display the individual or combined color channel information of all the layers in the Group. This is can be useful if you want to limit the color information of a particular layer. You can produce some rather interesting effects especially if you are applying a blending mode to the Group as in Figure 1.23. From this dialog box you can also color code a Layer Group for easy recognition.
Locking layers

Layer locks protect specific characteristics of a layer from being edited. There is an icon for each lock at top of the palette, as shown in Figure 1.24. To lock a layer, click the layer to highlight it and click one of the checkboxes. The lock types include:

- **Lock Transparent Pixels**: Protects the areas without pixels or with an opacity value of zero from being edited. If you try to paint on a transparent area, for example, no color will be deposited. The transparency lock works like a mask. The areas that do contain pixels will still respond to any Photoshop operation. Locking transparency does not protect transparent areas from the effect of transformations such as scaling, rotating, or moving.

- **Lock Image Pixels**: Protects the layer from editing functions such as painting, color adjustments, or filters. You can, however, transform or move the content of a layer.

- **Lock Position**: Prevents the layer from repositioning or the application of the Transformation functions such as Scale, Rotate, Distort, and so on.

- **Lock All**: Protects a targeted layer from all editing functions.

Creating new layers

You frequently need to make a new layer, either to add new content to the image or to move part of an existing layer onto a new layer. There are several options for creating new layers.

You can make new empty layers with any of these three methods:

- From the Layers menu, choose Layer ➤ New ➤ Layer to bring up the New Layer dialog box. Name the layer and specify its characteristics. Click OK.

- From the Layers palette pop-up menu, choose New Layer to bring up the New Layer dialog box, shown in Figure 1.25. Name the layer and click OK.
FIGURE 1.23
On the top is the original image and on the bottom a layer that has been placed in a Layer Group whose properties allow only the information from the Red and Green channel to be displayed. Combined with the Hard Light blending mode the effect produces a warm saturated look.

FIGURE 1.24
Click the Layer Locks icons to prevent layer content from being affected.
Click the New Layer icon at the bottom of the Layers palette. A new layer named Layer 1 appears in the stack immediately above the targeted layer. To rename the new layer, double-click its name and enter the new name in the Name field.

**FIGURE 1.25**
The New Layer dialog box.

You can also make a new layer by copying a selected area to a new layer. Copying leaves the original layer intact and transfers the selected area to a new layer immediately above it. To copy the contents of a new layer follow these steps:

1. Click the layer you want to copy and highlight it.
2. Select an area of a layer or background.
3. Choose Layer ➪ New ➪ Layer Via Copy. The selected portion of the image is duplicated and moved to the same position on a new layer. By default, the first new layer you copy or cut is assigned the name Layer and the next highest number that hasn’t been assigned (see Figure 1.26).
4. Double-click the layer’s name to rename the layer, and then press Return/Enter.

**FIGURE 1.26**
The Layers palette after the content has been copied to a new layer.
When you cut a selected portion of an image to a new layer, the selected area is either filled with the current background color if it’s on the background as in Figure 1.27, or replaced by transparency if it’s on a layer as in Figure 1.28. It is transferred to the same position on a new layer immediately above it.

To cut a selected area to a New Layer:

1. Target the layer or Background with the element(s) that you intend to cut.
2. Make selection of the area.
4. Double-click the layer’s name to rename the layer, and then press Return/Enter.

**FIGURE 1.27**
The Layers palette after the content has been cut from a background to a new layer.

**FIGURE 1.28**
The Layers palette after the content has been cut from a layer to a new layer.

**TIP**
To transfer selected content more quickly to a new layer, press Cmnd/Cntr1+J to copy or Shift+Ô/Ctrl+J to cut selected content to a new layer.
Transferring layer content

Individual layers can be copied from an open source document onto a destination document. The same is true with multiple highlighted layers and selected areas.

Copying individual layers

The entire contents of a layer can be dragged and dropped to an open document.

To drag a layer from a document, follow these steps:

1. Open the source document and the destination document so that they both appear on-screen.
2. In the Layers palette of the destination document, click the layer where you want the copied layers to appear.
3. In the Layers palette of the source document, click a layer or the background and drag it to the Image window of the destination document.
   Alternatively, you can choose the Move tool. Click the Image window of the source document and drag it to the Image window on the destination document.
4. Release the mouse when you see an outline. The new layer appears immediately above the targeted layer on the destination document.

Copying multiple layers

The entire contents of two or more layers can be dragged and dropped to an open document.

To drag a two or more layers from a document, follow these steps:

1. Open the source document and the destination document so that they both appear on-screen.
2. In the Layers palette of the destination document click the layer where you want the copied layers to appear.
3. On the source document click a layer or the background. Shift-click to select additional consecutive layers or Ctrl click to select non-consecutive layers.
4. In the Layers palette of the source document, click and drag the layers to the image window of the destination document.
   Alternatively, you can choose the Move tool. Click the Image window of the source document and drag it to the Image window in a destination document.
5. Release the mouse when you see an outline. The new layers appear above the targeted layer on the destination document.
Drag selected content

The contents of a selection can be moved from a source document to a destination document. When you drag and drop selected content, a new layer is automatically created in the destination document and will appear immediately above the targeted layer in the stack.

Here's how to drag and drop layers between two documents:

1. Open the source document and the destination document so that they both appear on-screen.
2. In the Layers palette of the destination document, click the layer where you want the selected content to appear.
3. Target the layer or background on the Layers palette of the source document.
4. Make an accurate selection of the area to be moved.
5. Choose the Move tool. Click and drag the selection from the source document’s Image window to the destination document’s Image window until you see a rectangular outline. Release your mouse when the outline appears where you want to position the selected content.

Duplicating layers

There are two techniques for creating a copy of a layer. The copy appears directly over the original in the stack and has identical characteristics and content. To duplicate a layer, do one of the following:

- Highlight a layer and then choose Duplicate Layer from the Layer menu or from the Layers Palette Options menu. The Duplicate Layer dialog box appears where you can name the layer and determine a destination document for it in the Destination field. Any currently open document will appear in the list. Then click OK.

- Drag the layer to the New Layer icon in the Layers palette. If you Option/Alt-drag, the Duplicate Layer dialog box, shown in Figure 1.29 appears.

**FIGURE 1.29**
The Duplicate Layer dialog box.
Discarding layers

You can discard individual or multiple layers. To discard a layer, do one of the following:

- Target the layer or layers to be deleted. Choose Delete Layer from the Layer menu or from the Layers Palette Options menu.
- Drag the layer or highlighted layers to the trash icon in the Layers palette.
- Highlight one or more layers and then click the trash icon. The dialog box shown in Figure 1.30 appears.
- Highlight one or more layers and then Opt/Alt-click the trash icon to delete the layer without the Delete Layer dialog box.

Blending layers

Blending layers is like having two color transparencies on a light table. If you sandwich a red transparent gel between the two transparencies you would have a combination of the bottom transparency and the top slide tinted by the gel. When you blend layers, instead of just the tinted image, you have the ability to sandwich in more complex effects, such as color saturation, which is shown in Figure 1.31.

Blending modes are preprogrammed formulas that affect the color relationships between aligned pixels on two consecutive layers. A blending mode can be assigned to a layer a couple of different ways:

- Highlight the layer. Click the Mode menu at the top of the Layers palette (directly under the Palette Title tab) to choose the desired blending option.
- Opt/Alt-double-click the layer name or double-click the thumbnail to display the Layer Style dialog box; see Figure 1.32. From the list on the left, choose Blending Options: Default. In the General Blending area, choose your blending mode and opacity level.

The options in the General Blending area are identical to those in the Mode menu at the top of the Layers palette. However, by using the General Blending in the Layer Style dialog, you can save the settings as a style and apply them to a different layer (see Saving Styles later in this chapter).
Applying layer styles

Layer styles are canned effects that simplify the application of enhancements such as shadows, glowing edges, and embossing that used to require labor-intensive channel and layer juggling. Most layer styles affect the edges of the layers content, so the content should be surrounded by transparency. To apply a style, double-click the layer or click the style icon at the bottom of the Layers palette and choose a style from the menu to display the Layer Styles dialog box.

When a layer has been affected by a style, the italic \( f \) icon appears to the right of its name in the Layers palette. Click the small arrow to the left of the \( f \) icon, to display a list of the current layer styles that have been applied to this layer. Clicking (Win)/double-clicking (Mac) any one of these effects displays its controls so that you can make modifications to it.

**FIGURE 1.31**
The original image on the top and a layer with the Hard Light blending mode applied to increase saturation in the bottom image.
If you want to create, define, or edit a layer style, access the Layer Style dialog box by doing one of the following. If a layer is targeted when you open this dialog, the style you choose will be applied to the layer.

**NOTE** You cannot apply a layer style to the Background.

![Layer Style dialog box](image)

**FIGURE 1.32**

The Layer Style dialog box with Blending Options displayed.

Add a layer style by following these steps:

1. Choose Layer ➪ Layer Style. Choose a style from the list.
2. Choose Blending Options from the Layers Palette Options menu. Click a layer style from the list to display its controls.
3. Double-click the layer.
4. Click the Layer Style icon at the bottom-left of the Layers palette and drag to a layer style to display its controls.
5. You can choose an effect from the Layer Style dialog box. To display the controls for each effect, click its name. Many of the controls have similarities, and experimentation with a live preview is the best way to see the results.

Each layer style provides a unique and potentially complex set of options. Experimentation with the controls and with combinations of styles is the key to producing the best possible effect.
Saving layer styles

If you've applied one or more styles or blending options to a layer you can save the style to later apply it to a separate layer. To save a style, click the New Style button in the Layer Style dialog box; a window is displayed where you'll be prompted to name your new style.

To apply the style, choose Window \(\rightarrow\) Styles. Highlight a layer and click the style that appears in the Styles palette.

Consolidating layers

During the editing process, you may accumulate quite a few layers. With each new layer, the size of your file of your document increases depending on the amount of information the layer contains. Or so many layers may be difficult to manage. To work more efficiently, you should periodically merge your layers. Merging layers combines the content of two or more layers into one layer. You can also flatten the image so that all the layers are consolidated into a Background. There are several ways to merge layers all of which can be selected from the Layers menu or the Layers Palette Options menu:

- **Merge visible layers**: This operation merges the content of all the visible layers into one layer. The layer retains the name of the current highlighted layer.
- **Merge layers**: Merges all highlighted layers into one layer. The layer retains the name of the topmost highlighted layer.
- **Merge linked layers**: Merges the content of all the linked layers into one layer. The layer retains the name of the current highlighted layer.
- **Merge down**: Merges the content of the targeted layer and the layer immediately below it into one layer. The layer retains the name of the highlighted layer.

To merge the content of layers into a single new layer press Opt/Alt and choose one of the Merge Options from the Layers menu or Layers Palette Options menu.

Flattening an image

Flattening an image discards all layers and creates a single background from all layer content. Before you flatten an image, make a duplicate version and save the original in PSD or TIFF format; both support layers. Flatten the duplicate because after the image has been flattened, saved, and closed, it cannot be un-flattened. To flatten your image, be sure all your layers are visible. Photoshop discards layers that are not visible. Choose Flatten Image from either the Layer menu or the Layers palette pop-up menu.
Masking Concepts

Masking is presented in detail throughout the book. In this section, I introduce masking briefly because it is such a key component of the Photoshop workflow. Masks provide the means to isolate regions of an image for various purposes. Creating accurate masks is essential to maintaining the credibility of a manipulated image.

When working with Photoshop, several types of masks are used:

- **Selection masks**: These are regions of an image temporarily defined by Photoshop’s selection tools. The selection tools are the primary method of isolating a region for editing (see Chapter 15 for a detailed look at making selections).

- **Quick masks**: This type of mask is made by clicking the Quick Mask icon on the Tool palette or pressing the Q key. A Quick Mask is a temporary mask that can be edited with the painting and editing tools. Quick Masks are an on-the-fly solution to accurately produce new selections or edit existing ones (see Chapter 16 to learn how to work in Quick Mask mode).

- **Alpha channels**: Save and store selections for later use. An alpha channel is created by saving a selection to the Channels palette and edited with Photoshop’s painting and editing functions. You can also apply filters to Alpha Channels to produce a variety of masks (see Chapter 16 for a closer look at Alpha Channels).

- **Layer masks**: Attached to a layer, these masks reveal or conceal layer content. They can be edited with Photoshop’s painting and editing features (see Chapter 20 to learn how to create Layer Masks).

- **Clipping masks**: Elements in a layer can be “clipped” to the pixels of the layer beneath it. The content in the top layer takes the shape of content of the lower layer. Transparent areas remain transparent (see Chapter 18 for more on Clipping Masks).

- **Filter masks**: This new feature that has been added to Photoshop CS3 enables you to block out portions of filtered areas on Smart Objects (Chapter 18 tells you all about it).

- **Vector masks**: Created from shapes or paths, Vector Masks are similar to Layer Masks except that they are created and edited using the Pen tools and Shape tools (see Chapter 20 to work with Vector Masks).

- **Type masks**: This typographical feature creates selections that conform to the shape of type characters in a font. Because many effects such as color adjustments and filters cannot be applied to type generated on layers, the Type Mask feature extends the typographical capabilities of Photoshop (see Chapter 22 to learn what Type Masks can do).
Summary

This chapter examines the construction of Photoshop images. You should now be familiar with how Photoshop image elements are assembled.

This chapter introduces many topics, including:

- Distinguishing between vector and raster graphics
- Understanding file formats
- Using the Crop tool
- Working with layers
- Duplicating and discarding layers

In this chapter, I touched on the basic fundamentals to get you familiar with building images. In the next chapter, you find more details on key Photoshop features.