Index

o/ o

About Us page
creating new site and, 50-51
editing, 28-30
accessibility, creating aura of, 42
accessing
existing site, 54
File Manager, 257-258
HTML, 228-229
HTML file, 61
Insert palette, 300
multiple pages, 303-305
Page Effects pane, 206
Web page, 61
Yahoo! SiteBuilder, 252-253
Yahoo! Web Hosting Control Panel,
252-253, 306
activity-oriented templates, 74
Add Item page, 276, 277
Add New Navigation Bar dialog box,
147-148
Add New Page dialog box
downloading template “on demand”
from, 76
store page, creating, 281
template page, creating, 78-79
Web page, creating, 59
adding
check box to form, 169-170
clip art image to page, 115-116
Contact Us form, 161
content to table, 132-133
list box to form, 168-169
navigation bar to new site, 51, 145-146
own images, 116-118
radio buttons to form, 170-171
Submit or Reset button to form, 172
table using Create New Table
dialog box, 131-132
table using toolbar, 130-131
text field or text area to form, 167-168

text from another source, 87-88
text to page, 86-87
add-on
accessing properties of, 182
benefits of, 12
Counter, 182-184
cutting, copying, and pasting, 182
description of, 180
Guestbook, 239-244
inserting, 181
Loan Calculator, 196-197
Presence Indicator, 194-196
previewing, 181
Pull-Down Menu, 236-239, 240
Site Search, 190-194
Time and Date Stamp, 184-185
Yahoo! Directions, 188-189
Yahoo! Map, 186-188
Yahoo! Search Box, 189-190
Yahoo! Web Hosting Control Panel and,
180, 233-236, 237
Add-Ons page, 233
administering site, 251. See also Yahoo!
Web Hosting Control Panel
Adobe Photoshop, 296
Advanced Navigation Bar Editor, 148
Align command (Ctrl+Shift+A), 70
Align dialog box, 70-71
aligning
gridlines and, 306-308
page elements, 70-71
text, 103-104
All Programsr>Yahoo! SiteBuilder=>Yahoo!
SiteBuilder, 16
Allow Common File Extensions option
(Preferences dialog box), 94
Allow Hyphenated Words option
(Preferences dialog box), 94
Alt Text option (Picture Properties dialog
box), 119-120
animated GIF, 293
Another Web Site option (Link dialog box),
106-107
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application, file-based, 45
Arial font, 96
Arranger>Bring Forward, 69
Arrange=>Bring to Front, 69
Arrange=>Grid Size, 308
Arrange=>Send Backward, 69
Arrange=>Send to Back, 69
Arrangec>Show Grid, 307
Arranger>Snap to Grid, 308
arrow key

moving page element with, 67

moving text box with, 89
assigning

alternative text to image, 119-120

link to image, 122
assumptions and design, 297
audio file, 202-205, 219
Audio Properties dialog box, 204
author meta tag, 63
Automatic Save feature, 302-303
Automatic Spell Checking feature, 91-92
Available Pages pane (Create Navigation

Bar dialog box), 146, 147
Available Pages pane (Edit Navigation Bar
dialog box), 150

ol e

Back button (browser), 188
background color of text box,
changing, 103
background image, turning picture into,
125-127
bank account, setting up, 285
“best of both worlds” goal, 1
bitmap graphics, 113
blank page
adding to site, 58
creating, 59
Blank Page command (Ctrl+N), 59
body, 228
Bold command (Ctrl+B), 97
bold text, 97-98
books, recommended, 311
Border Patrol effect, 207-208
Border Patrol Properties dialog box, 207
borderless table, 134
Bottom Justify button (toolbar), 104

Bouncing Images effect, 209-210
Bouncing Images Properties dialog
box, 209
Bring to Front command (Ctrl+Shift+F), 69
browser
Back button, 188
centering page inside, 64-65
testing site in, 294-295, 309-310
version of, 296
bulleted list
creating, 99-100
customizing, 101
Bullets and Numbering dialog box, 101
business site and effects, 219-220
business-oriented templates, 74
Button Images section (Navigation Bar
Properties dialog box), 153, 154
Buy Now button (PayPal), 266, 267-269
Buy Now Properties dialog box, 267, 268

oo

Catalog Manager (Yahoo! Merchant

Solutions)

adding new field to product catalog,
272-275

adding product to catalog, 276-278

bank account, setting up, 285

deleting catalog, 288

enabling catalog use with SiteBuilder,
279-280

importing catalog, 280-281

main page, 272, 273

online store, steps for building, 271-272

product module, adding, 286-287

publishing product catalog, 279

publishing site, 286

refreshing catalog information, 288

Shopping Cart button, adding, 284-285

store page, creating, 281-284

store tags, adding, 287

viewing product module properties,
287-288

CD

contents of, 313-314

Mac OS, using with, 313

Microsoft Windows, using with, 312

troubleshooting, 314-315



Index 3 ’ 7

cell
adjusting properties of, 133
merging, 138-139
selecting, 134
splitting, 139-140
Center Horizontally button (toolbar), 104
Center Vertically button (toolbar), 104
centering page inside browser, 64-65
changing user, 306
character formatting, 95
character style, setting, 97-98
charting software, 38
check box
adding to form, 169-170
description of, 165, 166
Check Punctuation option (Preferences
dialog box), 94
Check Spelling dialog box, 93
Checkbox Properties dialog box, 170
checking
grammar, 295
spelling, 91-95
validity of form text fields, 161
Choose a Background dialog box, 127
Choose a Name and Location dialog
box, 53
Choose an Image dialog box,
29, 115-116, 154-155
Choose Bullet dialog box, 100
Choose Import Destination
dialog box, 52, 53
Choose Layout box (Edit Navigation Bar
dialog box), 151
Choose Text Background dialog box, 103
Choose Text Color dialog box, 98
clicking through links, 55
Clip Art library
adding image from, 115-116
categories in, 115
image bulleted list and, 100
closing
Web page, 61
Web site, 55
code
downloadable JavaScript, 244
HTML, 222-227
location added, 229
reasons for learning and using, 227
code editor for Web page, 11

collapsing pane, 301
color codes, 97
color of text, changing, 98-99
column
deleting from table, 137-138
inserting in table, 136-137
commands on toolbar, 19-20. See also
specific commands
competing sites, evaluating, 37, 292
compression-based format, 112
confirmation page
customizing, 174-176
form submission process and, 158, 160
connection speed, 296
consistency of navigation, 143, 149-150
construction sign, 293
Contact Us form, 161-162
Contact Us page
creating new site and, 50-51
editing, 30-31
content of page
description of, 66
design and, 295
purpose-driven site, 41-43
scrollable, displaying, 245
searching for, 190-194
updating, 245
Control Panel (Yahoo! Web Hosting
Control Panel)
accessing, 252-253, 306
add-ons and, 180, 233-236, 237
description of, 252
features, 253
File Manager, 257-261
Guestbook add-on, 239-244
Pull-Down Menu add-on, 236-239, 240
Site Activity module, 182, 253, 254-256
Site Status module, 253, 257
Snapshot Backup feature, 261-263
Coordinates tab (Picture Properties dialog
box), 118, 123
Coordinates tab (Properties dialog box), 67
Copy command (Ctrl+C), 67
Copy command (toolbar), 19
Copy File dialog box, 79
copying
add-on, 182
page effect, 207
page element, 67
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copying (continued) forms, 163-165
text from another source, 88 look and feel of SiteBuilder, 308-309
Web page, 62 Cut command (Ctrl+X), 67
copyright date, 294 Cut command (toolbar), 19
Counter add-on cutting
description of, 180 add-on, 182
inserting, 182-184 element, 67
previewing, 181 page effect, 207
Counter Properties dialog box, 182-183
Courier New font, 96 PY D P

Create a New Site link (Help pane), 22, 23
Create Navigation Bar dialog box, 146-147 data transfer usage, 257

Create New Table dialog box, 131-132 debugging site, 55, 56
creating defining
dummy site, 75 “presence”, 36-37
link, 105-109 target visitor, 36
new Web page, 58-60 Delete button (Open Site dialog box), 55
new Web site, 46-51 Delete command (toolbar), 19
template page, 78-80 Delete Files confirmation page, 261
thumbnail image, 124-125 Delete key (Site Contents pane), 61
Yahoo! Map link, 187 deleting
Ctrl+A (Select All), 89 file from site, 260-261
Ctrl+B (Bold), 97 link, 109
Ctrl+C (Copy), 67 list item, 101
Ctrl+D (Select None), 89 page element, 67
Ctrl+I (Italic), 97 product catalog, 288
Ctrl+L (Link To), 122 row or column from table, 137-138
Ctrl+N (create new blank page), 59 Site Search add-on, 194
Ctrl+O (Open Page), 61 Web page, 61
Ctrl+S (Save Page), 60 Web site, 55
Ctrl+Shift+A (Align), 70 descriptive heading, writing, 41
Ctrl+Shift+B (Send to Back), 69 design. See also planning
Ctrl+Shift+F (Bring to Front), 69 assumptions and, 297
Ctrl+Shift+N (Create New Site), 46, 59 cute items, eliminating, 292-293
Ctrl+Shift+T (Insert Text), 86 reinventing wheel and, 292
Ctrl+U (Underline), 97 size of page, 294
Ctrl+V (Paste), 67 technology and, 296
Ctrl+X (Cut), 67 testing site in multiple browsers,
Ctrl+Y (Redo), 89 294-295, 309-310
Ctrl+Z (Undo), 89 text and, 295
custom template visitor profile, 255-256
advantages of, 81 Design pane
creating, 78-80 description of, 11, 17
Customize button (Edit Navigation Bar drag-and-drop-capability of, 132
dialog box), 151, 153, 154 editing in, 27-32
customizing visual effects and, 206
bulleted and numbered lists, 101 design time, 206

confirmation and error pages, 174-176 desktop publisher, 86



dictionary for spell checking, 94, 95
digital photograph, compressing before
using, 114-115
Directions add-on
description of, 180
inserting, 188-189
previewing, 181
disabilities, visitors with, 43
disabling Automatic Spell Checking
option, 91
disk space usage, 257
display order of elements, 69-70
Display Text box (Edit Navigation Bar
dialog box), 151, 154
displaying
gridlines, 306-307
scrollable content, 245
domain name, selecting, 13-14
Donations button (PayPal), 266, 270-271
Donations Properties dialog box, 270
double-clicking HTML element, 230
Download All Templates command
(toolbar), 20, 77
Download More Templates dialog box, 77
download size, being informative about, 43
downloading
template, 49, 50, 76-78
third-party script, 244
time for, and effects, 200
time for, and graphic size, 114
Yahoo! SiteBuilder, 15
dragging
element, 68
element to table cell, 132
image, 118
text box, 86, 89
drop-down menu, adding, 234, 236-239, 240
dummy site, creating, 75
duplicating
add-on, 182
element, 67
page effects, 207

oF o

earlier version of site, restoring, 261-263
Easy Upload page, 259

e-commerce. See also Yahoo!
Merchant Solutions
overview of, 265
page, creating, 281-284
PayPal buttons, 266-271
steps for creating, 271-272
tags, adding, 287
Edge-Locked Picture effect, 216-217
Edge-Locked Picture Properties dialog
box, 216-217
Edit Navigation Bar dialog box, 150-151
Edit Table page, 274, 275
Edit=>Align, 70
Edit~>Copy, 67
Edit=>Cut, 67
Edit=>Delete, 67
Edit=>Duplicate, 67
editing
HTML code, 230
link, 109
navigation bar, 150-151
text, 88-89
Web page, 27-32
Edit=>Page Properties, 62
Edit=>Paste, 67
Edit=>Select All, 66
Edit=>Select None, 66
effects. See also Page Effects pane
audio, 202-205, 219
Border Patrol, 207-208
Bouncing Images, 209-210
deciding when to use, 219-220
description of, 199, 205-206
Edge-Locked Picture, 216-217
fade-in or fade-out, 293
Flyby, 210-212
IE Page Transitions, 218
Image Tail, 212, 214-215, 220
multimedia, 199-200
Random Apparitions, 215-216
Text Tail, 212-213, 220
video clips, 200-202
element. See also add-on
adding to table, 132-133
aligning and spacing, 70-71
copying, 67
cutting, 67
deleting, 67

Index 3 ’9
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element (continued)
dragging, 68
duplicating, 67
inserting into page, 299-301
layering, 68-70
moving, 66-67
pasting, 67

right-clicking to access HTML Properties

dialog box, 232
selecting, 66
e-mail address, linking to, 107-108
e-mail response from form
example of, 173
sending to different address, 174
submission process and, 158, 159
embedded media, 12
embedding file
audio, 202-205
video, 200-202
enabling
Automatic Save feature, 302-303
Automatic Spell Checking option, 91
catalog use with SiteBuilder, 279-280
Reload open pages on startup
feature, 305
error page
customizing, 174-176
form submission process and, 158, 160
evaluating
competing sites, 37, 292
purpose-driven Web site, 43
site in multiple browsers, 294-295,
309-310
site with ten-second test-drive, 295-296
expanding pane, 301

ofF e

fade-in or fade-out effects, 293
family site and effects, 219
Feedback form, 162-163
feedback, planning for, 40-41
feel for site, planning, 39, 309
file

audio, 202-205, 219

deleting from site, 260-261

HTML, 11, 61, 228-230

linking to, 108-109

saving with new name, 60

uploading to site, 258-259
video, 200-202

file extension, 112

File Manager
accessing, 257-258
deleting file, 260-261
uploading file, 258-259

File menu, 45. See also specific commands

file-based application, 45
File>Change User, 306
Filem>Close All Pages, 61
File=>Close Site, 52, 55
Filec>Import Yahoo! Site, 52
File>New Pager>Without Template, 59
Filec>New Site, 46
File>New=>With Template, 161
File=>Open Page, 61
Filec>Open Site, 54
File=>Preview in Browser, 56
Filec>Publish to Yahoo! Site, 32, 57
Filec>Save All Pages, 32, 55
Filem>Save Page, 60
File>Save Page As, 60
Firefox (Mozilla), 295
Flyby effect, 210-212
Flyby Properties dialog box, 211
font style, selecting, 95-96
Form Properties dialog box, 173, 174
Form Settings dialog box, 175
Form Settings tab (Properties dialog
box), 173

format

audio, 202

compression-based, 112

video, 200
Format=>Bold, 97
Format>Bulleted List, 99
Format=>Bullets and Numbering, 101
Format=>Decrease Indentation, 102
Formatr>Increase Indentation, 102
Formatcyltalic, 97
FormatoNumbered List, 99
Format=>Remove Text Background, 103
Format=>Text Background, 103
Format=>Text Color, 98
formatting table, 133-134
formatting text

character style, setting, 97-98

color, changing, 98-99
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font style, selecting, 95-96
lists, 99-101
scope of, 95
size of font, setting, 96
Formatc>Underline, 97
forms
check box, adding, 169-170
Contact Us, 161-162
creating custom, 163-165
elements, working with, 165-166
e-mail response from, 173
Feedback, 162-163
list box, adding, 168-169
overview of, 157
pre-built, 161
process of submitting, 158-160
radio button, adding, 170-171
sending response to different e-mail
address, 174
Submit or Reset button, adding, 172
text field or text area, adding, 167-168
tweaking, 173-174
frame image, 115
freeware program, 313
F12 (Preview in Browser), 208
F2 (Rename File), 62
functionality, adding. See add-on

oG o

“geeky dust”, 221-222
General pane (Store Products Page dialog
box), 282
General tab (Preferences dialog box), 305
Georgia font, 96
GIF (Graphic Interchange Format),
112, 114, 293
.gif extension, 112
GNU software, 313-314
goals for site, identifying, 36
grammar, checking, 295
graphics. See also images
bitmap and vector, 113
deciding what kind to use, 111-112
file types, 112
format, selecting, 114
sizing, 114-115
graphics software, 11, 296

gridlines
snapping to, 308
turning on and off, 307
using, 306-307
group of radio buttons, adding to form,
170-171
Guestbook add-on, 234, 239-244
Guestbook Setup page, 241

o o

handles for resizing, 87
heading, writing descriptive, 41, 227-228
Help command (toolbar), 20
Help pane
Create a New Site link, 22, 23
description of, 18
Site Creation Wizard, 22, 23, 24, 25
Hex color codes, 97
hierarchy
mapping, 37-39
navigating, 39-40
site as, 37
home page
creating new site and, 50-51
editing, 27-28
HSB values, 97
HTML
description of, 222
example of, 222-227
HTML Code dialog box, 229
HTML element, 229-230
HTML file
accessing, 228-229
head and body of file, 227-228
information in, 11
opening, 61
HTML Properties dialog box, 231
hyperlinks (or hypertext links)
assigning to image, 122
clicking through, 55
editing, 109
to e-mail address, 107-108
to file, 108-109
in Guestbook, 244
media clips and, 200
to page in site, 105-106
to page on another site, 106-107
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hyperlinks (or hypertext links) (continued)
planning, 39
removing, 109
to resources from Web site, 12
Yahoo! Map, creating own, 187

o]e

identifying purpose for site, 36
IE Page Transitions effect, 218
IE Page Transitions Properties dialog
box, 218
iframe, adding, 245-247
Iframe Properties dialog box, 245
Ignore All button (Check Spelling dialog
box), 93
Ignore button (Check Spelling dialog
box), 93
Ignore Case option (Preferences dialog
box), 94
Ignore Duplicate Words option
(Preferences dialog box), 94
Ignore Mixed-Case Words option
(Preferences dialog box), 94
Ignore URL-Like Words option (Preferences
dialog box), 94
Ignore Words with Digits option
(Preferences dialog box), 94
image bulleted list, creating, 100
Image Tail effect, 212, 214-215, 220
Image Tail Properties dialog box, 214
images. See also graphics
adding own, 116-118
clip art, adding, 115-116
creating navigation bar using own,
154-155
logo, adding to SSL-protected folder, 269
mouse-over, specifying for, 120-121
moving on page, 118
power of, 111
product, uploading, 276
properties, setting, 119-121
publishing text as, 296-297
resizing, 122-123
returning to original size, 123-124
thumbnail, creating, 124-125
turning into background, 125-127
for Web site, 11

Import Site dialog box, 53-54
Import Store Catalog dialog box, 280-281
importing
product catalog, 280-281
Web site, 52-54
indenting text, 102
index cards, 38
index.html page, 27, 56
Insert Background command (toolbar), 19
Insert dialog box, 117
Insert Image command (toolbar),
19,29, 115
Insert Navigation Bar command (toolbar),
19, 146, 149
Insert palette, 299-301
Insert Palette button (toolbar), 181, 301
Insert Store Product dialog box, 286
Insert Store Tags command (toolbar),
20, 285
Insert Table command (toolbar),
20, 130-131
Insert Text command (Ctrl+Shift+T), 86
Insert Text command (toolbar), 19, 86, 87
Insert=>Add-Ons, 181
Insert>Add-Ons=>Counter, 182
Insert>Add-Ons>Loan Calculator, 196
Insert=>Add-Ons=>Presence Indicator, 195
Insert=>Add-Ons=>Site Search, 191
Insert=>Add-Ons=>Time and Date
Stamp, 184
Insert>Add-Ons=>Yahoo! Directions, 188
Insert=>Add-Ons=>Yahoo! Map, 186
Insert=>Add-Ons=Yahoo! Search Box, 189
Insert=>Audio, 203
Insert=>Code Elements=>HTML, 229
Insert=>Code Elements=iframe, 245
Insert=>Forms and Form Elements=>
Blank Form, 163
Insert>Forms and Form Elements=>
Checkbox, 169
Insert=>Forms and Form Elements=>
Contact Us Form, 161
Insert=>Forms and Form Elements~>
Feedback Form, 162
Insert=>Forms and Form Elementsc>List
Box, 168
Insert=>Forms and Form Elements=>Radio
Button, 171
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Insert>Forms and Form Elementsw>
Submit Button, 172
Insert>Forms and Form Elements=>
Text Field, 167
inserting
add-on, 181
column in table, 136-137
element into page, 299-301
navigation bar into another page, 149
row in table, 134-136
Inserte>Page Effectse>Border Patrol, 207
Insert=>Page Effects=>Bouncing
Images, 209
Insertc>oPage Effectsw>Edge-Locked
Picture, 216
Insert>Page Effects=Flyby, 211
Inserte>Page Effects=IE Page Transitions
effect, 218
Insert=>Page EffectseIlmage Tail, 214
Insert>Page EffectsoRandom Apparitions,
215
Inserte>Page Effectse>Text Tail, 212
Insert=>PayPal Buttons=>Buy Now, 267
Insert=>PayPal Buttons=>Donations, 270
Insert=>Picture, 117
Insert=>Table, 131
Insert=>Text, 86
Insert=>Video, 200
installing Yahoo! SiteBuilder, 16
interactive elements, 12
Internet connection speed, 296
Internet Explorer (Microsoft), 218, 295
Italic command (Ctrl+I), 97
italic text, 97-98
Items page, 276, 277

° ] °
Jackson, Peter (director), 9-10
JavaScript
description of, 222, 227
downloadable scripts, 244
JPG (Joint Photographic Experts Group)
format, 112, 114
. Jjpg extension, 112
justifying text, 103-104

oK o

key content, placement of, 42
keyboard shortcuts
Ctrl+A (Select All), 89
Ctrl+B (Bold), 97
Ctrl+C (Copy), 67
Ctrl+D (Select None), 89
Ctrl+I (Italic), 97
Ctrl+L (Link To), 122
Ctrl+N (create new blank page), 59
Ctrl+O (Open Page), 61
Ctrl+S (Save Page), 60
Ctrl+Shift+A (Align), 70
Ctrl+Shift+B (Send to Back), 69
Ctrl+Shift+F (Bring to Front), 69
Ctrl+Shift+N (Create New Site), 46, 59
Ctrl+Shift+T (Insert Text), 86
Ctrl+U (Underline), 97
Ctrl+V (Paste), 67
Ctrl+X (Cut), 67
Ctrl+Y (Redo), 89
Ctrl+Z (Undo), 89
editing, 88-89
F12 (Preview in Browser), 208
F2 (Rename File), 62
keyword, 63
Knowlt All Edit (We Know It All
Software), 314

o/ o

labeling of navigation bar, 143-144
Last Updated date, 294
launching
existing site, 54
File Manager, 257-258
HTML, 228-229
HTML file, 61
Insert palette, 300
multiple pages, 303-305
Page Effects pane, 206
Web page, 61
Yahoo! SiteBuilder, 16
Yahoo! Web Hosting Control Panel,
252-253, 306
layering page elements, 68-70
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Learn button (Check Spelling dialog
box), 93
Left Justify button (toolbar), 104
Link dialog box
Contact Us page and, 31
e-mail address, linking to, 107
file, linking to, 108
page in site, linking to, 105
page on Web, linking to, 106
Link It All Internet service provider, 314
Link Pages Together with a Navigation Bar
button, 51
Link To command (Ctrl+L), 122
Link To command (toolbar), 20
“link-itis”, avoiding, 42
links
assigning to image, 122
clicking through, 55
editing, 109
to e-mail address, 107-108
to file, 108-109
in Guestbook, 244
media clips and, 200
to page in site, 105-106
to page on another site, 106-107
planning, 39
removing, 109
to resources from Web site, 12
Yahoo! Map, creating own, 187
list box
adding to form, 168-169
description of, 165, 166
List Box Properties dialog box, 169
listing, Sampling of HTML Markup
Instructions, 223-227
lists, bulleted and numbered, 99-101
Loan Calculator add-on
description of, 180
HTML code for, 223-227
inserting, 196-197
previewing and testing, 181
logo image, adding to SSL-protected
folder, 269
Look and Feel tab (Preferences dialog
box), 309
Look Like Mac (MACWIN, Inc.), 314
The Lord of the Rings movies, 9-10
lossless compression format, 112
lossy compression format, 112

ol o

Mac OS, using CD with, 313
MACWIN Inc., Look Like Mac, 314
Manage tab (Yahoo! Web Hosting Control
Panel), 253
managing multiple sites, 305-306
manually checking spelling, 92-94
Map add-on
description of, 180
inserting, 186-188
previewing, 181
margins, specifying, 64
Merchant Solutions
adding new field to product
catalog, 272-275
adding product to catalog, 276-278
bank account, setting up, 285
deleting catalog, 288
e-commerce and, 265
enabling catalog use with SiteBuilder,
279-280
importing catalog, 280-281
online store and, 271-272
online store, steps for building, 271-272
product module, adding, 286-287
publishing product catalog, 279
publishing site, 286
refreshing catalog information, 288
Shopping Cart button, adding, 284-285
store page, creating, 281-284
store tags, adding, 287
viewing product module properties,
287-288
merging cells, 138-139
Messenger, 194-195
meta data, 63
Microsoft
Internet Explorer, 218, 295
PowerPoint, 38-39
Windows, using CD with, 312
mocking up site structure, 37-38
mouse tailing effects, 212
mouse-over, specifying for image, 120-121
moving. See also dragging
element, 66-67
image on page, 118
Insert palette, 300
text on page, 89
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Mozilla Firefox, 295
multimedia effects
audio, 202-205, 219
deciding when to use, 219
overview of, 199-200
video clips, 200-202

o\ o

navigating site, 39-40. See also
navigation bars
Navigation Bar Buttons list (Edit
Navigation Bar dialog box), 151
Navigation Bar Properties dialog box,
151, 153
navigation bars
adding to new site, 51, 145-146
benefits of, 142-143
consistency and, 143
creating after site is built, 146-148
creating with own images, 154-155
images and, 11
inserting into another page, 149
labeling of, 143-144
overview of, 141-142
placement of, 143, 149-150
poorly designed example of, 144
style, selecting, 147
template-based, creating, 152
text-based, creating, 152-154
tweaking, 150-151
well-designed example of, 145
Netscape browser, 295
New Page with Template command
(toolbar), 19
New Page without Template command
(toolbar), 19
New Site command (Ctrl+Shift+N), 46, 59
New Site command (toolbar), 19
News Headlines add-on, 234-236, 237
nonmodal dialog box, 300
nonstandard plug-in, 293
North by Northwest (movie), 210
numbered list
creating, 99
customizing, 101

o () o

Offset Variation setting (Flyby effect), 211
online store. See also Yahoo! Merchant
Solutions
overview of, 265
page, creating, 281-284
PayPal buttons, 266-271
steps for creating, 271-272
tags, adding, 287
Only Publish Modified Files button
(Publish Site dialog box), 57
opacity adjustment, 113
Open Page command (Ctrl+0O), 61
Open Page command (toolbar), 19, 61
Open Site dialog box, 54, 55
Open the Insert Palette command
(toolbar), 20
opening
existing site, 54
File Manager, 257-258
HTML, 228-229
HTML file, 61
Insert palette, 300
multiple pages, 303-305
Page Effects pane, 206
Web page, 61
Yahoo! SiteBuilder, 16
Yahoo! Web Hosting Control Panel,
252-253, 306
Opera browser, 295
Organization Chart tool (Microsoft
PowerPoint), 38-39
organizing
purpose-driven Web site, 37-41
workspace, 301-302
overlapping text boxes, 89

opPe

page. See also content of page;

specific pages

blank, adding to site, 58

blank, creating, 59

closing, 61

copying, 62

creating based on custom
template, 79-80
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page (continued)
creating new, 58-60
deleting, 61
description of, 11
editing, 27-32
opening, 61
opening multiple, 303-305
renaming, 62
resizing, 64

right-clicking to access HTML Properties

dialog box, 231
saving, 60
width of, 64
within site, 46
page counter, 293
page effects
Border Patrol, 207-208
Bouncing Images, 209-210
deciding when to use, 219-220
description of, 205-206
Edge-Locked Picture, 216-217
Flyby, 210-212
IE Page Transitions, 218
Image Tail, 212, 214-215, 220
Random Apparitions, 215-216
Text Tail, 212-213, 220
Page Effects pane
Background placeholder, 126
cutting, copying, and pasting, 207
description of, 18
properties, accessing, 206
viewing, 206
Page Layout pane (Store Products Page
dialog box), 282, 283
Page Properties dialog box
margins, specifying, 64
meta data, specifying, 63
overview of, 62—63
resizing page, 64
page view, 254, 255
Paint Shop Pro, 296
panes. See also Design pane; Help pane;
Page Effects pane
Preview, 17
Site Contents, 17, 61
working with, 301-302
paragraph formatting, 95
paragraph, indenting, 102

Paste command (toolbar), 19
pasting
add-on, 182
element, 67
page effect, 207
text from another source, 88
PayPal, 266
PayPal buttons
Buy Now, 266, 267-269
Donations, 266, 270-271
overview of, 266
personal site and effects, 219
personal-oriented templates, 74
photograph, compressing before using,
114-115
Photoshop (Adobe), 296
picture. See graphics; images
Picture Properties dialog box
Coordinates tab, 118, 123
options, 119-121
pixel, 64, 113
“pixel cramming”, avoiding, 42
“pixie dust”, 221
placement
of HTML element, 230
of key content, 42
of navigation bar, 143, 149-150
planning. See also design
accessibility, creating aura of, 42
for feedback, 40-41
link, 39
professional feel for site, 36
purpose-driven Web site, 36-37
section page, 39
for visitors with disabilities, 43
plug-in, nonstandard, 293
PNG (Portable Network Graphics)
format, 113
.png extension, 112
PowerPoint (Microsoft), 38-39
Preferences dialog box
Automatic Save tab, 302-303
General tab, 305
Look and Feel tab, 309
Spell Check tab, 94
spell checking options, 94-95
“presence”, defining, 36-37
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Presence Indicator add-on
description of, 180
inserting, 194-196
previewing, 181
Presence Indicator Properties dialog
box, 195
Preview in Browser command (F12), 208
Preview in Browser command
(toolbar), 19, 32
Preview pane, 17
previewing
add-on, 181
Guestbook, 243
with multiple browsers, 309-310
page effect, 208
Web site, 32, 55-56
product catalog
deleting, 288
enabling use with SiteBuilder, 279-280
importing, 280-281
new field, adding, 272-275
product, adding, 276-278
publishing, 279
refreshing information, 288
table, 278
Product dialog box, 287, 288
Product Layout pane (Store Products Page
dialog box), 282
product module
adding, 286-287
description of, 283
properties, viewing, 287-288
Products pane (Store Products Page dialog
box), 283
professional feel for site, planning, 36
Promote tab (Yahoo! Web Hosting Control
Panel), 253
Promote Your Site on Search Engines
page, 279-280
Properties command (toolbar), 19
Properties dialog box, Form Settings
tab, 173
Publish Site command (toolbar), 20, 32
Publish Site dialog box, 33, 57
publishing
creating and designing site on
computer, 10-12
overview of, 21-22
process for, 9-10

product catalog, 279

server and, 12

text as image, 296-297

Web site, 56-58
Pull-Down Menu add-on, 234, 236-239, 240
purpose-driven Web site

description of, 35

evaluating, 43

organizing, 37-41

planning for, 36-37

writing content for, 41-43

OQO

quality of image and resizing, 123
QuickTime Player, 200

o R o

radio button
adding to form, 170-171
description of, 165, 166
Radio Button Properties dialog box, 171
Random Apparitions effect, 215-216
Random Apparitions Properties dialog
box, 215-216
ranking of elements, 69
Real Estate templates, 74
RealPlayer, 200
Redo command (Ctrl+Y), 89
Redo command (toolbar), 19
Referrer Report, 256
refreshing catalog information, 288
reloading last open site, 305
Remove Text Background button
(toolbar), 103
removing
file from site, 260-261
link, 109
list item, 101
page element, 67
product catalog, 288
row or column from table, 137-138
Site Search add-on, 194
Web page, 61
Web site, 55
Rename File command (F2), 62
renaming Web page, 62
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Replace All button (Check Spelling dialog
box), 93
Replace button (Check Spelling dialog
box), 93
Replace By box (Check Spelling dialog
box), 93
replacing image on page, 119
Reset button
adding, 164, 172
description of, 166
resizing. See also sizing
bitmap image, 113
image, 122-123
pane, 301
table, 131
text box, 87, 90
text element box, 28
Web page, 64
resolution
graphics and, 114
screen, and design, 296
width of page and, 64
Restore/Maximize button, 303, 304
restoring
earlier version of site, 261-263
image to original size, 123-124
pane to default position, 301
RGB values, 97
Right Justify button (toolbar), 104
right-clicking to access HTML Properties
dialog box, 231, 232
rollover effect, 143
row
deleting from table, 137-138
inserting in table, 134-136
run time, 206

oS e

sand box, 68
Save As dialog box, 60
Save My Web Site Folder In box, 47
Save Page command (Ctrl+S), 60
Save Page command (toolbar), 19
saving
Automatic Save feature, 302-303
pages in site, 32
before publishing, 57

Web page, 60
Web site, 55
scrolling, avoiding, 42, 245
scrolling message, 293
Search Box add-on
description of, 180
inserting, 189-190
previewing, 181
searching
Site Search add-on, 190-194
Yahoo! Search Box add-on, 189-190
section page, planning, 39
Secure Sockets Layer (SSL)-protected
folder, 269
Select All command (Ctrl+A), 89
Select None command (Ctrl+D), 89
Select the Type of Link menu (Link dialog
box), 107
selecting
font style, 95-96
graphics format, 114
navigation bar style, 147
page element, 66
table cell, 134
template, 74-75
template in Site Creation Wizard,
24, 25, 49-50
text, 28
selling products. See also Yahoo! Merchant
Solutions
overview of, 265
page, creating, 281-284
PayPal buttons, 266-271
steps for creating, 271-272
tags, adding, 287
Send to Back command (Ctrl+Shift+B), 69
Services page, creating new site and, 50-51
shareware program, 313
Shopping Cart button, adding, 284-285
Shopping Fields list, 274, 275
shortcuts
Ctrl+A (Select All), 89
Ctrl+B (Bold), 97
Ctrl+C (Copy), 67
Ctrl+D (Select None), 89
Ctrl+I (Italic), 97
Ctrl+L (Link To), 122
Ctrl+N (create new blank page), 59
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Ctrl+O (Open Page), 61
Ctrl+S (Save Page), 60
Ctrl+Shift+A (Align), 70
Ctrl+Shift+B (Send to Back), 69
Ctrl+Shift+F (Bring to Front), 69
Ctrl+Shift+N (Create New Site), 46, 59
Ctrl+Shift+T (Insert Text), 86
Ctrl+U (Underline), 97
Ctrl+V (Paste), 67
Ctrl+X (Cut), 67
Ctrl+Y (Redo), 89
Ctrl+Z (Undo), 89
editing, 88-89
F12 (Preview in Browser), 208
F2 (Rename File), 62
sidekick principle, 85
Sign in to Yahoo! dialog box, 33, 252
signing up
for Yahoo! Merchant solutions plan, 265
for Yahoo! Web hosting, 13-14
site
closing, 55
creating and designing, 10
creating new, 46-51
creating, with Site Creation Wizard, 22-26
deleting, 55
dummy, creating, 75
embedded media and, 12
images and, 11
importing, 52-54
interactive elements for, 12
linked resources and, 12
opening existing, 54
pages for, 11, 46
previewing, 32, 55-56
publishing, 12, 56-58
purpose-driven, 35-43
saving, 55
updating, 13, 293
visiting, 13
Yahoo! add-ons and, 12
Site Activity module (Yahoo! Web Hosting
Control Panel), 182, 253, 254-256
Site Contents pane
Delete key, 61
description of, 17
Site Creation Wizard
creating new site, 46-51
downloading templates using, 76-78

navigation bar, adding, 145-146
steps for, 22-26
Site Search add-on
description of, 180, 190
inserting, 191-194
parts of, 191
previewing, 181
removing, 194
Site Search Properties dialog box, 191, 192
Site Statistics feature, 254-255
Site Status module (Yahoo! Web Hosting
Control Panel), 253, 257
SiteBuilder
downloading, 15
exploring, 16-17
installing, 16
panes, 17-18
starting, 16
as translator, 222
SiteBuilder Templates Gallery, 78
size
of download, being informative about, 43
of font, setting, 96
of HTML element, 230
of page, 294
sizing. See also resizing
graphics, 114-115
grid squares, 308
Small Business home page, 13, 14
Snap to Grid feature, 308
Snapshot Backup feature, 261-263
spacing page elements, 70-71
Spell Check tab (Preferences dialog
box), 94
spell checking
automatic, 91-92
manual, 92-94
preferences, setting, 94-95
Split Table Cells dialog box, 139, 140
splitting cells, 139-140
SSL (Secure Sockets Layer)-protected
folder, 269
starting. See launching
Stock Quotes add-on, 234-236
Store Manager page, 272, 273
Store Products Page dialog box, 282, 283
store tag
adding, 287
description of, 283



330

Yahoo! SiteBuilder For Dummies

storing Web site, 47
structure of site, mocking up, 37-38
Submit button
adding, 164, 172
description of, 166
form submission process and, 158, 159
Submit Button Properties dialog box, 172
Submit To text box (Form Settings dialog
box), 174
Summary Report page, 255, 256
Swatches tab (Choose Text Color dialog
box), 98
switching spell-checking dictionary, 94
system requirements, 311

o o

Table Properties dialog box, 133
Table=>Delete Table Column, 138
Table=>Delete Table Row, 138
Tablec>Insert Table Column, 137
TablervInsert Table Row, 134
Tabler>Merge Cells, 139
tables
adding using toolbar, 130-131
borderless, 134
column, inserting, 136-137
content, adding to, 132-133
Create New Table dialog box, 131-132
deleting row or column from, 137-138
formatting, 133-134
merging cells in, 138-139
overview of, 129
row, inserting in, 134-136
splitting cells in, 139-140
Tables page, 272, 274
Table=>Split Table Cells, 139
tags
HTML, 228
store, 283, 287
Tahoma font, 96
target visitor, defining, 36
technical support, 315
technology and design, 296
template page
advantages of, 81
creating, 78-80
template-based navigation bar,
creating, 152

template-based page
adding to site, 58
creating, 59-60

templates
advantages of SiteBuilder, 80-81
categories of, 74
choosing in Site Creation Wizard, 24, 25
components of, 74, 75
creating new site and, 47, 48-51
custom, 78-81
description of, 74
downloading, 49, 50, 76-78
images and, 11
mixing within site, 59
selecting, 74-75
SiteBuilder Templates Gallery, 78
tweaking, 78

Templates list, 49

ten-second test-drive, 295-296

testing
Loan Calculator add-on, 181
page effects, 55
site in multiple browsers, 294-295,

309-310

text. See also text, formatting
adding to page, 86-87
adding to table, 132-133
alternative, assigning to image, 119-120
from another source, adding, 87-88
Automatic Spell Checking, 91-92
checking spelling manually, 92-94
editing, 88-89
indenting, 102
justifying, 103-104
link, adding to, 104-105
linking to page in site, 105-106
moving on page, 89
publishing as image, 296-297
selecting, 28
working with, 85-86

text area
adding to form, 167-168
description of, 165, 166

text box
background color, changing, 103
background color, resetting, 103
resizing, 90

text box formatting, 95

Text Color button (toolbar), 98



text element
adding to check box, 170
adding to radio button, 171
text field
adding to form, 167-168
description of, 165, 166
Text Field Properties dialog box, 167
text, formatting
character style, setting, 97-98
color, changing, 98-99
font style, selecting, 95-96
lists, 99-101
scope of, 95
size of font, setting, 96
Text Tail effect, 212-213, 220
Text Tail Properties dialog box, 212-213
text-based navigation bar, creating,
152-154
Themes list (Edit Navigation Bar dialog
box), 151
third-party scripts, 244
thumbnail image, creating, 124-125
tiling effect, 125
Time and Date Stamp add-on
description of, 180
inserting, 184-185
previewing and testing, 181
Time and Date Stamp Properties dialog
box, 184-185
Times New Roman font, 96
title meta tag, 63
titled page, saving, 60
toolbar
alignment commands, 103-104
commands on, 19-20
description of, 18-19
Download All Templates command, 20
Insert Image command, 19, 29, 115
Insert Navigation Bar command,
19, 146, 149
Insert Palette button, 181, 301
Insert Store Tags command, 20, 285
Insert Text command, 19, 86, 87
Open Page command, 19, 61
Preview in Browser command, 19, 32
Publish Site command, 20, 32
Remove Text Background button, 103
table, adding using, 130-131
Text Color button, 98

Tools=>Check Spelling, 91
Tools=>Check Spelling=>Current Page, 92
Tools=>Check Spelling=>Entire Site, 92
Tools=>Check Spelling=>Opened Pages, 92
Tools=>Check Spelling=>Selected Text, 92
Tools=>Store Catalogr>Delete, 288
Tools=>Store Catalog=>Import, 280
Tools=>Store Catalog>Refresh, 288
Tools>Web Hosting Control Panel,
233, 252

Top Justify button (toolbar), 104
top of page, placing key content at, 42
translator, SiteBuilder as, 222
troubleshooting, 314-315
trustworthiness, emphasizing, 42
tweaking

forms, 173-174

look and feel of SiteBuilder, 308-309

navigation bars, 150-151

template, 78
typeface, selecting, 95-96

olf o

Underline command (Ctrl+U), 97
underline style, 97-98
Undo command (Ctrl+Z), 89
Undo command (toolbar), 19
unindenting paragraph, 102
Unknown Word box (Check Spelling dialog
box), 93
untitled page, saving, 60
updating
content, 245
Web site, 13, 293
upgrading to Yahoo! Merchant Solutions
plan, 272
uploading file, 258-259, 276
user, changing, 306

oo

validity checking, 161

vector graphics, 113

Verdana font, 96

video clips, 200-202

Video Properties dialog box, 201, 202
View Cart Properties dialog box, 285
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View Full Size button, 49

viewing. See also previewing
open pages side by side, 303-305
product module properties, 287-288
site statistics, 255

Viewe>Show Page Effects Pane, 206

Visio, 38

visiting Web site, 13

visitor profile, 255-256

visual editor for Web page, 11

o/ o

We Know It All Software, Knowlt All
Edit, 314
Weather add-on, 234-236
Web hosting, signing up for, 13-14
Web page
closing, 61
copying, 62
creating based on custom
template, 79-80
creating new, 58-60
deleting, 61
description of, 11
editing, 27-32
opening, 61
opening multiple, 303-305
renaming, 62
resizing, 64
right-clicking to access HTML Properties
dialog box, 231
saving, 60
within site, 46
Web publishing
creating and designing site on
computer, 10-12
overview of, 21-22
process for, 9-10
product catalog, 279
server and, 12
text as image, 296-297
Web site, 56-58
Web safe colors, 99
Web server, 12
Web site
closing, 55
creating and designing, 10

creating new, 46-51
creating, with Site Creation Wizard, 22-26
deleting, 55
dummy, creating, 75
embedded media and, 12
images and, 11
importing, 52-54
interactive elements for, 12
linked resources and, 12
opening existing, 54
pages for, 11, 46
previewing, 32, 55-56
publishing, 12, 56-58
purpose-driven, 35-43
saving, 55
updating, 13, 293
visiting, 13
Yahoo! add-ons and, 12
When Clicked, the Link Will Open In setting
(Link dialog box), 106
width of page, 64
Wiley Product Technical Support, 315
Windows Media Player, 200
Windows (Microsoft), using CD with, 312
word processor, 86
workspace
opening multiple pages, 303-305
organizing, 301-302
writing content
design and, 295
for purpose-driven Web site, 41-43

oyo

Yahoo! add-on. See add-on
Yahoo! Directions add-on
description of, 180
inserting, 188-189
previewing, 181
Yahoo! Directions Properties dialog
box, 188
Yahoo! Map add-on
description of, 180
inserting, 186-188
previewing, 181
Yahoo! Map Properties dialog box, 186
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adding new field to product catalog,
272-275
adding product to catalog, 276-278
bank account, setting up, 285
deleting catalog, 288
e-commerce and, 265
enabling catalog use with SiteBuilder,
279-280
importing catalog, 280-281
online store and, 271-272
online store, steps for building, 271-272
product module, adding, 286-287
publishing product catalog, 279
publishing site, 286
refreshing catalog information, 288
Shopping Cart button, adding, 284-285
store page, creating, 281-284
store tags, adding, 287
viewing product module properties,
287-288
Yahoo! Messenger, 194-195
Yahoo! Search Box add-on
description of, 180
inserting, 189-190
previewing, 181

Yahoo! SiteBuilder

downloading, 15
exploring, 16-17
installing, 16
panes, 17-18
starting, 16

as translator, 222

Yahoo! Small Business home page, 13, 14
Yahoo! Web Hosting Control Panel

accessing, 252-253, 306

add-ons and, 180, 233-236, 237
description of, 252

features, 253

File Manager, 257-261

Guestbook add-on, 239-244

Pull-Down Menu add-on, 236-239, 240
Site Activity module, 182, 253, 254-256
Site Status module, 253, 257

Snapshot Backup feature, 261-263

Yahoo! Web hosting, signing up for, 13-14












