
The Maya Interface

Three-dimensional modeling and animation are challenging tasks. Trying

to get your vision of a universe transferred into pixels is part science and part art and takes a

great deal of perseverance. Fortunately, the engineers at Alias have spent a large amount of

time and energy making Maya as helpful and transparent to use as a complex program can

be. Still, when you are confronted with a program as deep as Maya, a good introduction to its

components can be helpful in getting the most from your work as quickly as possible. This

chapter explores Maya’s user interface, examining each element of the work environment in

turn. After reading through the chapter, you should have a good understanding of the major

components of Maya’s GUI (graphical user interface) and know how to use these elements in

your modeling and animation work.

■ What’s behind the Maya interface?

■ Scene windows and scene objects

■ Window layouts

■ The Hotbox

■ Menus and shelves

■ The Outliner and the Hypergraph

■ The Channel Box and the Attribute Editor

■ The Timeline

■ The Command line, the Feedback line, and the Script Editor
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What’s Behind the Maya Interface?
What makes Maya work well as an animation package? First, interacting with it is a straight-

forward process, for several reasons. You can easily navigate all scene windows, plus the

Hypershade, Hypergraph, and other windows, via the same keyboard and mouse combinations

for zooming, tracking, and rotating. (Rotating works only in perspective camera views.)

Because navigating works the same way in all windows, you have to learn only one set of com-

mands to get around in Maya’s world. Moving objects around a Maya scene window is similarly

intuitive: select the Move, Scale, or Rotate (or any other) tool, grab a manipulator handle (or

the center box, to move on all axes simultaneously), and alter the object. To try an example,

create a new scene in Maya, and add a ball (by choosing Create ➔ NURBS Primitives ➔ Sphere).

Now rotate around the ball by holding down the Alt key and clicking the left mouse button.

This type of rotation is known as camera or scene rotation. To rotate the ball itself, choose the

Rotate tool from the Tool Box, located on the left of the scene window (or simply press the E

key on the keyboard), select any of the manipulator rings around the ball, and then rotate the

ball by dragging with the left mouse button, as in Figure 1.1. To move an object, select the

Move tool (or press the W key). To scale, select the Scale tool (or press the R key).

T H R E E - B U T T O N  M O U S E  C O N V E N T I O N S  I N  M A Y A

Maya makes extensive use of all three mouse buttons. This book—as well as the Maya documentation—uses a

shorthand notation to describe the basic mouse operations:

Click or LM click means to click (press and release) the left mouse button.

Drag or LM drag means to click the left mouse button, hold it down, and drag.

Shift+click means to LM click, hold down the Shift key, and click another item.

Choose means to either click or hold down the left mouse button and select an item from a menu.

MM drag means to click and drag with the middle mouse button.

RM choose means to hold down the right mouse button (in a specified area) and choose an item from the pop-

up contextual menu.

Rotate (Tumble) view means to rotate the (perspective) camera; that is, hold down the Alt key and the left

mouse button, and then drag in the perspective window to rotate the view.

Move view means to move any camera; that is, hold down the Alt key and the middle mouse button, and then

drag in any scene window.

Scale view means to scale—or zoom—any camera; that is, hold down the Alt key and the right (or left and mid-

dle) mouse button, and then drag in any scene window to zoom (or scale) the view in or out. This setup allows a

straightforward mouse button mapping of left=rotate, middle=pan, and right=zoom.
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After you configure the Panel/Layout button to your liking, you might want to save the

layout. RM click the Panel/Layout button and choose Save Current Layout from the pop-up

menu. A small window will open, asking you to name your layout. Type My Layout (or any-

thing you please) and click OK. To access your saved layout, RM click any of the first six

Quick Layout buttons to open the Saved Layouts pop-up menu (as you did before) and

choose it from the menu.

Moving in Scene Windows

Moving around in scene windows is fairly straightforward, once you learn the keyboard and

mouse combinations for doing so. Additionally, because you use the same commands to

move in all scene windows (plus several other windows), once you learn how to move in one

window, you can move in all. Because the perspective window has the most options (you 

can rotate, or tumble, the view as well as zoom and translate), let’s quickly look at how to

maneuver in the default perspective window.

Open a new scene in Maya; then hold down the Alt key and the left mouse button and

drag the mouse around. The scene should spin around as you drag the mouse.

To translate a scene (move up/down or left/right), hold down the Alt key once again, hold

down the middle mouse button (MMB), and drag the mouse. You will see the scene move

around with the mouse movements. (Notice that the camera is actually moving opposite to

your mouse movements: as you drag right, the camera moves left, so the objects appear to

move right. You can see this clearly if you make cameras visible and look at the camera in a

different view as you drag.)

If the scene does not rotate as you drag (you might see the cursor become a circle with a line

through it), you could be in an orthographic view, which does not allow rotations. To move

to a perspective view, either press the spacebar to display the four-view layout or LM click the

four-view Quick Layout button in the Tool Box; then click in the perspective window (top

right) and press the spacebar again.

The appearance of the seventh button, the Panel/Layout button, depends on the view layout

you chose from the first six buttons. For example, if you click the first Quick Layout button

(which, by default, is the Single Perspective View) the Panel/Layout button has one arrow. If

you chose the Four View button, four arrows appear on the Panel/Layout button. You can

change a specific panel by LM clicking any of the arrows and choosing from the pop-up

menu. RM clicking will give you options to change the layout configuration such as Single

Pane or Two Panes Side By Side.
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To scale your view (zoom the camera in and out), hold down the Alt key once again, hold

down the right (or left and middle) mouse button, and drag. As you drag right, the scene

grows larger (you’re zooming in); as you drag left, the scene grows smaller (you’re zooming

out). To quickly zoom in to a specific area of your scene, hold down the Alt and Ctrl keys,

and then drag (with the left mouse button) a box around the area of the scene, starting on

the left side. When you release the mouse, the scene zooms in, covering the area you out-

lined. If you drag the mouse from right to left, the scene zooms out so that the entire scene

window you start with fits into the box you drag. (The smaller your box, the farther out you

zoom.) If you now open the Hypergraph or the Hypershade (choose Window ➔ Hypergraph

or Window ➔ Rendering Editors ➔ Hypershade), you can use the same key/mouse combina-

tions to scale or move around. You will notice, however, that you cannot rotate either of

these views, because this would accomplish nothing useful.

You can think of the Alt key as the “scene movement key.” Whenever you hold down the

Alt key, you are in scene manipulation mode, rather than in object manipulation (or some

other) mode. The consistent use of the Alt key for movement is just one example of the

thought that has gone into the Maya interface.

Scene Objects
Scene objects (primitives, curves, cameras, and lights) are the fundamental building blocks

from which you create a Maya scene or animation. The procedure for creating and manipu-

lating any object is generally the same: create the object (most often by using the Create

menu), choose a manipulation tool (such as Translate or Rotate), and alter the object. You

can also adjust the pivot point (or “center”) of an object, and you can manipulate the individ-

ual components of geometric objects.

Creating Scene Objects

Because you create most scene objects in much the same fashion, we’ll go through a few rep-

resentative examples here, rather than discuss how to create all possible objects in Maya. If

you have specific questions about creating a type of object that is not covered here, you can

always check Maya’s online documentation (accessed via the Help menu).

Maya’s built-in help files are a great (and easy-to-use) resource. To access them, choose Help ➔

Contents And Search (or Index). You can also press F1 to access the main help library. After

opening the Maya documentation window (which opens in a web browser because it is an

HTML document), you can search for a term, browse through a complete index of all Maya

documents (the index alone is about 2MB of data!), or read any of the Maya manuals in elec-

tronic form.
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In addition to the menus you can see, four regions, called zones (defined by the four lines

extending from the Hotbox at 45-degree angles), have special functions. You use the top

zone to quickly select from several saved layouts. You use the right zone to toggle elements

of MayaÕs GUI on or off. You use the bottom zone to change the selected window to any of

several useful views (such as the Hypergraph or the Hypershade). You use the left zone to

toggle between object and component mode (mimicking the F8 key) and to toggle on and off

several masking modes.

Although you can use the Hotbox in its default configuration, it is more useful (if a bit more

cluttered) when you turn on all menu sets (Modeling, Rendering, and so on). In the Hotbox

Controls menu, choose Show All, which displays all menu sets, as shown in Figure 1.26.

In this configuration, you have access to nearly all of MayaÕs tools in one place, and itÕs all

available at the press of the spacebar. If you are not familiar with using the Hotbox, try forc-

ing yourself to use it for all your menu choices for a couple of hours of work; you may find

that you prefer using the Hotbox over the standard menu selection method.

Menus
Although we have discussed menu sets on and off throughout this chapter, letÕs take a

moment to look at how MayaÕs menus are organized. The top row of menus (or the top row in

the Hotbox) is split into two parts: the menus that are always present (the constant menus)

and those that change according to the mode of the program (the mode menus, such as the

Animation menu set, for example). Always present are File, Edit, Modify, Create, Display,

Window, and Help. To change the variable menus, choose the menu set you want from the

Status line (just below the menusÑor under Hotbox Controls in the Hotbox). You can

choose from Modeling, Animation, Dynamics, and Rendering sets. If you have Maya Unlim-

ited, you will also see an entry for MayaLive.

In addition to the general menus, nearly every view and options window in Maya has a

built-in menu. The perspective view, for example, has the following menus: View, Shading,

Lighting, Show, and Panels. (You use the Show

menu to display and hide different types of objects.)

The Hypergraph view contains these menus: Edit,

View, Bookmarks, Graph, Rendering, Options, Show,

and Help. For perspective and orthographic views,

you can either access their menus from the top of

the window pane or use the second row of menus 

in the Hotbox. For views such as the Hypergraph 

or the Hypershade, clicking and holding the right

mouse button in the body of the pane displays the

menus (or you can use the menu across the top of

the window). There are also menus for the Channel

24 � CHAPTER 1:  TH E MA Y A I NTERFACE

Figure 1.26

The results of selecting
the Show All option in

the Hotbox
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Box and the Attribute Editor. Many of the options windows also have menus with Edit and

Help options.

Generally speaking, most windows in Maya have their own menu set, which explains why

Maya doesn’t use just one menu bar across the top of the screen: there are at least 100 indi-

vidual menus, and there would be no space to place all these menus across one screen.

Attempting to nest all these menus, on the other hand, might have taken 10 or more levels to

fit all the menus into one menu bar, making the task of choosing any individual menu item

both laborious and baffling. Given the complexity of the task, organizing Maya’s windows into

contextual subsets was both a necessity and a more elegant solution to the problem.

Even so, it is often difficult to locate a menu item you have not used in a while. Fortu-

nately Maya provides a menu search function. Choose Help ➔ Find Menu, enter the text of

the menu (a partial name is fine), and press Enter. For example, if you enter sm in the text

box, the menu search will find all occurrences of smooth, smoothness, smart, and smoke.

This is a handy feature and worth trying out.

Shelves
Although we have not yet dealt much with shelves, they are a convenient way to group your

most frequently used commands and tools. The shelf (see Figure 1.27) is one of the most

noticeable features of Maya’s GUI, appearing just below the Status line. Several icons, organ-

ized into tabs called General, Curves, and so on, perform useful commands. For example, to

create a NURBS sphere, you merely click the blue Sphere button when the Surfaces shelf tab

is selected; to create a spotlight, click the Spotlight button in the Rendering tab; to create a

CV curve, click the CV Curve Tool button with the Curves tab selected. Most useful are the

two widgets just to the left of the shelf icons. By clicking the top one (a gray tab icon), you

can quickly navigate to any tab (useful for selecting the preinstalled tabs, as well as any that

you create). Clicking the bottom widget opens a menu of common shelf commands, plus

access to the Shelf Editor.

Having these buttons available on a shelf makes the process of creating each item much

more straightforward than having to find them in a hierarchical menu set.

Figure 1.27

The shelf, with the 

Surfaces shelf tab

selected

You can customize any shelf tab, adding a new button to it by simply Ctrl+Shift clicking the

menu item (on a Mac, use Command+Control+Shift). To discard a shelf icon, just MM drag it

to the trash can icon at the right of the shelf.
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The Outliner and the Hypergraph
The basic purpose of the Outliner and the Hypergraph is the same: to allow you to see an

abstract (or outline) of the scene. The ways the two display a scene’s outline, however, are 

very different.

If you have used a 3D animation program in the past, you are probably familiar with a

scene management tool such as the Outliner, shown in Figure 1.28. From top to bottom, the

Outliner (choose Window ➔ Outliner) lists all objects in your scene, including cameras (note

that the orthographic views—top, side, and front—are just cameras listed in the Outliner),

lights, curves, and geometric objects. If you have objects that are parented to one another 

(a leg, for example, is parented to a body so that they move together), the Outliner indicates

this relationship by displaying a plus sign to the left of the parent object (the body in this

case). Clicking the plus sign displays the child object (the leg), which, because it is the child

object, is tabbed in under the parent.

The Hypergraph, by contrast, is probably like nothing you’ve seen before. It is, essentially,

a linked (or hyperlinked) outline of your scene, showing not only your scene elements, but

how they are connected. Although the Hypergraph may at first appear bewildering, its fash-

ion of laying out a scene can prove invaluable. Figure 1.29 shows how the scene shown in the

Outliner, in Figure 1.28, would look in the Hypergraph.

The Channel Box and the Attribute Editor
The Channel Box (to the right of the main scene window) and the Attribute Editor are

related windows that give you access to just about every aspect of the objects and materials

in your scene. The Attribute Editor (to open it, press Ctrl+A) gives you access to all of an

object’s attributes, and the Channel Box displays a more simplified view of only the object’s

keyable (or animatable) attributes. Because these two panels are counterparts, it makes

sense for them to be grouped together, and by default the two are set to toggle, the Attribute

Editor replacing the Channel Box on the right side of the window.

Figure 1.29

The Hypergraph with

leg and body
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As you’ll see throughout this book, the Attribute Editor and the Channel Box are your

keys to controlling all of an object’s attributes, including numeric inputs for translation, rota-

tion, scale, and visibility, as well as its construction history, such as spans of CVs and the

radius of a circular object. The Attribute Editor, in addition (via its tabbed windows), allows

you to access materials, tessellation criteria for NURBS objects, and other features. To toggle

between the Channel Box and the Attribute Editor, press Ctrl+A.

If you click the name (not the text box, but the actual name—see Figure 1.30) of an

attribute in the Channel Box and then MM drag in the scene window, you will get a “virtual

slider” that controls the number next to the channel name, as shown in Figure 1.30. This is a

powerful, time-saving feature in Maya.

Figure 1.30

Creating and using a

virtual slider

Materials? Tessellation? If you’re new to 3D animation, don’t worry about absorbing all the

jargon right away. The following chapters introduce all the essential concepts in a logical and

straightforward way as they are needed.

The Channel Box is so named because elements that can be animated in a 3D program have

often been termed channels. To animate a ball going up and down, you animate its Y-axis

channel (by setting several keyframes over time). Although Maya uses the term attribute for

anything that could potentially be keyable in a scene, those that have actually been set to

keyable are placed in the Channel Box.
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The Timeline
The Timeline, just below the main scene window(s) and shown in Figure 1.31, is the key to

animation in Maya.

By default, the numbers on the Timeline are set to frames (and by default, frames per

second is set to film rate—24—so 24 frames equals one second of animation). To the right 

of the Time Slider is the Current Time marker (probably set to 1.00). To change the current

time in your animation, you can either drag the Current Time marker in the Time Slider or

double-click the Current Time field and enter a number (such as 5). You will then see the

Current Time marker move to that frame. Larger numbers (such as frame 20) are, of course,

later in the animation. Below the Time Slider is the Range Slider (the gray bar with a 1 on

one end and a 24 on the other) that lets you control the range of the Time Slider within a

larger animation. To change the position of the Time Slider while maintaining the same range

(24 frames by default), drag the Range Slider by its middle. To change the starting point of

the range, drag the left square left or right. To change the ending point, drag the right square

to the left or right, as shown in Figure 1.32.

To the left of the Range Slider are two numeric fields. The leftmost field sets the anima-

tion start frame (often people set this number to 0 for the first frame instead of 1). The field

to its right sets the starting frame of the time range. (Changing this number is equivalent to

dragging the left square of the Range Slider.) To the right of the Range Slider are two more

fields; the left field sets the ending time of the animation range (equivalent to dragging the

right square on the Range Slider), and the right field controls the end point of the animation

(set to 48 frames by default).

To change the settings for the Time Slider, open the Animation Timeline and Playback

Preferences in the Preferences window (either click the Animation Preferences button, to the

right of the key icon at the bottom right of the screen or choose Window ➔ Settings/Prefer-

ences ➔ Preferences and then choose the Settings/Timeline category). In the Preferences

window, shown in Figure 1.33, you can control the height of the Timeline (useful when sound

files are imported), set playback speed to Play Every Frame, Real-time, Half, or Twice (Play

Every Frame is required for playback of dynamics), and even adjust animation beginning and 

Figure 1.32

Drag the right square

to change the ending

point of the Time

Slider.

Start Time Playback Start Time

Time Slider

Range Slider

Current Time

End TimePlayback End Time

Figure 1.31

The Timeline
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end points. In the Settings section, you can change your slider units from the default film

(24fps) to PAL (Phase Alternating Lines—used in Europe and other countries), NTSC

(National Television Standards Committee—used in the USA among other countries), sec-

onds, minutes, or even hours.

The Command Line, the Feedback Line, and the Script Editor
At the bottom of the Maya screen is the Command/Feedback line. The two halves of this line

function in tandem and are simply the last lines of the Script Editor’s input and history windows,

respectively, so it makes sense for us to first take a quick look at

Maya’s Script Editor. Although most of your interaction with

Maya is via the GUI, what you actually tell Maya to do is passed

to it via MEL. The selections and other actions you make in the

GUI are recorded as MEL commands. Creating a NURBS

sphere, for example, is simply the command . followed by sev-

eral optional flags. To access the Script Editor, either click the

Script Editor icon just to the right of the Feedback line (at the

bottom right of the screen), or choose Window ➔ General Edi-

tors ➔ Script Editor. The Script Editor, shown in Figure 1.34, is

To play back an animation, you can either use the VCR-like controls to the right of the Time-

line, or you can press Alt+V to start and stop the animation and Alt+Shift+V to reset the ani-

mation to its starting frame.

Figure 1.33

The Animation Time-

line and Playback 

Preferences in the 

Preferences window
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split into two halves. The top, which is the history window, probably has several lines of code in

it (the last commands you issued to Maya). The input window at the bottom awaits any MEL

commands you might want to give to Maya.

To see how the Script Editor works, type sphere (in lowercase letters) in the input win-

dow and press the Enter key on the numeric keypad (not the alpha keyboard). You should

see the line

// Result: nurbsSphere1 makeNurbsSphere1 //

appear in the history window (telling you what Maya has done to complete your command),

and a sphere will appear at the origin of your scene.

S A V I N G  M A Y A  P R O J E C T  A N D  S C E N E  F I L E S

A Maya project consists of several folders (or directories) of information about the scene (which is where your work-

ing scene file is stored), any rendering jobs, source images, output images, textures, and so forth. When you first

create a new scene in Maya, there are two steps to saving: first, save your project (which contains all the proper

places for Maya to store your project’s information), and then save the actual scene file.

To save your new project, choose File ➔ Project ➔ New. You might want to browse for your new project’s file

location. With the New Project window open, click the Browse button next to the Location text field, and use the

standard file browser to choose the location of your project.

Maya is based on the Unix operating system, which means you must never use spaces in your filenames—even if

you’re running the Windows or Mac versions of Maya. If you do, Maya may display an error message when you try

to open your scene later, and you won’t be able to access your earlier work! The Windows and Mac operating sys-

tems will allow you to save according to their filename conventions, but Maya’s file system will have problems rec-

ognizing names with spaces.

To save your scene file itself, just choose File ➔ Save (or Save As) and give your scene a name.

It is a good idea to append a number to the name of every scene (for example, rocket001). Maya does this 

automatically when you turn on the Incremental Save option. Choose File ➔ Save Scene ❑. When the Save Scene

Options window opens, click the Incremental Save check box. As you work, you will want to save your scene often,

in case you run into any problems. With Incremental Save turned on, each time you save, Maya will create a new

file, numbered sequentially (rocket002, rocket003, and so on). If you are concerned about disk space on your hard

drive, you can limit the number of incremental saves since new backup files are created each time you save. In the

Save Scene Options window, click the Limit Incremental Saves check box. The default limit is 20 increments, which

is a good number of backup copies to keep. If you would rather, you can enter a different number into this field or

just leave the limit turned off. Once the incremental save limit is reached, Maya deletes the oldest incremental file

and replaces it with the most recently saved one.

For information on how to use MEL commands with the Script Editor, see Chapter 17.
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Because the Command line is just the last input line in the Script Editor, you don’t have to

open the Script Editor for a simple command. Try closing the Script Editor and then, in the

Command line, type cone (all lowercase letters), and press Enter (or Ctrl+Enter on the

alpha keyboard). A cone should appear in your scene, and the Feedback line (to the right of

the Command line) should now read

Result: nurbsCone1 makeNurbsCone1

This lets you know what actions Maya has taken to complete your command.

Summary
This quick tour has shown that, while Maya is a deep and complex program, a great deal of

thought has gone into making the interface intuitive. Consistent interface elements (such as

using the Alt key and mouse drags to move around many different windows), grouping tools,

and even placing clues about your orientation in space and the type of tool you’re using

directly in the scene windows—all of these features work together to ease the new user’s

entrance into this complex environment and to make the experienced user more productive.

More importantly, you can customize the interface, from its smallest to its largest detail,

so you can tailor the program to meet your needs. As you grow more comfortable with using

Maya, you will want to optimize its interface to allow you to work more quickly with less 

clutter. Throughout this book, you will find tips and tricks that you can use to optimize your

workspace, making you that much more efficient. If you are new to Maya, spend a bit of time

playing with the interface after reading this chapter. Otherwise, move on to the next chapter

and start the process of creating a large-scale animation from scratch!

If you are very new to Maya and 3D animation and would like to create a smaller, simpler ani-

mation before you begin the book-sized animation project, you can read the Rocket Tutorial

PDF file on the accompanying CD (rocketTutorial.pdf). That bonus chapter will lead you

through the process of creating a simpler animation from start to finish.

To “focus” on the Command line when you are in a scene window (so you don’t have to click

in the Command line field with your mouse), press the ` (reverse apostrophe) key on your

keyboard.

You can also press Ctrl+Enter (on the main keyboard) to execute your command.
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