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Bonus A

Preparing Drawings for
Transfer or Export

Just about every design project is a collaborative effort that requires you to share your files. You may
even have to share your files with users in another part of the country or the world. You need to know
how to best package or convert your drawings to a format that your project associates can use.

AutoCAD provides a wide variety of options for preparing and exporting your drawing files. Even
if you are not exporting your drawings to a different file format, you will need to combine support files
with the .dwg files you send to others. AutoCAD also provides options if you need to send drawings to
non-CAD users. For non-CAD users, you can export your files to other graphic file formats such as Win-
dows Metafiles, Encapsulated PostScript, or JPEG.

This chapter provides information on ways to prepare or export your drawings for others to use.
Here’s what you'll find here:

Using eTransmit to Package Drawings
Converting Drawings to PDF
Converting Drawings to DWF

Converting Drawings to other Formats

* & o o

Exporting High-Resolution Raster Images

Using eTransmit to Package Drawings

A typical AutoCAD drawing file depends on many external files to produce a drawing. If you use the
standard fonts, linetypes, and hatch patterns, you can usually get by with sending just the .dwg file
of your drawing along with any Xref files that are attached to it. But frequently, offices develop their
own set of custom linetypes and use fonts that may not be on every computer system. If you have
drawings that use custom resources such as these, you will want to make regular use of AutoCAD’s
eTransmit feature.

TIP You can use eTransmit to save your AutoCAD file to an earlier version, which is a common
requirement when sharing files with other offices.
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How eTransmit Works

eTransmit collects all your project drawings and their resource files into a single archive package. You
can create a .zip file or an executable .zip file or just isolate project files in a folder system. A report
file is included that describes the files included with the eTransmit package.

1. In AutoCAD, open a file you intend to send to someone; then choose File > eTransmit to open
the Create Transmittal dialog box. In the dialog box, you see a tree structure listing of the files
that are included in the transmittal.

b Current Drawing(s]: & Current user: George Omura

Files Tree | Files TaLJ'EI [~ Select a transmittal setup
EHER Current Drawing
EHER W john's house.dwg
@ AutaCAD Font Map

Included 2 file(s), 348KE Add File.. I Transmittal Setups, I
Enter notes to include with this transmittal package:
;I Wiew Report I ’T

Cancel

=l Help

2. Toadd more files to the transmittal than are shown in the list, click the Add File button to open
a file dialog box.

3. Toremove files, click the plus sign to expand the listed items; then remove the checkmark that
appears next to the file you want to exclude. You can also use the File Table tab to view the files
as a simple list.

WARNING Ifyou’ve edited the file before you choose File > eTransmit, you will see a message telling
you that you must save the drawing before continuing.

4. To enter notes to include with this transmittal package, click in the Enter Notes To Include
With This Transmittal Package input box and enter a description or other note.

If you need to set up the type of file or file location for your eTransmit package, do the following:

1. In the Select A Transmittal Setup group, click the Transmittal Setups button. You'll see the
Transmittal Setups dialog box.

5 Curent user: Geoige Omura
Hew.
Hename:
Madity...
Delete
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HOW ETRANSMIT WORKS

2. Click the Modify button to open the Modify Transmittal Setup dialog box.

@ Modify Transmittal Setup ll 5‘

Current user: George Ornura
Current transmittal setup: Standard

i~ Transmittal type and location
Transmittal package type:

File Format:

| Keep existing diawing fle formats =l
Transmitta il folder

IF \Documents and Settings\George Omuraiiy Ej Browse,

Transmittal fle name
Prompt for a flename =l

I\ohn‘s house - Standard.zip

1~ Transmittal O ption:
' |Jse grganized folder structure
Source roat folder.

IF “Documents and 5 ettings\Gearge Dmula\hj Browse. .

" Place all files in one folder
 Keep files and folders az iz
™ Include fonts

I~ Send e-mail with transmittal
I~ Set default plotter to ‘none’
I Bind egtemal references
™ Prompt for password

Transmittal setup description:

0k | Concel Help

3. In the Transmittal Package Type drop-down list, select the format for your collection
of files. You can create a Zip or self-extracting executable archive, or you can save the
files in a folder. If you choose the Zip or executable option, you can also add a password
by turning on the Prompt For Password option near the bottom of the dialog box. The
person receiving the transmittal file must then enter a password to extract the files. If
you choose the Folder option, you can tell AutoCAD where to place the files by clicking
the Browse button. For this exercise, choose the Folder option in the Transmittal Package
Type list.

4. Click the Browse button to open the Specify Location Folder dialog box. This is a typical
AutoCAD file dialog box that you can use to select a location for you files. You can use
the Create New Folder tool to create a new folder for your files. You'll want to keep your
transmittal files in a separate location from other files. Once you select a location, you
return to the Create Transmittal dialog box.

5. When you've set up your transmittal, click OK in the Modify Transmittal Setup dialog box,
and then click Close in the Transmittal Setups dialog box.

6. Finally, you can preview the report file by clicking the Report tab.
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The eTransmit report describes the files in your eTransmit package. It also alerts you to required
support files that eTransmit was unable to find.

Efview Transmittal Report x|

Current Drawingfs): 13-+ef.dwg

Transmittal Report: -
Created by AutoCAD eTransmit Monday, Febuary 23, 2004, 1:41 P

Drawing:
This is a transmittal based on 13-xref1.dwa.

Files:

Root Drawing:
13uief1.dwg

AutoCAD Diawing [External] References:
comman.dwg

Calgiid dwg
Floor!.dwg

AutoCAD Font Map Relerences:
acad.fmp

The following files were excluded from the l:

Fontshsimple. shs
Fontshtt. shw
Fontshltypeshp. shx
Forts\COUR.TTF

Notes for distiibution:

_DWG external reference files:

Save bz I

After you have set up eTransmit for your drawings, you can click OK in the Create Transmittal
dialog box; AutoCAD then proceeds to collect the files into an archive folder or a Zip file. Once
eTransmit has completed its work, you can send the resulting .zip or .exe file over the Internet or use
another medium such as a CD to store the drawings.

If you find that you use a handful of eTransmit settings regularly, you can create and save transmittal
setups and give them names in the Transmittal Setups dialog box. This allows you to have multiple
transmittal options so you don’t have to set up eTransmit each time a different situation arises.

The eTransmit Options

A number of options are available for configuring the transmittal setup. The following gives a run-
down of those options:

Transmittal File Name This option is not available if you select Folder as the transmittal package
type. Transmittal File Name lets you specify whether you are prompted for a filename or whether
AutoCAD creates a filename for you. Prompt For A File Name is self-explanatory. The other two
options, Increment File Name If Necessary and Overwrite If Necessary, offer predefined filenames
based on the transmittal style and main drawing name.

File Format This option lets you select between the AutoCAD 2004 /LT 2004 and AutoCAD
2000/LT 2000 file formats in case your recipient requires an earlier version.

Use Organized Folder Structure This option preserves the folder structure for the files in the
transmittal. This can be important when Xref and other files are located across several folder
locations. If the person receiving your files cannot open Xref files properly, try using this option
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when you re-send your transmittal files. This option will create new folders when required for
fonts, plot configuration files, and sheet set files. Note that Sheet Set data files (DTS) are placed
in the root folder of the transmittal. Also, AutoCAD will attempt to preserve paths up to one
level above the root path of the drawings.

Place All Files In One Folder This option is self-explanatory.

Keep Files And Folders As Is  This option preserves the entire folder structure for the files in the
transmittal.

Send E-Mail With Transmittal This option lets you send an e-mail transmittal with the files
included as an attachment. This option streamlines the transmittal process by opening an e-mail
dialog box that allows you to enter a message and select a recipient for your transmittal.

Set Default Plotter To “‘None’ The type of printer you've set up for your files is stored with the
drawing file. This option removes any reference to printers or plotters that you have set up for
the drawing. By using this option, you can avoid confusion for the person receiving the trans-
mittal drawings when they try to print.

Bind External References You can bind external references to the drawings that contain them if
itis not important for the recipient to maintain the external references as separate drawings. This
can help reduce the number of files in your transmittal, which in turn will reduce any confusion
regarding the files you've sent.

Prompt For Password This option lets you password protect the transmittal file. If you click
the Password button, you are presented with a dialog box that lets you enter a password and
confirm it. The person receiving the transmittal file must then enter this password to extract the
files.

Transmittal Setup Description This option lets you include a brief description of the current
transmittal setup.

Converting Drawings to .pdf

If you are sending drawings to someone for review and the recipient doesn’t care whether they can
edit the drawing, you might want to use Adobe Acrobat to generate files in the .pdf file format. Files
in the .pdf format are an excellent choice because they are so common and nearly everyone who uses
the Internet has a .pdf reader installed on their computer. Certainly most business users will have a
.pdf reader.

TIP Thelatest version of the Adobe Acrobat 7.0 Pro PDF reader offers a distance, perimeter, and area
tool that lets you get a rough measurement of scaled drawings. Many AutoCAD-specific features are
built into Pro 7, such as support for layers and red-line notation.

Adobe Acrobat 7.0 Professional has features that are designed specifically for AutoCAD
users; unfortunately, these special features are not yet implemented for the latest version of
AutoCAD.
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Before you can create .pdf files, you will need to purchase and install the full version of Adobe
Acrobat 7, not the free version, which is only a reader. Once installed, you will see Adobe PDF as a
printer option in the Plot dialog box of AutoCAD.

B plot - site plan 21|
11 Learn shout Plotting
~Page setup ~Plat style kable (pen assignments)
Mame: |<None> j Add... More hd D
~Printeriplotter —~Shaded viewport options
Mame: |@HF Desklet 895Cse =] Properties... | shads plot s displayed -
8 HP Decklet 835Cse -
Flatter: e Quality Normal d
wihere: i - =
Description: ublishTehw/eb PNG.pe3
efault Windows Syster Printer pc3 =
B WFE eFlol pe3 oo Plot options
K8 PostS cript Leved 2.0c3 hd I Plot in background

¥ | Plot object lineweights

~Paper size Mumber of copies
[Legal = { [ = I Piok with plot stylgs
¥ Flot paperspace last
Plot area Plot scale ™ Hide paperspace obiects
Sl (st I Ri-topaper I~ Plot stamp on
[lavo =] seaer [t 7] || T Save changes tolayaut
~Plot offset {origin set to printable area) 1 |mches ~| = | ~Drawing crientation———————————
4 |0.000000 inch I Center the plat ll—unlt  Portrait .
= ' Landscape
y; |0.000000  inch ™ 5cale [neweights ¥ Flot upside-down
Preview... Apply bo Layout | oK | Cancel | Help | @

Select the Adobe PDF printer option and then select a paper size and other options as described in
Chapter 11. When you proceed with the printjob by clicking OK, you will be asked for a filename and
location for your .pdf file.

Converting Drawings to .dwf

Although the .pdf file format is arguably the most trouble-free format to use, it requires some extra
work if you have more than one drawing in a set. With .pdf, you will have to print each sheet individ-
ually and then use the Adobe Acrobat Pro application to combine the separate sheets into a single file.

You can avoid this process, plus have drawings that will show more detail when you zoom in, if
you use the Autodesk .dwf file format. The .dwf format is like the .pdf format in that it produces a com-
pact, portable read-only file. The recipient of your .dwf file will have to download a reader from the
Autodesk site, but this isn't any more difficult than obtaining the Acrobat reader from the Adobe site.

The .dwf file format also offers some features not available in the .pdf format. With the .dwf
viewer, you can zoom in to much more detail on a drawing. If you have the Autodesk DWF Com-
poser application, you can annotate drawings with red mark comments and then transfer these
comments to AutoCAD. Red marks can also be cataloged and stored for future reference. DWF
Composer also allows you to obtain accurate drawing information such as distance and area cal-
culations and attribute data. Finally, if you have included hyperlinks in your drawing, the .dwf
format will preserve them. You can then use the Hyperlink feature to link parts of drawings within
a .dwf set.
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Creating a .dwf File from the Plot Dialog Box

If you only need to create a DWF file of a single sheet, you can use the Plot dialog box, since itis a simple
and familiar procedure as the following exercise demonstrates:

1. Open a file you want to convert to .dwf and then choose File > Plot.
2. In the Plot dialog box, select DWF6 ePlot.PC3 from the Name drop-down list.

3. Setup the rest of the plot options as if you were printing to paper. (See Chapter 11 for more on
setting up your printer options.)

4. Click OK in the Plot dialog box to proceed with the creation of the .dwf file.

CONFIGURING THE .DWF OUTPUT

In addition to the settings in the Plot dialog box, you can make some special configuration adjust-
ments to the .dwf plotter configuration file. Here is where to find those configuration settings.

1. Choose File » Page Setup Manager, select a setup from the Page Setups list in the Page Setup
Manager dialog box, and then click Modify to open the Page Setup dialog box.

2. Make sure the DWF6 ePlot PC3 configuration file is listed in the Name list box of the Printer/
Plotter group.

3. Click the Properties button to the right of the Name drop-down list to open the Plotter Con-
figuration Editor dialog box.

4. Make sure the Device And Document Settings tab is selected; then click the Custom Properties
listing.

7% Plotter Configuration Editor - DWF6 ePlotpcd 21|

ﬁgngm\| Paits  Device and Document Settings

# DWFE ePlot.pe3

B €5 Meda

. Source and Size <Size ANS|A [8.50 % 11.00 Inches]>
Graphics

e
1 &2 Userdefined PapBibSizes & Callbration
-8 Custom Paper Sizes
o) Modify Standard Paper Sizes (Printable Area]
@ Filter Paper Sizes
- [EL Plotter Calibration
B PP File Mame <Mone:

[~ &ccess Custom Dialog

Press the following button to access the
device diver-specific user-interface.

Custom Properties. ..

impor. | Saveds. | Defauls |

oK I Cancel | Help |
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5. Click the Custom Properties button that appears in the lower half of the dialog box to open the
DWEF Properties dialog box. In this dialog box, you can set the resolution, format, and back-
ground color and paper boundary for your .dwf file. You can also specify whether to include
layer and font information.

[~ Wector and Gradient Resolution [Dots Per Inch]
‘Yector resolution Custom vestor resolufion:
[ 4
Gradient resolution: Custom gradient resalutioh:
IZUU dpi =4 200 dpi
i~ Raster Image Resolution [Dots Per Inch]
Lolor and grayscale resolution [Custam colon resalution
IZDD dpi - 200 dpf
Elack and white resolution [Custam black and white resolution:
|4DD dpi - 400 dpf
i Font Handiing
" Capture none & Caplure some € Capture gl

Edit Font List... ™| &5 geometiy

r~ Additional Output Setting

D'wiF format:
IEompressed binary [recommended)

j ™ Include layer information

Background color shown in viswer L g papar b iz

[ White - ™ Save preview in DWwWF
[ o | coead | Hep |

6. Click OK after selecting your settings. The Plotter Configuration Editor dialog box opens
again. Once you've set the custom properties, you can save any new settings under the DWF6
ePlot. PC3 file, or you can create a new DWF6 PC3 plot configuration file. To save any setting
changes, click the Save As button and select the PC3 file in which you want to save the settings.

7. Click OK in the Plotter Configuration Editor dialog box to return to the Page Setup dialog box.
8. Click OK to exit the Page Setup dialog box.

After you select your custom configuration settings in step 5, you needn’t open the Plotter Con-
figuration Editor dialog box again the next time you plot a .dwf file. If you save your new settings as
anew PC3 file, you can select it from the File drop-down list in the Plotter Configuration group. You
needn’t reenter the custom settings.

Converting a Set of Drawings into a .dwf File

If you need to combine multiple drawing sheets into a single .dwf file, you can use the Publish feature
in AutoCAD. Publish lets you select a set of layouts or model tabs and combine them into one .dwf
file that contains multiple pages.

If you choose File » Publish, you'll see the Publish Drawing Sheets dialog box shown in Figure A.1.

Notice that the dialog box lists all the layouts from the current file in its main list box, including
Model tab. (See Chapter 11 for more on layouts.)

You can right-click and select Remove An Item From The List or click the Remove Sheets button
just below the list of sheets. If you want to add a layout to the list, including those from another file,
you can right-click in the list and select Add, or click the Add Sheet button below the list as shown in
Figure A.2.
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FIGUREA.1

The Publ.lsh Drawing E——
Sheets dIaIOg bOX Sheet Name | Page Setup I Status |
[Eichn's house-Modsl A% <Default: None> v Mo emors
h's house-site plan A% <Default: None> v Noenors
john's house-elevations [N] % <Default: None> ¥ Noenors
john's house-Plan-section % <Default: Nonex ¥ Noenors
john's house-Foundation details ‘f" <Default: None> ¥ MNoenors
|ohn's hauze-Skylite Details ‘f" <Default: Mone> ¥ Noenors
3| 1 25| s8] ] R B <] 5 it o ame were RIS
[~ Publigh to Include when adding sheets
% Platter named in page setup  DWF fils [F Model tab ¥ Layout tabs
Publish Options Shew Details | Publish | Cancel Help
FIGUREA.2 M heet d
The Publish Drawing ove sheet down.
Sheets dialog box toolbar Move sheet up. Load sheet list.
Remove sheet. Save sheet list.
Add sheets. Plot stamp settings.
Preview. Include plot stamp.

El gl El gl hiél il ﬁl IV Include plat stamp

Besides adding and removing items from the list of tabs to be published, you have a number of
other options to help you customize the way you print your set of drawings. Table A.1 lists and
describes those options. Refer to Figure A.2 for the location of the button options.

TABLEA.1: The Publish Drawing Sheets Dialog Box Options
OPTION PURPOSE
Preview Lets you see a print preview of an item from the list.
Add Sheets Adds sheets to the list. Sheets can be layouts or model tabs from other drawings not
currently open.
Remove Sheets Removes sheets from the list.
Move Sheet Up Moves a selected item up the list.
Move Sheet Down Moves a selected item down the list.
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10 BONUS A PREPARING DRAWINGS FOR TRANSFER OR EXPORT

TABLEA.1: The Publish Drawing Sheets Dialog Box Options (CONTINUED)
OPTION PURPOSE
Load Sheet List Loads a saved sheet list.
Save Sheet List Saves the current sheet list along with its settings.
Plot Stamp Settings Opens the Plot Stamp Settings dialog box where you can set up plot stamps. See

Chapter 11 for more on plot stamps.

Include Plot Stamp Turns on the Plot Stamp feature.

Number Of Copies Controls the number of copies of sets.

Publish Order Lets you reverse the print order of the listed sheets.

Publish To Lets you determine whether to print to a .dwf file or the default printer for the Page
Setup for each sheet.

Include When Adding Lets you filter out model or layout tabs when adding sheets from other drawings.

Sheets

TIP The Publish To option lets you print to an alternate file type, such as PDF or HPGL/2r. To do this,
however, you must first set up a page setup for each layout that indicates the file type you want to
print to, be it Adobe PDF or HPGL/2. See Chapter 11 for more on page setups.

APPLYING SHEET SETUPS TO ITEMS IN THE LIST
You might notice that the Sheets To Publish list in the Publish dialog box includes a Page Setup column.
If you select an item in the list, the Page Setup column becomes a drop-down list for the selected item.

~ Sheets to publish

Sheet Name | Page Setup I Status |
[Eichn's house-todsl % <Default: None> ¥ Noenors
[ERiohn's houss-site plan @ <Default None> =] v Noenors

i ¥ Noenors

[EBiohr's house-elevations (N]
[EBiohr's house Plan-section

[EBiohn's house Foundation detaile 5% <Defaul: None>
|ohn's hause-Skylite Details ‘f-‘ <Default: None>

Mo enors

Mo enors
Mo ermors

LSRR

EI gl E‘ll ;ﬂl ﬁl ﬂl ﬁl [ Includs plat stamp Mumber of copies: m =

1~ Publish ta "Include when adding sheets

% Platter named in page setup  DWF fils ¥ Model tab ¥ Layout tabs

Publish Options. . Show Details | Publish I Cancel Help
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If you have a page setup you want to apply to one or all of the items in the list, you can use this
drop-down list to select the setup. By default, AutoCAD applies the existing layout settings for

items in the list.

CONTROLLING WHERE .DWF PRINT FILES GO

You can also control where Publish places the .dwf file by opening the Publish Options

dialog box.

B Publish Dptions x|

& Current user: George Omura

Default output location (DWF and plot-to-file) 2
C:\Documents and Setlings\George OmuraiMy Documents's

Location

Diw'F type
Password prat..
Password

Dw'F naming
Mame

Layer informati
Block infarmti...
Block template.

Multi-shest D'WF
Disabled
N/A

Prampt for name
MN7&

Don't include
Don'tincluds

ok | cndl | rep |

This dialog box also lets you specify whether to plot individual .dwf files for each sheet in the list
or to combine them into one file. Table A.2 lists and describes the groups in this dialog box.

TABLE A.2: The Publish Options Dialog Box Options

OPTION GROUP

Default Output Location

General DWF Options

Multi-Sheet DWF Options

DWEF Data Options

PURPOSE

Offers options for the location for .dwf files.

Offers a choice between a multisheet .dwf file, which combines multiple sheets
into one file, or single-sheet .dwf files, which creates a file for each sheet. You
can also turn password protection and specify a password.

Lets you specify a default name for your .dwf files or have AutoCAD prompt you
for a name for each .dwf file.

Lets you include layer, block to block template information in the .dwf.
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12 BONUS A PREPARING DRAWINGS FOR TRANSFER OR EXPORT

Viewing .dwf Files

AutoCAD offers the DWF View program to allow anyone to view .dwf files. If you have AutoCAD,
it is installed automatically in your system. You can get a free copy from the Autodesk website.
To use DWF View to view .dwf files, follow these steps:

1. Choose Start > Programs » Autodesk » Autodesk DWF Viewer.

2. Choose File » Open, and then locate and open the .dwf file you created earlier. The .dwf file
appears with a view of the first sheet in the set displayed in the right side.

ENew Sheet Set (2).dwf - Autodesk DWF Yiewer (=] B3]
File Edit ¥iew Tools Help
B |[Saal [Ble 15 b | @

s

[2]2 a2
MK waod ot TG Wit Foetl oo @
i e . o
— wrdar itzcrs
Vi 1 * ﬁ,—dﬁ:’ 1 4 dbi—hing winder:

B Demolition - ...
| & B
| ﬂ
| =] [NI=H=] =] —
L == pepre——y
— Nomrd” ol md Xt 30MY @ WNGNA oM Gl

[5] AS Schedules
(22.0% 17.01n)

List |Boakmark

[31352 [4]4 A1 Plan -
Structural - A... 22x17 ArchL...

| Thurnbnails

W ==j
[ma]

Yow_ st gt [t e it
Yo atir i i3 -
- W E==S
i T ol
~ Properties | i [ _—
I -
B Hame Walue - i H
i Sheet Name 1 A3 Elevation -4 i — =
— author George Omura i v o et | &
& comments B —
£ company Autodesk, Inc. = m—
—— copyright 203

creationTime 2004-03-23T14:0
description

keywiords -

4 »

3. You have a set of thumbnail views in the panel to the left. Click each thumbnail to view the dif-
ferent sheets in the set.

Once you've opened a .dwf file, you can use the Pan and Zoom tools in the DWF View toolbar to
view the drawing. If you need a hard copy, you can print the current view by choosing File > Print.

Converting Drawings to Other Formats

Sometimes it’s helpful to be able to export your drawings into other formats. For example, you might
want to render a floor plan in Adobe Illustrator or some other drawing program. You can get the
best-quality image exported from AutoCAD by using the EPS or Windows Metafile (.mwf) format
for Illustrator-like programs. Or you might want to convert a drawing to a 3D format for analysis or

rendering.
This section looks at some of the ways AutoCAD lets you export files into other formats so you can

take advantage of a wider range of editing and viewing options.

Copyright © 2005 SYBEX Inc., 1151 Marina Village Parkway, Alameda, CA 94501. World rights reserved.



CONVERTING DRAWINGS TO .DWF

CONVERTING TO .DXF

Every now and then, you might need to export your drawing to a format that other CAD programs
can read. The .dxf format is fairly common, and most other CAD programs can read it.

There’s no mystery in exporting to .dxf. Choose File > Save As to open the Save Drawing As dialog
box, and then select the appropriate .dxf format from the Files Of Type drop-down list at the bottom
of the dialog box.

Save I@My Dacuments j @ @ ¥l views v Toos v
Name = [ Size sz
IChAutodesk Workspaces
[C3cADandPlans
() Gen Hazard Maps
[Chpersonal photos
[g3)5hortcut ko CADandPlans 1KB
| i |
™ Update sheet and view thurmbnails now
File name: |iohn's house dwg | Save
Files af type: | AutalCAD 2004 Drawing [+ dwa) j Cancel |
utoCAD 2004 Drawing [*.dwg)

AutoCAD 20004LT 2000 Draving [*.dvea)
AutoCAD Drawing Standards [* dws]
AutoCAD Drawing Template [+ dit]

A ) 2004 DXF [* dsf]
AutoCAD 2000/LT 2000 DXF (*.dxf)
AutoCAD R12/T2 DRF [~ daf)

You can choose from several .dxf options, including one for version 12 of AutoCAD. You also have
some additional options you can apply to the exported .dxf file. Choose Tools » Options from the
Save Drawing As dialog box to open the Saveas Options dialog box. Select the DXF Options tab to
view the DXF options.

Elx]

DWG Options | OXF UDITOHSfl

Fomat
* ASCI I Select ohiects
T BINARY I~ | Save thumbnail preview image

Decimal places of accwracy (Oto 18] |18

ok I Cancel I Help |

From here you can specify whether the file is standard ASCII or binary. You can also specify
whether AutoCAD prompts you to select portions of your drawing instead of exporting the whole
drawing. You can even set the decimal place accuracy of the exported file, though you will probably
want to keep it at the default value of 16.
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EXPORTING PARTS OF DRAWINGS USING THE EXPORT OPTION

AutoCAD also includes an Export option that offers a variety of file types to choose from. Choose
File » Export to open the Export Data dialog box. You can then specify the file type using the Files
Of Type drop-down list. Table A.3 lists the file types and describes their use.

EHExport Data x|
Savein: |[E:| My Documents - d Q0 Views v Tooks v
Mamg = | Size | Type | Date Madified
I autodesk Workspaces File Foldar /42003 3:53 AR
IEycapandPlans File Folder /42003 3:53 AM
[CGeo Hazard Maps File Folder 6/4/2003 3:52 AN
[Cpersonal photos File Folder &/4/2003 3:52 Al
&]Shortcut to CADandPlans 1KB Shorkeut 2/11/2004 3:54 P
< I m
File pame; Jiohnis house st = Save
Files of type: | Lithography [t | ﬂl

D50 Extract [ o)
Bitmap [*.bmp]

D Studio [+ 3ds)
Block [*.dwa)

Each of these export options will prompt you to select a part of your drawing. The Encapsu-
lated PS option offers additional options when you choose Tools » Options from the Export Data

dialog box.
BHExport Data x|
Save |[E:|George Ornra -]« @ 0 Wiews v Took v
— 0 = [omar  (iModty FTP Locations
s e =28 add Current Folder to Places
IhApplication Data File: Folder 6/4/20 o .
[C53My Documents File Folder Gajzo T

< I m

Fle ey Jiohn's house eps =] See
Files of type: | Encapsulated PS [*.eps] =] Cancel
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TABLE A.3: The Export file types
FILE TYPE TYPICAL USE
Metafile (*.wmf) Common file format for transfer to other graphics programs
ACIS (*.sat) 3D file format for analysis
Encapsulated PS (*.eps) PostScript format for Illustrator or other PostScript editors
DXX Extract (*.dxx) Attribute extraction file format
Bitmap (*.bmp) Common bitmap file format for rough black-and-white images
3D Studio (*.3ds) 3D Studio format for 3D modeling and rendering
Block (*.dwg) AutoCAD drawing format for saving portions of a file

This opens the PostScript Out Options dialog box in which you can select the area of the drawing
to export as well as a drawing size.

Prolog Section Name: [ scsle
Output Drawing
| Units Units
IT =
‘whatloplot— | [ Preview | :
& Display 1 MNone I Fit to paper
 Extents  EPSI PG
™ Limits width Height
1 ien 75 105
Wiew
T Wirdaw
windov.
Size Units
’7(: Inches MM nw =
Cancel

Exporting High-Resolution Raster Images

The Export option allows you to export to the bitmap file format, but the results are quite poor. If you
need a high-resolution bitmap equivalent of your drawing, you can set up an AutoCAD printer as a
raster file output device. (Raster is another term for bitmap.) This way, you can use AutoCAD’s print
feature to “print” a raster or an image file.

First, you need to use the Add-A-Plotter Wizard to set up a raster printer.

1. Choose Tools » Wizards » Add A Plotter.

2. On the Begin screen, choose Next, and then choose My Computer.
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11.

12.

13.

On the Plotter Model screen, select Raster File Formats from the Manufacturers list, and then
select the type of raster file you want to use from the Models list. For example, you can choose
Independent JPEG Group JFIF (JPEG Compression). This is one of the more universal file types.

Skip the Import PCP or PC2 screen and the Ports screen.
Enter a name for your raster output printer on the Plotter Name screen.

On the Finish screen, click the Edit Plotter Configuration button to open the Plotter Configu-
ration Editor dialog box.

7% Plotter Configuration Editor - Independent JPEG 21|

Gieneral| Ports | Devios and Document Settings |

:t'ti Independent JPEG Group JFIF MPEG Compression)
B¢ Media
[ oo e
15 Graphics

+-#5 Custom Properties
1 &2 Userdefined Paper Sizes & Callbration

L8} Custom Paper Sizes

A=) Modify Standard Paper Sizes (Printable Area]

- [5] Fier Paper Sizes

+{EL Plotter Calibration

. PMP File Mame <Mones

80100 Pixels]:

[~ Media Souice and Size

Source Size
| =1 [[15un HiRes [1600.00  1280.00 Plx..i’
i [5G4 HiRes (160000 % 120000 Fi.

Iﬁ 1S uper ®GA [1280.00 % 1024.00 Pix...

[95un Standard (1152.00 < 300.00 Pi...
™ Automatic B A (A AR ) FED A7 Banle) |
Frintable Bounds: 1600 : 1280

This device cannot configure somefal] of these values

impor. | Saveds. | Defauts |

oK I Cancel | Help |

Click the Source And Size listing that appears in the large list box in the top of the dialog box.
A list of options appears in the Size list box in the lower-right corner of the dialog box.

Click Custom Paper Sizes from the large list box at the top of the dialog box. The options
change in the lower half of the dialog box.

Click the Add button to start the Custom Paper Size Wizard.

Click the Start From Scratch radio button, and then click Next to open the Media Bounds
screen.

Enter a height and width in pixels for your image file, and then click Next to open the Paper
Size Name screen. Enter a name that best describes the size of the image file, and then click
Next to open the File Name screen.

Enter a name for the Plotter Model Parameters file. This file stores specific setting information
about the plotter. Click Next when you are finished.

On the Finish screen, click Finish. The Plotter Configuration Editor dialog box opens again.
Click OK, and then click Finish in the Add-A-Plotter Wizard.
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Once you've created a raster plotter, you can create a raster file version of your drawing using the
AutoCAD Plot feature. Choose File » Plot, and then in the Plot dialog box, select the raster output
device from the Name drop-down list of the Printer/ Plotter group. You can then proceed to plot your
drawing, but instead of paper output, you'll get a raster file.

Summary

As you've seen from this chapter, many file formats are available for export from AutoCAD, and if
AutoCAD doesn’t support the exact file format you need, you can usually find a program that can
convert one of the files that AutoCAD does produce. But chances are, you won’t have to go beyond
what AutoCAD offers to get the type of file you need.
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