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TUTORIALCreating a Compression Template with Discreet Cleaner

Discreet Cleaner is the industry-standard compression

software, used by practically every new-media shop and

producer out there. Chapter 20 of Final Cut Pro 3 and

the Art of Filmmaking shows how to use Discreet

Cleaner’s Settings Wizard to compress a Final Cut Pro

movie and export it for the Windows Media format. For

first-time users, the Settings Wizard can be a good way

to introduce yourself to the program and learn about

how it works. However, the real power of Discreet

Cleaner comes in its manual interface, where you can

program very detailed functions for QuickTime, Real,

Windows Media, and other formats. 

One of the key selling points of Discreet Cleaner is

that the templates you create can be permanently stored

as files, and so you can use them again and again. To

acquaint you with the depth of control that Discreet

Cleaner provides for media compression, we’re going to

show you how to design a basic compression template

for a downloadable QuickTime movie (compatible with

version 5 only) for a broadband audience. We will be

using this template to compress 720 × 480 NTSC DV

footage. If you don’t have any such material, you may

wish to reuse the Chapter 17 sequence provided on the

book’s DVD as described in Chapter 20. 

The following steps provide a basic map only, and

you should consult Discreet Cleaner’s technical manual

for performing these and similar functions in other for-

mats. Before using the manual settings, it’s a good idea to

select Edit > Preferences in Discreet Cleaner and make

sure your data rate units are set to Bits, the standard unit

used by modems for measuring data transfer rates, instead

of Bytes. Finally, note that although Discreet Cleaner

includes a basic version of the Sorensen 3 Video codec,

you can achieve even further control over compression
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by using the Professional Edition, which is sold sepa-

rately. Some of the options described below are available

only with the Professional Edition.

1. In Final Cut Pro, once you are ready to export your file,

choose File > Export and select Final Cut Pro Movie. In the win-

dow that appears, name your file and select its destination. Leave

all the default settings intact. (However, if Discreet Cleaner is on

the same computer where you’re using FCP, you can turn off the

Save As Self-Contained option to speed up the process.) Click Save.

When the file has finished exporting, close out of FCP.

2. Open Discreet Cleaner. To begin compressing your media

clip, either drag your Final Cut Pro movie onto the interface or

select File > Open and use the Finder to select your movie.

3. When you have successfully brought in your file, it will

appear in the Discreet Cleaner interface. 

4. To design a compression template, double-click the file

when it appears in the window. A Settings Wizard window will

appear, along with a Project window behind it that displays tech-

nical information about your FCP movie. Click the Advanced

Settings button at the bottom of the window. The Advanced Set-

tings window will appear. 
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5. The Advanced Settings window has three panes: a list of

Presets on the left, the Settings pane on the right, and a set of but-

tons for common operations. This is the place where finely tuned

aspects to media compression can be set manually.

6. You will notice a variety of

folders in the Presets pane, including

QuickTime, Real, Windows Media,

and others. For our purposes, choose

QuickTime Progressive. (This is the

downloadable format.) From within this

subdirectory, click QT Big Progressive. 

7. Click the Save As button. A window will pop up, allow-

ing you to rename your file. This way, the changes we are about to

make won’t alter the original default template. Notice that it is

saved into the Presets window alphabetically, and that it is auto-

matically highlighted. This means it is the setting that can be

altered.

8. Now, look at the Settings window. You’ll note a variety of

tabs with particular functions. Start with the Output tab and leave

all of the default settings as they are. The Flatten, Cross-Platform,

Fast Start option is essential for QuickTime movies that will be

played on Windows PCs as well as Macs, so definitely leave this

one on. You may also wish to add the Autoplay function so that

when people download your movie, it will play automatically on 
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their machine, either in the QuickTime window or as a full-screen

document.

9. Next click the Tracks tab. Leave all of these default set-

tings as they are. For Video, Audio, and MPEG, the Process setting

means that the final QuickTime movies are to be played as they are

downloaded. For people surfing on broadband, you may wish to

enable the Display High Quality function.

10. The Image tab is where you can perform accurate scal-

ing via manual cropping. In the Crop box, pull down the menu to

Numeric. Remember that we’re working with 720 × 480 material, so

that to get the material to 640 × 480, we must shave 80 pixels off the

width of our source material. To do this evenly, type 40 in both the

Left and Right boxes. Leave the Top and Bottom at 0. Change your

Image Size to 320 × 240—which accurately scales down your Final

Cut Pro Movie to a 4:3 aspect ratio. Remember that the quality of

compressed video is higher with a smaller image size. Leave the con-

strained aspect ratio at 4:3. Next, set your display size to Double.

This function will blow up a regular 320 × 240 back to 640 × 480

when the compression is complete. Leave all of the defaults as they

are. If you are working with film that has been transferred to video,

check the box to turn on the Telecine function. To set a watermark in

your video, turn on the Watermark function and use Set to choose a

graphic file on your computer. If you have purchased the profes-

sional edition of the Sorenson codec, you will probably want to use

the Watermark function in the Encode section, which allows for

deeper functionality than the version supplied with Discreet Cleaner.
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11. Next, select the Adjust tab. Generally, these controls

are not nearly as effective as their equivalents in Final Cut Pro.

However, because most computer monitors are darker than NTSC

or PAL monitors, you may wish to increase your Contrast and

Brightness to compensate for this difference.

12. Now select the Encode tab. Since we are targeting

QuickTime 5 users, we can change our codec to Sorenson Video 3

Compressor. If you have the professional edition of this codec, you

will have access to much more functionality than with the basic

edition that comes with Discreet Cleaner. Change your Bit Depth

to Millions of Colors+ for better color accuracy. Leave your Spatial

Quality at 50. Bump up your Frame Rate to 30 fps, and leave your

Keyframes at 150. If you have the professional edition of Sorenson

Video 3, go to the Video Data Rate box, pull down the menu and

change the setting from Basic to 2-pass VBR (Variable Bit Rate).

As explained in Chapter 20 of Final Cut Pro 3 and the Art of Film-

making, variable bit rate allows the highest-quality compression;

Sorenson will allocate more compression power to high action

sequences and less to slower motion sequences. Leave your data

rate at 400 (and note at the bottom that the Total Data Rate is

486.1 Kbps, including your audio file), which is the target broad-

band connection. For more sophisticated functionality with the

Sorenson 3 Professional Edition codec, select Options and Set. A

Sorenson pop-up window will launch. The functions here of note

are Image Smoothing (particularly effective for clips that will be

downloaded via low-bandwidth connections), and inserting a

watermark in your video—in the Playback and Watermark tabs

respectively.

13. Next, turn to the Audio tab. Change the codec from

IMA to MP3 to provide more control over how the audio is com-

pressed. Because MP3 compresses in a more sophisticated way

than IMA, the Total Data Rate will shrink, leaving you more space

to improve the quality of the compression. Change the sample rate

to 44.100 kHz. Most MP3 compressors automatically compress at

a Data Rate of 160 Kbps, but because even broadband has connec-

tion restrictions, you should only increase this setting to 80 Kbps.
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(This will leave approximately the same Total Data Rate as

before it was switched to MP3.) Turn on the Variable Bit Rate

function to perform a qualitative compress on your audio. Leave

the channel setting at Stereo, and change the Speed vs. Quality

setting to Highest Quality. (This delivers a better audio compres-

sion at the expense of a slower compression process.) The rest of

the functions are not as effective for audio correction as they are

in Final Cut Pro, but you may wish to select Volume to further

normalize it. You may also wish to perform an additional Noise

Removal.

14. In the Begin/End tab, you may wish to add Audio

and Video fades to your clip, if you haven’t already done so with

Final Cut Pro. If you were creating this compression template for

use with a low-bandwidth connection, it might also make sense to

add High-Quality Frames to the beginning of your clip. Web surfers

who have to wait for your clip to begin may be more impressed with

a high-quality image than with a pixelated one.

Another great function in the Begin/End tab is End Frame URL

Link. This inserts a “hidden link” at the end of the movie to the

web address you want your web surfers to visit. (If you plan to use

this function, you’ll first want to set up your movie for it in Final

Cut Pro, by making sure that the last frame contains text or a

graphic telling the viewer that clicking the frame will link them to

your web site. See Chapter 9 of Final Cut Pro 3 and the Art of

Filmmaking for information about adding titles.)

15. The Alternate tab is a very sophisticated function

that prevents users from accessing your file in particular ways.

Generally speaking, this function is to be used when you are creat-

ing multiple QuickTime versions of your movie for different con-

nection speeds. Unless you know how to use this functionality, you

should turn all of the options off. However, because we are com-

pressing our video with Sorenson 3, we should restrict users from
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QuickTime versions lower than 5. Change the QuickTime Version

pull-down menu to QuickTime 5.

16. The Metadata is information that users can see when

they download your movie with QuickTime Pro. You may wish

to input necessary information appropriate to your QuickTime

movie.

17. The Summary tab displays a comprehensive list of all

the manual configurations you have performed. (You may also

want to go back to the Encode tab to check the Total Data Rate

one last time.) If everything looks good, click Save. (Notice that

once your template is saved, the Save button is grayed out, mean-

ing that your compression template has been added permanently

to the collection.) Finally, click Apply to apply your settings to

your clip.

18. When you have entered all of the appropriate infor-

mation, either click the Play button, select Batch > Encode, or press

+E. The Output window will launch, showing you the encoding

process. (Note that since you are compressing only one movie, the

program will ask you to specify where the destination should be

one more time.)
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19. If you need to either pause or completely stop the com-

pression process, click the Pause or Stop button respectively.

20. Notice that as your video compresses, an icon of a

wrench appears. When your Final Cut movie has been fully con-

verted into a downloadable QuickTime, your computer will beep.

21. Go to where the compressed movie was saved. You

will find it named with a .mov extension—signifying that it is a

QuickTime movie.

22. Now that your broadband QuickTime movie is com-

pressed, launch it in the QuickTime Player. In the Movie Info win-

dow, notice the differences between the Normal and Current Size.

This functionality was implemented in the Image tab, and is further

described in the Manual QuickTime Pro Scaling section in Chapter

20 of Final Cut Pro 3 and the Art of Filmmaking. Also notice that

the title and related information are what you entered in the Meta-

data tab.
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