Chapter 9

Turning Data into Information with

SQL Server Reporting Services

In This Chapter

Configuring SQL Server Reporting Services with Reporting Services Configuration

Manager

Designing reports

Publishing and viewing reports

SQL Server Reporting Services (SSRS) is one of SQL Server 2008’s
advanced features. SSRS provides database administrators and develop-
ers with a built-in mechanism for designing data-driven reports and publish-
ing them to end users. Microsoft gave SSRS a significant overhaul with the
release of SQL Server 2008. Most notably, SSRS no longer requires Internet
Information Server (IIS) as it did in earlier SQL Server versions. It’s now a
stand-alone service.

SSRS offers a wide variety of reporting functionality and is the subject of
many entire books. In this chapter, [ provide you with a basic introduction to
SQL Server Reporting Services. I discuss how to set up and configure SSRS,
create and publish a basic report, and manage SSRS reports.

Setting Up SOL Server
Reporting Services

\\J

Before you can create and publish reports with SSRS, you need to configure
it to meet the requirements of your business environment. You can do this
using the Reporting Services Configuration Manager.

To use SQL Server Reporting Services, you must have it installed on your
SQL Server instance. (I discuss installing SQL Server components in
Chapters 1 and 2.) Follow these steps to set up SSRS:
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|
Figure 9-1:
The Report
Server
Status
screen.
|

1.

2.

b

From the All Programs menu, choose Microsoft SQL Server 2008->
Configuration Tools=>Reporting Services Configuration.

Provide the connection details for your Report Server in the
Reporting Services Configuration Connection window and click the
Connect button.

If you're running the configuration tool on your SQL Server computer,
the window will most likely pop up preconfigured with the correct
server name and instance. If you're connecting to a remote SSRS server,
you need to provide the server name. Additionally, you need to select
the report server instance if more than one exists on that system.

Review the details on the Report Server Status screen.

The status screen, shown in Figure 9-1, provides basic information about
your Report Server. You may use the Start and Stop buttons on this
screen to change the status of the SSRS instance.

Click the Service Account button in the left pane and confirm that
SSRS is running under the correct account. If you decide to make
changes, click the Apply button when you’re finished.

The Service Account page, shown in Figure 9-2, allows you to select the
account used to run SSRS. You may choose to use a domain account
(as shown in the example) or a built-in account.

i} Rep

orting Services Configuration Manager: VOSTRO\MSSQLSERVER [o ==

=3

i Reporting Services Configuration Manager

Microsoft SQL Server 2006 Reporting Services

4 Connect

Report Server Status

= VOSTRO\MSSQLSERVER

2 Service Account. = Usethe Reporting Services Configuration Manager tool to define or modify settings for the Report Server and
] Report Manager. Ifyou installed Reporting Services in files-only mode, you must configure the Web service URL,

¥ Web Service URL the database, and the Report Manager URL.

[0 patabase

@ Report Manager URL Current Report Server

~) Email Settings SQL Server Instance: MSSQLSERVER

[P Execution Account Instance ID: MSRS10.MSSQLSERVER
P\ Encryption Keys Edition: DEVELOPER EDITION
41, seale-out Deployment Product Version: 10.0.1075.23
Report Server Database Name: ReportServer
Report Server Mode: Native
Report Service Status: Started
o




___Chapter 9: Turning Data into Information with SQL Server Reporting Services

|
Figure 9-2:
Selecting

a service
account.
|
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5. Click the Web Service URL button to review the Web server configu-
ration and make any desired changes. When you finish, click the
Apply button.

SSRS distributes reports through the use of a Web server. On the screen
shown in Figure 9-3, you may modify the IP address(es) and TCP port
assigned to SSRS. This is especially important if your server fills multiple
roles in your organization because you may have only one server listen-
ing on the default HTTP port (80) for each IP address.

This screen also allows you to choose an SSL certificate to use if you
want to provide HTTPS secure encrypted access to your reports. This
protects the reports from eavesdroppers as they travel across the
network from the server to the client. Your server administrator must
install an SSL certificate on your server before it appears in the SSL
Certificate drop-down menu.

Make note of the URL(s) shown in the Report Server Web Service URLs
section of this window. You should provide these URLs to users who
need to access SSRS.

6. Review the other pages in the Configuration Manager and customize
any settings you want.
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I return to the Configuration Manager later in this chapter when |
discuss Report Manager (see the “Working with Deployed (Published)
Reports” section, later in this chapter). In the meantime, take a few
minutes to familiarize yourself with the other configuration settings
offered in the tool.

7. Click the Exit button to close the Reporting Services Configuration
Manager.

After you’ve set your basic configuration settings with Configuration
Manager, you're ready to begin designing reports for distribution on your
Report Server.

Creating an SSRS Report
with Report Builder

Report Builder allows you to create reports for distribution on an SSRS
server. It provides a graphical interface that allows you to visually design
reports, dropping in data-driven elements as needed. Report Builder allows
you to include tables, images, matrices, lists, and charts in your reports and
to populate those elements with data from your SQL Server database, and a
variety of other data sources.
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Figure 9-4:
Microsoft
Report
Builder.

Installing and starting Report Builder 2.0

With the release of SQL Server 2008, Microsoft planned to introduce a new
stand-alone reporting tool: Report Builder 2.0. Unfortunately, they weren’t
able to get it finished in time to release it with SQL Server 2008. You need to
download and install it separately to take advantage of the enhanced func-
tionality. It’s available for free on the Web at

www.microsoft.com/downloads/details.
aspx?FamilyID=9f783224-9871-4eea-bld5-
£f3140a253db6&displaylang=en

Downloading and installing Report Builder is easy: Just walk through the
wizard and accept all the default options. When you’ve installed Report
Builder, you may start it by choosing SQL Server 2008 Report Builder~
Report Builder 2.0 from the All Programs menu.

Choosing a data source and data set

After you start Report Builder, it opens with a new blank report, ready for
your design, as shown in Figure 9-4. To get started, you first need to configure
a data source using the following process:
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1. With Report Builder open, choose Newr>Dataset from the drop-down
list in the Report Data pane on the left side of the Report Builder
window.

2. Click the New button next to the Data Source field.

Report Builder displays the Data Source Properties dialog box, shown in
Figure 9-5.

Data Source Properties ==l

General
Change name, type, and connection options.
Credentials
Name:

Datasourcel

Use a shared connection or report madel

© Use a connection embedded in my report

Select connection type:

Microsoft SQL Server -

Connection string:

Figure 9-5: (&
The Data
Source Use single ransaction when processing the queries
Properties
dialog box.
|

3. Provide a name for your data source by typing it in the Name text box.

4. Choose the Use a Connection Embedded in My Report radio
button and select the appropriate connection type from the Select
Connection Type drop-down menu.

If you already have a shared data source you would like to use instead,
you may select the Use Shared Data Source Reference option instead.
For SQL Server database connections, choose Microsoft SQL Server from
the Select Connection Type drop-down menu.

Report Builder allows you to pull in data from non-SQL Server data
sources. Some of those include

¢ Oracle databases

* SAP NetWeaver

¢ OLE DB and ODBC data sources
e XML data sources

¢ Hyperion Essbase
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|
Figure 9-6:
The
Connection
Properties
dialog box.
|

5. Click the Build button.

The Connection Properties dialog box for your selected connection
type appears. Figure 9-6 shows the screen for Microsoft SQL Server

connections.
Connection Properties @
Data source:
Microsoft SQL Server (SqiClient) Change
Server name
WVOSTRO - Refresh
Log on to the server
@ Use Windows Authentication
Use SQL Server Authertication
Connect to a database
@) Select or enter a database name:
AdwventureWorksL T -
Aftach a database file:
Advanced
| Test Connection oK Cancel

6. Provide the connection details for your database and click the OK
button to continue.

[ recommend that before you click OK, you first click the Test Connection

button to verify that you have provided correct connection details.

7. Click the OK button to close the Data Source Properties window.

8. Type the SQL query that you want to use for your data source in the

Query text box that appears.

You need to provide a SQL query that produces the data you want

included in your report. If you don’t want to enter the query manually,

you may open an existing query (. sql) file or import a query from
another report using the Import button.

9. Click the OK button to create your dataset.

You return to Report Builder. Note that the dataset you created now
appears as an expandable folder in Report Builder’s Data pane.

/
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Laying out the report

After you’'ve added a data source for your report, you may use the various
items on the Insert Ribbon of Report Builder to add elements to your report.
Report Builder allows you to simply drag and drop elements where you’d like
them to appear.

Adding a text box

You may add static (unchanging) text to your report using the Text Box
control within Report Builder. Here’s the process:

1. Ensure that you’re viewing the Insert menu on the Report Builder
Ribbon, as shown in Figure 9-7.

|
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Rlbbon' Data Regions Report tems. Subreports | Header & Footer
|
2. Click the Text Box icon in the Report Items section of the Insert menu.
3. Drag the text box to the desired spot on your report.
For example, you may want to place the text box in the header or footer
section of your report.
4. Use the mouse to click inside the text box and type the text that you
would like to appear in the report.
NNG/ . .. .
D As with any other document, be sure to save your report periodically to avoid

losing your work. You can save your report by clicking the disk icon in the
upper-left corner of Report Builder.

Adding a chart

Report Builder makes it easy to add a variety of charts to your SSRS reports.
Available chart types include

v Pie charts

v Line graphs

v Column graphs
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v Funnel charts
v Bar graphs
v Area graphs
v Range graphs
v Scatter plots

To add a chart to your report, follow these steps:

1. Click Chart=>Insert Chart on the Ribbon’s Insert menu.

2. With the mouse, select an area on the report where you want to place
your chart.

Report Builder displays the Select Chart Type window, shown in

Figure 9-8.
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3. Select the type of chart you want to include in your report and
click OK.

Report Builder inserts a default chart of the type you selected, as shown
in Figure 9-9.
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4. Choose the data field or fields for your chart and drag them from
the Data pane onto the Drop Data Fields Here area above the sample
chart.

The data fields contain the values to be plotted on your chart.

5. Choose the category field or fields for your chart and drag them from
the Data pane onto the Drop Category Fields Here area above the
sample chart.

The category fields contain the names corresponding to each of the data
fields in your chart.

6. Click the Chart Title text box and enter the title you want to use for
your chart.

Adding a table

Adding a table to your report follows a similar process:

1. Click Table->Insert Table on the Ribbon’s Insert menu.

2. With the mouse, select an area on the report where you would like to
place your chart.

3. Add or delete columns from your table as necessary by right-clicking
the table and selecting the appropriate entries from the pop-up menu.

4. Click each cell in the Header row and type the text you want to
appear in the table header.
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5. Drag the data elements you would like to appear in each column from
the Data pane to the appropriate column in the Data portion of the

table.

You need to fill in only one row of the table. SSRS automatically creates
the necessary number of rows when it generates your report.

Figure 9-10 shows a completed report in the Preview view of Report Builder.
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Publishing the report

After you’ve completed your report layout and previewed it to ensure that
it meets with your satisfaction, you can publish the report to your Report
Server for other users to view.

Here’s how to publish a report to an SSRS server:
1. Click the round report icon in the upper-left corner of the screen to
activate the Report Builder pull-down menu and then choose Save As.
2. Type a name for the report in the Name text box.

3. Confirm the deployment settings and click Save.

Confirm that the Report Server URL appears in the Look In field at the
top of the Save As Report dialog box.

11
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If you attempt to publish a report and receive an error message about
improper permissions, verify that your account has membership in the
Publisher role. For more information, see “Configuring report security” later in
this chapter.

After you publish your report, it’s available to users accessing the reporting
server with the appropriate permissions.

Working with Deployed
(Published) Reports

Figure 9-11:
The SSRS
Web
Service
menu.
|

You may access and modify your deployed reports using the URLs you pro-
vided in the Reporting Services Configuration Manager. In this section, I
describe the basic concepts behind the SSRS Web interfaces.

Viewing reports

The simplest way to view SSRS reports is to use the Web Services URL you
were provided in the Reporting Services Configuration Manager. Simply open
a Web browser and type that URL into the address bar. SSRS prompts you for
your username and password and then displays a report menu similar to the
one shown in Figure 9-11.

vostro/ReportServer - /

Saturday, December 08, 2007 3:55 PM 21063 sales

Microsoft SQL Server Reporting Services Version 10.0.1075.23

Click the name of the report you want to view, and SSRS generates the report
dynamically and displays it in your browser window, as shown in Figure 9-12.
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Figure 9-12:
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Configuring report security

You need to set up permissions for the users you want to be able to admin-
ister and view SSRS reports. To do this, you first need to enable SSRS Report
Manager and then use it to assign SSRS roles to the appropriate users and

groups.

Setting up Report Manager

Report Manager is a Web application that allows you to modify SSRS settings
through your Web browser. Before you can access Report Manager, you need
to enable it using the following process:

N S U1 AW N -

. Click the Report Manager URL page.
. Click the Advanced button.
. Click the Add button under Multiple Identities for Report Manager.
. Click OK to accept the default options.
. Click OK to close the Advanced Multiple Web Site Configuration.

. Open Reporting Services Configuration Manager.

. Click the Apply button to start Report Manager.

Note the URL displayed in Configuration Manager. This is the URL
required to access Report Manager.
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Configuring site roles
Site-wide roles allow you to assign users permission to access Report
Manager. By default, all users in the BUILTIN\Administrators local adminis-
trators group are Report Manager System Administrators. Here’s how you
can add additional users:

1. Using Internet Explorer, open the URL for Report Manager.

You specified this URL when starting Report Manager in the previous
section.

. Click the Site Settings link.
. Click the Security page.
. Click the New Role Assignment button.

G e wN

. Type the name of the user or group in the Group or User Name
text box.

6. Select the box or boxes corresponding to any roles you would like to
assign to the user or group.

The roles you may choose from are

¢ System Administrator: These role members may perform all Report
Manager administrative activities.

e System User: These role members may view system properties and
shared schedules only.

7. Click the OK button to finish.

Setting up content roles

In addition to creating site roles to access Report Manager, you may also
create content roles that grant users varying levels of permission over SSRS
content. You may create these permissions at the Home level, where they
inherit downward to all newly created reports. Alternatively, you may set role
membership for subfolders or individual items.

To set content roles at the Home folder level, follow this process:

1. Click the Home link in Report Manager.
2. Click the Properties tab.
3. Click the New Role Assignment button.

You see the New Role Assignment screen, shown in Figure 9-13.
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4. Type the name of the user or group in the Group or User Name
text box.

5. Select the box or boxes corresponding to any role you would like to
assign to the user or group.

The roles you may choose from are as follows:

¢ Browser: Role members may view and subscribe to reports and
folders.

¢ Content Manager: Role members may manage folders, reports,
and resources.

¢ My Reports: Role members may publish reports and manage

folders, reports, and resources within their own My Reports
folder.

¢ Publisher: Role members may publish and update reports on the
Report Server.

¢ Report Builder: Role members may view report definitions.
6. Click the OK button to finish.
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