Bonus Chapter 5
Creating Calculator Programs

In This Chapter
Creating, saving, and editing calculator programs on the calculator
Creating, saving, and editing calculator programs on the computer
Downloading and installing the TI-Graph Link software
Transferring created programs between a computer and a calculator
Executing programs on the calculator

Deleting programs from the calculator’s memory

rle programming language used by the calculator is similar to
the Basic programming language. It uses the standard com-
mands (such as the “If ..., then ..., else ...” command) that are
familiar to anyone who has ever written a program. And, of course,
it also makes use of commands that are unique to the calculator
(such as ClrHome, which clears the Home screen). This chapter
explains the basics of creating a calculator program. (Chapter B6
describes the Basic programming commands used by the calcula-
tor; Chapter B7 discusses programming commands that are unique
to the calculator.)

Creating Calculator Programs
on the Calculator

It is much easier to create a calculator program on a computer
than it is to create it on the calculator. Then again, there may be
times when a computer is not handy so you have no recourse but
to create the program on the calculator. This section tells you how
to create, save, and edit a program on the calculator. Later in this
chapter, I tell you how to create a calculator program on a PC.
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Creating and saving a program
on the calculator

These are the basic steps for creating a program on the calculator:

1. Press [PRGM]D ] J[ENTER] to create a new program using the
Program editor.

This is illustrated in the first picture in Figure B5-1.
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Figure B5-1: The steps for creating a program.

2. Give your program a name and then press [ENTER].

The name of your program can consist of one to eight char-
acters that must be letters, numbers, or the Greek letter 6.
The first character in the name must be a letter or 6, as in
the second picture in Figure B5-1.

The [ after Name = indicates that the calculator is in Alpha
mode. In this mode, when you press a key you enter the
green letter above that key. To enter a number, press
to take the calculator out of Alpha mode and then enter the
number. To enter a letter after entering a number, you must
press to put the calculator back in Alpha mode.

When you press after naming your program, the cal-
culator puts you in the Program editor, as in the third pic-
ture in Figure B5-1. The program appearing in this picture is
entered in the next step.

3. Enter your program in the Program editor.

Your program consists of a series of commands, each of
which must be preceded by a colon, as shown in the third
picture in Figure B5-1. After entering a command, press
so the calculator supplies the colon preceding the
next command you enter. When you finish writing your
final command, press and ignore the colon that is
waiting for a command to be entered.
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An example of entering a program appears in the third pic-
ture in Figure B5-1. The program in this picture writes HI
on the Home screen. The ClrHome command is entered
into the program by pressing [PRGM]>][8])[ENTER], and Disp is
entered by pressing [PRGM]>](3][ENTER].

The program commands supplied by the calculator, such
as ClrHome and Disp, are explained in Chapters B6 and B7.

4. Press when you’re finished writing your program.

This saves your program in the memory of the calculator
and returns you to the Home screen. The name under
which the program is stored in the calculator is the same
name you gave the program in Step 2.

Editing a program on the calculator

To edit a program stored on the calculator, follow these steps:

1. Press [PRGM]»] and press the number of the program you
want to edit.

2. Edit the program.

Editing is explained in Chapter 1. Pressing erases the
line containing the cursor.

3. Press to save the program and return to the
Home screen.

P After creating a program on the calculator, you can transfer it to a
computer and edit it on the computer. To edit the program on a
computer you need the free TI-Graph Link software. Downloading,
installing, and using this software is explained in the next section.

Creating a Calculator Program
on the Computer

You can create a program on the computer and then transfer it to
your calculator (or vice versa). To do so, you need the TI Connect
software, the TI-Graph Link software, and a TI-Graph Link cable

to connect your calculator to your computer. The software is free;
the TI-Graph Link cable, if it didn’t come with your calculator,

can be purchased at the Texas Instruments online store at
www.education.ti.com.
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Downloading and installing
Tl-Graph Link software

The TI-Graph Link software is in the TI Connectivity directory on
the TI Resource CD that most likely came with your calculator. It
can also be downloaded from Texas Instruments’ Web site. If Tl
hasn’t revised its Web site since this book was written, then to
download the software:

1. Go to Texas Instruments’ Web site that is located at
www.education.ti.com.

2. Open the “Know what you’re looking for?” drop-down
menu and click on TI Connect.

3. Click on downloads in the column on the left of the
screen.

. Click on “Are you looking for TI-GRAPH LINK Software?”
. Click on Windows, Macintosh, or MS-DOS.
. Click on the type of calculator you have.

. Click on the language you want.

QW 1 & U1

. Follow the directions given during the downloading
process. Make a note of the directory in which you save
the download file.

To install TI-Graph Link, double-click on the downloaded TI-Graph
Link file (t183pUSA, for example) you saved on your computer or
double-click on the file on the TI Resource CD. Then follow the
directions given by the installation program you just launched.

Using TI-Graph Link to create and
save a calculator program

After installing TI Connect and TI-Graph Link, as explained earlier
in this chapter, you can create a program using TI-Graph Link, as
follows:

1. Start the TI Connect software.

2. Click the Program Editors button at the top of the screen.

You see a screen containing pictures of the various TI
calculators.
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At the bottom of this screen you see a message that says the
TI-Graph Link software does not support the USB TI-Graph
Link cable. This means that USB cable users can still use
TI-Graph Link to write their program, but they must use

TI Connect, and not TI-Graph Link, to transfer the program
to the calculator. This issue is fully addressed in the follow-
ing steps.

. Click on the appropriate calculator.

On the left of the screen you see a picture of the calculator
keyboard, and on the right you see the Program editor.

. If necessary, clear the Program editor.

If a program appears in the Program editor, click
File>)New=>OK to clear the Program editor.

. In the box following Name, enter a name for your

program.

The name of your program can consist of one to eight char-
acters that must be letters, numbers, or the Greek letter 6.
The first character in the name must be a letter or 6.

Don’t press the Enter key on the computer after entering
the name of the program. If you do, the software attempts
to send the not-yet-completed program to your calculator.
If you have a USB cable or a serial cable that isn’t con-
nected to the computer, you get an error message.

. If desired, in the box following Comment, enter a

comment.

Use the mouse or Tab key to get from the Name box to the
Comment box (see the above warning). Because an eight
letter name for your program usually doesn’t tell you
much, writing a comment really helps when at a much later
date you find yourself wondering what the program does.

Don’t press the Enter key on the computer after entering
the comment. See the previous warning for details.

. Enter your program.

Use the mouse or Tab key to get from the Comment box to
the large box where the program is entered. (Also note the
warning that follows Step 5 in this procedure.)

Your program consists of a series of commands. In TI-Graph
Link, commands are separated by pressing the Enter key
after entering a command, or by placing a colon between
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two commands appearing on the same line of the Program
editor. If the Enter key is pressed after each command, the
result should look like the third picture in Figure B5-1 with-
out the colons. The program in this picture writes HI on
the Home screen. (Explicit directions for entering the pro-
gram in Figure B5-1 appear in Step 3 in the previous section
“Creating and Saving a Program on the Calculator.”)

The calculator keyboard to the left of the Program editor
is fully functional. Click on the keys using the mouse. For
example, to enter 1t in your program, click and then

click [7].

The program commands supplied by the calculator, such
as ClrHome and Disp, are explained in Chapters B6 and B7.

When writing a program using the TI-Graph Link software,
if you precede each command with a colon — as you do
when writing a program on the calculator — no harm will
be done. The calculator simply interprets each colon as a
command that does nothing.

8. Save your program on the computer.

To do so, click Filer>Save As. Select the directory in which
you want to save the program, and then click OK. The pro-
gram is saved under the name you gave it in Step 4.

Editing a program saved
on a computer

After installing TI Connect and TI-Graph Link (as explained earlier
in this chapter), to edit a program using TI-Graph Link, follow
these steps:

1. If necessary, place your program in the Program editor.

If the Program editor (TI-Graph Link) isn’t currently run-
ning on your computer, follow the first three steps in the
section, “Using TI-Graph Link to create and save a calcula-
tor program.”

If the Program is running on your computer but your pro-
gram does not appear in this editor, click File>Open.
Select the directory containing your program, click on your
program, and then click OK to enter the program in the
Program editor.
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2. Edit your program.

You edit your program the same way you would edit your
work in a word processor. The Edit menu in TI-Graph Link
contains the typical editing commands, such as Undo, Cut,
Copy, Paste, and so on.

3. When you’re finished editing, click File=>Save to replace
the previous edition of your program with the revised
edition.

Transferring a program created in
T1-Graph Link to your calculator

To transfer a program from a computer to a calculator, the com-
puter and the calculator must be connected using a TI-Graph Link
cable.

If the computer and calculator are connected with a serial TI-Graph
Link cable, then after creating your program using the TI-Graph Link
software, as explained earlier in this chapter, you can transfer your
program to the calculator by clicking on the Send to RAM button
in the upper right hand corner of the TI-Graph Link Program editor.
If the computer and calculator are connected with a USB cable, then
clicking the Send to RAM button results in a transmission error
message because the TI-Graph Link software does not support the
USB cable. Creating a program using TI-Graph Link is explained
earlier in this chapter.

Independent of the type (serial or USB) of TI-Graph Link cable used
to connect the computer and calculator, you can always use the TI
Device Explorer program housed in the TI Connect software to
transfer your program to your calculator.

Executing a Calculator Program

After creating your program and saving it on the calculator, you
can run the program on the calculator by performing the following
steps:

1. Press [PRGM] to enter the Program Execute menu and
use [~] to move the indicator to your program.

This is illustrated in the first picture in Figure B5-2.
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2. Press [ENTER] to place the program on the Home screen.
This is illustrated in the second picture in Figure B5-2.
3. Press [ENTER] to execute the program.

This operation is shown in the third picture in Figure B5-2.
The program being executed in this figure is the program in
the third picture in Figure B5-1. When the calculator is fin-
ished executing the program, it writes Done on the Home

screen.
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Figure B5-2: Executing a program.

Deleting a Program from
the Calculator

To delete a program from the calculator:

1. Press to access the Memory menu.
2. Press [2] to access the Mem Mgt/Del menu.

3. Press [7] to access the Program files stored in the
calculator.

4. If necessary, repeatedly press [~] to move the indicator to
the program you want to delete.

5. Press to delete the program.

You are asked whether you really want to delete this pro-
gram. Press [2] if you want it deleted or press [1] if you've
changed your mind.

6. Press MODE] to exit this menu and return to the Home
screen.



