Bonus Chapter 1
Secrets of Rendering
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Customizing render options, such as playback quality
Rendering a clip or sequence

Reducing rendering times

Managing renders on your hard drive

Rendering audio

M ost people working in the video industry believe that the Gods of Digital
Video invented rendering to punish mortal editors for the sins of their
past lives. Why? Rendering occurs when Final Cut Pro calculates how to dis-
play a video clip or play an audio clip after you add a new effect, filter, text
selection, or other element to the clip (an effect or filter that wasn’t there
originally). This process doesn’t happen instantly after you’ve made your
changes, though; you often have to wait while your Mac does all sorts of
calculations to determine how a video clip should look or how an audio clip
should sound. If you're doing lots of experimenting — for instance, trying to
find the best settings for a blur filter or the length of a cross-fade or some other
effect — you can quickly get tired of having to render your clips every time
you make a change. What’s more, those renders can take up valuable space
on your hard drive, because Final Cut Pro creates a separate video or audio
file for each rendering and stores it on your drive (each of these rendered
files is called a render cache file).

Fortunately, over the past couple of years, Final Cut Pro has been steadily
reducing editors’ need to render clips, and Final Cut Pro HD represents the
pinnacle of those antirendering efforts. If your Mac is fast enough, Final Cut
can do on-the-fly rendering, which automatically renders a clip in its RAM
memory at full quality instantly. But if a clip or a sequence is doing lots of
fancy stuff — for instance, if a clip has more than a couple of effects applied
to it, or if a Timeline sequence involves playing a number of clips at the same
time (as in a montage or picture-in-picture scenario) — even the fastest Mac
can’t do real-time rendering.
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However, a fast Mac can, in real-time, do rough approximations of what a
render should look like. These approximations are rendered quickly because
not every frame of the clip is calculated, only as many frames as are needed
for real-time playback. These approximations may not look as sharp as truly
rendered video, and playback may be jittery, but they’'re good enough for
quickly doing experiments with clips (as when you endlessly tweak the set-
tings for an effect applied to a clip or when you adjust the motion path of a
moving clip until it’s just right). All these real-time approximations are done
by Final Cut behind the scenes, and editors need to genuinely render clips
the old-fashioned way only when they’re ready to output their project to
videotape or QuickTime digital files.

Understanding Rendering Status

Some clips don’t need rendering at all (like raw DV video from your camera
that you haven’t enhanced with a filter or other effect). How can you know if
your clip needs rendering? Handily, Final Cut shows you the rendering status
of your clips in the Timeline window. As shown in Figure BC1-1, the Timeline
contains two Render Status bars, just above the timecode ruler. The upper
status bar is for video, and the lower one shows audio. You may have to look
closely, because the Render Status bars are thin and located quite close to
one another. The colors of these bars indicate the clips on the Timeline that
require rendering.

The colors of these status bars have the following meanings:

v Red: The clip needs to be rendered. Sorry — hang out and relax.

v Dark gray: No rendering is necessary. This color is for clips whose clip
and sequence settings match and for clips that don’t have any effects.

v Green: This color is for effects that don’t need rendering and can be
played in real-time. You see this color if you're lucky enough to be using
Final Cut Pro in any real-time configuration that’s available. (See the side-
bar “Real-time or not?” later in this chapter.) Still, the playback quality of
the rendered video or audio may be slightly reduced, but that’s usually
okay for preview purposes. When you finally output your project to tape
or digital files, the media will be fully rendered at top quality.

v Dark green: You see this color if you're using an effect that can be played
back in real-time and is available for output to video at full quality without
rendering. You see dark green status bars more often if you have a fast
computer.

v Yellow: Good news: Yellow indicates that Final Cut Pro can show a real-
time approximation of the final effect during playback. Bad news: To get
the real final effect, you still need to render the material. That’s life!

v Light gray: The clip has already been rendered! Don’t worry about it,
dude. Go party!
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v Blue: This color indicates that some real-time effects are unsupported
and are likely to drop frames.

v Orange: When you're using Unlimited RT, an orange Render Status bar
takes the place of a red bar and indicates that Unlimited RT can play the
clip, although you’re likely to encounter dropped frames.
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You may encounter two other indicators that specify that you need to render.
The first one is a big white Unrendered message over a blue background in the
Viewer or the Canvas window. The message fills these windows and is hard to
miss. The second indicator is a steady beep that you may hear. This beeping
indicates that the audio material can’t be played in real-time and requires
rendering.

Playing Back a Sequence
with Real-Time Options

Final Cut Pro 4 introduced new RT, or real-time, options for sequences

that play back in the Timeline. Essentially, these RT functions allow you to
watch complex sequences that you couldn’t watch before without rendering.
Unlimited RT reduces the time it takes to preview a sequence, even if you're
working on an older machine. You can access the RT options from the RT pop-
up menu that appears in the upper-left corner of the Timeline window. You
can also access these options from the Playback Control tab in the Systems
Settings window by choosing Final Cut Pro HDm>System Settingse>Playback
Control (see Figure BC1-2).

v Unlimited RT: If you want to quickly preview any changes or effects that
you've added to a sequence, and you don’t care whether a few frames are
dropped, you should use the Unlimited RT setting. Unlimited RT tells Final
Cut Pro to play back as much as possible in the Timeline without render-
ing, even if it means exceeding the real-time capabilities of your computer.
The result is usually dropped frames or stuttering playback, but that’s
often fine when you're just trying to set up things quickly. Previously, you
had to render out memory-intensive portions of the Timeline before you
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could check the changes you had made. With Unlimited RT, you can try
out several more filters and effects in the time it once took to render a
single sequence. Unlimited RT can work well without additional modifica-
tions, but it really starts to show its stuff when it’s combined with other
RT settings.

v~ Safe RT: If you don’t want real-time previews of renders that may drop
frames (resulting in stuttering playback), Safe RT is your best choice.
Safe RT turns off Unlimited RT and ensures that Final Cut tries to gener-
ate previews of only those parts of a sequence that can play back at a
normal, smooth frame rate.

v Play Base Layer Only: This option ignores effects that cannot be rendered
in real-time. Also, if a portion of your sequence with multiple layers of
composited video tracks causes difficulty, only the bottom layer plays
back. Personally, I've never used this option — I just go for either Safe or
Unlimited RT — but it’s here if you want it!

v+ Playback Video Quality: Regardless of the RT mode you’'ve selected,
you can set the quality level used for real-time previews of effects. The
higher the quality, the more “thinking” your Mac has to do on the fly,
and the fewer effects it can preview without dropping frames. You have
the following quality choices:

¢ High: Using a high playback-quality setting ensures that the quality
of your video playback never suffers. In exchange for not dropping
frames, you decrease the number of effects that can be viewed in
real-time. For many simpler projects (especially if you're using a fast
Mac), this option works great. Many times, the High setting can be
accessed only through the Playback Control tab in the User Settings
window (choose Final Cut Pro=>User Settings=Playback Control).

Medium: If you need a compromise between high- and low-quality
playback, the Medium setting works fine. Of course, the trick with
any real-time option is to achieve the right balance. How many
effects are you using? Would a decrease in playback quality elimi-
nate a few dropped frames? Try using this setting together with
Unlimited RT if your Mac can’t keep up with the real-time demands.

* Low: A low playback quality can seriously increase the effectiveness
of real-time previews. For instance, if you have a large number of
effects and you don’t mind sacrificing playback quality, you should
select Unlimited RT and low playback quality from the RT pop-up
menu. You may not get the quality you want, but it certainly helps
you preview complex sequences.

Remember, though: Eventually, even the fastest machines need to render a
sequence, particularly if several complex effects are being used. Also, render-
ing can decrease the amount of memory used by Final Cut Pro, which makes
it easier to run other applications in the background or to free other resources.



Bonus Chapter 1: Secrets of Rendering

Figure BC1-2:
The RT pop-
up menu in
the Timeline

and playback |;

control
options in the
System
Settings
window.
|

s

System Settings

ETTa o Scraich Disks . Memory & Cache Pybck Convol \ External Edtos \ Efect Handing |

Playback
RT: [ Unlimited |4

Video Quality:

Medium
Pulldown Pattern:| | oy iG]

i
1 Play Base Layer Only (if render needed)

Record

Full Quality e

To increase the render speed of a sequence even more, adjust the Render and
Playback settings on the Render Control tab of the User Preferences window.
To access these options, choose Final Cut Pro>User Preferencesr>Render
Control from the menu bar, and check the items that you want to include in
your Render or Playback modes (Filters, Frame Blending for Speed, Motion
Blur, Frame Rate, and Resolution).

Rendering a Clip or Sequence

When you encounter any kind of rendering indicator, you often should stop
and render before you proceed, unless you chose to use the Unlimited RT
function that I mention in the preceding section. Within Final Cut Pro, you
can render your material in many ways. Some of the ways to render your
material are as follows:

1+ Rendering a clip or an effect: Select the clip or the transition, and
choose Sequencer>Render Selection=>Both from the menu bar. You can
also choose whether to render only the video or audio portion of a clip,
although rendering both is the best way to ensure consistent playback.

+* Rendering an entire sequence: Open the sequence by double-clicking it
in the Browser and then choosing Sequence=>Render All=>Both.

1 Rendering a portion of a sequence: Select one or more clips or effects
on the Timeline, or use the [ and O keys to set an In and Out point, respec-
tively, in the sequence. Then choose Sequence=>Render Selection=>Both.
Remember that you can set In and Out points in the Viewer, Timeline, and
Canvas windows.

+ Batch-rendering a sequence: In the Browser, select the sequences you
want to render, and choose Sequencer>Render All=>Both.
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A progress bar, as shown in Figure BC1-3, indicates the percentage of render-
ing that has been finished, along with an estimated time until completion.

Figure BC1-3:
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You can cancel rendering at any time by pressing Esc or 38+. (that is, 38 plus
the period key).

® If Final Cut doesn’t render your selection, you may need to give it a bit more
guidance. Check the color of the line that appears above your clip on the
Timeline’s Render Status bar. (It’s probably green or orange.) Then choose
Sequencer>Render Selection or Sequence>Render All, and make sure that the
same color is checked on the Render menu (by doing this, you're telling Final
Cut not to ignore clips that fall into certain render classifications). Now try to
render your selection again.

Real-time or not?

Among the latest and greatest features in Final
Cut Pro are the real-time effects. Given the right
equipment, you don’t need to render! To take
advantage of these software-based, real-time
effects, you need a 500 MHz (or faster) Power
Mac G4 or PowerBook G4 with at least 256MB
of RAM. No extra hardware is needed, although
it doesn't hurt. Dual-processor machines can
also speed these real-time effects.

Depending on your computer's speed, you may
see a variety of transitions and effects in real-
time. If you click the Effects tab in the Browser
and look inthe Transitions and Effects
folders, you can see certain items listed in bold
text; these effects are the ones that can work in
real-time on your computer.

If you're using the DV video format, you can at
least see the following in real-time:

v+ Cross Dissolve

v~ Iris transitions: Diamond, Oval, Point, Rectan-
gle, and Star

v~ Wipe transitions: Center, Clock, Edge, Inset,
and V

v~ Color Corrector 3-way filter

+~ Real-time motion effects: Opacity, Scale,
Center, Offset, Crop, and Aspect

If you're working with video other than DV, you
can look up the Apple-approved third-party video
capture cards. Many of these cards, such as the
Aurora Igniter, feature real-time effects when
you're working with high-end video.

The real-time features are under constant devel-
opment at Apple. For the latest information, visit
the Final Cut Pro site, at www.apple.com/
finalcutpro.
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Final Cut Pro provides a handy way to quickly get a rough preview of your
effect before you begin rendering. On the Timeline or in the Viewer, drag the
playhead across the clip with the effect, and Final Cut Pro attempts to update
the effect as fast as your computer allows. Drag the playhead slowly enough
so that Final Cut Pro can keep up, and you get a fairly good idea of how your
final rendered effect looks.

Planning Efficient Rendering

A\

Rendering takes time, pure and simple. Every time you make a change to an
effect or a transition, you probably have to re-render unless you're using a suit-
able Unlimited RT setting. The time that rendering consumes can be significant
while a producer breathes down the back of your neck, not to mention the
simple aggravation factor.

You can do a few things to minimize the time you need to devote to rendering,
especially if you're working with effect-intensive sequences. Follow these
simple suggestions to manage your rendering times:

1 Make your rough cut first and then add effects. The rule here is to
plan ahead. If you can, work only with sequences with cuts. After you
refine your rough cut to an acceptable look, work on adding effects and
transitions.

+~ Disable updates to avoid unnecessary renders. Another trick you can
use is to disable any updates in the Viewer and Canvas windows by press-
ing the Caps Lock key. This way, you can toggle the key on and off when
you want to just edit or lay out your effects and when you later decide
that you’re ready to render. Locking down Caps Lock avoids the time that
Final Cut Pro must take to update effect changes. This delay can often
slow your work.

v Start by using a low-quality setting. You can start out by choosing a low
or medium setting from the RT pop-up menu, which is in the upper-left
corner of the Timeline window. Only when you’re satisfied with the final
timing should you switch the quality back to High and render the final
sequence for output.

v Do test renders. Try test-rendering short sections of the Timeline before
committing to an effect. For instance, if you add a sepia tint to a clip that’s
3 minutes long, and it doesn’t display in real-time, render only a portion
of the 3-minute clip, decide on the settings, and then move on without
waiting to render the entire clip. Later, at the end of the day, you can
render the entire 3-minute clip.

/
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If you ever drop a clip from the Browser into the Timeline, and a red render
line appears on the status bar (see the section “Understanding Rendering
Status,” earlier in this chapter), check to see whether a mismatch exists
between the capture settings of the clip and the settings of the sequence
preset. If a clip without an effect creates a red render line, this mismatch is
most likely the culprit.

Managing Renders on Your Hard Drive

gMBER
S

Whenever you render in Final Cut Pro, a render cache file is generated. This
render file is what Final Cut Pro plays during the effect that was rendered. For
instance, imagine a dissolve between two clips. After the dissolve is rendered,
the render file that’s created from the two clips fading into one another plays
when you play through the dissolve. While playing around the dissolve, how-
ever, the respective media files for the clips (not the render file) are used for
playback.

Rendering can take time, and in certain projects you may end up with hun-
dreds, if not thousands, of render cache files. You must, therefore, manage
your render files efficiently. | explain how to do this in this section.

Setting storage for your render files

The first step in managing your render files is to set a proper location in which
to store them. You do this task on the Scratch Disks tab, which I discuss in
Chapter 2. After you set the location, Final Cut Pro organizes the files for you,
which [ explain in the next section. Note that if you don’t set a location, Final
Cut Pro defaults to storing your render files on your main system drive. Follow
these steps to set a location for storing your render files:

1. Choose Final Cut Pro HD=System Settings from the menu bar.

2. Click the Scratch Disks tab in the System Settings window (see
Figure BC1-4).

3. Make sure that the Video Render and Audio Render check boxes in
the top row of buttons are selected.

The Video Capture check box should also be selected if you're setting
the scratch disk for your video captures.

4. Click the Set button in the top row.
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Figure BC1-4:
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Final Cut Pro enables you to set numerous drives as your capture and
render scratch disks. Here, I'm just using the top row of buttons to select
just one drive. If you have more than one drive that you want to assign
as your capture or render scratch disk, click the relevant buttons in the
subsequent rows.

A dialog box appears that shows your drives.
5. In the dialog box, select a drive, and click Choose.
6. Click OK on the Scratch Disks tab when you’re done.

Final Cut Pro now uses the drive you selected to store your render files.
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Locating your render files

What happens after you specify a location to store your render files? Final
Cut Pro first creates a Final Cut Pro Documents subfolder in the Documents
folder, which is located on your scratch disk. This Final Cut Pro Documents
folder has subfolders for captured media, render files, and cache files for
waveforms and thumbnails. In the Render Files folder, Final Cut Pro creates
a subfolder for each of your projects by name and stores all the render files
for that project in the relevant folder. Figure BC1-5 shows how Final Cut Pro
organizes the render files.

The labels on these render files may at first seem confusing, but they’re easy to
decode. For instance, consider the render file Final Sequenc-FIN-0000002.
The name tells you that this render file is from a sequence named Final
Sequence and that this is the second render file from that sequence. The
code FIN stands for the render quality that was used to create this render,
which in this case is your final, highest resolution.
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Dump those old renders?

What happens to renders when they grow old? No, they aren’t put out to a
peaceful pasture.

Imagine this scenario: You render a 1-minute clip after you apply a blur and
sepia tint effect to it. This action creates a render cache file for the 1-minute
clip. Because the DV video format uses 3.6MB per second, this file measures
approximately 216MB.

Later, you decide that you need to reduce the blur effect on your clip, so you
go ahead and make the change. Of course, you have to rerender your effect.
This action creates another render cache file, which is approximately 216MB
as well. Now you have two large render cache files taking up space on your
scratch disk, one of which isn’t being used. And of course, Final Cut Pro has
to save the first one for a while, in case you decide that you like the original
render better and you use the Undo command (38+Z) a few times to go back
to your first render. Hmm. All this stuff can get complicated.

Fear not! It’s not as bad as it sounds. Final Cut Pro holds on to an old render
cache file until it drops off the undo queue. So if you chose Final Cut Pro=>
User Preferences and set your undo levels to 10 on the General tab, you can go
back 10 steps by using the Undo command (88+Z). Final Cut Pro then holds on
to your first render cache file until the second render is the 11th step in the
undo queue. You can do at least 10 undoable actions after rendering the first
file, but when the second render action becomes the 11th action, Final Cut Pro
automatically deletes the old render cache file.



Bonus Chapter 1: Secrets of Rendering

WMBER
‘x&
&

It sounds like you don’t need to worry about deleting your old render cache
files. However, in some cases, your projects may get quite large, and you may
spread your render files out across so many disks and folders that you simply
lose track of them. This can happen despite the fact that Final Cut Pro is very
good at keeping your files organized. In addition, you may have created render
files at various render qualities, and you now may want to delete all except the
ones that were done at the highest quality setting. In many cases, you may
have rendered many times at the same render quality. This process can get
pretty messy and disorganized.

In such a case, you could delete all render files and then rerender your entire
sequence or sequences in the project. This technique may take time, but it
cleans up the render cache file mess.

[ would be remiss, however, if I didn’t mention that Apple engineers strongly
recommend against this approach; they state in no uncertain terms that you
should avoid manually deleting your old render cache files. In other words,
don’t just go through your render folders on the various drives and toss out
all the render files. This action may cause some issues later, when you reopen
the project. Final Cut Pro may still look for the old render files and attempt to
link to them.

The proper way to delete old render cache files is to use the Render Manager,
so keep reading.

Using the Render Manager

Apple engineers designed the Render Manager to help you do two key things:
delete render files from old or deleted projects; and delete files that are no
longer needed, such as the ones that were created at a lower quality setting.

When you use the Render Manager, you see files from projects that are open,
as well as the ones that aren’t open. You can use the modification dates on
these files to determine what you want to save and what you want to delete.

To use the Render Manager, follow these steps:

1. Choose Tools=>Render Manager from the menu bar.

The Render Manager window appears (see Figure BC1-6). In the Render
Manager window, the files are sorted into folders by project and sequence
name. The first main folder is the project folder, and the subfolders rep-
resent the sequences.

2. Click in the Remove column next to a file to add a check mark to the
file you want to remove.

11
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3. Click the OK button.

All the checked render files are removed. Bear in mind that files
NG removed via the Render Manager cannot be restored.
!
S
S Files removed by using the Render Manager cannot be restored by pressing
8+Z to undo the action.

A Word about Audio Rendering

Final Cut Pro can play back about eight audio tracks in real-time. However, as
you add audio effects and transitions, the track costs add up, and you can’t
play as many tracks in real -time. Again, the trick is to render audio often.

To render individual audio clips with effects applied to them, select the audio
clip, and choose Sequencer>Render Only=>Mixdown from the menu bar. You
can also mark In and Out points (by pressing the I and O keys) in the Timeline
and then choose Sequence~>Render Only=>Mixdown to render just the audio
items that are between the In and Out points.



