Bonus Chapter 4
Getting More Graphic

In This Chapter
Curving and connecting
Applying cool bitmap filtering
Using lively layering
Animating text
Applying thrilling 3-D effects

From shapes and curves to animating text, from filtering bitmaps to mind-
blowing 3-D, OpenOffice.org Draw has it all, as you can see in this chap-

ter. It’s an easy-to-use yet full-featured draw program that can make an artist

out of anyone — and maybe a Picasso out of an artist.

Angling Those Curves

The Curves feature in Draw allows you to create all kinds of professional-

looking art with incredible ease. Whether you want to draw cartoons (for

example, the cartoon elephant shown later in Figure 3) or more elaborate,
real-life art, the Curve feature can fulfill your needs.

Long-click the Curves icon on the Main toolbar to view the four curve icons
and four polygon icons on the draggable toolbar. The curve icons are Curve,
Curve-filled, Freeform Line, and Freeform-Line—filled. Curves can be created
from any of these icons.

To create a simple curve, click the Curve icon, and click and drag a short dis-
tance in the Draw document to define the first endpoint and arc of the curve.
Then release the mouse button and move the mouse to define the endpoint.
Now double-click, and your curve is created. Don’t worry if it’s not exactly
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the right size or orientation — or even the right curve. Just get it close, and
then you can resize it, flip it, rotate it, and duplicate it as well as group curves
together. Or, you can change the curve by clicking the Edit Points icon on the
Object toolbar.

To create a curve that loops around, click the Curve icon and then click and
drag a short distance in the Draw document to define the first endpoint and
arc of the curve. Then release the mouse button and move the mouse to
define the endpoint. Now click and drag the mouse to generate a control line
with which you can adjust the curve that you just created, and then release
the mouse button. The control line turns into a new curve. Move the mouse
so that the new curve curls over the first curve. Then double-click to com-
plete the curlicue.

Editing Curves and Polygons

3

The Edit Points feature is a veritable powerhouse for creating art. It is not only
used for simple curves but also for polygons. And because you can turn just
about anything into either a curve or a polygon by choosing Modify=>Convert,
this feature is fairly universal. For example, you can use it to create the ele-
phant that’s shown later in Figure 3. Use rough shapes to outline the art, as
shown in Figure 1. Merge the shapes, and then apply edit points to refine the
art, as shown in Figure 2. Then add a few finishing touches to create the picture
that’s shown in Figure 3. Using curves, shapes, and edit points is a great way to
quickly create nice work.

To use edit points, perform the following steps:

1. Select the object that contains points that you want to edit.

This object can be a curve or a polygon. A complex merged shape, such
as the one shown in Figure 2, qualifies as a polygon.

¢ Pulling points on polygons produces straight lines.

¢ Pulling points on curves creates curves along with control lines
and control points to refine the curve.

To apply edit points to a shape, choose Modify=>Convert=>To Curve or
Modify=>Convert=>To Polygon. You can change a curve into a polygon if
you want to straighten some of it, or you can pull straight lines from its
points.

2. Click the Edit Points icon on the Object toolbar. This is the first icon
on the left.

The Object toolbar changes to the Edit Points toolbar, which consists of
such icons as Move Points and Insert Points.

The handles on your selected object change from green to blue. Draw
calls these handles data points.
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If the Edit Points icons do not appear on the Object toolbar, your
selected object is not in the proper format. To correct this, choose
Modify=>Convert=>To Curve, and then repeat Step 2.
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3. Edit your curves and polygons in the following ways:

e To reshape your curve or polygon, pull a data point. Pulling a data
point on a polygon creates straight lines between points. Pulling a
data point on a curve reshapes your curve.

¢ To modify your curve with greater precision, click a data point of a
curve. One or two control points and control lines appear.
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Figure 3:
Adding a
few extra
details
creates your
finished
drawing.
|
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Control points are attached to control lines, which emerge from the
handle that you select. Click and drag on a control point. Moving

a control point changes the shape of the curve. Then, when your
curve is just the way you want it, deselect your control point by
clicking anywhere in the draw document or by clicking another
data point. Your control point(s) and control line(s) then vanish.
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Sometimes a control point may look like a data point. If you are not sure
whether a square is a control point or data point, roll your mouse over
it. If your cursor turns white and a symbol appears like two strings
twisted together, the square is a control point.

e To add a new data point, click the Insert Point icon and then click
and drag slightly on the curve or polygon at the location that you
want to add a point. A new data point appears.

¢ To delete a data point, click it and press Backspace.

Don’t expect the Eliminate Points icon to delete a selected data
point. The function of the Eliminate Points icon is to delete unnec-
essary points according to the tolerance that you set in Tools=>
Options-Drawing=>Grid.

e To split your curve or polygon in two, select the data point at
which you want to split the curve or polygon and click the Split
Curve icon on the Edit Points Object toolbar.

¢ To change a straight line of your object into a curve or vice versa,
select the data point that you want to convert and click the
Convert to Curve icon.

¢ To display two control lines and points when you click a curve
data point, select the data point and click the Corner Point icon.
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e [f you want the two curves that a data point joins to join smoothly,
click the Smooth Transition icon.

e [f you want the two curves that a data point joins to join smoothly
and symmetrically, click the Symmetric Transition icon.

e To omit points that are not needed, click the Eliminate Points icon.
You can set the tolerance for this feature in the Points Reduction
spin box found in Tools=>Options>Drawing=>Grid.

If you select an object to change the line size or color, for example, and the
Edit Points feature appears automatically on the Object toolbar, click the Edit
Points icon to make the Edit Points Object toolbar disappear.

If the Edit Points Object toolbar is active and you want to change your area
color or line size or color, for example, but your combo boxes are not show-
ing, you can always choose Format=>Area or Formatr>Line.

Filtering Those Bitmaps (and
Everything Else, Too)

Figure 4:

A pot of
flowers

is filtered
with the
Charcoal
Sketch filter.

OpenOffice.org Draw comes complete with a toolbar of bitmap filters; these
filters are incredibly powerful and fun to use. Filters are cool because they

do so much with so little effort from you. For example, the pot of flowers that’s
shown in Figure 4 has been converted to a bitmap and had some filters applied
toit.
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To apply one or more filters to an object, perform the following steps:

1. Select your object, and choose Modify=Convert~ Bitmap.

The Object toolbar changes to the Bitmap Object toolbar, as shown
in Figure 4. Using this toolbar, you can modify the percentage of red,
green, or blue; the brightness; the contrast; and the transparency of
your bitmap. You can also choose Black/White or Greyscale from the
combo box.

2. Click the Filter icon on the Bitmap Object toolbar.

The Filter icon is the first icon on the left. It brings up the draggable
Filter toolbar, which contains these filters: Invert, Smooth, Sharpen,
Remove Noise, Solarization, Aging, Posterize, Pop Art, Charcoal Sketch,
Relief, and Mosaic.

3. Click the appropriate filter to apply it to the bitmap.

As you click, the bitmap changes to the new filtered image. To achieve
the effect that’s shown in Figure 4, we clicked the Sharpen filter four
times and then clicked the Charcoal Sketch filter.

Filters can be a lot of fun, so have fun!

Loving Those Layers

Did you ever try to select an object and end up selecting an object behind
the one that you really wanted to select? Wouldn't it be useful to lock some
objects in place so that they couldn’t be selected by accident, such as a fancy
background? Or, did you ever feel like focusing on just one object at a time
and hiding all the other parts of your image? Or, are you a Web designer who
wants to have all your buttons automatically separated so that you can easily
find and program them? You can do all these things using layers.

To create layers, choose Viewr>Layer. Three layer tabs replace the Slide tab
or tabs at the bottom of the Draw window. The layer tabs are labeled Layout,
Controls, and Dimension Lines. ( Draw automatically puts any dimension
lines that you draw on the Dimension Line layer, and any buttons that contain
actions are put on the Controls layer. You can’t delete these three default
layers.)

To use your new layers, just select the layer that you want and then add or
draw any objects that you want on that layer. It’s that simple.
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To create a new custom layer, follow these steps:

1. Right-click on a layer name and choose Insert Layer from the shortcut
menu that appears.

The Insert Layer dialog box appears.

2. Type a new name in the input box, and select the properties that you
want to apply to the layer: Visible, Printable, and/or Locked. Then
click OK.

Your new layer name appears on a new tab at the end of the line of
layer tabs.

3. To modify your layer, select the layer tab that you want to modify,
right-click it, and choose Modify from the shortcut menu that appears.

The Modify Layer dialog box appears, which is similar to the Insert
Layer dialog box. You can rename the layer, make it visible or hidden,
lock it, or make it printable or not printable.

When you are switching between layers, locking and hiding the layers
makes it easier to quickly complete complex art projects.

4. To view your slide tabs again, choose Viewr>Layer.
NG/
&V& The order of the layers in Draw does not specify the arrangement from top to
bottom. An object can be on the last layer yet still be on top, if it is the last
object that you created.

Animating Text

Moving text adds sparkle to your Web site or presentation. And it’s amazingly
easy to do.

To animate text, perform the following steps:

1. Select the text box that contains the text that you want to animate.

Make sure that your text box is big enough to accommodate your anima-
tion in the direction or directions that you plan for it to move — unless
you just want the text to blink.

2. Choose Format=>Text, and click the Text Animation tab of the Text
dialog box.

3. In the Effects combo box, choose Blink, Scroll Through, Scroll Back
and Forth, or Scroll In.

Scroll Through scrolls like a marquee. Scroll Back and Forth scrolls back
and forth in the text box. (Be sure that the text box is large enough to
give the text room to move back and forth.) Finally, Scroll In just scrolls
the text in and stops.
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4. Choose the direction of your scroll by clicking a direction arrow.

5. Select the Start Inside check box or the Text Visible When Exiting
check box to activate either of those features.

6. Select the Continuous Animation Cycles check box, or deselect this
check box and choose the number of animation cycles. Also, choose
the Increment, which regulates the speed at which the animation
appears.

For example, if you want your text to race across the page, choose a
higher increment.

7. If you want your animation to be delayed, deselect the Automatic
check box and choose a delay from the spin box.

8. Click OK.
The Text dialog box closes.
9. Deselect the text box.

Your animation occurs just as you specified.

Thrilling 3-D Effects

OpenOffice.org offers powerful 3-D effects. Shapes, lines, curves, and even
text can be converted to 3-D. And once a component is converted, it can be
modified, grouped with other 3-D or 2-D objects, rotated, and given shadows,
textures, lighting effects, and more.

Your object can be converted into 3-D by giving it depth, or it can be rotated
using the 3-D rotation feature. For instance, the speaker and earpiece of the
old-fashioned telephone that is shown in Figure 5 are both the letter Z that
was converted to a 3-D rotation object and then lengthened slightly. The
handle for the earpiece is the letter U, which has been extruded (given
depth) with the 3-D feature. The dial comprises two circles that were con-
verted to 3-D. (The holes on the dial are 2-D ovals.)

The best part about OpenOffice.org Draw’s 3-D feature is that it’s easy to use,
regardless of whether you are an artist.

3-D basics

Draw offers several ways to create 3-D objects. The simplest way is to use the
3-D toolbar, which is found on the Main toolbar. Long-click the 3-D icon, and a
draggable toolbar of 3-D icons appears. These icons are Cube, Sphere, Cylinder,
Cone, Pyramid, Donut, Shell, and Half-Circle. Click the icon of your choice, and
click and drag in the document window. The object of your choice appears.



Bonus Chapter 4: Getting More Graphic

e Q .‘;|Can(muous j‘ J'i Black j &‘Color j’i Blug 7 j [}
i | ‘ B
| éﬂ: [ |
Figure 5: :,
Anold- | g
fashioned |& J
telephone |22
thatwas | =
created | ™
using |©
OpenOffice. E“:
org Draw's &
3-D tools. bz ol " J_l
| w &

To rotate your 3-D shape, click the Rotation icon either on the Main toolbar
or on the Effects toolbar, which you can open by long-clicking the Effects icon
on the Main toolbar. Then click your 3-D object. Red handles appear, along
with a center indicator. Corner handles rotate the object in 2-D, and the other
handles rotate it in a 3-D perspective.

You can also make your 3-D object bigger in either direction, just like a 2-D
object. Just select the object and pull the handles.

To create a 3-D object, select a shape, line, curve, or text. Practically any-
thing converts to 3-D — even grouped objects. (When selecting text, click the
deselected text so that no cursor appears. If a cursor is showing, the text will
not convert to 3-D.) Choose Modify=>Convert=>To 3D. Your shape transforms
into 3-D. Figure 6 shows the 3D Effects dialog box.

To create a 3-D rotation object, perform the following steps:
1. Create and select the object that you want to change to a 3-D rotation
object.
You can use the following ideas:
¢ A slanted line becomes a cone.
e A circle becomes a donut-shaped object.

e The letter 7'makes a nice doorknob shape. (Or, if the T is slanted, it
makes a nice stubby candleholder.)

¢ And of course, the letter Z makes a great telephone speaker and
earpiece, as shown in Figure 5.

Letters can be upright, slanted, or sideways to make different effects.
And curves are also wonderfully expressive in 3-D.

9
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Unfilled shapes do not convert to 3-D, unless you change their lines to
fills. (See the following Tip.)

Text must be selected with a single click. A cursor must not appear in
the text box.

2. Choose Modify~>Convert~>To 3D Rotation Object.

Your 3-D rotation object appears. Sometimes the details of the object are
unclear. Rotating the object, zooming in or enlarging it, and changing its
color can all help to define the object’s complex shape.

The 3-D rotation tool can be addictive. Don’t stay up all night 3-D-ing crazy
curves and the entire alphabet in all your fonts!

Unfilled shapes do not convert to 3-D, unless you change their lines to fills.
You can do this by copying and pasting one shape over another and then
offsetting it slightly. Then select both shapes and choose Modify=>Shaper>
Merge. The lines of your shape are now fills instead of lines. You can now
convert to 3-D.

When working with 3-D, make sure that your unit of measurement is either
Millimeter, Centimeter, Inch, Point, or Pica. It should not be Meter, Kilometer,
Foot, or Mile. The spin boxes for the 3-D effects work better with smaller
units of measurement. To change the unit of measurement, choose Toolsw>
Options=>Drawing=>General. Then choose the unit of measurement from the
combo box.
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Before modifying a 3-D object, be sure that Help=>Tips is selected. Otherwise,
it’s not always easy to decipher the icons in the 3D Effects dialog box.

To modify the shape of your 3-D object or to create a 3-D object from a 2-D
object, perform the following steps:

1.

Select your 2-D object or 3-D object.

For example, Figure 6 shows that you can select an unfilled circle and
convert it into a pipe.

. Choose Format=>3D Effects.

The 3D Effects dialog box appears, showing lots of luscious-looking
donuts.

. Click the Geometry button, the second button from the left in the 3D

Effects dialog box.

The Geometry panel appears, as shown in Figure 6.

. Choose the percentage of Rounded edges and Scaled depth, and select

the Depth.

Experiment until your object looks good. To get the shape that is shown
in Figure 6, we chose 5% Rounded edges, a Scaled depth of 120%, and a
Depth of 3.35 cm.

. If you want your object to show some jaggedness instead of smooth

corners, choose smaller values in the Segments spin boxes.

Segments are the number of longitudinal lines and latitudinal lines that
define your object. More segments mean greater definition of curves.
Draw offers 24 horizontal and 24 vertical segments as the default. Very
small values drastically change the shape of your 3-D object. This fea-
ture has no effect on extruded 2-D objects.

. To emphasize the flatness of the sides of your 3-D object, change the

Normals option to Flat. To emphasize the roundness of the object,
change the Normals option to Round. Or, just let Draw decide how to
deal with these settings by clicking the Object-Specific button, which
is the default.

Normals options specify the way that light bounces off your object. For
instance, to create a more realistic coin from an extruded circle, you
could choose the Flat Normal option to show some ridges around the
sides of the coin.

. Select the object:

¢ To modify a 3-D object, click the Assign button in the upper-right
corner of the 3D Effects dialog box. (It’s the button with the green
check mark.)

11
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e To extrude a 2-D object, click the Convert to 3D button at the
bottom of the dialog box.

¢ To create a 3-D rotational object, click the Lathe button.

Your object transforms.

To create a 3-D rotation object with a space in the middle — like a donut —
create two circles, place them side by side, group them, and then convert the
group to a 3-D rotation object. A donut appears, with an extra circle in the
middle. To get rid of that extra circle, choose Modify=>Enter Group and delete
the middle part, so just the hole remains. Then choose Modify=>Exit Group.

Texturing

Textures are bitmaps that wrap around your 3-D object the way that you
would expect them to look on a real object. You can choose from a large vari-
ety of bitmaps that Draw provides, or you can import your own bitmaps.
Check out the section “Bitmapping brilliantly,” in Chapter 21, to find out how
to create and refine your own bitmaps. Or, read about the bitmap filtering
options in this chapter. Textures are a whole world in themselves, but fortu-
nately Draw makes them easy to apply.

To map a texture on a 3-D object, select the object and choose Bitmap from
the Area Style/Filling combo box on the Object toolbar. Then select your
bitmap from the available choices. (Mapping a texture on a 3-D object is simi-
lar to applying a bitmap to a 2-D object, except Draw puts perspective into
the 3-D bitmap.)

Texture maps start with default settings that are set by Draw. To change the
default settings, such as mapping the image flatter or rounder or changing it
to black and white, Draw allows you to do this.

To modify a texture, perform the following steps:

1. Select the 3-D object for which you want to modify the texture.
2. Choose Format~>3D Effects.

The 3D Effects dialog box appears. Notice that the bitmap or color of the
object that you selected appears on a sphere in the Preview area.

3. Click the Textures button at the top of the 3D Effects dialog box.

The Textures panel appears, as shown in Figure 7. The figure shows a
custom-made bitmap that has been mapped to a 3-D sphere to look like a
child’s ball.

4. To change your texture to black and white, click the Black and White
button, which is a Type choice in the Textures panel.
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Figure 7:
The
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3D Effects
dialog box
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The sphere in the Preview window changes to black and white, unless
the light source is colored. You may also need to modify the light-source
color to make your image black and white.
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5. Choose the Mode, either Texture and Shading or Texture only. Also,
choose your type of projection on the X and Y axes. These options can
be Object-Specific (the default), Parallel, or Circular.

Your texture changes in the Preview area. Try different combinations
until you find the one that you like the best. Figure 7 shows Projection Y
changed to Parallel.

6. If you want a fuzzy look, turn off filtering by clicking the Filter icon.
Turning off filtering sometimes adds a nice blurring effect to the image.
7. Click the Assign button in the upper-right corner of the dialog box.

Your selected object changes to adopt the new texture. If the result
wasn’t exactly what you had in mind, try again. Sometimes it takes a few
tries to get it right.

Lighting

Casting shadows wherever you want, changing the ambient light color or the
color of the light source, and brightening or dulling the highlight are all fea-
tures that add subtlety to your work. You can also change the look of your
3-D object to metal, chrome, plastic, wood, or even gold, or you can create a
user-defined gradient.

13
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The look of your 3-D object not only depends on the color, gradient, or
bitmap of the object but also on several light-source colors, intensities, and
angles that you use. The types of light are as follows:

» Ambient light is simply the surrounding light, which comes from no par-
ticular direction.

v Specular light is like a beam of light. Draw allows you to change the
angle of this beam.

v [llumination color is the color of the object.

To change the ambient light color and light-beam color and angle, perform
the following steps:

1. Select a 2-D or 3-D object for which you want to modify the lighting.
A 2-D object automatically extrudes in Step 5, becoming a 3-D object.

2. Choose Format=>3D Effects, and click the Illumination button at the
top of the 3D Effects dialog box. This button shows a light bulb icon.

The lllumination window appears. A sphere appears in the Preview
window of the lllumination window. This sphere shows the same lighting
and texture as your selected object. A group of eight buttons indicating
eight light sources are available. At present, OpenOffice.org 1.1 has only
one of these light sources available for use. We can look forward to the
rest in future free upgrades.

3. Choose the color for both the ambient light source and the light-beam
source. Either use the combo boxes or click the Color Dialog button to
open the Colors dialog box, and click in one of the boxes to choose
your color.

The left box is limited to 256 colors, and the right box offers millions of
colors. If you clicked the Color Dialog button, click OK after choosing
your color to close the dialog box.

Watch your changes occur in the Preview area. Remember, your object
is not in the Preview area, just a sphere with the same color, bitmap, or
gradient as your object and the same lighting effects.

4. Click and drag the light source in the Preview area to choose the
angle by which the light source should strike your object.

Move the light source in any direction up to 180 degrees vertically and
180 degrees horizontally to get the angle just right.

5. To adjust the intensity of the light source, click the Materials tab on
the top bar of the 3D Effects dialog box and choose the Specular
Intensity from the spin box that is shown.
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The Materials window contains several color settings, and each is set
to your selected object. You can change these settings if you want.

The combo box has ready-made lighting and object color options that
you can apply to your 3-D object to make it look like gold, metal, wood,
chrome, or plastic, or you can play with the colors and create your own
look. You may simply want to adjust the Specular intensity.

Watch the highlight on your object grow as you decrease the Specular
Intensity.

6. Click the Assign button in the upper-left corner of the dialog box.

The new lighting effect is applied to your 3-D object. (And any 2-D object
that was selected now becomes 3-D as well.)

Shading and shadows

Shading is another great 3-D effect. Draw provides three methods of shading:
Gouraud, Phong, and Flat. Draw also allows you to create shadows and to
choose the angle of the shadow.

To apply shadows and shading to a 3-D object, perform the following steps:

1. Select your 3-D object.

2. Choose Format->3D Effects, and click the Shading button in the 3D
Effects dialog box.

The Shading window appears.
3. Choose Gouraud, Phong, or Flat shading from the Mode combo box.
Think of your 3-D object as a polygon with lots of tiny sides to it.
¢ Flat shading applies a single color to each individual polygon side.
® Gouraud shading blends colors from one polygon side to another

¢ Phong shading averages the color of each pixel depending on the
pixels surrounding it.

Phong is the most processor-intensive shading.

4. Click the Shadow button to automatically generate shadows for your
3-D object. Choose the angle of the shadow from the Surface Angle
spin box.

Watch the preview change.

5. To tweak the shadow a bit, select different Camera Distance and Focal
Length settings.

15
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Watch the shadow and even the shape of the sphere change in the
Preview area.

After applying a long Camera Distance, you can’t always view your
object closely again without choosing Edit=>Undo.

6. Click the Assign button.

Your shadows and shading effects are now assigned to your object.

<® For complex objects, such as the telephone that was shown in Figure 5, not
all of the individual components create believable-looking shadows. For
those components, you need to draw the shadows and connect them to
others that are correctly generated. To easily draw a shadow, copy the part
of the 3-D image that you want to create a shadow for, choose Format=>3D
Effects, click the lllumination button, and then click the Light Source 1 icon to
turn off the light source. Click the Assign button, and your 3-D object now
appears like a 2-D object. Just color the lines and area gray like a shadow,
rotate the object into place, and use the Arrange icon, choosing Send to Back.

Creating Flow Charts, Org
Charts, and Family Trees

Connectors are great for creating such displays as flow charts, organizational
charts, and family trees. Draw offers a large assortment of connector types
on the Connector toolbar, as shown in Figure 8, and allows you to insert “glue
points” wherever you want. Using Draw’s connectors is a snap!
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Bonus Chapter 4: Getting More Graphic

To create a flow chart or organizational chart, such as the organizational
chart that is shown in Figure 8, perform the following steps:

1. Create the boxes for your chart, and lay them out in your Draw
document.

An easy approach for this is to draw one rectangle with no fill, duplicate
as many rectangles as you need, and align them in rows, as shown in
Figure 8.

2. Long-click the Connectors icon on the Main toolbar.
The Connectors toolbar appears with lots of connector options.
3. For each connection, apply these steps:
e Click the Connector of your choice.

We used the connector in the upper-left corner of the toolbar to
create Figure 8.

e Move the mouse over the first box to which you want to attach the
connector.

The connection sites, called glue points, appear as Xs.

e Click a glue point, and drag the connector from one glue point of
your choice to another.

If no glue point exists where you need one, see the instructions in
the following list to add a glue point.

e If you are not using a Line connector or a Straight connector, you
can adjust the connection line. Click the connection line so that
the handles appear, and drag the small square handle to adjust the
line.

Do this to center the line between your rows or columns of boxes
or to modify the curve of the curve connector.

You may want to add a glue point where no glue point exists. To add a glue
point, perform the following steps:

1. Choose Viewr>Toolbars=>Option Bar to make the Option toolbar visi-
ble at the bottom of the document window. Then click the second icon
from the left, which is Edit Glue Points.

This makes the Edit Glue Points Object toolbar visible, as shown in
Figure 8.

2. Select the object to which you want to attach the glue point.

3. Click the Insert Glue Point icon on the Edit Glue Points Object tool-
bar. It is the first icon on the left.
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4. Click the selected object at the place where you want to insert the
glue point.

A small box that contains an X appears. The next time that you try to
use a connector, this new glue point will be available to you.
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